指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 
炒股叉_20190710_104228.png

炒股叉_20190710_104238.png

[lywrap=通达信主图指标公式][lycode=tdx,true]M3:=EMA(CLOSE,3);
M8:EMA(CLOSE,8),COLOR008000;
M13:EMA(M8,13),COLOR0000FF;
M62:EMA(M8,55),COLORF0F000;
VAR1:=EMA(M13,62);
M81:EMA(M62,81),COLOR00FFFF;
M144:EMA(VAR1,144),LINETHICK2,COLOR0000FF;
M250:EMA(VAR1,250),POINTDOT,LINETHICK2,COLORF00FF0;
MA250:MA(CLOSE,250);
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
Y:=IF(CROSS(J,REF(J+0.01,1)) AND X AND J<20,30,0);
主力:=EMA( (CLOSE-MA(CLOSE,3))/MA(CLOSE,3),2);
散户:=EMA( (CLOSE-MA(CLOSE,20))/MA(CLOSE,20),7);
VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
动能趋势线:=100*EMA((CLOSE-VAR2)/(VAR3-VAR2),4);
DRAWTEXT(CROSS(动能趋势线,70),HIGH*1.02,'风险'),COLORGREEN;
DRAWTEXT(CROSS(动能趋势线,80),HIGH*1.02,'减仓'),COLOR00FF00;
DRAWTEXT(CROSS(动能趋势线,87.5),HIGH*1.02,'出局'),COLORWHITE;
DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<20,LOW,'短进'),COLORFF00FF;
DRAWTEXT(CROSS(主力,散户) AND 主力<0 AND 散户<0,LOW,'见底'),COLORRED;
DRAWICON(CROSS(主力,散户) AND 主力<0 AND 散户<0,LOW,1);[/lycode][lycode=tdx2,true]M3赋值:收盘价的3日指数移动平均
输出M8:收盘价的8日指数移动平均,COLOR008000
输出M13:M8的13日指数移动平均,COLOR0000FF
输出M62:M8的55日指数移动平均,COLORF0F000
VAR1赋值:M13的62日指数移动平均
输出M81:M62的81日指数移动平均,COLOR00FFFF
输出M144:VAR1的144日指数移动平均,线宽为2,COLOR0000FF
输出M250:VAR1的250日指数移动平均,POINTDOT,线宽为2,COLORF00FF0
输出MA250:收盘价的250日简单移动平均
RSV赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
K赋值:RSV的3日[1日权重]移动平均
D赋值:K的3日[1日权重]移动平均
J赋值:3*K-2*D
X赋值:2日内J的最低值=8日内J的最低值
Y赋值:如果J上穿1日前的J+0.01ANDXANDJ<20,返回30,否则返回0
主力赋值:(收盘价-收盘价的3日简单移动平均)/收盘价的3日简单移动平均的2日指数移动平均
散户赋值:(收盘价-收盘价的20日简单移动平均)/收盘价的20日简单移动平均的7日指数移动平均
VAR2赋值:10日内最低价的最低值
VAR3赋值:25日内最高价的最高值
动能趋势线赋值:100*(收盘价-VAR2)/(VAR3-VAR2)的4日指数移动平均
当满足条件动能趋势线上穿70时,在最高价*1.02位置书写文字,画绿色
当满足条件动能趋势线上穿80时,在最高价*1.02位置书写文字,COLOR00FF00
当满足条件动能趋势线上穿87.5时,在最高价*1.02位置书写文字,画白色
当满足条件J上穿1日前的J+0.01ANDXANDJ<20时,在最低价位置书写文字,COLORFF00FF
当满足条件主力上穿散户AND主力<0AND散户<0时,在最低价位置书写文字,画红色
当满足条件主力上穿散户AND主力<0AND散户<0时,在最低价位置画1号图标
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1mWs3bzpJWh0e4678_amf5Q

看了该指标的人还看了:
叶公跟庄指标    股海神偷指标    降龙贰式指标
均线进多头指标    主力主升指标    画线指标指标

使用道具 举报

回复