指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 买卖点 
炒股叉_20190710_103852.png

炒股叉_20190710_103857.png

[lywrap=通达信主图指标公式][lycode=tdx,true]MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA24:MA(CLOSE,24);
MA30:MA(CLOSE,30);
MA60:MA(CLOSE,60);
MA120:MA(CLOSE,120);
MA250:MA(CLOSE,250);
DIF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIF,9);
AAA:=(DIF-DEA)*2*60;
起爆:=CROSS(AAA-REF(AAA,1),15),COLORRED,LINETHICK2;
DRAWTEXT(起爆,L*0.99,'◆■◆↖暴张'),COLORYELLOW,LINETHICK2;
STICKLINE(REF(COUNT(C<MA(REF(HHV((C+L+O+H)/4,40),1),3),5)=5,1) AND C>MA(REF(HHV((C+L+O+H)/4,40),1),3) AND C>O,C,O,1.3,0),COLORYELLOW;
TYX2:=MA(REF(HHV((C+L+O+H)/4,10),1),3);
STICKLINE(REF(COUNT(C<TYX2,5)=5,1) AND C>TYX2 AND C>O,C,O,1.3,0),COLORBLUE;DRAWTEXT(HIGH>REF(HIGH,1) AND REF(HIGH,2)>REF(HIGH,1) AND LOW>REF(LOW,1)
AND REF(LOW,2)>REF(LOW,1)
AND MA(CLOSE,5)<MA(CLOSE,10),L-0.4,'■底方买进'),COLORMAGENTA;
主力:=EMA(((2*C+H+L)/4-LLV(L,34))/(HHV(H,34)-LLV(L,34))*100,13){*VAR2},COLORRED;
散户:=EMA(0.667*REF(主力,1)+0.333*主力,2),COLORFF9933;
上扬:IF(CROSS(主力,30) AND 散户<主力,L,DRAWNULL),POINTDOT,LINETHICK7,COLORLIMAGENTA;
{35,STICK,LINETHICK2,COLOR000000;
强弱分界线:=50, POINTDOT, LINETHICK2, COLORFFFF00;}
买入脉冲:IF(CROSS(主力,散户) AND 主力<35,L*0.99,DRAWNULL),POINTDOT,LINETHICK7,COLORLIBLUE;
VAR1:=(CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100;
操盘线:=SMA(VAR1,5,1),LINETHICK2,COLORRED;
趋势线:=SMA(操盘线,3,1),LINETHICK2,COLORYELLOW;
买入航标:IF(CROSS(操盘线,趋势线) AND 趋势线<25,L*0.98,DRAWNULL),POINTDOT,LINETHICK5,COLORRED;
卖出脉冲:IF(CROSS(散户,主力) AND 散户>75,H*1.03,DRAWNULL),CROSSDOT,LINETHICK3,COLORGRAY;
DRAWTEXT(CROSS(主力,散户) AND 主力<22,L,'起动'),COLORYELLOW;
DRAWTEXT(CROSS(主力,30) AND 散户<主力,L,'上扬 '),COLOR00CCFF;
DRAWTEXT(CROSS(主力,65) AND 散户<主力,H,'冲顶 '),COLOR9933FF;
DRAWTEXT(CROSS(主力,75) AND 散户<主力,H,'小心被套'),COLORRED;
DRAWTEXT(CROSS(散户,主力) AND 散户>75,H,'头部'), COLORYELLOW;
DRAWTEXT(买入航标>0,L,'买入'),COLORMAGENTA;
DRAWTEXT(CROSS(趋势线,操盘线)AND 操盘线>70,H*1.02,'卖出'),COLOR00FF00;
FA:=BARSLAST(CROSS(MA10,MA5)) AND CROSS(MA5,MA10);
FB:=FA AND MA5>MA30 AND MA10>MA30 AND MA10>REF(MA10,1);
DRAWTEXT(FB,L-0.58,'★追涨'),COLORRED;
V1:=EMA(CLOSE,5);
V2:=EMA(EMA(CLOSE,90)*1.01,10);
DRAWTEXT(CROSS(V1,V2),V1+0.05,'牛起步'),COLOR00FF00;
VARA1:=LLV(LOW,21);
VARA2:=HHV(HIGH,21);
AK1:=EMA((((CLOSE - VARA1) / (VARA2 - VARA1)) * 100),5);
AK:=EMA((((CLOSE - VARA1) / (VARA2 - VARA1)) * 50),13);
AB:=CROSS(AK1,AK);
DRAWTEXT((AB = 1),(LOW * 0.99),'○关注'),COLORYELLOW;
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
介入:=BB1 AND CC1 AND DD1 AND EE1,LINETHICK0,COLOR0099FF;
DRAWTEXT(介入,L*0.99,'介入'),COLOR0099FF;
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.93),'★买入 '),COLOR00FFFF;
DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(0.99000001),'★加仓'),COLOR00FFFF;
VZ:=INTPART(AMOUNT)/INTPART(V)/100;
DRAWTEXT_FIX(1,0.00,0,0,'所属地区:')COLOR00FFFF;
DRAWTEXT_FIX(1,0.07,0,0,DYBLOCK)COLOR00FFFF;
DRAWTEXT_FIX(1,0.00,0.06,0,'所属行业:')COLORFF00FF;
DRAWTEXT_FIX(1,0.07,0.06,0,HYBLOCK)COLORFF00FF;
EMA20:EMA(C,20),COLORWHITE,NODRAW;
EMA40:EMA(C,40),COLORYELLOW,NODRAW;
EMA60:EMA(C,60),COLORFF00FF;
MA020:=EMA(CLOSE,20);
MA040:=EMA(CLOSE,40);
MA060:=EMA(CLOSE,60);
A1:=OPEN<MA020 OR OPEN<MA040 OR OPEN<MA060;
A2:=C>MAX(MA020,MAX(MA040,MA060));
A3:=V/MA(V,10)>1.2;
A4:=C/REF(C,1)>1.049;
A5:=VOL/REF(VOL,1)>=1.9;
出水芙蓉:=A1 AND A2 AND A3 AND A4 AND A5 AND O<MA060 AND C>MA060;
DRAWTEXT(出水芙蓉,H-0.20,'出水芙蓉');[/lycode][lycode=tdx2,true]输出MA5:收盘价的5日简单移动平均
输出MA10:收盘价的10日简单移动平均
输出MA24:收盘价的24日简单移动平均
输出MA30:收盘价的30日简单移动平均
输出MA60:收盘价的60日简单移动平均
输出MA120:收盘价的120日简单移动平均
输出MA250:收盘价的250日简单移动平均
DIF赋值:不定周期收盘价的12日指数移动平均-不定周期收盘价的26日指数移动平均
DEA赋值:DIF的9日指数移动平均
AAA赋值:(DIF-DEA)*2*60
起爆赋值:AAA-1日前的AAA上穿15,画红色,线宽为2
当满足条件起爆时,在最低价*0.99位置书写文字,画黄色,线宽为2
当满足条件1日前的统计5日中满足收盘价<1日前的40日内(收盘价+最低价+开盘价+最高价)/4的最高值的3日简单移动平均的天数=5ANDC>1日前的40日内(收盘价+最低价+开盘价+最高价)/4的最高值的3日简单移动平均ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1.3,0不为0则画空心柱.,画黄色
TYX2赋值:1日前的10日内(收盘价+最低价+开盘价+最高价)/4的最高值的3日简单移动平均
当满足条件1日前的统计5日中满足收盘价<TYX2的天数=5ANDC>TYX2ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1.3,0不为0则画空心柱.,画蓝色
当满足条件最高价>1日前的最高价ANDREF(最高价,2)>1日前的最高价ANDLOW>1日前的最低价ANDREF(最低价,2)>1日前的最低价ANDMA(收盘价,5)<收盘价的10日简单移动平均时,在最低价-0.4位置书写文字,画洋红色
主力赋值:((2*收盘价+最高价+最低价)/4-34日内最低价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)*100的13日指数移动平均,画红色
散户赋值:0.667*1日前的主力+0.333*主力的2日指数移动平均,COLORFF9933
输出上扬:如果主力上穿30AND散户<主力,返回最低价,否则返回无效数,POINTDOT,线宽为7,画淡洋红色
输出买入脉冲:如果主力上穿散户AND主力<35,返回最低价*0.99,否则返回无效数,POINTDOT,线宽为7,画淡蓝色
VAR1赋值:(收盘价-30日内最低价的最低值)/(30日内最高价的最高值-30日内最低价的最低值)*100
操盘线赋值:VAR1的5日[1日权重]移动平均,线宽为2,画红色
趋势线赋值:操盘线的3日[1日权重]移动平均,线宽为2,画黄色
输出买入航标:如果操盘线上穿趋势线AND趋势线<25,返回最低价*0.98,否则返回无效数,POINTDOT,线宽为5,画红色
输出卖出脉冲:如果散户上穿主力AND散户>75,返回最高价*1.03,否则返回无效数,CROSSDOT,线宽为3,画深灰色
当满足条件主力上穿散户AND主力<22时,在最低价位置书写文字,画黄色
当满足条件主力上穿30AND散户<主力时,在最低价位置书写文字,COLOR00CCFF
当满足条件主力上穿65AND散户<主力时,在最高价位置书写文字,COLOR9933FF
当满足条件主力上穿75AND散户<主力时,在最高价位置书写文字,画红色
当满足条件散户上穿主力AND散户>75时,在最高价位置书写文字, 画黄色
当满足条件买入航标>0时,在最低价位置书写文字,画洋红色
当满足条件趋势线上穿操盘线AND操盘线>70时,在最高价*1.02位置书写文字,COLOR00FF00
FA赋值:上次MA10上穿MA5距今天数 AND MA5上穿MA10
FB赋值:FA AND MA5>MA30 AND MA10>MA30 AND MA10>1日前的MA10
当满足条件FB时,在最低价-0.58位置书写文字,画红色
V1赋值:收盘价的5日指数移动平均
V2赋值:收盘价的90日指数移动平均*1.01的10日指数移动平均
当满足条件V1上穿V2时,在V1+0.05位置书写文字,COLOR00FF00
VARA1赋值:21日内最低价的最低值
VARA2赋值:21日内最高价的最高值
AK1赋值:(((收盘价-VARA1)/(VARA2-VARA1))*100)的5日指数移动平均
AK赋值:(((收盘价-VARA1)/(VARA2-VARA1))*50)的13日指数移动平均
AB赋值:AK1上穿AK
当满足条件(AB=1)时,在(最低价*0.99)位置书写文字,画黄色
AA1赋值:成交额(元)/成交量(手)
BB1赋值:最低价<AA1*0.9
CC1赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100>1.2
DD1赋值:最低价<收盘价的5日简单移动平均*0.921
EE1赋值:成交量(手)<成交量(手)的5日简单移动平均*1.5
介入赋值:BB1 AND CC1 AND DD1 AND EE1,线宽为0,COLOR0099FF
当满足条件介入时,在最低价*0.99位置书写文字,COLOR0099FF
VAR3AA赋值:如果(收盘价>1日前的收盘价),返回88,否则返回0
VAR4AA赋值:如果((收盘价)/(1日前的收盘价)>1.05)AND((最高价)/(收盘价)<1.01)AND(VAR3AA>0),返回91,否则返回0
当满足条件(VAR4AA>90)的45日过滤时,在(最低价)*(0.93)位置书写文字,COLOR00FFFF
当满足条件(VAR4AA>90)的35日过滤时,在(最低价)*(0.99000001)位置书写文字,COLOR00FFFF
VZ赋值:成交额(元)的整数部分/成交量(手)的整数部分/100
当满足条件1时,在横轴0.00纵轴0位置书写文字COLOR00FFFF
当满足条件1时,在横轴0.07纵轴0位置书写文字COLOR00FFFF
当满足条件1时,在横轴0.00纵轴0.06位置书写文字COLORFF00FF
当满足条件1时,在横轴0.07纵轴0.06位置书写文字COLORFF00FF
输出EMA20:收盘价的20日指数移动平均,画白色,NODRAW
输出EMA40:收盘价的40日指数移动平均,画黄色,NODRAW
输出EMA60:收盘价的60日指数移动平均,COLORFF00FF
MA020赋值:收盘价的20日指数移动平均
MA040赋值:收盘价的40日指数移动平均
MA060赋值:收盘价的60日指数移动平均
A1赋值:开盘价<MA020 OR 开盘价<MA040 OR 开盘价<MA060
A2赋值:收盘价>MA020和MA040和MA060的较大值的较大值
A3赋值:成交量(手)/成交量(手)的10日简单移动平均>1.2
A4赋值:收盘价/1日前的收盘价>1.049
A5赋值:成交量(手)/1日前的成交量(手)>=1.9
出水芙蓉赋值:A1 AND A2 AND A3 AND A4 AND A5 AND 开盘价<MA060 AND 收盘价>MA060
当满足条件出水芙蓉时,在最高价-0.20位置书写文字
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1GrL18A_VV_hP-1oSeexoYg

看了该指标的人还看了:
叶公跟庄指标    股海神偷指标    降龙贰式指标
均线进多头指标    主力主升指标    画线指标指标

使用道具 举报

回复