指标公式
软件: 通达信 
公式类型: 主图 选股 
二级分类: 波段 无未来函数 短线 买卖点 
炒股叉_20190710_103318.png

炒股叉_20190710_103330.png

[lywrap=通达信主图指标公式][lycode=tdx,true]N:=20;N1:=7;N2:=79;
JJ:=(CLOSE+HIGH+LOW)/3;
A:=EMA(JJ,10);
B:=REF(A,1);
DRAWTEXT(A<B,A,'*'),COLOR00FF00,LINETHICK5;
DRAWTEXT(A>B,B,'*'),COLOR0000FF,LINETHICK5;
DRAWICON(REF(A<B,1) AND A>B,L-0.05,1);
DRAWTEXT(REF(A<B,1) AND A>B,L,'--------------买进'), COLORYELLOW;
M1:EMA(CLOSE,3);
M2:EMA(CLOSE,8);
M3:EMA(M2,13);
M4:EMA(M2,55);
VAR1:=EMA(M3,55);
M5:EMA(M4,81);
M6:EMA(VAR1,144), COLORRED,LINETHICK2;
VAR2:=(REF(HIGH,1)+REF(LOW,1))/2;
VAR3:=MA(CLOSE,N)+2*STD(CLOSE,N);
DRAWICON(CROSS(VAR2,VAR3),HIGH+0.1,2);
DRAWTEXT(CROSS(VAR2,VAR3),HIGH*1.02,'卖出'), COLORGREEN;
VAR4:=REF(CLOSE,1);
VAR5:=SMA(MAX(CLOSE-VAR4,0),N1,1)/SMA(ABS(CLOSE-VAR4),N1,1)*100;
VAR6:=CROSS(N2,VAR5);
VAR7:=FILTER(VAR6,4);
DRAWICON(VAR7,HIGH+0.1,2);
DRAWTEXT(VAR7,HIGH*1.02,'卖出'), COLORGREEN;[/lycode][lycode=tdx2,true]N赋值:20
N1赋值:7
N2赋值:79
JJ赋值:(收盘价+最高价+最低价)/3
A赋值:JJ的10日指数移动平均
B赋值:1日前的A
当满足条件A<B时,在A位置书写文字,COLOR00FF00,线宽为5
当满足条件A>B时,在B位置书写文字,COLOR0000FF,线宽为5
当满足条件1日前的A<BANDA>B时,在最低价-0.05位置画1号图标
当满足条件1日前的A<BANDA>B时,在最低价位置书写文字, 画黄色
输出M1:收盘价的3日指数移动平均
输出M2:收盘价的8日指数移动平均
输出M3:M2的13日指数移动平均
输出M4:M2的55日指数移动平均
VAR1赋值:M3的55日指数移动平均
输出M5:M4的81日指数移动平均
输出M6:VAR1的144日指数移动平均, 画红色,线宽为2
VAR2赋值:(1日前的最高价+1日前的最低价)/2
VAR3赋值:收盘价的N日简单移动平均+2*收盘价的N日估算标准差
当满足条件VAR2上穿VAR3时,在最高价+0.1位置画2号图标
当满足条件VAR2上穿VAR3时,在最高价*1.02位置书写文字, 画绿色
VAR4赋值:1日前的收盘价
VAR5赋值:收盘价-VAR4和0的较大值的N1日[1日权重]移动平均/收盘价-VAR4的绝对值的N1日[1日权重]移动平均*100
VAR6赋值:N2上穿VAR5
VAR7赋值:VAR6的4日过滤
当满足条件VAR7时,在最高价+0.1位置画2号图标
当满足条件VAR7时,在最高价*1.02位置书写文字, 画绿色
[/lycode][/lywrap]

[lywrap=通达信选股公式指标][lycode=tdx,true]{红箭头选股,别看他少,但是很有价值!}
JJ:=(CLOSE+HIGH+LOW)/3;
A:=EMA(JJ,10);
B:=REF(A,1);
REF(A<B,1) AND A>B;[/lycode][lycode=tdx2,true]JJ赋值:(收盘价+最高价+最低价)/3
A赋值:JJ的10日指数移动平均
B赋值:1日前的A
1日前的A<B AND A>B[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1Dw5L-A5umqcwzYxmNBtglA

看了该指标的人还看了:
RSI突破下降趋势线指标    股海神偷指标    高抛低吸指标
抄死主力指标    股神短线指标    多空电波指标

使用道具 举报

回复