指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 抄底逃顶 
炒股叉_20190710_103155.png

炒股叉_20190710_103159.png

[lywrap=通达信副图指标公式][lycode=tdx,true]VAR3:=(CLOSE-LLV(LOW,26))/(HHV(HIGH,26)-LLV(LOW,26))*100;
VAR4:=SMA(SMA(VAR3,3,1),3,1);
VAR5:=EMA(VAR4,5);
VAR6:=VAR5;
VAR7:=3*VAR4-2*VAR5;
VAR8:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K: SMA(VAR8,3,1);
D: SMA(K,3,1);

VARA:=LLV(LOW,36);
VARB:=HHV(HIGH,30);
VARC:=EMA((CLOSE-VARA)/(VARB-VARA)*4,4)*25;
VARD:=87.5;
趋势:VARC;
DRAWTEXT(IF(CROSS(VARD,趋势),87,0),85,'赚了'),COLORGREEN;
STICKLINE(VARC>90,100,90,20,0),COLORGREEN;
STICKLINE(VARC<10,0,10,7,0),COLORRED;
VARF:=SMA(VAR3,20,1);
VAR10:=SMA(VARF,15,1);
VAR11:=(3*VARF+2*VAR10)/4;
VAR12:=REF(VAR11,1);
VAR13:=SMA(MAX(VAR11-VAR12,0),2,1)/SMA(ABS(VAR11-VAR12),2,1)*100;
VAR14:=MA(VAR13,10);
VAR15:=IF(CROSS(VAR14,90),25,0);
DRAWTEXT(CROSS(VAR14,90),27,'强势整理'),COLORBLUE;[/lycode][lycode=tdx2,true]VAR3赋值:(收盘价-26日内最低价的最低值)/(26日内最高价的最高值-26日内最低价的最低值)*100
VAR4赋值:VAR3的3日[1日权重]移动平均的3日[1日权重]移动平均
VAR5赋值:VAR4的5日指数移动平均
VAR6赋值:VAR5
VAR7赋值:3*VAR4-2*VAR5
VAR8赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
输出K: VAR8的3日[1日权重]移动平均
输出D: K的3日[1日权重]移动平均
VARA赋值:36日内最低价的最低值
VARB赋值:30日内最高价的最高值
VARC赋值:(收盘价-VARA)/(VARB-VARA)*4的4日指数移动平均*25
VARD赋值:87.5
输出趋势:VARC
当满足条件如果VARD上穿趋势,返回87,否则返回0时,在85位置书写文字,画绿色
当满足条件VARC>90时,在100和90位置之间画柱状线,宽度为20,0不为0则画空心柱.,画绿色
当满足条件VARC<10时,在0和10位置之间画柱状线,宽度为7,0不为0则画空心柱.,画红色
VARF赋值:VAR3的20日[1日权重]移动平均
VAR10赋值:VARF的15日[1日权重]移动平均
VAR11赋值:(3*VARF+2*VAR10)/4
VAR12赋值:1日前的VAR11
VAR13赋值:VAR11-VAR12和0的较大值的2日[1日权重]移动平均/VAR11-VAR12的绝对值的2日[1日权重]移动平均*100
VAR14赋值:VAR13的10日简单移动平均
VAR15赋值:如果VAR14上穿90,返回25,否则返回0
当满足条件VAR14上穿90时,在27位置书写文字,画蓝色
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/18yvQJq_pbv1cCtRjZyAEzQ

看了该指标的人还看了:
叶公跟庄指标    股海神偷指标    降龙贰式指标
均线进多头指标    主力主升指标    画线指标指标

使用道具 举报

回复