指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 买卖点 
买入法:
1.安全买点,出现买点可以买入作为中长线
2.出现启爆,可以关注,可能是牛启涨点
3.出现3D立体K线时,多留意这样的股票

炒股叉_20190617_105819.png

炒股叉_20190617_105825.png

[lywrap=通达信主图指标公式][lycode=tdx,true]Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.001,0.050,0,GNBLOCK),COLORCYAN;{概念};

AHC1:=CLOSE*VOL;
AHC11:=EMA((EXPMA(AHC1,1)/EXPMA(VOL,1)+EXPMA(AHC1,2)/EXPMA(VOL,2)+EXPMA(AHC1,4)/EXPMA(VOL,4)+EXPMA(AHC1,6)/EXPMA(VOL,6))/4,7),COLORYELLOW;
AHC2:EMA((EXPMA(AHC1,3)/EXPMA(VOL,3)+EXPMA(AHC1,6)/EXPMA(VOL,6)+EXPMA(AHC1,12)/EXPMA(VOL,12)+EXPMA(AHC1,24)/EXPMA(VOL,24))/4,13),POINTDOT,COLORYELLOW;
AHC22:=EMA((EXPMA(AHC1,27)/EXPMA(VOL,27)+EXPMA(AHC1,54)/EXPMA(VOL,54)+EXPMA(AHC1,108)/EXPMA(VOL,108)+EXPMA(AHC1,316)/EXPMA(VOL,316))/4,13),COLORWHITE,POINTDOT;
顶:=1.3*AHC2;
内上:=1.06*AHC2;
内下:=AHC2*0.94;
底:=AHC2*0.87;
~11:1.03*AHC2,POINTDOT,COLORYELLOW;
~22:0.97*AHC2,POINTDOT,COLORYELLOW;
IF((内上 <= REF(内上,1)),内上,DRAWNULL),COLORGREEN,DOTLINE,LINETHICK2;
IF((内上 >= REF(内上,1)),内上,DRAWNULL),COLORMAGENTA,DOTLINE,LINETHICK2;
IF((内下 <= REF(内下,1)),内下,DRAWNULL),COLORGREEN,DOTLINE,LINETHICK2;
IF((内下 >= REF(内下,1)),内下,DRAWNULL),COLORMAGENTA,DOTLINE,LINETHICK2;
DRAWKLINE(H,O,L,C);
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
启爆1:=CROSS(C,内上) OR CROSS(C,内下) AND ZT;
DRAWTEXT(启爆1,L*0.98,'启爆'),COLORYELLOW;
STICKLINE(启爆1,C,O,3,1),COLORWHITE;
STICKLINE(启爆1,C,O,1,0),COLORGREEN;
买点:=REF(内下,2)>REF(内下,1) AND 内下>REF(内下,1);
DRAWTEXT(买点,L*0.98,'↖买点')COLORWHITE;


DF:=(C-REF(C,1))/REF(C,1)*100<-5;
DF4:=(C-O)/O*100<-4;
AAAA:=BARSLAST(DF);
突破箱体:=CROSS(C,REF(C,AAAA));
箱顶:DRAWLINE(DF,O,REF(DF,1),REF(O,1),1),COLORMAGENTA,DOTLINE;
箱顶1:DRAWLINE(DF4,O,REF(DF4,1),REF(O,1),1),COLORMAGENTA,DOTLINE;
箱底:=LLV(MIN(L,REF(L,AAAA)),AAAA),COLORCYAN,LINETHICK2;
蓝柱:=REF(DF,2)=1 AND ZT AND CROSS(C,箱顶);

DRAWTEXT(蓝柱,L,'回头牛'),COLORGREEN;
STICKLINE(蓝柱,C,O,3,1),COLORYELLOW;
STICKLINE(蓝柱,C,O,1,0),COLORBLUE;

红柱:=REF(DF,1)=1 AND ZT AND CROSS(C,箱顶);
DRAWTEXT(红柱,L,'反转牛'),COLORRED;
STICKLINE(红柱,C,O,3,1),COLORYELLOW;
STICKLINE(红柱,C,O,1,0),COLORRED;
蓝柱1:=REF(DF4,2)=1 AND ZT AND CROSS(C,箱顶1);
DRAWTEXT(蓝柱1,L,'回头牛'),COLORGREEN;
STICKLINE(蓝柱1,C,O,3,1),COLORYELLOW;
STICKLINE(蓝柱1,C,O,1,0),COLORBLUE;

红柱1:=REF(DF4,1)=1 AND ZT AND CROSS(C,箱顶1);
DRAWTEXT(红柱1,L,'反转牛'),COLORRED;
STICKLINE(红柱1,C,O,3,1),COLORYELLOW;
STICKLINE(红柱1,C,O,1,0),COLORRED;

牛股:=C>内上 AND O>内上;
STICKLINE( 牛股 AND C>O,C,O,3.2,0),COLOR000066;
STICKLINE(牛股 AND C>O,C,O,2.0,0),COLOR000077;
STICKLINE(牛股 AND C>O,C,O,1.5,0),COLOR000099;
STICKLINE(牛股 AND C>O,C,O,0.9,0),COLOR0000CC;
STICKLINE(牛股 AND C>O,C,O,0.5,0),COLOR0000FF;
STICKLINE(牛股 AND C>0,O,C,0,0),COLORFFFFFF;

STICKLINE( 牛股 AND C<O,L,H,0,0),COLOR009900;
STICKLINE( 牛股 AND C<O,C,O,3.2,0),COLOR009900;
STICKLINE( 牛股 AND C<O,C,O,2.5,0),COLOR00BB00;
STICKLINE(牛股 AND C<O,C,O,1.5,0),COLOR00DD00;
STICKLINE(牛股 AND C<O,C,O,0.5,0),COLOR00FF00;
STICKLINE(牛股 AND C<O,C,O,0,0),COLORFFFFFF;[/lycode][lycode=tdx2,true]Z1赋值:字符串相加
Z2赋值:字符串相加
Z3赋值:字符串相加
当满足条件是否最后一个周期时,在横轴0纵轴0位置书写文字,画红色
当满足条件是否最后一个周期时,在横轴0.001纵轴0.050位置书写文字,画青色

AHC1赋值:收盘价*成交量(手)
AHC11赋值:(AHC1的1日指数移动平均/成交量(手)的1日指数移动平均+AHC1的2日指数移动平均/成交量(手)的2日指数移动平均+AHC1的4日指数移动平均/成交量(手)的4日指数移动平均+AHC1的6日指数移动平均/成交量(手)的6日指数移动平均)/4的7日指数移动平均,画黄色
输出AHC2:(AHC1的3日指数移动平均/成交量(手)的3日指数移动平均+AHC1的6日指数移动平均/成交量(手)的6日指数移动平均+AHC1的12日指数移动平均/成交量(手)的12日指数移动平均+AHC1的24日指数移动平均/成交量(手)的24日指数移动平均)/4的13日指数移动平均,POINTDOT,画黄色
AHC22赋值:(AHC1的27日指数移动平均/成交量(手)的27日指数移动平均+AHC1的54日指数移动平均/成交量(手)的54日指数移动平均+AHC1的108日指数移动平均/成交量(手)的108日指数移动平均+AHC1的316日指数移动平均/成交量(手)的316日指数移动平均)/4的13日指数移动平均,画白色,POINTDOT
顶赋值:1.3*AHC2
内上赋值:1.06*AHC2
内下赋值:AHC2*0.94
底赋值:AHC2*0.87
输出~11:1.03*AHC2,POINTDOT,画黄色
输出~22:0.97*AHC2,POINTDOT,画黄色
如果(内上<=1日前的内上),返回内上,否则返回无效数,画绿色,DOTLINE,线宽为2
如果(内上>=1日前的内上),返回内上,否则返回无效数,画洋红色,DOTLINE,线宽为2
如果(内下<=1日前的内下),返回内下,否则返回无效数,画绿色,DOTLINE,线宽为2
如果(内下>=1日前的内下),返回内下,否则返回无效数,画洋红色,DOTLINE,线宽为2
K线
ZT赋值:1日前的收盘价*1.1-收盘价<0.01 AND 最高价=收盘价
启爆1赋值:收盘价上穿内上 OR 收盘价上穿内下 AND ZT
当满足条件启爆1时,在最低价*0.98位置书写文字,画黄色
当满足条件启爆1时,在收盘价和开盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,画白色
当满足条件启爆1时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,画绿色
买点赋值:2日前的内下>1日前的内下 AND 内下>1日前的内下
当满足条件买点时,在最低价*0.98位置书写文字画白色
DF赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100<-5
DF4赋值:(收盘价-开盘价)/开盘价*100<-4
AAAA赋值:上次DF距今天数
突破箱体赋值:收盘价上穿AAAA日前的收盘价
输出箱顶:当满足条件DF时,在开盘价位置画直线起点,当满足条件1日前的DF时,在1日前的开盘价位置画直线终点,1表示是否延长.,画洋红色,DOTLINE
输出箱顶1:当满足条件DF4时,在开盘价位置画直线起点,当满足条件1日前的DF4时,在1日前的开盘价位置画直线终点,1表示是否延长.,画洋红色,DOTLINE
箱底赋值:AAAA日内最低价和AAAA日前的最低价的较小值的最低值,画青色,线宽为2
蓝柱赋值:2日前的DF=1 AND ZT AND 收盘价上穿箱顶
当满足条件蓝柱时,在最低价位置书写文字,画绿色
当满足条件蓝柱时,在收盘价和开盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,画黄色
当满足条件蓝柱时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,画蓝色
红柱赋值:1日前的DF=1 AND ZT AND 收盘价上穿箱顶
当满足条件红柱时,在最低价位置书写文字,画红色
当满足条件红柱时,在收盘价和开盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,画黄色
当满足条件红柱时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,画红色
蓝柱1赋值:2日前的DF4=1 AND ZT AND 收盘价上穿箱顶1
当满足条件蓝柱1时,在最低价位置书写文字,画绿色
当满足条件蓝柱1时,在收盘价和开盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,画黄色
当满足条件蓝柱1时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,画蓝色
红柱1赋值:1日前的DF4=1 AND ZT AND 收盘价上穿箱顶1
当满足条件红柱1时,在最低价位置书写文字,画红色
当满足条件红柱1时,在收盘价和开盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,画黄色
当满足条件红柱1时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,画红色
牛股赋值:收盘价>内上 AND 开盘价>内上
当满足条件牛股ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3.2,0不为0则画空心柱.,COLOR000066
当满足条件牛股ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2.0,0不为0则画空心柱.,COLOR000077
当满足条件牛股ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR000099
当满足条件牛股ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为0.9,0不为0则画空心柱.,COLOR0000CC
当满足条件牛股ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR0000FF
当满足条件牛股ANDC>0时,在开盘价和收盘价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFFFFFF
当满足条件牛股ANDC<开盘价时,在最低价和最高价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR009900
当满足条件牛股ANDC<开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3.2,0不为0则画空心柱.,COLOR009900
当满足条件牛股ANDC<开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLOR00BB00
当满足条件牛股ANDC<开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR00DD00
当满足条件牛股ANDC<开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR00FF00
当满足条件牛股ANDC<开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFFFFFF
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1vQIOKGsry6MBqU517rYZ3g

看了该指标的人还看了:
与私募同进出指标    真涨指标,成功率非常高    三碗不过岗指标
主力买卖指标    明明白白指标    绝对底部指标

使用道具 举报

回复