指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 
炒股叉_20190617_105632.png

炒股叉_20190617_105636.png

[lywrap=通达信副图指标公式][lycode=tdx,true]N:=55;
WL:(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100,LINETHICK2,COLOR0000FF;
WLT:MA(WL,89),COLOR00FFFF,LINETHICK2;
WLT1:=CROSS(WL,WLT);
WLT11:=CROSS(WL,-10);
WLT2:=FILTER(WLT1,8);
SKY:10,POINTDOT,COLORFF0000,LINETHICK1;
SEA:-10,POINTDOT,COLORFF00FF,LINETHICK1;
DRAWICON(WLT2,WLT,23);
DRAWICON(WLT11,SEA,15);
WLT3:=COUNT(WL>10,5)>=3;
WLT33:=CROSS(10,WL);
SEL:=WLT3 AND WLT33;
DRAWICON(SEL,10,19);
STICKLINE(WL>10,WL,10,0.001,0),COLOR00FF00;
STICKLINE(WL<-10,WL,-10,0.001,0),COLORFF00FF;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2,COLORSTICK;
DIF底:=LLV(DIF,120);
最底价:=L=LLV(L,120);
距今:=BARSLAST(最底价);
偏离:=IF((距今=0 AND DIF>DIF底),1,0);
DDD:=EXIST(偏离,20) AND SLOPE(DEA,2)>=0;
HRY:=FILTER(DDD,10);
STICKLINE(HRY,-5,-10,3,0),COLOR00FFFF;
DRAWTEXT(HRY,-5,'M背'),COLOR00FFFF;
{YYY:COUNT(偏离,5);}
DIF顶:=HHV(DIF,120);
最高价:=H=HHV(H,120);
距今高:=BARSLAST(最高价);
偏离高:=IF((距今高=0 AND DIF<DIF顶),1,0);
GGG:=EXIST(偏离高,20) AND SLOPE(DEA,2)<0;
HRY1:=FILTER(GGG,10);
STICKLINE(HRY1,10,5,3,0),COLORFF0000;
DRAWTEXT(HRY1,5,'M背'),COLORFF0000;
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));

KDJ底背:FILTER(IF(B2>0,-1,0),13),NODRAW;
STICKLINE(KDJ底背,-10,-5,3,0),COLORFF00FF;
DRAWTEXT(KDJ底背,-5,'K背'),COLORFF00FF;
RSI底背:FILTER(IF(B3>0,-1,0),13),NODRAW;
STICKLINE(RSI底背,-10,-5,3,0),COLOR0000FF;
DRAWTEXT(RSI底背,-5,'R背'),COLOR0000FF;
KDJ顶背:FILTER(IF(D2>0,1,0),13),NODRAW;
STICKLINE(KDJ顶背,10,5,3,0),COLORFFFF00;
DRAWTEXT(KDJ顶背,5,'K背'),COLORFFFF00;
RSI顶背:FILTER(IF(D3>0,1,0),13),NODRAW;
STICKLINE(RSI顶背,10,5,3,0),COLOR00FF00;
DRAWTEXT(RSI顶背,5,'R背'),COLOR00FF00;
DRAWTEXT(REF("KDJ.J",1)<0 AND "KDJ.J">0,-4,'短'),COLORRED ;
STICKLINE(REF("KDJ.J",1)<0 AND "KDJ.J">0,-10,-5,3,0),COLOR00FFFF;
AA1:=HHV(H,55);
BB1:=REF(H,13);
TJ1:=AA1=BB1;
XX:=LLV(L,55);
YY:=REF(L,13);
YY1:=REF(L,21);
TJ2:=XX=YY;
TJ3:=XX=YY1;
XG:=TJ1 OR TJ2;
DRAWTEXT(TJ2,-6,'离底13'),COLOR00FF00;
STICKLINE(TJ2 ,-10,-6,2,0),COLOR00FF00;
DRAWTEXT(TJ3,-4,'离底21'),COLOR00FFFF;
STICKLINE(TJ3 ,-10,-4,2,0),COLOR00FFFF;
DRAWTEXT(TJ1,-6,'离高13'),COLOR0000FF;
STICKLINE(TJ1 ,-10,-6,2,0),COLOR0000FF;
LV:=MA(C,24);
HR0:=HHV(HIGH,N);
HRY0:=LLV(LOW,N);
HRY110:=HR0*HRY0;
HRY330:=SQRT(HRY110);
NS1:=C>HRY330 AND HRY330 >=REF(HRY330,1) AND C>LV;
STICKLINE(C>0,-10,-11.5,3,0),COLORFF0000;
STICKLINE(WLT2 OR WL>WLT,-10,-11.5,3,0),COLOR00FFFF;
STICKLINE(NS1,-10,-11.5,3,0),COLOR0000FF;
DRAWTEXT(FILTER(NS1,21),-11,'持股'),COLORFFFFFF;
DRAWTEXT(FILTER(WLT2 OR WL>WLT,13),-11,'买入'),COLOR0000FF;[/lycode][lycode=tdx2,true]N赋值:55
输出WL:(收盘价-收盘价的6日简单移动平均)/收盘价的6日简单移动平均*100,线宽为2,COLOR0000FF
输出WLT:WL的89日简单移动平均,COLOR00FFFF,线宽为2
WLT1赋值:WL上穿WLT
WLT11赋值:WL上穿-10
WLT2赋值:WLT1的8日过滤
输出SKY:10,POINTDOT,COLORFF0000,线宽为1
输出SEA:-10,POINTDOT,COLORFF00FF,线宽为1
当满足条件WLT2时,在WLT位置画23号图标
当满足条件WLT11时,在SEA位置画15号图标
WLT3赋值:统计5日中满足WL>10的天数>=3
WLT33赋值:10上穿WL
SEL赋值:WLT3 AND WLT33
当满足条件SEL时,在10位置画19号图标
当满足条件WL>10时,在WL和10位置之间画柱状线,宽度为0.001,0不为0则画空心柱.,COLOR00FF00
当满足条件WL<-10时,在WL和-10位置之间画柱状线,宽度为0.001,0不为0则画空心柱.,COLORFF00FF
DIF赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
DEA赋值:DIF的9日指数移动平均
MACD赋值:(DIF-DEA)*2,COLORSTICK
DIF底赋值:120日内DIF的最低值
最底价赋值:最低价=120日内最低价的最低值
距今赋值:上次最底价距今天数
偏离赋值:如果(距今=0ANDDIF>DIF底),返回1,否则返回0
DDD赋值:最近20日存在偏离 AND DEA的2日线性回归斜率>=0
HRY赋值:DDD的10日过滤
当满足条件HRY时,在-5和-10位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00FFFF
当满足条件HRY时,在-5位置书写文字,COLOR00FFFF
DIF顶赋值:120日内DIF的最高值
最高价赋值:最高价=120日内最高价的最高值
距今高赋值:上次最高价距今天数
偏离高赋值:如果(距今高=0ANDDIF<DIF顶),返回1,否则返回0
GGG赋值:最近20日存在偏离高 AND DEA的2日线性回归斜率<0
HRY1赋值:GGG的10日过滤
当满足条件HRY1时,在10和5位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF0000
当满足条件HRY1时,在5位置书写文字,COLORFF0000
A2赋值:上次1日前的"KDJ的K"(9,3,3)上穿"KDJ的D"(9,3,3)距今天数
B2赋值:A2+1日前的收盘价>收盘价 AND A2+1日前的"KDJ的K"(9,3,3)<"KDJ的K"(9,3,3) AND "KDJ的K"(9,3,3)上穿"KDJ的D"(9,3,3)
A3赋值:上次1日前的"RSI的RSI1"(6,12,24)上穿"RSI的RSI2"(6,12,24)距今天数
B3赋值:A3+1日前的收盘价>收盘价 AND A3+1日前的"RSI的RSI1"(6,12,24)<"RSI的RSI1"(6,12,24) AND "RSI的RSI1"(6,12,24)上穿"RSI的RSI2"(6,12,24)
C2赋值:上次1日前的"KDJ的D"(9,3,3)上穿"KDJ的K"(9,3,3)距今天数
D2赋值:C2+1日前的收盘价<收盘价 AND C2+1日前的"KDJ的K"(9,3,3)>"KDJ的K"(9,3,3) AND "KDJ的D"(9,3,3)上穿"KDJ的K"(9,3,3)
C3赋值:上次1日前的"RSI的RSI2"(6,12,24)上穿"RSI的RSI1"(6,12,24)距今天数
D3赋值:C3+1日前的收盘价<收盘价 AND C3+1日前的"RSI的RSI1"(6,12,24)>"RSI的RSI1"(6,12,24) AND "RSI的RSI2"(6,12,24)上穿"RSI的RSI1"(6,12,24)
输出KDJ底背:如果B2>0,返回-1,否则返回0的13日过滤,NODRAW
当满足条件KDJ底背时,在-10和-5位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF00FF
当满足条件KDJ底背时,在-5位置书写文字,COLORFF00FF
输出RSI底背:如果B3>0,返回-1,否则返回0的13日过滤,NODRAW
当满足条件RSI底背时,在-10和-5位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR0000FF
当满足条件RSI底背时,在-5位置书写文字,COLOR0000FF
输出KDJ顶背:如果D2>0,返回1,否则返回0的13日过滤,NODRAW
当满足条件KDJ顶背时,在10和5位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFFFF00
当满足条件KDJ顶背时,在5位置书写文字,COLORFFFF00
输出RSI顶背:如果D3>0,返回1,否则返回0的13日过滤,NODRAW
当满足条件RSI顶背时,在10和5位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00FF00
当满足条件RSI顶背时,在5位置书写文字,COLOR00FF00
当满足条件1日前的"KDJ的J"<0AND"KDJ的J">0时,在-4位置书写文字,画红色
当满足条件1日前的"KDJ的J"<0AND"KDJ的J">0时,在-10和-5位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00FFFF
AA1赋值:55日内最高价的最高值
BB1赋值:13日前的最高价
TJ1赋值:AA1=BB1
XX赋值:55日内最低价的最低值
YY赋值:13日前的最低价
YY1赋值:21日前的最低价
TJ2赋值:XX=YY
TJ3赋值:XX=YY1
XG赋值:TJ1 OR TJ2
当满足条件TJ2时,在-6位置书写文字,COLOR00FF00
当满足条件TJ2时,在-10和-6位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR00FF00
当满足条件TJ3时,在-4位置书写文字,COLOR00FFFF
当满足条件TJ3时,在-10和-4位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR00FFFF
当满足条件TJ1时,在-6位置书写文字,COLOR0000FF
当满足条件TJ1时,在-10和-6位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR0000FF
LV赋值:收盘价的24日简单移动平均
HR0赋值:N日内最高价的最高值
HRY0赋值:N日内最低价的最低值
HRY110赋值:HR0*HRY0
HRY330赋值:HRY110的开方
NS1赋值:收盘价>HRY330 AND HRY330 >=1日前的HRY330 AND 收盘价>LV
当满足条件收盘价>0时,在-10和-11.5位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF0000
当满足条件WLT2ORWL>WLT时,在-10和-11.5位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00FFFF
当满足条件NS1时,在-10和-11.5位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR0000FF
当满足条件NS1的21日过滤时,在-11位置书写文字,COLORFFFFFF
当满足条件WLT2ORWL>WLT的13日过滤时,在-11位置书写文字,COLOR0000FF
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1zwaflogVfCQZK9B1yTN9Jw

看了该指标的人还看了:
与私募同进出指标    真涨指标,成功率非常高    三碗不过岗指标
主力买卖指标    明明白白指标    绝对底部指标

使用道具 举报

回复