指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 抄底逃顶 
炒股叉_20190617_105454.png

炒股叉_20190617_105501.png

[lywrap=通达信副图指标公式][lycode=tdx,true]VAR0:=(2*CLOSE+HIGH+LOW)/4;
VAR1:=(HHV(HIGH,24)-CLOSE)/(HHV(HIGH,24)-LLV(LOW,24))*100;
VAR2:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;
B0:=EMA((VAR0-LLV(LOW,26))/(HHV(HIGH,34)-LLV(LOW,26))*100,16);
AA:SMA(SMA(VAR2,2,1)+3,2,1),COLORRED,LINETHICK1;
浮筹:=EMA(B0,4),LINETHICK1,DOTLINE,COLORYELLOW;
BB:SMA(VAR1,3,1),COLORGREEN,LINETHICK1;
{背景}
STICKLINE(AA>BB,6,90,5,0),COLOR000044;
STICKLINE(BB>AA,6,90,5,0),COLOR422D00;
多方:SMA(SMA(VAR2,2,1)+3,2,1),COLOR0000FF,LINETHICK2;
空方:SMA(VAR1,3,1),COLORFFFF00,LINETHICK1,DOTLINE;
强势线:90,COLORMAGENTA,DOTLINE;
中轴线: 50,COLOR0080FF,DOTLINE;
弱势线:10,COLORLICYAN,DOTLINE;
STICKLINE(多方>强势线,多方,强势线,1,0),COLOR0000FF;
STICKLINE(多方<弱势线,多方,弱势线,1,0),COLOR0000FF;
STICKLINE(空方<弱势线,空方,弱势线,1,0),COLORGREEN;
STICKLINE(空方>强势线,空方,强势线,1,0),COLORGREEN;
LC:= REF(C,1);
VAR02:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR02),13,1)/SMA(MAX(LOW-VAR02,0),13,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);
VAR5:=LLV(LOW,34);
VAR6:=HHV(VAR4,34);
VAR7:=IF(LLV(LOW,56),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
VAR9:=EMA(CLOSE,5);
VAR10:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*(-10);
VAR11:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7*(-1);
VAR12:=EMA(CLOSE,5)*(-1);
力度:=VAR10*5, COLORWHITE,LINETHICK2;
XL1:=MA(LOW,2)*0.96;
XL2:=MA(LOW,26)*0.85;
XL3:=REF(XL1,1)<XL2 AND REF(XL1,1)<XL1 AND REF(XL1,1)<REF(XL1,2);
WR1:=-120*(HHV(HIGH,40)-CLOSE)/(HHV(HIGH,40)-LLV(LOW,40)),COLORGREEN;
超跌:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,60)*100*1.1;
买:力度>7 AND 超跌<-15.5 AND WR1<-100,COLOR3535FF,STICK,LINETHICK1;
DRAWTEXT(买>0,0.0,'买'),COLORFFFFFF;
DRAWICON(买>0,买,1 );
{私募顶底}
趋势:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
见底:=10;
见顶:=90;
短期底部:=CROSS(趋势,见底),COLORRED;
STICKLINE(短期底部,4,40,1,0),COLORRED;
DRAWTEXT(CROSS(趋势,见底),40,'底');
短期顶部:=CROSS(见顶,趋势),COLORGREEN;
STICKLINE(短期顶部,4,40,1,0),COLORGREEN;
DRAWTEXT(CROSS(见顶,趋势),40,'顶'),COLORYELLOW;
RSVV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
VARB2:=(RSVV/2+22)*1;
量:=EMA(VOL,13);
资金:=EMA(AMOUNT,13);
过滤:=((资金 /量) / 100);
提纯:=(((CLOSE -过滤) / 过滤) * 100);
黄金:=((提纯 < (0)) AND ZXNH),COLORRED,NODRAW;
进:IF(黄金 AND RSVV<VARB2-2,28,0),STICK,COLOR464646;
DRAWTEXT(进>0,0.99,'进'),COLORFFFFFF;
DRAWICON(进>0,进,1 );
小股民:= EMA(((2*CLOSE+HIGH+LOW)/4-LLV(LOW,5))/(HHV(HIGH,4)-LLV(LOW,5))*100,4);
庄家:= EMA(0.667*REF(小股民,1)+0.333*小股民,2);
减:100*(CROSS(庄家,小股民) AND 小股民>50),COLOR333333,STICK,LINETHICK1;
DRAWTEXT(减>0,0.99,'减'),COLORFFFF00;
DRAWICON(减>0,减,2 );
STICKLINE(减,0,2,0,1),COLOR0000FF,NODRAW;
A1:=(C-REF(C,1))/REF(C,1)*100;
MA5:=BARSLAST(A1>3);
Z1:=MA(C,13);
ZX:=REF(Z1,13/2+1);
MA20:=IF(MA5>0,1,0);
底:CROSS(C,ZX) AND MA20=0,COLOR464646,STICK,LINETHICK1;
DRAWICON(底>0,底,1 );
STICKLINE(底,0,2,0,9),COLOR0000FF;
主力资金:EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3),
COLORRED,LINETHICK1,NODRAW;
即将爆发线: 65,COLOR00FF00,NODRAW;
爆发线:80,COLORWHITE,LINETHICK1,NODRAW;
DRAWTEXT(CROSS(主力资金,爆发线),主力资金,'爆发') ,COLORYELLOW;
爆发警戒线: 50,COLOR00FF00,NODRAW;
抄底线:20,COLORWHITE,LINETHICK2,NODRAW;
DRAWTEXT(CROSS(主力资金,爆发警戒线),主力资金,'加') ,COLORWHITE;
DRAWTEXT(CROSS(主力资金,即将爆发线),主力资金,'加') ,COLORWHITE;
AA05:=MA(C,5);
五日乖离率:=(C-AA05)/AA05*100;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
翻倍:IF(FILTER(MR,10),1,0)STICK,COLOR464646;
DRAWTEXT(翻倍>0,0.1,'  翻倍'),COLORFFFFFF;
DRAWICON(翻倍>0,翻倍,1 );
DIF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIF,9);
AAA:=(DIF-DEA)*2*60;
启动:CROSS(AAA-REF(AAA,1),15),STICK,COLOR464646;
DRAWTEXT(启动>0,0.0,'  牛启动'),COLORFFFFFF;
DRAWICON(启动>0,启动,1 );[/lycode][lycode=tdx2,true]VAR0赋值:(2*收盘价+最高价+最低价)/4
VAR1赋值:(24日内最高价的最高值-收盘价)/(24日内最高价的最高值-24日内最低价的最低值)*100
VAR2赋值:(收盘价-18日内最低价的最低值)/(18日内最高价的最高值-18日内最低价的最低值)*100
B0赋值:(VAR0-26日内最低价的最低值)/(34日内最高价的最高值-26日内最低价的最低值)*100的16日指数移动平均
输出AA:VAR2的2日[1日权重]移动平均+3的2日[1日权重]移动平均,画红色,线宽为1
浮筹赋值:B0的4日指数移动平均,线宽为1,DOTLINE,画黄色
输出布林极限:VAR1的3日[1日权重]移动平均,画绿色,线宽为1
当满足条件AA>BB时,在6和90位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOR000044
当满足条件BB>AA时,在6和90位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOR422D00
输出多方:VAR2的2日[1日权重]移动平均+3的2日[1日权重]移动平均,COLOR0000FF,线宽为2
输出空方:VAR1的3日[1日权重]移动平均,COLORFFFF00,线宽为1,DOTLINE
输出强势线:90,画洋红色,DOTLINE
输出中轴线: 50,COLOR0080FF,DOTLINE
输出弱势线:10,画淡青色,DOTLINE
当满足条件多方>强势线时,在多方和强势线位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0000FF
当满足条件多方<弱势线时,在多方和弱势线位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0000FF
当满足条件空方<弱势线时,在空方和弱势线位置之间画柱状线,宽度为1,0不为0则画空心柱.,画绿色
当满足条件空方>强势线时,在空方和强势线位置之间画柱状线,宽度为1,0不为0则画空心柱.,画绿色
LC赋值: 1日前的收盘价
VAR02赋值:1日前的最低价
VAR3赋值:最低价-VAR02的绝对值的13日[1日权重]移动平均/最低价-VAR02和0的较大值的13日[1日权重]移动平均*100
VAR4赋值:如果收盘价*1.2,返回VAR3*13,否则返回VAR3/13的13日指数移动平均
VAR5赋值:34日内最低价的最低值
VAR6赋值:34日内VAR4的最高值
VAR7赋值:如果56日内最低价的最低值,返回1,否则返回0
VAR8赋值:如果最低价<=VAR5,返回(VAR4+VAR6*2)/2,否则返回0的3日指数移动平均/618*VAR7
VAR9赋值:收盘价的5日指数移动平均
VAR10赋值:(收盘价-收盘价的34日简单移动平均)/收盘价的34日简单移动平均*(-10)
VAR11赋值:如果最低价<=VAR5,返回(VAR4+VAR6*2)/2,否则返回0的3日指数移动平均/618*VAR7*(-1)
VAR12赋值:收盘价的5日指数移动平均*(-1)
力度赋值:VAR10*5, 画白色,线宽为2
XL1赋值:最低价的2日简单移动平均*0.96
XL2赋值:最低价的26日简单移动平均*0.85
XL3赋值:1日前的XL1<XL2 AND 1日前的XL1<XL1 AND 1日前的XL1<2日前的XL1
WR1赋值:-120*(40日内最高价的最高值-收盘价)/(40日内最高价的最高值-40日内最低价的最低值),画绿色
超跌赋值:(收盘价-收盘价的40日简单移动平均)/收盘价的60日简单移动平均*100*1.1
输出买:力度>7 AND 超跌<-15.5 AND WR1<-100,COLOR3535FF,STICK,线宽为1
当满足条件买>0时,在0.0位置书写文字,COLORFFFFFF
当满足条件买>0时,在买位置画1号图标
趋势赋值:3*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均的3日[1日权重]移动平均
见底赋值:10
见顶赋值:90
短期底部赋值:趋势上穿见底,画红色
当满足条件短期底部时,在4和40位置之间画柱状线,宽度为1,0不为0则画空心柱.,画红色
当满足条件趋势上穿见底时,在40位置书写文字
短期顶部赋值:见顶上穿趋势,画绿色
当满足条件短期顶部时,在4和40位置之间画柱状线,宽度为1,0不为0则画空心柱.,画绿色
当满足条件见顶上穿趋势时,在40位置书写文字,画黄色
RSVV赋值:(收盘价-10日内最低价的最低值)/(10日内最高价的最高值-10日内最低价的最低值)*100
VARB2赋值:(RSVV/2+22)*1
量赋值:成交量(手)的13日指数移动平均
资金赋值:成交额(元)的13日指数移动平均
过滤赋值:((资金 /量) / 100)
提纯赋值:(((收盘价 -过滤) / 过滤) * 100)
黄金赋值:((提纯 < (0)) AND 直线拟合),画红色,NODRAW
输出进:如果黄金ANDRSVV<VARB2-2,返回28,否则返回0,STICK,COLOR464646
当满足条件进>0时,在0.99位置书写文字,COLORFFFFFF
当满足条件进>0时,在进位置画1号图标
小股民赋值: ((2*收盘价+最高价+最低价)/4-5日内最低价的最低值)/(4日内最高价的最高值-5日内最低价的最低值)*100的4日指数移动平均
庄家赋值: 0.667*1日前的小股民+0.333*小股民的2日指数移动平均
输出减:100*(庄家上穿小股民 AND 小股民>50),COLOR333333,STICK,线宽为1
当满足条件减>0时,在0.99位置书写文字,COLORFFFF00
当满足条件减>0时,在减位置画2号图标
当满足条件减时,在0和2位置之间画柱状线,宽度为0,1不为0则画空心柱.,COLOR0000FF,NODRAW
A1赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100
MA5赋值:上次A1>3距今天数
Z1赋值:收盘价的13日简单移动平均
ZX赋值:13/2+1日前的Z1
MA20赋值:如果MA5>0,返回1,否则返回0
输出底:收盘价上穿ZX AND MA20=0,COLOR464646,STICK,线宽为1
当满足条件底>0时,在底位置画1号图标
当满足条件底时,在0和2位置之间画柱状线,宽度为0,9不为0则画空心柱.,COLOR0000FF
输出主力资金:100*(收盘价-34日内最低价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)的3日指数移动平均,画红色,线宽为1,NODRAW
输出即将爆发线: 65,COLOR00FF00,NODRAW
输出爆发线:80,画白色,线宽为1,NODRAW
当满足条件主力资金上穿爆发线时,在主力资金位置书写文字 ,画黄色
输出爆发警戒线: 50,COLOR00FF00,NODRAW
输出抄底线:20,画白色,线宽为2,NODRAW
当满足条件主力资金上穿爆发警戒线时,在主力资金位置书写文字 ,画白色
当满足条件主力资金上穿即将爆发线时,在主力资金位置书写文字 ,画白色
AA05赋值:收盘价的5日简单移动平均
五日乖离率赋值:(收盘价-AA05)/AA05*100
AA30赋值:收盘价的30日简单移动平均
三拾日乖离率赋值:(收盘价-AA30)/AA30*100
MR赋值:统计3日中满足五日乖离率上穿0的天数>=1 AND 三拾日乖离率>1日前的三拾日乖离率 AND AA05>1日前的AA05 AND (收盘价/1日前的收盘价-1)*100>5 AND 1日前的收盘价<AA30
输出翻倍:如果MR的10日过滤,返回1,否则返回0STICK,COLOR464646
当满足条件翻倍>0时,在0.1位置书写文字,COLORFFFFFF
当满足条件翻倍>0时,在翻倍位置画1号图标
DIF赋值:不定周期收盘价的12日指数移动平均-不定周期收盘价的26日指数移动平均
DEA赋值:DIF的9日指数移动平均
AAA赋值:(DIF-DEA)*2*60
输出启动:AAA-1日前的AAA上穿15,STICK,COLOR464646
当满足条件启动>0时,在0.0位置书写文字,COLORFFFFFF
当满足条件启动>0时,在启动位置画1号图标
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1g8PFlZcwX57HenPqG9TuFQ

看了该指标的人还看了:
与私募同进出指标    真涨指标,成功率非常高    三碗不过岗指标
主力买卖指标    明明白白指标    绝对底部指标

使用道具 举报

回复