指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 操盘控盘 
炒股叉_20190617_104955.png

炒股叉_20190617_105000.png


[lywrap=通达信副图指标公式][lycode=tdx,true]A1:=MA(MAX(HHV(H,13),C),2);
A2:=MA(MAX(HHV(H,5),A1),2);
A3:=MA(MAX(HHV(H,3),A2),2);
A4:=MA(MIN(LLV(A3,13),A3),2);
A5:=MA(MIN(LLV(L,13),A4),2);
A6:=(A1+A4+A5)/3;
中线:EMA(SLOPE(MA(C,2),21)*20+MA(C,2),55),COLORGREEN,LINETHICK3;
长线:MA(中线,20);
AC:=IF(C>中线,C*0.98,L),COLORYELLOW;
短A:MA(AC,5);
A8:=IF(C>中线,A1,中线*1.02);
A9:=IF(C>中线,A2,中线*1.02);
A10:=IF(C>中线,A3,中线*1.02);
A11:=(A8+A9+A10)/3;
A12:=MA(A11,10);
短B:MA(短A,5),COLORYELLOW;
DRAWTEXT(CROSS(C,短B),短B,'★'),COLORRED;
DRAWTEXT(CROSS(C,中线),中线,'★'),COLORRED;
DRAWTEXT(CROSS(C,长线),长线,'★'),COLORRED;
DRAWRECTREL(200,10,800,990,90);
DRAWRECTREL(500,100,501,990,60);
DRAWRECTREL(200,100,800,100,60);
DRAWRECTREL(200,200,800,200,60);
DRAWRECTREL(200,300,800,300,60);
DRAWRECTREL(200,400,800,400,60);
DRAWRECTREL(200,500,800,500,60);
DRAWRECTREL(200,600,800,600,60);
DRAWRECTREL(200,700,800,700,60);
DRAWRECTREL(200,800,800,800,60);
DRAWRECTREL(200,900,800,900,60);
DRAWTEXT_FIX(1,0.53,0.05,1,'个 股 综 评'),COLORYELLOW;
DRAWTEXT_FIX(1,0.35,0.15,1,'买 入 条 件'),COLORYELLOW;
DRAWTEXT_FIX(1,0.65,0.15,1,'卖 出 理 由'),COLORYELLOW;
DRAWTEXT_FIX(1,0.285,0.25,1,'股价上穿短B'),COLORYELLOW;
DRAWTEXT_FIX(1,0.29,0.35,1,'股价上穿中线'),COLORYELLOW;
DRAWTEXT_FIX(1,0.29,0.45,1,'股价上穿长线'),COLORYELLOW;
DRAWTEXT_FIX(1,0.322,0.55,1,'股价收阳且小于3点'),COLORYELLOW;
DRAWTEXT_FIX(1,0.288,0.65,1,'量大于昨同期'),COLORYELLOW;
DRAWTEXT_FIX(1,0.292,0.75,1,'乖离率小于1.2'),COLORYELLOW;
DRAWTEXT_FIX(1,0.26,0.95,1,'买入评分'),COLORYELLOW;
DRAWTEXT_FIX(1,0.58,0.25,1,'股价下穿短A'),COLORGREEN;
DRAWTEXT_FIX(1,0.585,0.35,1,'股价下穿中线'),COLORGREEN;
DRAWTEXT_FIX(1,0.585,0.45,1,'股价下穿长线'),COLORGREEN;
DRAWTEXT_FIX(1,0.61,0.55,1,'股价收阴且小于-2'),COLORGREEN;
DRAWTEXT_FIX(1,0.585,0.65,1,'量小于昨同期'),COLORGREEN;
DRAWTEXT_FIX(1,0.59,0.75,1,'乖离率大于1.2'),COLORGREEN;
DRAWTEXT_FIX(1,0.56,0.95,1,'卖出评分'),COLORGREEN;
T1:=CROSS(C,短B)AND EXIST(CROSS(中线,C),5);DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.48,0.25,1,T1);
T2:=CROSS(C,中线);DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.48,0.35,1,T2);
T3:=CROSS(C,长线);DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.48,0.45,1,T3);
T4:=C>REF(C,1) AND C/REF(C,1)<1.031;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.48,0.55,1,T4);
T5:=V>REF(V,1)*FROMOPEN/240;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.48,0.65,1,T5);
T6:=C/中线<1.21;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.48,0.75,1,T6);
买入评分:=T1+T2+T3+T4+T5+T6;
STICKLINE(CURRBARSCOUNT=1 AND C>REF(C,1),C,中线,3,1),COLORRED;
STICKLINE(CURRBARSCOUNT=1 AND C>REF(C,1),长线,中线,2,0),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.48,0.95,1,买入评分);
DRAWRECTREL(930,500,970,990,0);
DRAWRECTREL(930,CONST(990-买入评分*100),970,990,95);
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.95,0.95,1,买入评分),COLORRED;
DRAWTEXT_FIX(1,0.98,0.75,1,'买入评分'),COLORYELLOW;
T7:=CROSS(短A,C);DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.78,0.25,1,T7);
T8:=CROSS(中线,C);DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.78,0.35,1,T8);
T9:=CROSS(中线,C);DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.78,0.45,1,T9);
T10:=C/REF(C,1)<0.98;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.78,0.55,1,T10);
T11:=V<REF(V,1)*FROMOPEN/240;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.78,0.65,1,T11);
T12:=C/中线>1.2;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.78,0.75,1,T12);
卖出评分:=T7+T8+T9+T10+T11+T12;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.78,0.95,1,卖出评分);
量比前1:=V/(REF(V,1)*FROMOPEN/240);
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.35,0.65,1,量比前1);[/lycode][lycode=tdx2,true]A1赋值:13日内最高价的最高值和收盘价的较大值的2日简单移动平均
A2赋值:5日内最高价的最高值和A1的较大值的2日简单移动平均
A3赋值:3日内最高价的最高值和A2的较大值的2日简单移动平均
A4赋值:13日内A3的最低值和A3的较小值的2日简单移动平均
A5赋值:13日内最低价的最低值和A4的较小值的2日简单移动平均
A6赋值:(A1+A4+A5)/3
输出中线:收盘价的2日简单移动平均的21日线性回归斜率*20+收盘价的2日简单移动平均的55日指数移动平均,画绿色,线宽为3
输出长线:中线的20日简单移动平均
AC赋值:如果收盘价>中线,返回收盘价*0.98,否则返回最低价,画黄色
输出短A:AC的5日简单移动平均
A8赋值:如果收盘价>中线,返回A1,否则返回中线*1.02
A9赋值:如果收盘价>中线,返回A2,否则返回中线*1.02
A10赋值:如果收盘价>中线,返回A3,否则返回中线*1.02
A11赋值:(A8+A9+A10)/3
A12赋值:A11的10日简单移动平均
输出短B:短A的5日简单移动平均,画黄色
当满足条件收盘价上穿短B时,在短B位置书写文字,画红色
当满足条件收盘价上穿中线时,在中线位置书写文字,画红色
当满足条件收盘价上穿长线时,在长线位置书写文字,画红色
相对位置上画矩形
相对位置上画矩形
相对位置上画矩形
相对位置上画矩形
相对位置上画矩形
相对位置上画矩形
相对位置上画矩形
相对位置上画矩形
相对位置上画矩形
相对位置上画矩形
相对位置上画矩形
当满足条件1时,在横轴0.53纵轴0.05位置书写文字,画黄色
当满足条件1时,在横轴0.35纵轴0.15位置书写文字,画黄色
当满足条件1时,在横轴0.65纵轴0.15位置书写文字,画黄色
当满足条件1时,在横轴0.285纵轴0.25位置书写文字,画黄色
当满足条件1时,在横轴0.29纵轴0.35位置书写文字,画黄色
当满足条件1时,在横轴0.29纵轴0.45位置书写文字,画黄色
当满足条件1时,在横轴0.322纵轴0.55位置书写文字,画黄色
当满足条件1时,在横轴0.288纵轴0.65位置书写文字,画黄色
当满足条件1时,在横轴0.292纵轴0.75位置书写文字,画黄色
当满足条件1时,在横轴0.26纵轴0.95位置书写文字,画黄色
当满足条件1时,在横轴0.58纵轴0.25位置书写文字,画绿色
当满足条件1时,在横轴0.585纵轴0.35位置书写文字,画绿色
当满足条件1时,在横轴0.585纵轴0.45位置书写文字,画绿色
当满足条件1时,在横轴0.61纵轴0.55位置书写文字,画绿色
当满足条件1时,在横轴0.585纵轴0.65位置书写文字,画绿色
当满足条件1时,在横轴0.59纵轴0.75位置书写文字,画绿色
当满足条件1时,在横轴0.56纵轴0.95位置书写文字,画绿色
T1赋值:收盘价上穿短BAND 最近5日存在中线上穿收盘价
当满足条件到最后交易的周期=1时,在横轴0.48纵轴0.25位置书写数字
T2赋值:收盘价上穿中线
当满足条件到最后交易的周期=1时,在横轴0.48纵轴0.35位置书写数字
T3赋值:收盘价上穿长线
当满足条件到最后交易的周期=1时,在横轴0.48纵轴0.45位置书写数字
T4赋值:收盘价>1日前的收盘价 AND 收盘价/1日前的收盘价<1.031
当满足条件到最后交易的周期=1时,在横轴0.48纵轴0.55位置书写数字
T5赋值:成交量(手)>1日前的成交量(手)*当前离开盘分钟数/240
当满足条件到最后交易的周期=1时,在横轴0.48纵轴0.65位置书写数字
T6赋值:收盘价/中线<1.21
当满足条件到最后交易的周期=1时,在横轴0.48纵轴0.75位置书写数字
买入评分赋值:T1+T2+T3+T4+T5+T6
当满足条件到最后交易的周期=1ANDC>1日前的收盘价时,在收盘价和中线位置之间画柱状线,宽度为3,1不为0则画空心柱.,画红色
当满足条件到最后交易的周期=1ANDC>1日前的收盘价时,在长线和中线位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色
当满足条件到最后交易的周期=1时,在横轴0.48纵轴0.95位置书写数字
相对位置上画矩形
相对位置上画矩形
当满足条件到最后交易的周期=1时,在横轴0.95纵轴0.95位置书写数字,画红色
当满足条件1时,在横轴0.98纵轴0.75位置书写文字,画黄色
T7赋值:短A上穿收盘价
当满足条件到最后交易的周期=1时,在横轴0.78纵轴0.25位置书写数字
T8赋值:中线上穿收盘价
当满足条件到最后交易的周期=1时,在横轴0.78纵轴0.35位置书写数字
T9赋值:中线上穿收盘价
当满足条件到最后交易的周期=1时,在横轴0.78纵轴0.45位置书写数字
T10赋值:收盘价/1日前的收盘价<0.98
当满足条件到最后交易的周期=1时,在横轴0.78纵轴0.55位置书写数字
T11赋值:成交量(手)<1日前的成交量(手)*当前离开盘分钟数/240
当满足条件到最后交易的周期=1时,在横轴0.78纵轴0.65位置书写数字
T12赋值:收盘价/中线>1.2
当满足条件到最后交易的周期=1时,在横轴0.78纵轴0.75位置书写数字
卖出评分赋值:T7+T8+T9+T10+T11+T12
当满足条件到最后交易的周期=1时,在横轴0.78纵轴0.95位置书写数字
量比前1赋值:成交量(手)/(1日前的成交量(手)*当前离开盘分钟数/240)
当满足条件到最后交易的周期=1时,在横轴0.35纵轴0.65位置书写数字
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1ulhqXyC_fXmPrwjiM9Wp6Q

看了该指标的人还看了:
与私募同进出指标    真涨指标,成功率非常高    三碗不过岗指标
主力买卖指标    明明白白指标    绝对底部指标

使用道具 举报

回复