指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 买卖点 
炒股叉_20190527_101252.png

炒股叉_20190527_101300.png

[lywrap=通达信主图指标公式][lycode=tdx,true]时限:=IF(DATE+19000000>20110301,0,1);
DRAWTEXT(时限=0 AND ISLASTBAR=1,C,'公式的使用时间限制到了,请联系作者'),LINETHICK3,COLORYELLOW;
CDP:=时限*(REF(H,1)+REF(L,1)+2*REF(C,1))/4;
高:时限*CDP+(H-L),COLORGREEN,NODRAW;
卖:时限*CDP*2-L,COLORCYAN,NODRAW;
阻:时限*((H+O+L+C)/4)-L+DYNAINFO(21),COLORWHITE,NODRAW;
支:时限*DYNAINFO(20)-(((H+L+8*C)/10)-L),COLORYELLOW,NODRAW;
买:时限*CDP*2-H,COLORMAGENTA,NODRAW;
低:CDP-(H-L),COLORRED,NODRAW;
价:C,COLORWHITE,NODRAW;
单股:LLV(MA(HIGH,(3)),1),LINETHICK1,COLORRED;
双币:HHV(MA(HIGH,(3)),2),LINETHICK0,COLORCYAN;
DRAWBAND(单股,RGB(250,10,10),双币,RGB(10,200,10));
DRAWKLINE(H,O,L,C);
PH:=TROUGHBARS(2,5,1);
LL:=HHV(H,PH);
TJ1:=LL=HIGH AND LL<REF(LL,1);
TS:=SUMBARS(TJ1,2);
TJ:=PEAKBARS(2,5,1)=1 AND TS>=PH;
DRAWICON(TJ,HIGH*1.01+0.02,2);
YGB1:=MA(CLOSE,5);
YGB2:=MA(CLOSE,10);
YGB3:=MA(CLOSE,20);
X1:=EMA(C,7);
DRAWICON(FILTER(YGB3 AND YGB2 AND COUNT(X1<REF(X1,1),5)>2 AND X1>REF(X1,1),3),L,1);
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT(CROSS(75,RSI), HIGH*1.01,'  卖'),COLORWHITE;
STICKLINE(C>REF(C,1)*1.099,C,O,2.7,0)COLORRED,LINETHICK2;
STICKLINE(C<REF(C,1)*0.901,C,O,2.7,0)COLORGREEN,LINETHICK2;
N1:=(3,30,10);
箱顶:=PEAK(CLOSE,N1,1)*0.98,COLORGREEN,LINETHICK1;
箱底:=TROUGH(CLOSE,N1,1)*1.02,COLORCYAN,LINETHICK1;
N:=(80,120,102);
M:=(2,20,7);
AA:=MA((2*CLOSE+HIGH+LOW)/4,5);
道1:=AA*N/100,COLORBLUE;
道2:=AA*(200-N)/100,COLORGREEN;
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
道3:=(1+M/100)*DD,COLORCYAN;
道4:=(1-M/100)*DD,COLORGRAY;
MB1:=EMA(WINNER(C)*100,5),COLORYELLOW;
MB2:=EMA(MB1,2),COLORBLUE;
MB3:=EMA(MB2,2),COLORBLUE;
MB4:=EMA(MB3,2),COLORBLUE;
MB5:=EMA(MB4,2),COLORBLUE;
MB6:=EMA(MB5,2),COLORBLUE;
MB7:=EMA(MB6,2),COLORBLUE;
MB8:=EMA(MB7,2),COLORBLUE;
MB9:=EMA(MB8,2),COLORBLUE;
MB10:=EMA(MB9,2),COLORBLUE;
MB11:=EMA(MB10,2),COLORBLUE;
MB12:=EMA(MB11,2),COLORBLUE;
MB13:=EMA(MB12,2),COLORBLUE;
MB14:=EMA(MB13,2),COLORBLUE;
VAR3:=DRAWLINE(MB1>=HHV(MB1,5)=1,MB1,MB1<=LLV(MB1,5)=1,MB1,1),COLORWHITE;
XG1:=REF(MB1,1)=REF(VAR3,1) AND REF(MB1,1)<REF(MB4,1);
XG2:=REF(MB1,1)=REF(VAR3,1) AND MB1>REF(MB1,1);
XG3:=时限*C>箱底;
DRAWTEXT(XG1 AND XG2 AND XG3,L,'  买'),COLORYELLOW;
STICKLINE(REF(C,1)>REF(箱顶,1) AND C<箱顶,MIN(O,C)+ABS(C-O)*0.75,MAX(O,C),2.7,0),COLORBLUE;
DRAWTEXT(MB1=VAR3 AND MB1<MB4,MIN(O,C)+ABS(C-O)*0.5,'  ★'),COLORMAGENTA;
DRAWTEXT(XG2,MIN(O,C)+ABS(C-O)*0.5,'   ★'),COLORYELLOW;
VC:=(2*C+H+L)/4;
VD:=LLV(L,3);
VE:=HHV(H,3);
V12:=EMA((VC-VD)/(VE-VD)*100,5);
V13:=EMA(V12,2);
IF(V12>V13,双币,DRAWNULL),COLORRED,LINETHICK1;
RSI2:=SMA(RSI,6,1);
IF(RSI>RSI2,单股,DRAWNULL),COLORRED,LINETHICK1;
YGBLQH1:=(HHV(H,36)-C)/(HHV(H,36)-LLV(L,36))*100;
YGBLQH2:=SMA(YGBLQH1,5,1);
YGBLQH3:=SMA(YGBLQH2,8,1);
DRAWICON(CROSS(YGBLQH2,YGBLQH3) AND YGBLQH3<20,H*1.03,2);
VARYGB2:=TROUGHBARS(3,15,1)<10;
VARYGB3:=PEAKBARS(3,15,1)<10;
VARYGB4:=IF(VARYGB2=1,50,0);
VARYGB5:=IF(VARYGB3=1,50,0);
底部:=时限*IF(VARYGB4=50,10,0);
YGBLQH:=IF(底部=10 AND REF(底部,1)=10 AND REF(底部,2)=0,25,0),COLORCYAN,LINETHICK1;
DRAWTEXT(底部=10 AND REF(底部,1)=10 AND REF(底部,2)=0,MIN(O,C)+ABS(C-O)*0.5,'▲'),COLORYELLOW;
DRAWTEXT(TROUGHBARS(3,10,1)=0 AND HIGH>LOW+0.01,MIN(O,C)+ABS(C-O)*0.5,'▲'),COLORMAGENTA;[/lycode][lycode=tdx2,true]时限赋值:如果日期+19000000>20110301,返回0,否则返回1
当满足条件时限=0ANDISLASTBAR=1时,在收盘价位置书写文字,线宽为3,画黄色
CDP赋值:时限*(1日前的最高价+1日前的最低价+2*1日前的收盘价)/4
输出高:时限*CDP+(最高价-最低价),画绿色,NODRAW
输出卖:时限*CDP*2-最低价,画青色,NODRAW
输出阻:时限*((最高价+开盘价+最低价+收盘价)/4)-最低价+卖价(即卖一价),画白色,NODRAW
输出支:时限*买价(即买一价)-(((最高价+最低价+8*收盘价)/10)-最低价),画黄色,NODRAW
输出买:时限*CDP*2-最高价,画洋红色,NODRAW
输出低:CDP-(最高价-最低价),画红色,NODRAW
输出价:收盘价,画白色,NODRAW
输出单股:1日内最高价的(3)日简单移动平均的最低值,线宽为1,画红色
输出双币:2日内最高价的(3)日简单移动平均的最高值,线宽为0,画青色
画带状线
K线
PH赋值:最低价5%之字转向的前1个波谷位置
LL赋值:PH日内最高价的最高值
TJ1赋值:LL=最高价 AND LL<1日前的LL
TS赋值:TJ1累加至2的天数
TJ赋值:最低价5%之字转向的前1个波峰位置=1 AND TS>=PH
当满足条件TJ时,在最高价*1.01+0.02位置画2号图标
YGB1赋值:收盘价的5日简单移动平均
YGB2赋值:收盘价的10日简单移动平均
YGB3赋值:收盘价的20日简单移动平均
X1赋值:收盘价的7日指数移动平均
当满足条件YGB3ANDYGB2ANDCOUNT(X1<1日前的X1,5)>2ANDX1>1日前的X1的3日过滤时,在最低价位置画1号图标
LC赋值:1日前的收盘价
RSI赋值:收盘价-LC和0的较大值的6日[1日权重]移动平均/收盘价-LC的绝对值的6日[1日权重]移动平均*100
当满足条件75上穿RSI时,在最高价*1.01位置书写文字,画白色
当满足条件收盘价>1日前的收盘价*1.099时,在收盘价和开盘价位置之间画柱状线,宽度为2.7,0不为0则画空心柱.画红色,线宽为2
当满足条件收盘价<1日前的收盘价*0.901时,在收盘价和开盘价位置之间画柱状线,宽度为2.7,0不为0则画空心柱.画绿色,线宽为2
N1赋值:(3,30,10)
箱顶赋值:收盘价N1%之字转向的前1个波峰值*0.98,画绿色,线宽为1
箱底赋值:收盘价N1%之字转向的前1个波谷值*1.02,画青色,线宽为1
N赋值:(80,120,102)
M赋值:(2,20,7)
AA赋值:(2*收盘价+最高价+最低价)/4的5日简单移动平均
道1赋值:AA*N/100,画蓝色
道2赋值:AA*(200-N)/100,画绿色
CC赋值:(2*收盘价+最高价+最低价)/4-收盘价的20日简单移动平均的绝对值/收盘价的20日简单移动平均
DD赋值:以CC为权重收盘价的动态移动平均
道3赋值:(1+M/100)*DD,画青色
道4赋值:(1-M/100)*DD,画深灰色
MB1赋值:以收盘价计算的获利盘比例*100的5日指数移动平均,画黄色
MB2赋值:MB1的2日指数移动平均,画蓝色
MB3赋值:MB2的2日指数移动平均,画蓝色
MB4赋值:MB3的2日指数移动平均,画蓝色
MB5赋值:MB4的2日指数移动平均,画蓝色
MB6赋值:MB5的2日指数移动平均,画蓝色
MB7赋值:MB6的2日指数移动平均,画蓝色
MB8赋值:MB7的2日指数移动平均,画蓝色
MB9赋值:MB8的2日指数移动平均,画蓝色
MB10赋值:MB9的2日指数移动平均,画蓝色
MB11赋值:MB10的2日指数移动平均,画蓝色
MB12赋值:MB11的2日指数移动平均,画蓝色
MB13赋值:MB12的2日指数移动平均,画蓝色
MB14赋值:MB13的2日指数移动平均,画蓝色
VAR3赋值:当满足条件MB1>=5日内MB1的最高值=1时,在MB1位置画直线起点,当满足条件MB1<=5日内MB1的最低值=1时,在MB1位置画直线终点,1表示是否延长.,画白色
XG1赋值:1日前的MB1=1日前的VAR3 AND 1日前的MB1<1日前的MB4
XG2赋值:1日前的MB1=1日前的VAR3 AND MB1>1日前的MB1
XG3赋值:时限*收盘价>箱底
当满足条件XG1ANDXG2ANDXG3时,在最低价位置书写文字,画黄色
当满足条件1日前的收盘价>1日前的箱顶ANDC<箱顶时,在开盘价和收盘价的较小值+收盘价-开盘价的绝对值*0.75和开盘价和收盘价的较大值位置之间画柱状线,宽度为2.7,0不为0则画空心柱.,画蓝色
当满足条件MB1=VAR3ANDMB1<MB4时,在开盘价和收盘价的较小值+收盘价-开盘价的绝对值*0.5位置书写文字,画洋红色
当满足条件XG2时,在开盘价和收盘价的较小值+收盘价-开盘价的绝对值*0.5位置书写文字,画黄色
VC赋值:(2*收盘价+最高价+最低价)/4
VD赋值:3日内最低价的最低值
VE赋值:3日内最高价的最高值
V12赋值:(VC-VD)/(VE-VD)*100的5日指数移动平均
V13赋值:V12的2日指数移动平均
如果V12>V13,返回双币,否则返回无效数,画红色,线宽为1
RSI2赋值:RSI的6日[1日权重]移动平均
如果RSI>RSI2,返回单股,否则返回无效数,画红色,线宽为1
YGBLQH1赋值:(36日内最高价的最高值-收盘价)/(36日内最高价的最高值-36日内最低价的最低值)*100
YGBLQH2赋值:YGBLQH1的5日[1日权重]移动平均
YGBLQH3赋值:YGBLQH2的8日[1日权重]移动平均
当满足条件YGBLQH2上穿YGBLQH3ANDYGBLQH3<20时,在最高价*1.03位置画2号图标
VARYGB2赋值:收盘价15%之字转向的前1个波谷位置<10
VARYGB3赋值:收盘价15%之字转向的前1个波峰位置<10
VARYGB4赋值:如果VARYGB2=1,返回50,否则返回0
VARYGB5赋值:如果VARYGB3=1,返回50,否则返回0
底部赋值:时限*如果VARYGB4=50,返回10,否则返回0
YGBLQH赋值:如果底部=10ANDREF(底部,1)=10ANDREF(底部,2)=0,返回25,否则返回0,画青色,线宽为1
当满足条件底部=10ANDREF(底部,1)=10ANDREF(底部,2)=0时,在开盘价和收盘价的较小值+收盘价-开盘价的绝对值*0.5位置书写文字,画黄色
当满足条件收盘价10%之字转向的前1个波谷位置=0ANDHIGH>最低价+0.01时,在开盘价和收盘价的较小值+收盘价-开盘价的绝对值*0.5位置书写文字,画洋红色
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1k7yyxI5CQ6WkYWbTWDA4jg

看了该指标的人还看了:
绝佳买点指标    股海神偷指标    短线追踪指标
估抄底F指标    压力走势指标    中线指标

使用道具 举报

回复