指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 
炒股叉_20190524_104357.png

炒股叉_20190524_104411.png

[lywrap=通达信主图指标公式][lycode=tdx,true]买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWICON(BU,L-0.1,1);
DRAWICON(SEL,H+0.1,2);
STICKLINE(买线>=卖线,LOW,HIGH,0.0,1),COLORRED;
STICKLINE(买线>=卖线,CLOSE,OPEN,2,1),COLORRED;
STICKLINE(买线<卖线,LOW,HIGH,0.0,1),COLORGREEN;
STICKLINE(买线<卖线,CLOSE,OPEN,2,1),COLORGREEN;
STICKLINE(BU,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(SEL,OPEN,CLOSE,2,0),COLORBLUE;

主力:EMA(CLOSE,10),COLORRED;
散户:EMA(CLOSE,5),COLORWHITE;
绿降:(46.18*EMA(CLOSE,10)-31.82*EMA(CLOSE,4))/14.36,COLORGREEN,LINETHICK1;
操盘:MA(CLOSE,9),COLORCYAN,LINETHICK2;
界点:MA(CLOSE,20),COLORMAGENTA;

LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),'底背离'),COLOR0000FF;

AA:=(HHV(HIGH,20) - (2 * ATR));
BB:=CROSS(CLOSE,REF(HHV(HIGH,55),1));
SSS:=CROSS(MIN(MA(CLOSE,13),AA),CLOSE);
BBB:=BARSLAST(BB);
SSSB:=BARSLAST(SSS);
B1:=((BBB = 0) AND (REF(SSSB,1) < REF(BBB,1)));
B1B:=BARSLAST(B1);
B2:=((((BB = 1) AND (B1B < SSSB)) AND (B1B > 0)) AND (COUNT(BB,SSSB) < 3));
B2B:=BARSLAST(B2);
B3:=((((BB = 1) AND (B2B < B1B)) AND (COUNT(BB,SSSB) < 4)) AND (COUNT(BB,SSSB) > 2));
DRAWTEXT((B1 = 1),(LOW - 0.6),'跟进'),COLORYELLOW;
DRAWTEXT((B2 = 1),(LOW - 0.6),'加码'),COLORFFAAFF;[/lycode][lycode=tdx2,true]买线赋值:收盘价的2日指数移动平均
卖线赋值:收盘价的21日线性回归斜率*20+收盘价的42日指数移动平均
BU赋值:买线上穿卖线
SEL赋值:卖线上穿买线
当满足条件BU时,在最低价-0.1位置画1号图标
当满足条件SEL时,在最高价+0.1位置画2号图标
当满足条件买线>=卖线时,在最低价和最高价位置之间画柱状线,宽度为0.0,1不为0则画空心柱.,画红色
当满足条件买线>=卖线时,在收盘价和开盘价位置之间画柱状线,宽度为2,1不为0则画空心柱.,画红色
当满足条件买线<卖线时,在最低价和最高价位置之间画柱状线,宽度为0.0,1不为0则画空心柱.,画绿色
当满足条件买线<卖线时,在收盘价和开盘价位置之间画柱状线,宽度为2,1不为0则画空心柱.,画绿色
当满足条件BU时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色
当满足条件SEL时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,画蓝色
输出主力:收盘价的10日指数移动平均,画红色
输出散户:收盘价的5日指数移动平均,画白色
输出绿降:(46.18*收盘价的10日指数移动平均-31.82*收盘价的4日指数移动平均)/14.36,画绿色,线宽为1
输出操盘:收盘价的9日简单移动平均,画青色,线宽为2
输出界点:收盘价的20日简单移动平均,画洋红色
LC赋值:1日前的收盘价
RSI赋值:(((收盘价-LC)和0的较大值的3日[1日权重]移动平均 / (收盘价-LC)的绝对值的3日[1日权重]移动平均) * 100)
FF赋值:收盘价的3日指数移动平均
MA15赋值:收盘价的21日指数移动平均
当满足条件FF上穿MA15时,在(最低价*0.99)位置书写文字,COLOR0000FF
AA赋值:(20日内最高价的最高值 - (2 * 真实波幅))
BB赋值:收盘价上穿1日前的55日内最高价的最高值
SSS赋值:收盘价的13日简单移动平均和AA的较小值上穿收盘价
BBB赋值:上次BB距今天数
SSSB赋值:上次SSS距今天数
B1赋值:((BBB = 0) AND (1日前的SSSB < 1日前的BBB))
B1B赋值:上次B1距今天数
B2赋值:((((BB = 1) AND (B1B < SSSB)) AND (B1B > 0)) AND (统计SSSB日中满足BB的天数 < 3))
B2B赋值:上次B2距今天数
B3赋值:((((BB = 1) AND (B2B < B1B)) AND (统计SSSB日中满足BB的天数 < 4)) AND (统计SSSB日中满足BB的天数 > 2))
当满足条件(B1=1)时,在(最低价-0.6)位置书写文字,画黄色
当满足条件(B2=1)时,在(最低价-0.6)位置书写文字,COLORFFAAFF
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1aeL88FKv9kejnpzUq3IyLg

看了该指标的人还看了:
绝佳买点指标    股海神偷指标    短线追踪指标
估抄底F指标    压力走势指标    中线指标

使用道具 举报

回复