指标公式
软件: 通达信 
公式类型: 副图 
二级分类: KDJ指标 MACD指标 波段 短线 买卖点 
炒股叉_20190523_095239.png

炒股叉_20190523_095245.png

[lywrap=通达信副图指标公式][lycode=tdx,true]N:=9;{参数:         N:     1   100   9,M1: 1   100   3,M2: 1   100   3}
M1:=100;
M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1),LINETHICK2,COLORWHITE;
D:=SMA(K,M2,1),COLORYELLOW;
量能:=3*K-2*D,LINETHICK2;
RSIE:=EMA(量能,3);
DIFF : EMA(RSIE,12) - EMA(RSIE,26);
BBDIFF:=DIFF-REF(DIFF,1);
DEA  : EMA(DIFF,9);
DRAWBAND(DIFF,RGB(255,105,180),DEA,RGB(34,139,34));
BBDEA:=DEA-REF(DEA,1);
MACD : 2*(DIFF-DEA), COLORSTICK;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2,0),COLORFFFF00;
STICKLINE(MACD<REF(MACD,1)AND MACD<0,0,MACD,2,0),COLOR00FF00;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2,0),COLOR0099FF;
STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,MACD,2,0),COLORRED;
0,COLORFF8855,LINETHICK2;
IF(DIFF>DEA,DIFF,DRAWNULL),COLORRED,LINETHICK2;
IF(DEA>REF(DEA,1),DEA,DRAWNULL),COLORMAGENTA;
DRAWICON(CROSS(DIFF,DEA),DEA,1);
DRAWICON(CROSS(DEA,DIFF),DEA,2);
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
STICKLINE(低位金叉,0,-1.5,2,0),COLORFFFF00;
DRAWTEXT(低位金叉,-1.5, 低位金叉),COLORFFFF00;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,-1,5,0),COLORFF00FF;
DRAWICON(二次金叉,DEA*1.2,11) ;
DRAWTEXT(二次金叉,-1, 二次金叉),COLORFF00FF;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
STICKLINE(底背离,0,1.5,3,0),COLOR00FF00;
DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK2;
DRAWTEXT(底背离,2, 底背离),COLOR00FF00;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
STICKLINE(顶背离,0,2,3,0),COLORFF8855;
DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORFF8855,LINETHICK2;
DRAWTEXT(顶背离,2, 顶背离),COLORFF8855;[/lycode][lycode=tdx2,true]N赋值:9
M1赋值:100
M2赋值:3
RSV赋值:(收盘价-N日内最低价的最低值)/(N日内最高价的最高值-N日内最低价的最低值)*100
K赋值:RSV的M1日[1日权重]移动平均,线宽为2,画白色
D赋值:K的M2日[1日权重]移动平均,画黄色
量能赋值:3*K-2*D,线宽为2
RSIE赋值:量能的3日指数移动平均
输出DIFF : RSIE的12日指数移动平均 - RSIE的26日指数移动平均
BBDIFF赋值:DIFF-1日前的DIFF
输出DEA  : DIFF的9日指数移动平均
画带状线
BBDEA赋值:DEA-1日前的DEA
输出平滑异同平均 : 2*(DIFF-DEA), COLORSTICK
当满足条件平滑异同平均<1日前的平滑异同平均ANDMACD>0时,在0和平滑异同平均位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLORFFFF00
当满足条件平滑异同平均<1日前的平滑异同平均ANDMACD<0时,在0和平滑异同平均位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR00FF00
当满足条件平滑异同平均>1日前的平滑异同平均ANDMACD<0时,在0和平滑异同平均位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR0099FF
当满足条件平滑异同平均>1日前的平滑异同平均ANDMACD>0时,在0和平滑异同平均位置之间画柱状线,宽度为2,0不为0则画空心柱.,画红色
0,COLORFF8855,线宽为2
如果DIFF>DEA,返回DIFF,否则返回无效数,画红色,线宽为2
如果DEA>1日前的DEA,返回DEA,否则返回无效数,画洋红色
当满足条件DIFF上穿DEA时,在DEA位置画1号图标
当满足条件DEA上穿DIFF时,在DEA位置画2号图标
低位金叉赋值:DIFF上穿DEA AND DIFF<-0.1
当满足条件低位金叉时,在0和-1.5位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLORFFFF00
当满足条件低位金叉时,在-1.5位置书写文字,COLORFFFF00
JCCOUNT赋值:统计上次DEA>=0距今天数日中满足DIFF上穿DEA的天数
二次金叉赋值:DIFF上穿DEA AND DEA<0 AND 统计21日中满足JCCOUNT=2的天数=1
当满足条件二次金叉时,在0和-1位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLORFF00FF
当满足条件二次金叉时,在DEA*1.2位置画11号图标
当满足条件二次金叉时,在-1位置书写文字,COLORFF00FF
A1赋值:上次1日前的DIFF上穿DEA距今天数
底背离赋值:A1+1日前的收盘价>收盘价 AND DIFF>A1+1日前的DIFF AND DIFF上穿DEA
当满足条件底背离时,在0和1.5位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00FF00
当满足条件A1=0时,在DEA位置画直线起点,当满足条件底背离时,在DEA位置画直线终点,0表示是否延长.,画红色,线宽为2
当满足条件底背离时,在2位置书写文字,COLOR00FF00
A2赋值:上次1日前的DEA上穿DIFF距今天数
顶背离赋值:A2+1日前的收盘价<收盘价 AND A2+1日前的DIFF>DIFF AND DEA上穿DIFF
当满足条件顶背离时,在0和2位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF8855
当满足条件A2=0时,在DEA位置画直线起点,当满足条件顶背离时,在DEA位置画直线终点,0表示是否延长.,COLORFF8855,线宽为2
当满足条件顶背离时,在2位置书写文字,COLORFF8855
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1lAfmle8glVTa3YEqOBMZpQ

看了该指标的人还看了:
叶公跟庄指标    股海神偷指标    降龙贰式指标
均线进多头指标    主力主升指标    画线指标指标

使用道具 举报

回复