指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 买卖点 
炒股叉_20190522_093445.png

炒股叉_20190522_093455.png

[lywrap=通达信主图指标公式][lycode=tdx,true]M5:MA(CLOSE,5);
M10:MA(CLOSE,10);
M30:MA(CLOSE,30);
VAR1:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),25);
VAR2:=HIGH-REF(HIGH,1);
VAR3:=REF(LOW,1)-LOW;
VAR4:=SUM(IF(VAR2>0 AND VAR2>VAR3,VAR2,0),25);
VAR5:=SUM(IF(VAR3>0 AND VAR3>VAR2,VAR3,0),25);
VAR6:=VAR4*100/VAR1;
VAR7:=VAR5*100/VAR1;
VAR8:=MA(ABS(VAR7-VAR6)/(VAR7+VAR6)*100,15);
VAR9:=(VAR8+REF(VAR8,15))/2;
BUY1:=ZIG(3,10);
SELL1:=MA(BUY1,2);
DRAWICON(CROSS(BUY1,SELL1),L-0.1,7);
DRAWICON(CROSS(SELL1,BUY1),H+0.1,8);
STICKLINE(BUY1>SELL1 AND O>=C,C,O,-1,0),COLORRED;
STICKLINE(BUY1>SELL1 AND O>=C,L,H,0,0),COLORRED;
STICKLINE(BUY1<SELL1 AND O<=C,O,C,-1,1),COLORCYAN;
STICKLINE(BUY1<SELL1 AND O<=C,O,L,0,1),COLORCYAN;
STICKLINE(BUY1<SELL1 AND O<=C,C,H,0,1),COLORCYAN;
VAR11:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR12:=SMA(VAR11,3,1);
VAR13:=SMA(VAR12,3,1);
VAR14:=VAR13 AND VAR13<20;
LJB:=1/WINNER(CLOSE);[/lycode][lycode=tdx2,true]输出M5:收盘价的5日简单移动平均
输出M10:收盘价的10日简单移动平均
输出M30:收盘价的30日简单移动平均
VAR1赋值:最高价-最低价和最高价-1日前的收盘价的绝对值的较大值和最低价-1日前的收盘价的绝对值的较大值的25日累和
VAR2赋值:最高价-1日前的最高价
VAR3赋值:1日前的最低价-最低价
VAR4赋值:如果VAR2>0ANDVAR2>VAR3,返回VAR2,否则返回0的25日累和
VAR5赋值:如果VAR3>0ANDVAR3>VAR2,返回VAR3,否则返回0的25日累和
VAR6赋值:VAR4*100/VAR1
VAR7赋值:VAR5*100/VAR1
VAR8赋值:VAR7-VAR6的绝对值/(VAR7+VAR6)*100的15日简单移动平均
VAR9赋值:(VAR8+15日前的VAR8)/2
BUY1赋值:收盘价10%的之字转向
SELL1赋值:BUY1的2日简单移动平均
当满足条件BUY1上穿SELL1时,在最低价-0.1位置画7号图标
当满足条件SELL1上穿BUY1时,在最高价+0.1位置画8号图标
当满足条件BUY1>SELL1ANDO>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为-1,0不为0则画空心柱.,画红色
当满足条件BUY1>SELL1ANDO>=收盘价时,在最低价和最高价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画红色
当满足条件BUY1<SELL1ANDO<=收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为-1,1不为0则画空心柱.,画青色
当满足条件BUY1<SELL1ANDO<=收盘价时,在开盘价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画青色
当满足条件BUY1<SELL1ANDO<=收盘价时,在收盘价和最高价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画青色
VAR11赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
VAR12赋值:VAR11的3日[1日权重]移动平均
VAR13赋值:VAR12的3日[1日权重]移动平均
VAR14赋值:VAR13 AND VAR13<20
LJB赋值:1/以收盘价计算的获利盘比例
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1XL1hwEGxqaepI3elhDsAyw

看了该指标的人还看了:
RSI突破下降趋势线指标    股海神偷指标    高抛低吸指标
抄死主力指标    股神短线指标    多空电波指标

使用道具 举报

回复