指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 抄底逃顶 
炒股叉_20190521_093700.png
炒股叉_20190521_093631.png


[lywrap=通达信副图指标公式][lycode=tdx,true]VARA:=BARSCOUNT(CLOSE)*3.142/180;
A2: SIN(VARA*8)*100,LINETHICK2;
A3: COS(VARA*8)*100,LINETHICK2;
X1: 0;
VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,10);
VAR3:=MA(CLOSE,20);
VAR4:=MA(CLOSE,30);
VAR5:=(VAR1+VAR2+VAR3+VAR4)/4;
VAR6:=(VAR5-REF(VAR5,5))/REF(VAR5,5)*1500;
VAR7:=(VAR5-REF(VAR5,5))/REF(VAR5,5)*1500;
VAR8:=EMA(VAR6,8);
注意: STICKLINE(VAR6>REF(VAR6,1) AND VAR6<0 AND VAR6<VAR8,VAR6,0,5,0);
转强: STICKLINE(VAR8>REF(VAR8,1) AND VAR6<0 AND VAR6>VAR8,VAR8,0,5,0),COLORYELLOW;
买点: STICKLINE(VAR6>REF(VAR6,1) AND VAR6>0 AND VAR8<0,VAR6,VAR8,10,0);
DRAWICON(FILTER(VAR6>REF(VAR6,1) AND VAR6>0 AND VAR8<0,30),-140,4);
DRAWTEXT(FILTER(VAR6>REF(VAR6,1) AND VAR6>0 AND VAR8<0,30),-40,'买点'),COLORFFFFFF;
持股: STICKLINE(VAR8>REF(VAR8,1) AND VAR8>0,VAR6,0,5,0),COLORRED;
观望: STICKLINE(VAR6<REF(VAR6,1) AND VAR8>REF(VAR8,1) AND VAR6>0,VAR6,VAR8,10,0);
持币: STICKLINE(VAR6<REF(VAR6,1) AND VAR6<VAR8,VAR6,VAR8,5,1),COLORFFFF00;
VAR9:=TROUGHBARS(3,15,1)<10;
VAR10:=PEAKBARS(3,15,1)<10;
VAR11:=IF(VAR9=1,50,0);
VAR12:=IF(VAR10=1,50,0);
底部:= IF(VAR11=50,50,0);
头部:= IF(VAR12=50,100,0);
A:IF( 底部>REF(底部,1),50,0);
AA:IF(头部>REF(头部,1),50,0);
DRAWTEXT(A=50,100,'买' ),COLORRED,LINETHICK2;
DRAWTEXT(AA=50,100,'卖'),COLOR00FF00,LINETHICK2;
注意底部:0,COLORFFFFFF;
低位转强:0,COLORYELLOW;
坚决持股:0,COLORRED;
谨慎观望:0,COLOR400080;
果断持币:0,COLORFFFF00;[/lycode][lycode=tdx2,true]VARA赋值:收盘价的有效数据周期数*3.142/180
输出A2: VARA*8的正弦*100,线宽为2
输出A3: VARA*8的余弦*100,线宽为2
输出X1: 0
VAR1赋值:收盘价的5日简单移动平均
VAR2赋值:收盘价的10日简单移动平均
VAR3赋值:收盘价的20日简单移动平均
VAR4赋值:收盘价的30日简单移动平均
VAR5赋值:(VAR1+VAR2+VAR3+VAR4)/4
VAR6赋值:(VAR5-5日前的VAR5)/5日前的VAR5*1500
VAR7赋值:(VAR5-5日前的VAR5)/5日前的VAR5*1500
VAR8赋值:VAR6的8日指数移动平均
输出注意: 当满足条件VAR6>1日前的VAR6ANDVAR6<0ANDVAR6<VAR8时,在VAR6和0位置之间画柱状线,宽度为5,0不为0则画空心柱.
输出转强: 当满足条件VAR8>1日前的VAR8ANDVAR6<0ANDVAR6>VAR8时,在VAR8和0位置之间画柱状线,宽度为5,0不为0则画空心柱.,画黄色
输出买点: 当满足条件VAR6>1日前的VAR6ANDVAR6>0ANDVAR8<0时,在VAR6和VAR8位置之间画柱状线,宽度为10,0不为0则画空心柱.
当满足条件VAR6>1日前的VAR6ANDVAR6>0ANDVAR8<0的30日过滤时,在-140位置画4号图标
当满足条件VAR6>1日前的VAR6ANDVAR6>0ANDVAR8<0的30日过滤时,在-40位置书写文字,COLORFFFFFF
输出持股: 当满足条件VAR8>1日前的VAR8ANDVAR8>0时,在VAR6和0位置之间画柱状线,宽度为5,0不为0则画空心柱.,画红色
输出观望: 当满足条件VAR6<1日前的VAR6ANDVAR8>1日前的VAR8ANDVAR6>0时,在VAR6和VAR8位置之间画柱状线,宽度为10,0不为0则画空心柱.
输出持币: 当满足条件VAR6<1日前的VAR6ANDVAR6<VAR8时,在VAR6和VAR8位置之间画柱状线,宽度为5,1不为0则画空心柱.,COLORFFFF00
VAR9赋值:收盘价15%之字转向的前1个波谷位置<10
VAR10赋值:收盘价15%之字转向的前1个波峰位置<10
VAR11赋值:如果VAR9=1,返回50,否则返回0
VAR12赋值:如果VAR10=1,返回50,否则返回0
底部赋值: 如果VAR11=50,返回50,否则返回0
头部赋值: 如果VAR12=50,返回100,否则返回0
输出A:如果底部>1日前的底部,返回50,否则返回0
输出AA:如果头部>1日前的头部,返回50,否则返回0
当满足条件A=50时,在100位置书写文字,画红色,线宽为2
当满足条件AA=50时,在100位置书写文字,COLOR00FF00,线宽为2
输出注意底部:0,COLORFFFFFF
输出低位转强:0,画黄色
输出坚决持股:0,画红色
输出谨慎观望:0,COLOR400080
输出果断持币:0,COLORFFFF00
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/11oH_3mzuSy0D1tpWggpnPA

看了该指标的人还看了:
叶公跟庄指标    股海神偷指标    降龙贰式指标
均线进多头指标    主力主升指标    画线指标指标

使用道具 举报

回复