指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 买卖点 
炒股叉_20190517_101114.png

炒股叉_20190517_101120.png

[lywrap=通达信主图指标公式][lycode=tdx,true]DRAWTEXT_FIX(1,0.88,5,0,'~☆~隆逸优化作品~☆~'),COLORRED;
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED;
HAN:=DATE<1141230;
当前获利筹码:=IF(WINNER(CLOSE),WINNER(CLOSE)*100,0);
DRAWKLINE(H,O,L,C);
九十成本集中:=(COST(95)-COST(5))/(COST(95)+COST(5))*100;
成本价:COST(九十成本集中),LINETHICK2,COLORMAGENTA;
入1:IF(成本价>REF(成本价,1),成本价,DRAWNULL),COLORRED,LINETHICK2;
出1:IF(成本价<REF(成本价,1),成本价,DRAWNULL),COLORGREEN,LINETHICK2;

STICKLINE(成本价>LOW AND 成本价<HIGH,成本价,MIN(MIN(OPEN,CLOSE),成本价),3.2,0)*HAN,COLOR0077FF;
STICKLINE(成本价>LOW AND 成本价<HIGH,成本价,MIN(MIN(OPEN,CLOSE),成本价),2.5,0)*HAN,COLOR0099FF;
STICKLINE(成本价>LOW AND 成本价<HIGH,成本价,MIN(MIN(OPEN,CLOSE),成本价),1.9,0)*HAN,COLOR00BBFF;
STICKLINE(成本价>LOW AND 成本价<HIGH,成本价,MIN(MIN(OPEN,CLOSE),成本价),1.2,0)*HAN,COLOR00DDFF;
STICKLINE(成本价>LOW AND 成本价<HIGH,成本价,MIN(MIN(OPEN,CLOSE),成本价),0.3,0)*HAN,COLOR00FFFF;

STICKLINE(成本价>MIN(C,O) AND 成本价<MAX(C,O),成本价,MIN(OPEN,CLOSE),3.2,0)*HAN,COLOR0077FF;
STICKLINE(成本价>MIN(C,O) AND 成本价<MAX(C,O),成本价,MIN(OPEN,CLOSE),2.5,0)*HAN,COLOR0099FF;
STICKLINE(成本价>MIN(C,O) AND 成本价<MAX(C,O),成本价,MIN(OPEN,CLOSE),1.9,0)*HAN,COLOR00BBFF;
STICKLINE(成本价>MIN(C,O) AND 成本价<MAX(C,O),成本价,MIN(OPEN,CLOSE),1.2,0)*HAN,COLOR00DDFF;
STICKLINE(成本价>MIN(C,O) AND 成本价<MAX(C,O),成本价,MIN(OPEN,CLOSE),0.3,0)*HAN,COLOR00FFFF;

STICKLINE(成本价>HIGH,CLOSE,OPEN,3.2,0)*HAN,COLOR0077FF;
STICKLINE(成本价>HIGH,CLOSE,OPEN,2.5,0)*HAN,COLOR0099FF;
STICKLINE(成本价>HIGH,CLOSE,OPEN,1.9,0)*HAN,COLOR00BBFF;
STICKLINE(成本价>HIGH,CLOSE,OPEN,1.2,0)*HAN,COLOR00DDFF;
STICKLINE(成本价>HIGH,CLOSE,OPEN,0.3,0)*HAN,COLOR00FFFF;
STICKLINE(成本价>HIGH,HIGH,LOW,0,0),COLORGREEN;
DF2:=(C-REF(C,1))/REF(C,1)*100>5;
DF3:=(C-O)/O*100>4;
当天涨幅:(C-O)/O*100,NODRAW;
V型反转:=L<成本价 AND DF2;
V型反转2:=CROSS(C,成本价) AND DF2;
V型反转3:=L<成本价 AND DF3;
DRAWTEXT(V型反转,L*0.98,'↖狙击'),COLORCYAN;
DRAWTEXT(V型反转2,L*0.98,'↖狙击'),COLORCYAN;
DRAWTEXT(V型反转3,L*0.98,'↖狙击'),COLORCYAN;
STICKLINE(V型反转=1,C,O,3.2,0),COLORRED;
STICKLINE(V型反转2=1,C,O,3.2,0),COLORRED;
STICKLINE(V型反转3=1,C,O,3.2,0),COLORRED;[/lycode][lycode=tdx2,true]当满足条件1时,在横轴0.88纵轴5位置书写文字,画红色
Z1赋值:字符串相加
Z2赋值:字符串相加
Z3赋值:字符串相加
当满足条件是否最后一个周期时,在横轴0纵轴0位置书写文字,画红色
HAN赋值:日期<1141230
当前获利筹码赋值:如果以收盘价计算的获利盘比例,返回以收盘价计算的获利盘比例*100,否则返回0
K线
九十成本集中赋值:(获利盘为95%的成本分布-获利盘为5%的成本分布)/(获利盘为95%的成本分布+获利盘为5%的成本分布)*100
输出成本价:获利盘为九十成本集中%的成本分布,线宽为2,画洋红色
输出入1:如果成本价>1日前的成本价,返回成本价,否则返回无效数,画红色,线宽为2
输出出1:如果成本价<1日前的成本价,返回成本价,否则返回无效数,画绿色,线宽为2
当满足条件成本价>LOWAND成本价<最高价时,在成本价和开盘价和收盘价的较小值和成本价的较小值位置之间画柱状线,宽度为3.2,0不为0则画空心柱.*HAN,COLOR0077FF
当满足条件成本价>LOWAND成本价<最高价时,在成本价和开盘价和收盘价的较小值和成本价的较小值位置之间画柱状线,宽度为2.5,0不为0则画空心柱.*HAN,COLOR0099FF
当满足条件成本价>LOWAND成本价<最高价时,在成本价和开盘价和收盘价的较小值和成本价的较小值位置之间画柱状线,宽度为1.9,0不为0则画空心柱.*HAN,COLOR00BBFF
当满足条件成本价>LOWAND成本价<最高价时,在成本价和开盘价和收盘价的较小值和成本价的较小值位置之间画柱状线,宽度为1.2,0不为0则画空心柱.*HAN,COLOR00DDFF
当满足条件成本价>LOWAND成本价<最高价时,在成本价和开盘价和收盘价的较小值和成本价的较小值位置之间画柱状线,宽度为0.3,0不为0则画空心柱.*HAN,COLOR00FFFF
当满足条件成本价>收盘价和开盘价的较小值AND成本价<收盘价和开盘价的较大值时,在成本价和开盘价和收盘价的较小值位置之间画柱状线,宽度为3.2,0不为0则画空心柱.*HAN,COLOR0077FF
当满足条件成本价>收盘价和开盘价的较小值AND成本价<收盘价和开盘价的较大值时,在成本价和开盘价和收盘价的较小值位置之间画柱状线,宽度为2.5,0不为0则画空心柱.*HAN,COLOR0099FF
当满足条件成本价>收盘价和开盘价的较小值AND成本价<收盘价和开盘价的较大值时,在成本价和开盘价和收盘价的较小值位置之间画柱状线,宽度为1.9,0不为0则画空心柱.*HAN,COLOR00BBFF
当满足条件成本价>收盘价和开盘价的较小值AND成本价<收盘价和开盘价的较大值时,在成本价和开盘价和收盘价的较小值位置之间画柱状线,宽度为1.2,0不为0则画空心柱.*HAN,COLOR00DDFF
当满足条件成本价>收盘价和开盘价的较小值AND成本价<收盘价和开盘价的较大值时,在成本价和开盘价和收盘价的较小值位置之间画柱状线,宽度为0.3,0不为0则画空心柱.*HAN,COLOR00FFFF
当满足条件成本价>最高价时,在收盘价和开盘价位置之间画柱状线,宽度为3.2,0不为0则画空心柱.*HAN,COLOR0077FF
当满足条件成本价>最高价时,在收盘价和开盘价位置之间画柱状线,宽度为2.5,0不为0则画空心柱.*HAN,COLOR0099FF
当满足条件成本价>最高价时,在收盘价和开盘价位置之间画柱状线,宽度为1.9,0不为0则画空心柱.*HAN,COLOR00BBFF
当满足条件成本价>最高价时,在收盘价和开盘价位置之间画柱状线,宽度为1.2,0不为0则画空心柱.*HAN,COLOR00DDFF
当满足条件成本价>最高价时,在收盘价和开盘价位置之间画柱状线,宽度为0.3,0不为0则画空心柱.*HAN,COLOR00FFFF
当满足条件成本价>最高价时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画绿色
DF2赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100>5
DF3赋值:(收盘价-开盘价)/开盘价*100>4
输出当天涨幅:(收盘价-开盘价)/开盘价*100,NODRAW
V型反转赋值:最低价<成本价 AND DF2
V型反转2赋值:收盘价上穿成本价 AND DF2
V型反转3赋值:最低价<成本价 AND DF3
当满足条件V型反转时,在最低价*0.98位置书写文字,画青色
当满足条件V型反转2时,在最低价*0.98位置书写文字,画青色
当满足条件V型反转3时,在最低价*0.98位置书写文字,画青色
当满足条件V型反转=1时,在收盘价和开盘价位置之间画柱状线,宽度为3.2,0不为0则画空心柱.,画红色
当满足条件V型反转2=1时,在收盘价和开盘价位置之间画柱状线,宽度为3.2,0不为0则画空心柱.,画红色
当满足条件V型反转3=1时,在收盘价和开盘价位置之间画柱状线,宽度为3.2,0不为0则画空心柱.,画红色
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1qZLErGf2ZhzuO_eJPf0-uA

看了该指标的人还看了:
波段利器指标    金财神SB指标    主力买卖指标
主力轨迹买卖指标    瀑布线指标    沉船寻宝指标

使用道具 举报

回复