指标公式
软件: 通达信 
公式类型: 副图 
二级分类: KDJ指标 波段 短线 买卖点 
炒股叉_20190517_100843.png

炒股叉_20190517_100849.png

[lywrap=通达信副图指标公式][lycode=tdx,true]底部动态:EMA(IF(L<= LLV(L,40),SMA(ABS(L-REF(L,1)),40,1)/SMA(MAX(L-REF(L,1),0),40,1),0),3)*10,STICK,COLORRED,LINETHICK2;
RSV:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
RSV1:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:SMA(RSV,3,1),COLORWHITE;
D1:=SMA(K,3,1);
K1:=SMA(RSV,5,1);
K2:=SMA(RSV1,3,1);
D:SMA(K1,5,1),COLORYELLOW;
D2:=SMA(K2,3,1);
J:3*K-2*D1,LINETHICK2,COLORFF00FF;
J1:=3*K2-2*D2;
X1:=LLV(J1,2)=LLV(J1,8);
DRAWLINE(D1>=HHV(D1,21),D1,D1<=LLV(D1,21),D1,1),COLOR00FF00;
STICKLINE(D>REF(D,1),D,D,6,0),COLORRED,LINETHICK3;
DRAWTEXT(CROSS(J1,REF(J1+0.01,1)) AND X1 AND J1<20,J1,'★买'),COLORYELLOW;
超卖区: 20,COLORRED;
底部区:0,COLORGREEN;
超买区:80,COLORRED;
高危区:100,COLORYELLOW;
股价趋势: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK0;
底部警戒: 10,COLORRED,LINETHICK0;
买入警戒:STICKLINE(股价趋势<=10,0,2,1,0),COLORYELLOW;
买入信号: STICKLINE(CROSS(股价趋势,底部警戒),0,30,0,0),COLORFFF666,LINETHICK2;
DRAWTEXT(买入信号,30,'进场'),COLORGREEN;
顶部警戒: 90,COLORFFBB66,LINETHICK0;
卖出警戒:STICKLINE(股价趋势>=85,81,80,2,0),COLORWHITE;
止损出局:STICKLINE(CROSS(顶部警戒,股价趋势),100,70,0,0),COLORFFF666;
DRAWTEXT(止损出局,110,'出局'),COLORRED;
HSV:=IF(SUM(VOL/CAPITAL,20)<1,SUM(VOL/CAPITAL,20),0.998);
VAR1:=DMA(EMA(CLOSE,13),HSV);
QS:=(CLOSE-VAR1)/VAR1*100;
量:=SMA(QS,3,1);
{IF(量>REF(量,1),量,DRAWNULL),COLORRED;}
DRAWICON(CROSS(量,0 ),0,23);[/lycode][lycode=tdx2,true]输出底部动态:如果最低价<=40日内最低价的最低值,返回最低价-1日前的最低价的绝对值的40日[1日权重]移动平均/最低价-1日前的最低价和0的较大值的40日[1日权重]移动平均,否则返回0的3日指数移动平均*10,STICK,画红色,线宽为2
RSV赋值:(收盘价-21日内最低价的最低值)/(21日内最高价的最高值-21日内最低价的最低值)*100
RSV1赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
输出K:RSV的3日[1日权重]移动平均,画白色
D1赋值:K的3日[1日权重]移动平均
K1赋值:RSV的5日[1日权重]移动平均
K2赋值:RSV1的3日[1日权重]移动平均
输出D:K1的5日[1日权重]移动平均,画黄色
D2赋值:K2的3日[1日权重]移动平均
输出J:3*K-2*D1,线宽为2,COLORFF00FF
J1赋值:3*K2-2*D2
X1赋值:2日内J1的最低值=8日内J1的最低值
当满足条件D1>=21日内D1的最高值时,在D1位置画直线起点,当满足条件D1<=21日内D1的最低值时,在D1位置画直线终点,1表示是否延长.,COLOR00FF00
当满足条件D>1日前的D时,在D和D位置之间画柱状线,宽度为6,0不为0则画空心柱.,画红色,线宽为3
当满足条件J1上穿1日前的J1+0.01ANDX1ANDJ1<20时,在J1位置书写文字,画黄色
输出超卖区: 20,画红色
输出底部区:0,画绿色
输出超买区:80,画红色
输出高危区:100,画黄色
输出股价趋势: 3*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均的3日[1日权重]移动平均,线宽为0
输出底部警戒: 10,画红色,线宽为0
输出买入警戒:当满足条件股价趋势<=10时,在0和2位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色
输出买入信号: 当满足条件股价趋势上穿底部警戒时,在0和30位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFFF666,线宽为2
当满足条件买入信号时,在30位置书写文字,画绿色
输出顶部警戒: 90,COLORFFBB66,线宽为0
输出卖出警戒:当满足条件股价趋势>=85时,在81和80位置之间画柱状线,宽度为2,0不为0则画空心柱.,画白色
输出止损出局:当满足条件顶部警戒上穿股价趋势时,在100和70位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFFF666
当满足条件止损出局时,在110位置书写文字,画红色
HSV赋值:如果成交量(手)/当前流通股本(手)的20日累和<1,返回成交量(手)/当前流通股本(手)的20日累和,否则返回0.998
VAR1赋值:以HSV为权重收盘价的13日指数移动平均的动态移动平均
QS赋值:(收盘价-VAR1)/VAR1*100
量赋值:QS的3日[1日权重]移动平均
当满足条件量上穿0时,在0位置画23号图标
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1WSAjJHecZktvlpSSfup9Eg

看了该指标的人还看了:
与私募同进出指标    真涨指标,成功率非常高    三碗不过岗指标
主力买卖指标    明明白白指标    绝对底部指标

使用道具 举报

回复