指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 
炒股叉_20190517_100311.png

炒股叉_20190517_100320.png

[lywrap=通达信主图指标公式][lycode=tdx,true]DRAWBAND(MA(CLOSE,60),RGB(200,80,80),MA(CLOSE,120),RGB(0,0,115));
MA5:MA(CLOSE,5),COLORFFFFFF;
MA10:MA(CLOSE,10),COLOR00FFFF;
MA20:MA(C,20),COLORFF00FF;
MA60:MA(CLOSE,60),COLORFF9988;
MA120:MA(CLOSE,120),COLOR0000FF;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
BDGD:=C=HHV(C,13);
GDSJ:=BARSLAST(FILTER(CROSS(0.8,BDGD),2))+1;
高点:REF(C,GDSJ),COLORFF00FF,POINTDOT;
突破:CROSS(C,REF(高点,1)),COLOR00FFFF,POINTDOT,NODRAW;
STICKLINE(GDSJ<=6,高点,高点,3,0),COLORFF00FF;
DRAWTEXT(突破,LOW,'↑'),COLOR00FFFF;
BDDD:=C=LLV(C,13);
DDSJ:=BARSLAST(FILTER(CROSS(0.8,BDDD),2))+1;
低点:REF(C,DDSJ),COLOR00FF00,POINTDOT;
STICKLINE(DDSJ<=6,低点,低点,3,0),COLOR00FF00;
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
回调买:=(AV + NEWVOL);
DRAWTEXT(CROSS(回调买,0),L*0.95,'←回调买'),COLORYELLOW;
DRAWICON(CROSS(回调买,-5),L*0.98,1);[/lycode][lycode=tdx2,true]画带状线
输出MA5:收盘价的5日简单移动平均,COLORFFFFFF
输出MA10:收盘价的10日简单移动平均,COLOR00FFFF
输出MA20:收盘价的20日简单移动平均,COLORFF00FF
输出MA60:收盘价的60日简单移动平均,COLORFF9988
输出MA120:收盘价的120日简单移动平均,COLOR0000FF
K线
BDGD赋值:收盘价=13日内收盘价的最高值
GDSJ赋值:上次0.8上穿BDGD的2日过滤距今天数+1
输出高点:GDSJ日前的收盘价,COLORFF00FF,POINTDOT
输出突破:收盘价上穿1日前的高点,COLOR00FFFF,POINTDOT,NODRAW
当满足条件GDSJ<=6时,在高点和高点位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF00FF
当满足条件突破时,在最低价位置书写文字,COLOR00FFFF
BDDD赋值:收盘价=13日内收盘价的最低值
DDSJ赋值:上次0.8上穿BDDD的2日过滤距今天数+1
输出低点:DDSJ日前的收盘价,COLOR00FF00,POINTDOT
当满足条件DDSJ<=6时,在低点和低点位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00FF00
LC赋值:1日前的收盘价
RSI5赋值:(((收盘价-LC)和0的较大值的5日[1日权重]移动平均 / (收盘价-LC)的绝对值的5日[1日权重]移动平均) * 100)
TR1赋值:(最高价-最低价)和(最高价-1日前的收盘价)的绝对值的较大值和(最低价-1日前的收盘价)的绝对值的较大值的10日累和
HD赋值:(最高价 - 1日前的最高价)
LD赋值:(1日前的最低价 - 最低价)
DMP赋值:如果((HD>0)AND(HD>LD)),返回HD,否则返回0的10日累和
DMM赋值:如果((LD>0)AND(LD>HD)),返回LD,否则返回0的10日累和
PDI赋值:((DMP * 100) / TR1)
MDI赋值:((DMM * 100) / TR1)
ADX赋值:(((MDI-PDI)的绝对值/(MDI+PDI))*100)的5日简单移动平均
AV赋值:(RSI5 + ADX)
DXR赋值:(((ADX + 5日前的ADX) / 2) + RSI5)
WR10赋值:((100 * (10日内最高价的最高值 - 收盘价)) / (10日内最高价的最高值 - 10日内最低价的最低值))
NEWVOL赋值:(RSI5 - WR10)
回调买赋值:(AV + NEWVOL)
当满足条件回调买上穿0时,在最低价*0.95位置书写文字,画黄色
当满足条件回调买上穿-5时,在最低价*0.98位置画1号图标
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1uXpAFTMbLCTtuD1nxtVErg

看了该指标的人还看了:
与私募同进出指标    真涨指标,成功率非常高    三碗不过岗指标
主力买卖指标    明明白白指标    绝对底部指标

使用道具 举报

回复