指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 画线 趋势 压力支撑 
炒股叉_20190517_100125.png

炒股叉_20190517_100135.png

[lywrap=通达信主图指标公式][lycode=tdx,true]向上跳空:=LOW>REF(HIGH,1);
STICKLINE(向上跳空,LOW,REF(HIGH,1),10,0),COLORWHITE;
下突缺口:=HIGH<REF(LOW,1),COLORGREEN;
STICKLINE(下突缺口,HIGH,REF(LOW,1),10,0),COLORWHITE;



AB:=EMA(((2*C+H+L)/4-LLV(LOW,30))/
(HHV(HIGH,30)-LLV(LOW,30))*100,8);
BA:=EMA(AB,5);
A1{高}:=REFDATE(REF(HHV(H,96),5),DATE);
B1{低}:=REFDATE(REF(LLV(L,96),5),DATE);
D{中}:=((A1)+(B1))/2;
五:=MA(C,5)LINETHICK2,COLOR00FFFF;
二O:=EMA(C,20),COLORMAGENTA;
空仓:IF(AB-BA<0,五,DRAWNULL),LINETHICK2,COLOR00FFFF;
持仓:IF(AB-BA>0,五,DRAWNULL),,LINETHICK2,COLORRED;
箱顶:IF(AB>0 AND AB-BA<=0,A1,A1),LINETHICK3,COLOR00FF00;
箱腰:IF(AB>0 AND AB-BA<=0,D,D),LINETHICK3,COLOR00FF00;
箱低:IF(AB>0 AND AB-BA<=0,B1,B1),LINETHICK3,COLOR00FF00;
_____五:IF(CURRBARSCOUNT=6,L*0.992-0.02,DRAWNULL),
CROSSDOT,COLORWHITE,LINETHICK3;{五日转点}
十:IF(CURRBARSCOUNT=11,L*0.992-0.02,DRAWNULL),
CROSSDOT,COLORYELLOW,LINETHICK3;{十日转点}
二十:IF(CURRBARSCOUNT=21,L*0.992-0.02,DRAWNULL),
CROSSDOT,COLORRED,LINETHICK3;{二十日转点};
三十:IF(CURRBARSCOUNT=31,L*0.992-0.02,DRAWNULL),
CROSSDOT,COLORCYAN,LINETHICK3;{三十日转点};
六十:IF(CURRBARSCOUNT=61,L*0.992-0.02,DRAWNULL),
CROSSDOT,COLORYELLOW,LINETHICK3;{六十日转点};
九十:IF(CURRBARSCOUNT=91,L*0.992-0.02,DRAWNULL),
CROSSDOT,COLORYELLOW,LINETHICK3;{九十日转点};
高1:IF(AB>0 AND AB-BA>0,A1,DRAWNULL),LINETHICK3,COLORRED;
中1:IF(AB>0 AND AB-BA>0,D,DRAWNULL),LINETHICK3,COLORRED;
低1:IF(AB>0 AND AB-BA>0,B1,DRAWNULL),LINETHICK3,COLORRED;
C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(涨停,H,L,0,0),COLORRED;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(跌停,H,L,0,1),COLORGREEN;
{选股}
HHH:=CROSS(C,MA(L+(H-L)/2,25)*0.95);LLL:=CROSS(MA(L+(H-L)/2,25)*0.95,C);
CCC:=CROSS(H,MA(L+(H-L)/2,25)*1.15);DDD:=CROSS(H,MA(L+(H-L)/2,25)*1.25);
DRAWTEXT(HHH AND MA(L+(H-L)/2,75)>=REF(MA(L+(H-L)/2,75),1),L*0.98,'买了'),COLOR6699FF;
DRAWTEXT(CCC AND MA(L+(H-L)/2,75)>=REF(MA(L+(H-L)/2,75),1),H*1.02,'卖了'),COLOR6699FF;
DRAWTEXT(DDD AND MA(L+(H-L)/2,75)>=REF(MA(L+(H-L)/2,75),1),H*1.02,'小心顶'),COLOR6699FF;
VAR1:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VAR2:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
DIR1:=ABS(CLOSE-REF(CLOSE,5));
VIR1:=SUM(ABS(CLOSE-REF(CLOSE,1)),5);
ER1:=DIR1/VIR1;
CS1:=ER1*(0.8-2/8)+2/8;
CQ1:=CS1*CS1;
DIR2:=ABS(CLOSE-REF(CLOSE,10));
VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),10);
ER2:=DIR2/VIR2;
CS2:=ER2*(0.8-2/24)+2/24;
CQ2:=CS2*CS2;
STICKLINE(VAR2 < MA(VAR3,6),LOW,HIGH,0,1),COLORLIBLUE;
STICKLINE(VAR2 > MA(VAR3,6),LOW,HIGH,0,1),COLORRED;
STICKLINE(((OPEN>CLOSE)AND(VAR2<MA(VAR3,6))),(CLOSE-0.03),OPEN,3.05,0),COLORLIBLUE;
STICKLINE(((OPEN<CLOSE)AND(VAR2<MA(VAR3,6))),CLOSE,OPEN,3.05,1),COLORLIBLUE;
STICKLINE(((OPEN>CLOSE)AND(VAR2>MA(VAR3,6))),OPEN,(CLOSE-0.03),3.05,0),COLORRED;
STICKLINE(((OPEN<CLOSE)AND(VAR2>MA(VAR3,6))),OPEN,CLOSE,3.05,1),COLORRED;
DRAWICON(CROSS(VAR2,MA(VAR3,6)),(LOW - (LOW*0.02)),7);
DRAWICON(CROSS(MA(VAR3,6),VAR1),(HIGH+(HIGH*0.02)),8);
PT:=REF(H,1)-REF(L,1);
CDP:=(REF(H,1)+REF(L,1)+REF(C,1)*2)/4;
AH:=CDP+PT;
AL:=CDP-PT;
NH:=CDP*2-REF(L,1);
NL:=CDP*2-REF(H,1);
强:IF(AH>REF(C,1)*1.1,REF(C,1)*1.1,AH)NODRAW;
阻:IF(NH>强,(强-CDP)*0.618+CDP,NH)NODRAW,COLORBLUE;
M:=IF(AL<REF(C,1)/1.1,REF(C,1)/1.1,AL);
撑:IF(NL<M,CDP-(CDP-M)*0.618,NL)NODRAW;
底:IF(AL<REF(C,1)/1.1,REF(C,1)/1.1,AL)NODRAW;
{量能饱和度}
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
【量能饱和】:=IF(SAT>1,1,SAT)*100,COLORYELLOW,NODRAW;
{活跃度}
LC:=REF(CLOSE,1);
RSI5:=(SMA(MAX(CLOSE-LC,0),3,1))/(SMA(ABS(CLOSE-LC),3,1))*100;
WR10:=(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))*100;
活跃度:=(RSI5-WR10),COLORFFFF00,LINETHICK1,NODRAW;
活跃度比:=IF(活跃度>=0,(活跃度+100)/2,100-ABS((活跃度-100)/2));

T:=MA(HIGH-LOW,20);
C8:=CLOSE/REF(CLOSE,1)>1.09 AND CLOSE/REF(CLOSE,1)<1.11 AND CLOSE==HIGH;
DRAWICON(PERIOD==5 AND C8,CLOSE+T*1.25,9);
V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
STICKLINE(V2>=1,O,C,2,0),COLORYELLOW;

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2,COLORSTICK;
VA1:=HHVBARS(H,BARSLAST(MACD<0)+1);
VA2:=CROSS(BACKSET(CROSS(0,MACD),REF(VA1,1)+2),0.5);
JQG:=DRAWLINE(VA2,H,REF(VA2,1),REF(H,1),1),COLORGREEN,DOTLINE;{在价格画线}
NOTEXT前高A:DRAWLINE(VA2,H,ISLASTBAR,REF(H,BARSLAST(VA2)),1),COLORWHITE,DOTLINE;
DRAWNUMBER(ISLASTBAR,NOTEXT前高A,NOTEXT前高A),COLORWHITE;

VA3:=LLVBARS(L,BARSLAST(MACD>0)+1);
VA4:=CROSS(BACKSET(CROSS(MACD,0),REF(VA3,1)+2),0.5);
NOTEXT前低A:DRAWLINE(VA4,L,ISLASTBAR,REF(L,BARSLAST(VA4)),1),COLORWHITE,DOTLINE;
DRAWNUMBER(ISLASTBAR,NOTEXT前低A,NOTEXT前低A),COLORWHITE;

基准:=CONST(SUM(VA2,0));
前高4:=基准-4=SUM(VA2,0) AND VA2,COLORWHITE,NODRAW;
前高3:=基准-3=SUM(VA2,0) AND VA2,COLORWHITE,NODRAW;
前高2:=基准-2=SUM(VA2,0) AND VA2,COLORWHITE,NODRAW;
前高1:=基准-1=SUM(VA2,0) AND VA2,COLORYELLOW,NODRAW;
前高:=基准=SUM(VA2,0) AND VA2,COLORCYAN,NODRAW;

距离G1:=BARSLAST(前高1);
距离G2:=BARSLAST(前高2);
距离G3:=BARSLAST(前高3);
距离G4:=BARSLAST(前高4);

NOTEXTG1:DRAWLINE(前高1,H,前高 AND H>=REF(H,距离G1),H,0),COLORYELLOW;
NOTEXTG2:DRAWLINE(前高1,H,前高 AND H<REF(H,距离G1),H,0),COLORGREEN;
NOTEXTG3:DRAWLINE(前高2,H,前高1 AND H>=REF(H,距离G2),H,0),COLORYELLOW;
NOTEXTG4:DRAWLINE(前高2,H,前高1 AND H<REF(H,距离G2),H,0),COLORGREEN;
NOTEXTG5:DRAWLINE(前高3,H,前高2 AND H>=REF(H,距离G3),H,0),COLORYELLOW;
NOTEXTG6:DRAWLINE(前高3,H,前高2 AND H<REF(H,距离G3),H,0),COLORGREEN;
NOTEXTG7:DRAWLINE(前高4,H,前高3 AND H>=REF(H,距离G4),H,0),COLORYELLOW;
NOTEXTG8:DRAWLINE(前高4,H,前高3 AND H<REF(H,距离G4),H,0),COLORGREEN;

基准2:=CONST(SUM(VA4,0));
前低:=基准2=SUM(VA4,0) AND VA4;
前低1:=基准2-1=SUM(VA4,0) AND VA4;
前低2:=基准2-2=SUM(VA4,0) AND VA4;
前低3:=基准2-3=SUM(VA4,0) AND VA4;
前低4:=基准2-4=SUM(VA4,0) AND VA4;


距离D1:=BARSLAST(前低1);
距离D2:=BARSLAST(前低2);
距离D3:=BARSLAST(前低3);
距离D4:=BARSLAST(前低4);

NOTEXTD1:DRAWLINE(前低1,L,前低 AND L>=REF(L,距离D1),L,0),COLORYELLOW;
NOTEXTD2:DRAWLINE(前低1,L,前低 AND L<REF(L,距离D1),L,0),COLORGREEN;
NOTEXTD3:DRAWLINE(前低2,L,前低1 AND L>=REF(L,距离D2),L,0),COLORYELLOW;
NOTEXTD4:DRAWLINE(前低2,L,前低1 AND L<REF(L,距离D2),L,0),COLORGREEN;
NOTEXTD5:DRAWLINE(前低3,L,前低2 AND L>=REF(L,距离D3),L,0),COLORYELLOW;
NOTEXTD6:DRAWLINE(前低3,L,前低2 AND L<REF(L,距离D3),L,0),COLORGREEN;
NOTEXTD7:DRAWLINE(前低4,L,前低3 AND L>=REF(L,距离D4),L,0),COLORYELLOW;
NOTEXTD8:DRAWLINE(前低4,L,前低3 AND L<REF(L,距离D4),L,0),COLORGREEN;[/lycode][lycode=tdx2,true]向上跳空赋值:最低价>1日前的最高价
当满足条件向上跳空时,在最低价和1日前的最高价位置之间画柱状线,宽度为10,0不为0则画空心柱.,画白色
下突缺口赋值:最高价<1日前的最低价,画绿色
当满足条件下突缺口时,在最高价和1日前的最低价位置之间画柱状线,宽度为10,0不为0则画空心柱.,画白色
AB赋值:((2*收盘价+最高价+最低价)/4-30日内最低价的最低值)/(30日内最高价的最高值-30日内最低价的最低值)*100的8日指数移动平均
BA赋值:AB的5日指数移动平均
A1赋值:日期日5日前的96日内最高价的最高值
B1赋值:日期日5日前的96日内最低价的最低值
D赋值:((A1)+(B1))/2
五赋值:收盘价的5日简单移动平均线宽为2,COLOR00FFFF
二O赋值:收盘价的20日指数移动平均,画洋红色
输出空仓:如果AB-BA<0,返回五,否则返回无效数,线宽为2,COLOR00FFFF
输出持仓:如果AB-BA>0,返回五,否则返回无效数,,线宽为2,画红色
输出箱顶:如果AB>0ANDAB-BA<=0,返回A1,否则返回A1,线宽为3,COLOR00FF00
输出箱腰:如果AB>0ANDAB-BA<=0,返回D,否则返回D,线宽为3,COLOR00FF00
输出箱低:如果AB>0ANDAB-BA<=0,返回B1,否则返回B1,线宽为3,COLOR00FF00
输出_____五:如果到最后交易的周期=6,返回最低价*0.992-0.02,否则返回无效数,CROSSDOT,画白色,线宽为3
输出十:如果到最后交易的周期=11,返回最低价*0.992-0.02,否则返回无效数,CROSSDOT,画黄色,线宽为3
输出二十:如果到最后交易的周期=21,返回最低价*0.992-0.02,否则返回无效数,CROSSDOT,画红色,线宽为3

输出三十:如果到最后交易的周期=31,返回最低价*0.992-0.02,否则返回无效数,CROSSDOT,画青色,线宽为3

输出六十:如果到最后交易的周期=61,返回最低价*0.992-0.02,否则返回无效数,CROSSDOT,画黄色,线宽为3

输出九十:如果到最后交易的周期=91,返回最低价*0.992-0.02,否则返回无效数,CROSSDOT,画黄色,线宽为3

输出高1:如果AB>0ANDAB-BA>0,返回A1,否则返回无效数,线宽为3,画红色
输出中1:如果AB>0ANDAB-BA>0,返回D,否则返回无效数,线宽为3,画红色
输出低1:如果AB>0ANDAB-BA>0,返回B1,否则返回无效数,线宽为3,画红色
C2赋值:1日前的收盘价
涨停赋值:如果(收盘价-C2)*100/C2>=(10-0.01*100/C2),返回1,否则返回0
当满足条件涨停时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色
当满足条件涨停时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画红色
跌停赋值:如果(C2-收盘价)*100/C2>=(10-0.01*100/C2),返回1,否则返回0
当满足条件跌停时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,画绿色
当满足条件跌停时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画绿色
HHH赋值:收盘价上穿最低价+(最高价-最低价)/2的25日简单移动平均*0.95
LLL赋值:最低价+(最高价-最低价)/2的25日简单移动平均*0.95上穿收盘价
CCC赋值:最高价上穿最低价+(最高价-最低价)/2的25日简单移动平均*1.15
DDD赋值:最高价上穿最低价+(最高价-最低价)/2的25日简单移动平均*1.25
当满足条件HHHANDMA(最低价+(最高价-最低价)/2,75)>=1日前的最低价+(最高价-最低价)/2的75日简单移动平均时,在最低价*0.98位置书写文字,COLOR6699FF
当满足条件CCCANDMA(最低价+(最高价-最低价)/2,75)>=1日前的最低价+(最高价-最低价)/2的75日简单移动平均时,在最高价*1.02位置书写文字,COLOR6699FF
当满足条件DDDANDMA(最低价+(最高价-最低价)/2,75)>=1日前的最低价+(最高价-最低价)/2的75日简单移动平均时,在最高价*1.02位置书写文字,COLOR6699FF
VAR1赋值:(100 - ((90 * (14日内最高价的最高值 - 收盘价)) / (14日内最高价的最高值 - 14日内最低价的最低值)))
VAR2赋值:(100 - ((90 * (14日内最高价的最高值 - 收盘价)) / (14日内最高价的最高值 - 14日内最低价的最低值)))
VAR3赋值:(100 - ((100*(6日内最高价的最高值-收盘价))/(6日内最高价的最高值-6日内最低价的最低值))的34日简单移动平均)
DIR1赋值:收盘价-5日前的收盘价的绝对值
VIR1赋值:收盘价-1日前的收盘价的绝对值的5日累和
ER1赋值:DIR1/VIR1
CS1赋值:ER1*(0.8-2/8)+2/8
CQ1赋值:CS1*CS1
DIR2赋值:收盘价-10日前的收盘价的绝对值
VIR2赋值:收盘价-1日前的收盘价的绝对值的10日累和
ER2赋值:DIR2/VIR2
CS2赋值:ER2*(0.8-2/24)+2/24
CQ2赋值:CS2*CS2
当满足条件VAR2<VAR3的6日简单移动平均时,在最低价和最高价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画淡蓝色
当满足条件VAR2>VAR3的6日简单移动平均时,在最低价和最高价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画红色
当满足条件((收阴线)AND(VAR2<VAR3的6日简单移动平均))时,在(收盘价-0.03)和开盘价位置之间画柱状线,宽度为3.05,0不为0则画空心柱.,画淡蓝色
当满足条件((收阳线)AND(VAR2<VAR3的6日简单移动平均))时,在收盘价和开盘价位置之间画柱状线,宽度为3.05,1不为0则画空心柱.,画淡蓝色
当满足条件((收阴线)AND(VAR2>VAR3的6日简单移动平均))时,在开盘价和(收盘价-0.03)位置之间画柱状线,宽度为3.05,0不为0则画空心柱.,画红色
当满足条件((收阳线)AND(VAR2>VAR3的6日简单移动平均))时,在开盘价和收盘价位置之间画柱状线,宽度为3.05,1不为0则画空心柱.,画红色
当满足条件VAR2上穿VAR3的6日简单移动平均时,在(最低价-(最低价*0.02))位置画7号图标
当满足条件VAR3的6日简单移动平均上穿VAR1时,在(最高价+(最高价*0.02))位置画8号图标
PT赋值:1日前的最高价-1日前的最低价
CDP赋值:(1日前的最高价+1日前的最低价+1日前的收盘价*2)/4
AH赋值:CDP+PT
AL赋值:CDP-PT
NH赋值:CDP*2-1日前的最低价
NL赋值:CDP*2-1日前的最高价
输出强:如果AH>1日前的收盘价*1.1,返回1日前的收盘价*1.1,否则返回AHNODRAW
输出阻:如果NH>强,返回(强-CDP)*0.618+CDP,否则返回NHNODRAW,画蓝色
M赋值:如果AL<1日前的收盘价/1.1,返回1日前的收盘价/1.1,否则返回AL
输出撑:如果NL<M,返回CDP-(CDP-M)*0.618,否则返回NLNODRAW
输出底:如果AL<1日前的收盘价/1.1,返回1日前的收盘价/1.1,否则返回ALNODRAW
SAT赋值:(成交额(元)/收盘价)/(20日内成交额(元)的最高值/20日内收盘价的最高值)
【量能饱和】赋值:如果SAT>1,返回1,否则返回SAT*100,画黄色,NODRAW
LC赋值:1日前的收盘价
RSI5赋值:(收盘价-LC和0的较大值的3日[1日权重]移动平均)/(收盘价-LC的绝对值的3日[1日权重]移动平均)*100
WR10赋值:(3日内最高价的最高值-收盘价)/(3日内最高价的最高值-3日内最低价的最低值)*100
活跃度赋值:(RSI5-WR10),COLORFFFF00,线宽为1,NODRAW
活跃度比赋值:如果活跃度>=0,返回(活跃度+100)/2,否则返回100-(活跃度-100)/2的绝对值
T赋值:最高价-最低价的20日简单移动平均
C8赋值:收盘价/1日前的收盘价>1.09 AND 收盘价/1日前的收盘价<1.11 AND 收盘价 最高价
当满足条件周期类型5ANDC8时,在收盘价+T*1.25位置画9号图标
V2赋值:如果到最后交易的周期=1,返回成交量(手)*240/当前离开盘分钟数/1日前的成交量(手)-1,否则返回成交量(手)/1日前的成交量(手)-1
当满足条件V2>=1时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色
DIF赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
DEA赋值:DIF的9日指数移动平均
MACD赋值:(DIF-DEA)*2,COLORSTICK
VA1赋值:上次MACD<0距今天数+1日内最高价距今天数
VA2赋值:若0上穿MACD则将最近1日前的VA1+2周期置为1上穿0.5
JQG赋值:当满足条件VA2时,在最高价位置画直线起点,当满足条件1日前的VA2时,在1日前的最高价位置画直线终点,1表示是否延长.,画绿色,DOTLINE
输出NOTEXT前高A:当满足条件VA2时,在最高价位置画直线起点,当满足条件是否最后一个周期时,在上次VA2距今天数日前的最高价位置画直线终点,1表示是否延长.,画白色,DOTLINE
当满足条件是否最后一个周期时,在NOTEXT前高A位置书写数字,画白色
VA3赋值:上次MACD>0距今天数+1日内最低价距今天数
VA4赋值:若MACD上穿0则将最近1日前的VA3+2周期置为1上穿0.5
输出NOTEXT前低A:当满足条件VA4时,在最低价位置画直线起点,当满足条件是否最后一个周期时,在上次VA4距今天数日前的最低价位置画直线终点,1表示是否延长.,画白色,DOTLINE
当满足条件是否最后一个周期时,在NOTEXT前低A位置书写数字,画白色
基准赋值:VA2的历史累和的最后一日取值设为常数
前高4赋值:基准-4=VA2的历史累和 AND VA2,画白色,NODRAW
前高3赋值:基准-3=VA2的历史累和 AND VA2,画白色,NODRAW
前高2赋值:基准-2=VA2的历史累和 AND VA2,画白色,NODRAW
前高1赋值:基准-1=VA2的历史累和 AND VA2,画黄色,NODRAW
前高赋值:基准=VA2的历史累和 AND VA2,画青色,NODRAW
距离G1赋值:上次前高1距今天数
距离G2赋值:上次前高2距今天数
距离G3赋值:上次前高3距今天数
距离G4赋值:上次前高4距今天数
输出NOTEXTG1:当满足条件前高1时,在最高价位置画直线起点,当满足条件前高ANDH>=距离G1日前的最高价时,在最高价位置画直线终点,0表示是否延长.,画黄色
输出NOTEXTG2:当满足条件前高1时,在最高价位置画直线起点,当满足条件前高ANDH<距离G1日前的最高价时,在最高价位置画直线终点,0表示是否延长.,画绿色
输出NOTEXTG3:当满足条件前高2时,在最高价位置画直线起点,当满足条件前高1ANDH>=距离G2日前的最高价时,在最高价位置画直线终点,0表示是否延长.,画黄色
输出NOTEXTG4:当满足条件前高2时,在最高价位置画直线起点,当满足条件前高1ANDH<距离G2日前的最高价时,在最高价位置画直线终点,0表示是否延长.,画绿色
输出NOTEXTG5:当满足条件前高3时,在最高价位置画直线起点,当满足条件前高2ANDH>=距离G3日前的最高价时,在最高价位置画直线终点,0表示是否延长.,画黄色
输出NOTEXTG6:当满足条件前高3时,在最高价位置画直线起点,当满足条件前高2ANDH<距离G3日前的最高价时,在最高价位置画直线终点,0表示是否延长.,画绿色
输出NOTEXTG7:当满足条件前高4时,在最高价位置画直线起点,当满足条件前高3ANDH>=距离G4日前的最高价时,在最高价位置画直线终点,0表示是否延长.,画黄色
输出NOTEXTG8:当满足条件前高4时,在最高价位置画直线起点,当满足条件前高3ANDH<距离G4日前的最高价时,在最高价位置画直线终点,0表示是否延长.,画绿色
基准2赋值:VA4的历史累和的最后一日取值设为常数
前低赋值:基准2=VA4的历史累和 AND VA4
前低1赋值:基准2-1=VA4的历史累和 AND VA4
前低2赋值:基准2-2=VA4的历史累和 AND VA4
前低3赋值:基准2-3=VA4的历史累和 AND VA4
前低4赋值:基准2-4=VA4的历史累和 AND VA4
距离D1赋值:上次前低1距今天数
距离D2赋值:上次前低2距今天数
距离D3赋值:上次前低3距今天数
距离D4赋值:上次前低4距今天数
输出NOTEXTD1:当满足条件前低1时,在最低价位置画直线起点,当满足条件前低ANDL>=距离D1日前的最低价时,在最低价位置画直线终点,0表示是否延长.,画黄色
输出NOTEXTD2:当满足条件前低1时,在最低价位置画直线起点,当满足条件前低ANDL<距离D1日前的最低价时,在最低价位置画直线终点,0表示是否延长.,画绿色
输出NOTEXTD3:当满足条件前低2时,在最低价位置画直线起点,当满足条件前低1ANDL>=距离D2日前的最低价时,在最低价位置画直线终点,0表示是否延长.,画黄色
输出NOTEXTD4:当满足条件前低2时,在最低价位置画直线起点,当满足条件前低1ANDL<距离D2日前的最低价时,在最低价位置画直线终点,0表示是否延长.,画绿色
输出NOTEXTD5:当满足条件前低3时,在最低价位置画直线起点,当满足条件前低2ANDL>=距离D3日前的最低价时,在最低价位置画直线终点,0表示是否延长.,画黄色
输出NOTEXTD6:当满足条件前低3时,在最低价位置画直线起点,当满足条件前低2ANDL<距离D3日前的最低价时,在最低价位置画直线终点,0表示是否延长.,画绿色
输出NOTEXTD7:当满足条件前低4时,在最低价位置画直线起点,当满足条件前低3ANDL>=距离D4日前的最低价时,在最低价位置画直线终点,0表示是否延长.,画黄色
输出NOTEXTD8:当满足条件前低4时,在最低价位置画直线起点,当满足条件前低3ANDL<距离D4日前的最低价时,在最低价位置画直线终点,0表示是否延长.,画绿色
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1kU9yKJl5oq2CtguHAZtKkA

看了该指标的人还看了:
与私募同进出指标    真涨指标,成功率非常高    三碗不过岗指标
主力买卖指标    明明白白指标    绝对底部指标

使用道具 举报

回复