指标公式
软件: 通达信 
公式类型: 副图 
二级分类: RSI指标 波段 无未来函数 短线 买卖点 抄底逃顶 
炒股叉_20190517_094808.png

炒股叉_20190517_094815.png

[lywrap=通达信副图指标公式][lycode=tdx,true]R1:=(RSI-50)/1.5;{将RSI指标转换到零轴附近并按比例缩小}
DRAWBAND(R1,RGB(0,180,255),18,RGB(00,00,00));
R2:=IF(R1>=0,0,R1);
DRAWBAND(-15,RGB(255,100,155),R2,RGB(00,00,00));
R:R1;
F:=100*(C/REF(C,1)-1);{单日涨幅}
MAR:=EMA(R,13);{均}
XX:R-MAR,COLORSTICK;
GD:=(C=HHV(C,5) OR H=HHV(H,5));
排除1:=NOT(GD OR REF(GD,1));
排除2:=NOT(EXIST(F<-9,3));
排除3:=C/EXPMA(C,50)-1<0.1;
入:DRAWICON(CROSS(XX,-10) AND 排除1 AND 排除2 AND 排除3,-10,1);
CHUTJ:=XX<REF(XX,1) AND REF(XX,1)>REF(XX,2);
出:DRAWTEXT(FILTER(COUNT(CHUTJ,BARSLAST(入))=2 AND XX>0,6) ,10,'!'),COLORGREEN;
-10,POINTDOT;
18,POINTDOT;
-15,POINTDOT;[/lycode][lycode=tdx2,true]R1赋值:(RSI-50)/1.5
画带状线
R2赋值:如果R1>=0,返回0,否则返回R1
画带状线
输出R:R1
F赋值:100*(收盘价/1日前的收盘价-1)
MAR赋值:R的13日指数移动平均
输出XX:R-MAR,COLORSTICK
GD赋值:(收盘价=5日内收盘价的最高值 OR 最高价=5日内最高价的最高值)
排除1赋值:取反
排除2赋值:取反
排除3赋值:收盘价/收盘价的50日指数移动平均-1<0.1
输出入:当满足条件XX上穿-10AND排除1AND排除2AND排除3时,在-10位置画1号图标
CHUTJ赋值:XX<1日前的XX AND 1日前的XX>2日前的XX
输出出:当满足条件统计上次入距今天数日中满足CHUTJ的天数=2ANDXX>0的6日过滤时,在10位置书写文字,画绿色
-10,POINTDOT
18,POINTDOT
-15,POINTDOT
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1nvNpKDry5QHG10s4z8cgqw

看了该指标的人还看了:
与私募同进出指标    真涨指标,成功率非常高    三碗不过岗指标
主力买卖指标    明明白白指标    绝对底部指标

使用道具 举报

回复