指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 趋势 操盘控盘 
炒股叉_20190517_091720.png

炒股叉_20190517_091732.png

[lywrap=通达信主图指标公式][lycode=tdx,true]中点:(H+L)/2,NODRAW;{御览图}

OK1:=BARSLAST(L=LLV(L,360))+1;
OK2:=REF(L,OK1);
日360最低:=IF(CURRBARSCOUNT<=CONST(OK1+1),CONST(IF(OK1,OK2,OK2)),DRAWNULL)COLORGREEN;
OK6:=IF(CURRBARSCOUNT<=CONST(OK1),CONST(IF(OK1,OK1,OK1)),DRAWNULL);

月开:=O#MONTH;
月高:H#MONTH,NODRAW,COLORRED;
月中:(H#MONTH+L#MONTH)/2,NODRAW,COLORYELLOW;
月低:L#MONTH,NODRAW,COLORGREEN;
月收:=C#MONTH;
STICKLINE(OK6&&月收>=月开,月高,月低,3.2,-1),COLORRED;
STICKLINE(OK6&&月收<=月开,月高,月低,3.2,-1),COLORCYAN;

周开:=O#WEEK;
周高:H#WEEK,NODRAW,COLORRED;
周中:(H#WEEK+L#WEEK)/2,NODRAW,COLORYELLOW;
周低:L#WEEK,NODRAW,COLORGREEN;
周收:=C#WEEK;
STICKLINE(OK6&&周收>=周开,周高,周低,4.1,0),COLORFF0098;{COLORFF0098}
STICKLINE(OK6&&周收<=周开,周高,周低,4.1,0),COLOR006000;{COLOR006000}
DRAWKLINE(H,O,L,C);{K线}
STICKLINE(O>C,C,O,3,1),COLOR00CC00;
O5:=OK6&&O<C;
STICKLINE(O5,C,O,3.03,0),COLOR450099;{红}
STICKLINE(O5,C,O,2.5,0),COLOR4500AA;
STICKLINE(O5,C,O,2,0),COLOR4500BB;
STICKLINE(O5,C,O,1.5,0),COLOR4500CC;
STICKLINE(O5,C,O,1,0),COLOR4500DD;
STICKLINE(O5,C,O,0.5,0),COLOR4500EE;
STICKLINE(O5,C,O,0.1,0),COLOR4500FF;
O2:=OK6&&O>C;
STICKLINE(O2,C,O,3.03,0),COLOR009900;{绿}
STICKLINE(O2,C,O,2.5,0),COLOR00AA00;
STICKLINE(O2,C,O,2,0),COLOR00BB00;
STICKLINE(O2,C,O,1.5,0),COLOR00CC00;
STICKLINE(O2,C,O,1,0),COLOR00DD00;
STICKLINE(O2,C,O,0.5,0),COLOR00EE00;
STICKLINE(O2,C,O,0.1,0),COLOR00FF00;
STICKLINE(中点,中点,中点,0.01,1),COLOR00FFFF;
HHH:=STICKLINE(周中,周中,周中,4.1,0),COLORCYAN;
Q1:=STICKLINE(月中,月中,月中,4.1,-1),COLORYELLOW;
STICKLINE(OK6&&周中,周中,周中,4.1,-1),COLORYELLOW;

K8:=BARSLAST(EMA(C,5)>=EMA(C,20));
K9:=BARSLAST(EMA(C,5)<=EMA(C,20));
K110:=IF(EMA(C,5)>=EMA(C,20),(EMA(C,5)+EMA(C,20))/2,DRAWNULL);
K115:=IF(EMA(C,5)>=EMA(C,20),EMA(C,5),DRAWNULL);
K120:=IF(EMA(C,5)>=EMA(C,20),EMA(C,20),DRAWNULL);
线5:IF(CURRBARSCOUNT<CONST(K9+2),K115,DRAWNULL)COLORYELLOW;
线10:IF(CURRBARSCOUNT<CONST(K9+2),K110,DRAWNULL),COLORYELLOW;
线20:IF(CURRBARSCOUNT<CONST(K9+2),K120,DRAWNULL),COLORYELLOW;

立春:=FILTER(MONTH=2 AND (DAY=3 OR DAY=5 ),2);
雨水:=FILTER(MONTH=2 AND (DAY=18 OR DAY=20),2);
惊蛰:=FILTER(MONTH=3 AND (DAY=5 OR DAY=7 ),2);
春分:=FILTER(MONTH=3 AND (DAY=20 OR DAY=22),2);
清明:=FILTER(MONTH=4 AND (DAY=3 OR DAY=6 ),2);
谷雨:=FILTER(MONTH=4 AND (DAY=19 OR DAY=21),2);
立夏:=FILTER(MONTH=5 AND (DAY=6 OR DAY=8 ),2);
小满:=FILTER(MONTH=5 AND (DAY=20 OR DAY=22),2);
芒种:=FILTER(MONTH=6 AND (DAY=5 OR DAY=7 ),2);
夏至:=FILTER(MONTH=6 AND (DAY=20 OR DAY=22),2);
小暑:=FILTER(MONTH=7 AND (DAY=6 OR DAY=8 ),2);
大暑:=FILTER(MONTH=7 AND (DAY=22 OR DAY=24),2);
立秋:=FILTER(MONTH=8 AND (DAY=7 OR DAY=9 ),2);
处暑:=FILTER(MONTH=8 AND (DAY=22 OR DAY=24),2);
白露:=FILTER(MONTH=9 AND (DAY=7 OR DAY=9 ),2);
秋分:=FILTER(MONTH=9 AND (DAY=22 OR DAY=24),2);
寒露:=FILTER(MONTH=10 AND (DAY=7 OR DAY=9 ),2);
霜降:=FILTER(MONTH=10 AND (DAY=22 OR DAY=24),2);
立冬:=FILTER(MONTH=11 AND (DAY=7 OR DAY=9 ),2);
小雪:=FILTER(MONTH=11 AND (DAY=22 OR DAY=24),2);
大雪:=FILTER(MONTH=12 AND (DAY=6 OR DAY=8 ),2);
冬至:=FILTER(MONTH=12 AND (DAY=21 OR DAY=23),2);
小寒:=FILTER(MONTH=1 AND (DAY=5 OR DAY=7 ),2);
大寒:=FILTER(MONTH=1 AND (DAY=19 OR DAY=21),2);
OK7:=IF(CURRBARSCOUNT<=CONST(4),CONST(IF(4,4,4)),DRAWNULL);
DRAWTEXT(OK7&&立春,L/1.003,'立');
DRAWTEXT(OK7&&立春,L/1.008,'春');
DRAWTEXT(OK7&&雨水,L/1.003,'雨');
DRAWTEXT(OK7&&雨水,L/1.008,'水');
DRAWTEXT(OK7&&惊蛰,L/1.003,'惊');
DRAWTEXT(OK7&&惊蛰,L/1.008,'蛰');
DRAWTEXT(OK7&&春分,L/1.003,'春');
DRAWTEXT(OK7&&春分,L/1.008,'分');
DRAWTEXT(OK7&&清明,L/1.003,'清');
DRAWTEXT(OK7&&清明,L/1.008,'明');
DRAWTEXT(OK7&&谷雨,L/1.003,'谷');
DRAWTEXT(OK7&&谷雨,L/1.008,'雨');
DRAWTEXT(OK7&&立夏,L/1.003,'立');
DRAWTEXT(OK7&&立夏,L/1.008,'夏');
DRAWTEXT(OK7&&小满,L/1.003,'小');
DRAWTEXT(OK7&&小满,L/1.008,'满');
DRAWTEXT(OK7&&芒种,L/1.003,'芒');
DRAWTEXT(OK7&&芒种,L/1.008,'种');
DRAWTEXT(OK7&&夏至,L/1.003,'夏');
DRAWTEXT(OK7&&夏至,L/1.008,'至');
DRAWTEXT(OK7&&小暑,L/1.003,'小');
DRAWTEXT(OK7&&小暑,L/1.008,'暑');
DRAWTEXT(OK7&&大暑,L/1.003,'大');
DRAWTEXT(OK7&&大暑,L/1.008,'暑');
DRAWTEXT(OK7&&立秋,L/1.003,'立');
DRAWTEXT(OK7&&立秋,L/1.008,'秋');
DRAWTEXT(OK7&&处暑,L/1.003,'处');
DRAWTEXT(OK7&&处暑,L/1.008,'暑');
DRAWTEXT(OK7&&白露,L/1.003,'白');
DRAWTEXT(OK7&&白露,L/1.008,'露');
DRAWTEXT(OK7&&秋分,L/1.003,'秋');
DRAWTEXT(OK7&&秋分,L/1.008,'分');
DRAWTEXT(OK7&&寒露,L/1.003,'寒');
DRAWTEXT(OK7&&寒露,L/1.008,'露');
DRAWTEXT(OK7&&霜降,L/1.003,'霜');
DRAWTEXT(OK7&&霜降,L/1.008,'降');
DRAWTEXT(OK7&&立冬,L/1.003,'立');
DRAWTEXT(OK7&&立冬,L/1.008,'冬');
DRAWTEXT(OK7&&小雪,L/1.003,'小');
DRAWTEXT(OK7&&小雪,L/1.008,'雪');
DRAWTEXT(OK7&&大雪,L/1.003,'大');
DRAWTEXT(OK7&&大雪,L/1.008,'雪');
DRAWTEXT(OK7&&冬至,L/1.003,'冬');
DRAWTEXT(OK7&&冬至,L/1.008,'至');
DRAWTEXT(OK7&&小寒,L/1.003,'小');
DRAWTEXT(OK7&&小寒,L/1.008,'寒');
DRAWTEXT(OK7&&大寒,L/1.003,'大');
DRAWTEXT(OK7&&大寒,L/1.008,'寒');[/lycode][lycode=tdx2,true]输出中点:(最高价+最低价)/2,NODRAW
OK1赋值:上次最低价=360日内最低价的最低值距今天数+1
OK2赋值:OK1日前的最低价
日360最低赋值:如果到最后交易的周期<=OK1+1的最后一日取值设为常数,返回如果OK1,返回OK2,否则返回OK2的最后一日取值设为常数,否则返回无效数画绿色
OK6赋值:如果到最后交易的周期<=OK1的最后一日取值设为常数,返回如果OK1,返回OK1,否则返回OK1的最后一日取值设为常数,否则返回无效数
月开赋值:开盘价[取月线数据]
输出月高:最高价[取月线数据],NODRAW,画红色
输出月中:(最高价[取月线数据]+最低价[取月线数据])/2,NODRAW,画黄色
输出月低:最低价[取月线数据],NODRAW,画绿色
月收赋值:收盘价[取月线数据]
当满足条件OK6并且月收>=月开时,在月高和月低位置之间画柱状线,宽度为3.2,-1不为0则画空心柱.,画红色
当满足条件OK6并且月收<=月开时,在月高和月低位置之间画柱状线,宽度为3.2,-1不为0则画空心柱.,画青色
周开赋值:开盘价[取周线数据]
输出周高:最高价[取周线数据],NODRAW,画红色
输出周中:(最高价[取周线数据]+最低价[取周线数据])/2,NODRAW,画黄色
输出周低:最低价[取周线数据],NODRAW,画绿色
周收赋值:收盘价[取周线数据]
当满足条件OK6并且周收>=周开时,在周高和周低位置之间画柱状线,宽度为4.1,0不为0则画空心柱.,COLORFF0098
当满足条件OK6并且周收<=周开时,在周高和周低位置之间画柱状线,宽度为4.1,0不为0则画空心柱.,COLOR006000
K线
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,COLOR00CC00
O5赋值:OK6并且收阳线
当满足条件O5时,在收盘价和开盘价位置之间画柱状线,宽度为3.03,0不为0则画空心柱.,COLOR450099
当满足条件O5时,在收盘价和开盘价位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLOR4500AA
当满足条件O5时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR4500BB
当满足条件O5时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR4500CC
当满足条件O5时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR4500DD
当满足条件O5时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR4500EE
当满足条件O5时,在收盘价和开盘价位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,COLOR4500FF
O2赋值:OK6并且收阴线
当满足条件O2时,在收盘价和开盘价位置之间画柱状线,宽度为3.03,0不为0则画空心柱.,COLOR009900
当满足条件O2时,在收盘价和开盘价位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLOR00AA00
当满足条件O2时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR00BB00
当满足条件O2时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR00CC00
当满足条件O2时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00DD00
当满足条件O2时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR00EE00
当满足条件O2时,在收盘价和开盘价位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,COLOR00FF00
当满足条件中点时,在中点和中点位置之间画柱状线,宽度为0.01,1不为0则画空心柱.,COLOR00FFFF
HHH赋值:当满足条件周中时,在周中和周中位置之间画柱状线,宽度为4.1,0不为0则画空心柱.,画青色
Q1赋值:当满足条件月中时,在月中和月中位置之间画柱状线,宽度为4.1,-1不为0则画空心柱.,画黄色
当满足条件OK6并且周中时,在周中和周中位置之间画柱状线,宽度为4.1,-1不为0则画空心柱.,画黄色
K8赋值:上次收盘价的5日指数移动平均>=收盘价的20日指数移动平均距今天数
K9赋值:上次收盘价的5日指数移动平均<=收盘价的20日指数移动平均距今天数
K110赋值:如果收盘价的5日指数移动平均>=收盘价的20日指数移动平均,返回(收盘价的5日指数移动平均+收盘价的20日指数移动平均)/2,否则返回无效数
K115赋值:如果收盘价的5日指数移动平均>=收盘价的20日指数移动平均,返回收盘价的5日指数移动平均,否则返回无效数
K120赋值:如果收盘价的5日指数移动平均>=收盘价的20日指数移动平均,返回收盘价的20日指数移动平均,否则返回无效数
输出线5:如果到最后交易的周期<K9+2的最后一日取值设为常数,返回K115,否则返回无效数画黄色
输出线10:如果到最后交易的周期<K9+2的最后一日取值设为常数,返回K110,否则返回无效数,画黄色
输出线20:如果到最后交易的周期<K9+2的最后一日取值设为常数,返回K120,否则返回无效数,画黄色
立春赋值:月份=2AND(日=3ORDAY=5)的2日过滤
雨水赋值:月份=2AND(日=18ORDAY=20)的2日过滤
惊蛰赋值:月份=3AND(日=5ORDAY=7)的2日过滤
春分赋值:月份=3AND(日=20ORDAY=22)的2日过滤
清明赋值:月份=4AND(日=3ORDAY=6)的2日过滤
谷雨赋值:月份=4AND(日=19ORDAY=21)的2日过滤
立夏赋值:月份=5AND(日=6ORDAY=8)的2日过滤
小满赋值:月份=5AND(日=20ORDAY=22)的2日过滤
芒种赋值:月份=6AND(日=5ORDAY=7)的2日过滤
夏至赋值:月份=6AND(日=20ORDAY=22)的2日过滤
小暑赋值:月份=7AND(日=6ORDAY=8)的2日过滤
大暑赋值:月份=7AND(日=22ORDAY=24)的2日过滤
立秋赋值:月份=8AND(日=7ORDAY=9)的2日过滤
处暑赋值:月份=8AND(日=22ORDAY=24)的2日过滤
白露赋值:月份=9AND(日=7ORDAY=9)的2日过滤
秋分赋值:月份=9AND(日=22ORDAY=24)的2日过滤
寒露赋值:月份=10AND(日=7ORDAY=9)的2日过滤
霜降赋值:月份=10AND(日=22ORDAY=24)的2日过滤
立冬赋值:月份=11AND(日=7ORDAY=9)的2日过滤
小雪赋值:月份=11AND(日=22ORDAY=24)的2日过滤
大雪赋值:月份=12AND(日=6ORDAY=8)的2日过滤
冬至赋值:月份=12AND(日=21ORDAY=23)的2日过滤
小寒赋值:月份=1AND(日=5ORDAY=7)的2日过滤
大寒赋值:月份=1AND(日=19ORDAY=21)的2日过滤
OK7赋值:如果到最后交易的周期<=4的最后一日取值设为常数,返回如果4,返回4,否则返回4的最后一日取值设为常数,否则返回无效数
当满足条件OK7并且立春时,在最低价/1.003位置书写文字
当满足条件OK7并且立春时,在最低价/1.008位置书写文字
当满足条件OK7并且雨水时,在最低价/1.003位置书写文字
当满足条件OK7并且雨水时,在最低价/1.008位置书写文字
当满足条件OK7并且惊蛰时,在最低价/1.003位置书写文字
当满足条件OK7并且惊蛰时,在最低价/1.008位置书写文字
当满足条件OK7并且春分时,在最低价/1.003位置书写文字
当满足条件OK7并且春分时,在最低价/1.008位置书写文字
当满足条件OK7并且清明时,在最低价/1.003位置书写文字
当满足条件OK7并且清明时,在最低价/1.008位置书写文字
当满足条件OK7并且谷雨时,在最低价/1.003位置书写文字
当满足条件OK7并且谷雨时,在最低价/1.008位置书写文字
当满足条件OK7并且立夏时,在最低价/1.003位置书写文字
当满足条件OK7并且立夏时,在最低价/1.008位置书写文字
当满足条件OK7并且小满时,在最低价/1.003位置书写文字
当满足条件OK7并且小满时,在最低价/1.008位置书写文字
当满足条件OK7并且芒种时,在最低价/1.003位置书写文字
当满足条件OK7并且芒种时,在最低价/1.008位置书写文字
当满足条件OK7并且夏至时,在最低价/1.003位置书写文字
当满足条件OK7并且夏至时,在最低价/1.008位置书写文字
当满足条件OK7并且小暑时,在最低价/1.003位置书写文字
当满足条件OK7并且小暑时,在最低价/1.008位置书写文字
当满足条件OK7并且大暑时,在最低价/1.003位置书写文字
当满足条件OK7并且大暑时,在最低价/1.008位置书写文字
当满足条件OK7并且立秋时,在最低价/1.003位置书写文字
当满足条件OK7并且立秋时,在最低价/1.008位置书写文字
当满足条件OK7并且处暑时,在最低价/1.003位置书写文字
当满足条件OK7并且处暑时,在最低价/1.008位置书写文字
当满足条件OK7并且白露时,在最低价/1.003位置书写文字
当满足条件OK7并且白露时,在最低价/1.008位置书写文字
当满足条件OK7并且秋分时,在最低价/1.003位置书写文字
当满足条件OK7并且秋分时,在最低价/1.008位置书写文字
当满足条件OK7并且寒露时,在最低价/1.003位置书写文字
当满足条件OK7并且寒露时,在最低价/1.008位置书写文字
当满足条件OK7并且霜降时,在最低价/1.003位置书写文字
当满足条件OK7并且霜降时,在最低价/1.008位置书写文字
当满足条件OK7并且立冬时,在最低价/1.003位置书写文字
当满足条件OK7并且立冬时,在最低价/1.008位置书写文字
当满足条件OK7并且小雪时,在最低价/1.003位置书写文字
当满足条件OK7并且小雪时,在最低价/1.008位置书写文字
当满足条件OK7并且大雪时,在最低价/1.003位置书写文字
当满足条件OK7并且大雪时,在最低价/1.008位置书写文字
当满足条件OK7并且冬至时,在最低价/1.003位置书写文字
当满足条件OK7并且冬至时,在最低价/1.008位置书写文字
当满足条件OK7并且小寒时,在最低价/1.003位置书写文字
当满足条件OK7并且小寒时,在最低价/1.008位置书写文字
当满足条件OK7并且大寒时,在最低价/1.003位置书写文字
当满足条件OK7并且大寒时,在最低价/1.008位置书写文字
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/13X7Hn5ac6I7_h2RFFM-eNw

看了该指标的人还看了:
波段利器指标    金财神SB指标    主力买卖指标
主力轨迹买卖指标    瀑布线指标    沉船寻宝指标

使用道具 举报

回复