请选择 进入手机版|继续访问电脑版
132 2 0

顾比变色+倒数线 通达信 主图 趋势

[复制链接]
HUNTIANLING 注册会员 发表在 指标公式  2019-5-15 15:44:07 显示全部楼层 阅读模式

发表新帖
发表于 2019-5-15 15:44:07|阅读模式
指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 趋势 
本帖最后由 HUNTIANLING 于 2019-5-15 17:14 编辑

DA:=EMA(CLOSE,3);NOTEXT6:DA,COLORBLUE;
DB:=EMA(CLOSE,5) ;NOTEXT7:DB,COLORBLUE;
DC:=EMA(CLOSE,8) ;NOTEXT8:DC,COLORBLUE;
DD:=EMA(CLOSE,10);NOTEXT9:DD,COLORBLUE;
DE:=EMA(CLOSE,12);NOTEXT10:DE,COLORBLUE;
DF:=EMA(CLOSE,15);NOTEXT11:DF,COLORBLUE;
CA:=EMA(CLOSE,30);NOTEXT12:CA,COLORYELLOW;
CB:=EMA(CLOSE,35);NOTEXT13:CB,COLORYELLOW;
CC:=EMA(CLOSE,40);NOTEXT14:CC,COLORYELLOW;
CD:=EMA(CLOSE,45);NOTEXT15:CD,COLORYELLOW;
CE:=EMA(CLOSE,50);NOTEXT16:CD,COLORYELLOW;
CF:=EMA(CLOSE,60);NOTEXT17:CF,COLORYELLOW;
CDYX:=CA>CB AND CB>CC AND CC>CD AND CD>CE AND CE>CF;
CKYX:=CA<CB AND CB<CC AND CC<CD AND CD<CE AND CE<CF;
DDYX:=DA>DB AND DB>DC AND DC>DD AND DD>DE AND DE>DF;
DKYX:=CA<CB AND DB<DC AND DC<DD AND DD<DE AND DE<DF;
NOTEXT18:IF(CDYX,CA,DRAWNULL),COLORBROWN;
NOTEXT19:IF(CDYX,CB,DRAWNULL),COLORBROWN;
NOTEXT20:IF(CDYX,CC,DRAWNULL),COLORBROWN;
NOTEXT21:IF(CDYX,CD,DRAWNULL),COLORBROWN;
NOTEXT22:IF(CDYX,CE,DRAWNULL),COLORBROWN;
NOTEXT23:IF(CDYX,CF,DRAWNULL),COLORBROWN;
NOTEXT24:IF(CKYX,CA,DRAWNULL),COLORCYAN;
NOTEXT25:IF(CKYX,CB,DRAWNULL),COLORCYAN;
NOTEXT26:IF(CKYX,CC,DRAWNULL),COLORCYAN;
NOTEXT27:IF(CKYX,CD,DRAWNULL),COLORCYAN;
NOTEXT28:IF(CKYX,CE,DRAWNULL),COLORCYAN;
NOTEXT29:IF(CKYX,CF,DRAWNULL),COLORCYAN;

NOTEXT30:IF(DDYX,DA,DRAWNULL),COLORRED;
NOTEXT31:IF(DDYX,DB,DRAWNULL),COLORRED;
NOTEXT32:IF(DDYX,DC,DRAWNULL),COLORRED;
NOTEXT33:IF(DDYX,DD,DRAWNULL),COLORRED;
NOTEXT34:IF(DDYX,DE,DRAWNULL),COLORRED;
NOTEXT35:IF(DDYX,DF,DRAWNULL),COLORRED;

NOTEXT36:IF(DKYX,DA,DRAWNULL),COLORGREEN;
NOTEXT37:IF(DKYX,DB,DRAWNULL),COLORGREEN;
NOTEXT38:IF(DKYX,DC,DRAWNULL),COLORGREEN;
NOTEXT39:IF(DKYX,DD,DRAWNULL),COLORGREEN;
NOTEXT40:IF(DKYX,DE,DRAWNULL),COLORGREEN;
NOTEXT41:IF(DKYX,DF,DRAWNULL),COLORGREEN;

A23:=((C + L) + H) / 3;
A24:=EMA(A23,6);
A25:=EMA(A24,5);
A26:=CROSS(A24,A25);
DRAWICON(A26,(LOW / 1.015),1),LINETHICK2,COLORMAGENTA;



P:=21;
WH1:=IF(L=LLV(L,P),L,DRAWNULL);
WH2:=CONST(BARSLAST(WH1!=DRAWNULL));
WH3:=CONST(IF(WH2=0,H,REF(H,WH2)));
WH4:=CONST(REF(BARSLAST(H>WH3),WH2+1)+WH2+1);
WH5:=CONST(IF(WH4=0,H,REF(H,WH4)));
WH6:=CONST(REF(BARSLAST(H>WH5),WH4+1)+WH4+1);
进场:IF(CURRBARSCOUNT<=WH2+21,CONST(IF(WH6=0,H,REF(H,WH6))),DRAWNULL),COLORRED;
IF(CURRBARSCOUNT<=WH2+1,IF(L=LLV(L,P),L,DRAWNULL),DRAWNULL),CIRCLEDOT,COLORRED;
DRAWTEXT(CURRBARSCOUNT=INTPART((WH2+21)*0.618),进场,'进场线'),COLORRED;
H1:=IF(H=HHV(H,P),H,DRAWNULL);
H2:=CONST(BARSLAST(H1!=DRAWNULL));
H3:=CONST(IF(H2=0,L,REF(L,H2)));
H4:=CONST(REF(BARSLAST(L<H3),H2+1)+H2+1);
H5:=CONST(IF(H4=0,L,REF(L,H4)));
H6:=CONST(REF(BARSLAST(L<H5),H4+1)+H4+1);
止损:IF(CURRBARSCOUNT<=H2+21,CONST(IF(H6=0,L,REF(L,H6))),DRAWNULL),COLORYELLOW;
IF(CURRBARSCOUNT<=H2+1,IF(H=HHV(H,P),H,DRAWNULL),DRAWNULL),CIRCLEDOT,COLORBLUE;
DRAWTEXT(CURRBARSCOUNT=INTPART((H2+21)*0.618),止损,'止损线'),COLORYELLOW;
止盈:IF(CURRBARSCOUNT<=H2+21,CONST(IF(H4=0,L,REF(L,H4))),DRAWNULL),COLORCB21BE;
DRAWTEXT(CURRBARSCOUNT=INTPART((H2+21)*0.618),止盈,'止盈线'),COLORCB21BE;
GB1:=EMA(C,8)>EMA(C,15) AND EMA(C,40)>REF(EMA(C,40),1) AND CROSS(EMA(C,3),EMA(C,35));
GB2:=EMA(C,15)>EMA(C,40) AND EMA(C,35)>REF(EMA(C,35),1) AND CROSS(EMA(C,3),EMA(C,5));
GB3:=ABS(EMA(C,15)-EMA(C,60))/C<0.01 AND EMA(C,15)>EMA(C,30) AND O<EMA(C,3) AND C>EMA(C,3) AND O<EMA(C,15) AND C>EMA(C,15) AND O<EMA(C,30) AND C>EMA(C,30) AND O<EMA(C,60) AND C>EMA(C,60);
GB4:=ABS(EMA(C,45)-EMA(C,30))/C<0.011 AND EMA(C,3)>EMA(C,15) AND EMA(C,15)>EMA(C,40) AND CROSS(EMA(C,5),EMA(C,60));
Z1:=OPEN<EMA(C,20) OR OPEN<EMA(C,40) OR OPEN<EMA(C,60);
Z2:=C>MAX(EMA(C,20),MAX(EMA(C,40),EMA(C,60)));
Z3:=V/MA(V,10)>1.2;
Z4:=C/REF(C,1)>1.049;
出水芙蓉:=Z1 AND Z2 AND Z3 AND Z4 AND O<EMA(C,60) AND C>EMA(C,60);
XG:=IF(GB1 OR GB2 OR GB3 OR GB4 OR 出水芙蓉,C,23);
DRAWICON(EMA(C,8)>EMA(C,15) AND EMA(C,40)>REF(EMA(C,40),1) AND CROSS(EMA(C,3),EMA(C,35)),L-0.20,24);
DRAWICON(EMA(C,15)>EMA(C,40) AND EMA(C,35)>REF(EMA(C,35),1) AND CROSS(EMA(C,3),EMA(C,5)),L-0.20,25);
DRAWICON(ABS(EMA(C,15)-EMA(C,60))/C<0.01 AND EMA(C,15)>EMA(C,30) AND O<EMA(C,3) AND C>EMA(C,3) AND O<EMA(C,15) AND C>EMA(C,15) AND O<EMA(C,30) AND C>EMA(C,30) AND O<EMA(C,60) AND C>EMA(C,60),L-0.20,27);



DK:=MA(C,25);
IF(DK<=REF(DK,1),DK,DRAWNULL),COLORGREEN,LINETHICK3;
IF(DK>REF(DK,1),DK,DRAWNULL),COLORRED,LINETHICK3;
多空:DK,NODRAW;
总股本:=FINANCE(1)/100000000;
流通股本:=FINANCE(7)/100000000;
未流通比:=(总股本-流通股本)/总股本*100;
现价:=C;
全流通后价:=C*流通股本/总股本;
解禁股:=IF((流通股本-REF(流通股本,1))>0,(流通股本-REF(流通股本,1)),0),COLORYELLOW;{流通股增加}
DRAWTEXT(解禁股>0, L,'解禁'),COLORYELLOW;
冻结:IF((流通股本-REF(流通股本,1))<0,(REF(流通股本,1)-流通股本),0),COLORGREEN,NODRAW;{流通股减少};



看了该指标的人还看了:
上升之星指标    抄底神器指标    金财神SB指标
趋势操盘指标    五福临门指标    猎庄买点指标
tdxjietu2.JPG
tdxjietu3.JPG

使用道具 举报

回复

精彩评论(2)

发表于 2019-5-15 15:48:13
以上是我使用的主图,具体用法需要学习顾比的著作。同时,其中结合了2560战法。供大家参考。
tdxjietu1.JPG

使用道具 举报

回复

发表于 2019-5-16 16:07:47
不错,加油哦,,

使用道具 举报

回复

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表