指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 买卖点 抄底逃顶 趋势 
炒股叉_20190515_103134.png

炒股叉_20190515_103139.png

[lywrap=通达信主图指标公式][lycode=tdx,true]DRAWBAND(MA(CLOSE,60),RGB(55,0,0),MA(CLOSE,120),RGB(0,91,0));
DRAWBAND(MA(CLOSE,5),RGB(155,50,50),MA(CLOSE,10),RGB(83,123,68));
DRAWKLINE(H,O,L,C);
MA5:MA(CLOSE,5),COLORWHITE;
MA10:MA(CLOSE,10),COLORYELLOW;
MA20:MA(CLOSE,20),COLORMAGENTA;
MA60:MA(CLOSE,60),COLORGREEN,LINETHICK1;
MA120:MA(CLOSE,120),COLORLIRED,LINETHICK1;
MA240:MA(CLOSE,240),COLORBLUE;
DRAWICON(CROSS(MA10,MA20),MA20,1);
DRAWICON(CROSS(MA20,MA60),MA60,1);
DRAWICON(CROSS(MA20,MA120),MA120,1);
DRAWICON(CROSS(MA20,MA240),MA240,1);
DRAWICON(CROSS(MA60,MA120),MA60,1);
DRAWICON(CROSS(MA60,MA240),MA240,1);
DRAWICON(CROSS(MA20,MA10),MA20,2);
DRAWICON(CROSS(MA60,MA20),MA60,2);
DRAWICON(CROSS(MA120,MA60),MA120,2);
DRAWTEXT(CROSS(ZIG(3,8),REF(ZIG(3,8),1)),LOW*0.978,'★抄底') ,LINETHICK2,COLORRED;
STICKLINE(C<0.905*REF(C,1),C,O,5,0),COLORWHITE;
STICKLINE(C>1.095*REF(C,1),C,O,5,0),COLORYELLOW;
N:=10;
T1:=CONST(HHVBARS(V,10)),COLOR0000FF,LINETHICK1;
量能平台:IF(CURRBARSCOUNT<=N+15,CONST(IF(T1=0,C,REF(C,T1))),DRAWNULL)COLOR0000FF,LINETHICK2;
新量能点:IF(CURRBARSCOUNT=T1+1,量能平台,DRAWNULL),CIRCLEDOT,COLORLIGRAY,LINETHICK1;
DRAWTEXT(ISLASTBAR,量能平台,' 压力支撑');
JJ:=(CLOSE+HIGH+LOW)/3;
A:=EMA(JJ,10);
B:=REF(A,1);
Q:=REF(C,1);
涨停:=IF((C-Q)*100/Q>=(10-0.01*100/Q),1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),,COLORYELLOW;
STICKLINE(涨停,H,L,0,0),,COLORYELLOW;
半分位:=(O+C)/2;
昨半分位:=REF(半分位,1);
STICKLINE(ISLASTBAR,昨半分位,昨半分位,10,0);
DRAWNUMBER(ISLASTBAR,昨半分位,昨半分位);
DRAWTEXT(ISLASTBAR,昨半分位,' 中轴');
SST1:=DATE>REF(DATE,1);
SST2:=BARSLAST(SST1)+1;
SST3:=REF(IF(SST2=1,1,SST2),SST2);
SST4:=CONST(REF(HHV(H,SST3),SST2));
SST5:=CONST(REF(LLV(L,SST3),SST2));
SST6:=MA(AMO,SST3)/MA(VOL,SST3)/100;
SST7:=REF(MA((H+O+L+C)/4,SST3),SST2);
SST8:=IF(CAPITAL>0,REF(SST6,SST2),SST7);
昨高:IF(CURRBARSCOUNT<=CONST(SST3+SST2),SST4,DRAWNULL),COLOR0000FF;
昨低:IF(CURRBARSCOUNT<=CONST(SST3+SST2),SST5,DRAWNULL),COLOR37FF37;
昨均:IF(CURRBARSCOUNT<=CONST(SST3+SST2),CONST(SST8),DRAWNULL),COLOR37FFFF;
DRAWTEXT(ISLASTBAR,昨高-0.001,' 放量突破加仓'),COLORRED;
DRAWTEXT(ISLASTBAR,昨低+0.003,' 放量收漏止损'),COLORGREEN;
DRAWTEXT(ISLASTBAR,昨均,' 缩量回调低吸'),COLORYELLOW;
持股区域:STICKLINE(A>B,A,B,2,0),COLORYELLOW;
持币区域:STICKLINE(A<B,A,B,2,0),COLORBLUE;[/lycode][lycode=tdx2,true]画带状线
画带状线
K线
输出MA5:收盘价的5日简单移动平均,画白色
输出MA10:收盘价的10日简单移动平均,画黄色
输出MA20:收盘价的20日简单移动平均,画洋红色
输出MA60:收盘价的60日简单移动平均,画绿色,线宽为1
输出MA120:收盘价的120日简单移动平均,画淡红色,线宽为1
输出MA240:收盘价的240日简单移动平均,画蓝色
当满足条件MA10上穿MA20时,在MA20位置画1号图标
当满足条件MA20上穿MA60时,在MA60位置画1号图标
当满足条件MA20上穿MA120时,在MA120位置画1号图标
当满足条件MA20上穿MA240时,在MA240位置画1号图标
当满足条件MA60上穿MA120时,在MA60位置画1号图标
当满足条件MA60上穿MA240时,在MA240位置画1号图标
当满足条件MA20上穿MA10时,在MA20位置画2号图标
当满足条件MA60上穿MA20时,在MA60位置画2号图标
当满足条件MA120上穿MA60时,在MA120位置画2号图标
当满足条件收盘价8%的之字转向上穿1日前的收盘价8%的之字转向时,在最低价*0.978位置书写文字 ,线宽为2,画红色
当满足条件收盘价<0.905*1日前的收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为5,0不为0则画空心柱.,画白色
当满足条件收盘价>1.095*1日前的收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为5,0不为0则画空心柱.,画黄色
N赋值:10
T1赋值:10日内成交量(手)距今天数的最后一日取值设为常数,COLOR0000FF,线宽为1
输出量能平台:如果到最后交易的周期<=N+15,返回如果T1=0,返回收盘价,否则返回T1日前的收盘价的最后一日取值设为常数,否则返回无效数COLOR0000FF,线宽为2
输出新量能点:如果到最后交易的周期=T1+1,返回量能平台,否则返回无效数,CIRCLEDOT,画淡灰色,线宽为1
当满足条件是否最后一个周期时,在量能平台位置书写文字
JJ赋值:(收盘价+最高价+最低价)/3
A赋值:JJ的10日指数移动平均
B赋值:1日前的A
Q赋值:1日前的收盘价
涨停赋值:如果(收盘价-Q)*100/Q>=(10-0.01*100/Q),返回1,否则返回0
当满足条件涨停时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,,画黄色
当满足条件涨停时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,,画黄色
半分位赋值:(开盘价+收盘价)/2
昨半分位赋值:1日前的半分位
当满足条件是否最后一个周期时,在昨半分位和昨半分位位置之间画柱状线,宽度为10,0不为0则画空心柱.
当满足条件是否最后一个周期时,在昨半分位位置书写数字
当满足条件是否最后一个周期时,在昨半分位位置书写文字
SST1赋值:日期>1日前的日期
SST2赋值:上次SST1距今天数+1
SST3赋值:SST2日前的如果SST2=1,返回1,否则返回SST2
SST4赋值:SST2日前的SST3日内最高价的最高值的最后一日取值设为常数
SST5赋值:SST2日前的SST3日内最低价的最低值的最后一日取值设为常数
SST6赋值:成交额(元)的SST3日简单移动平均/成交量(手)的SST3日简单移动平均/100
SST7赋值:SST2日前的(最高价+开盘价+最低价+收盘价)/4的SST3日简单移动平均
SST8赋值:如果当前流通股本(手)>0,返回SST2日前的SST6,否则返回SST7
输出昨高:如果到最后交易的周期<=SST3+SST2的最后一日取值设为常数,返回SST4,否则返回无效数,COLOR0000FF
输出昨低:如果到最后交易的周期<=SST3+SST2的最后一日取值设为常数,返回SST5,否则返回无效数,COLOR37FF37
输出昨均:如果到最后交易的周期<=SST3+SST2的最后一日取值设为常数,返回SST8的最后一日取值设为常数,否则返回无效数,COLOR37FFFF
当满足条件是否最后一个周期时,在昨高-0.001位置书写文字,画红色
当满足条件是否最后一个周期时,在昨低+0.003位置书写文字,画绿色
当满足条件是否最后一个周期时,在昨均位置书写文字,画黄色
输出持股区域:当满足条件A>B时,在A和B位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色
输出持币区域:当满足条件A<B时,在A和B位置之间画柱状线,宽度为2,0不为0则画空心柱.,画蓝色
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1WvWd5nGIZVaa2peZUzj81A

看了该指标的人还看了:
绝佳买点指标    股海神偷指标    短线追踪指标
估抄底F指标    压力走势指标    中线指标

使用道具 举报

回复