指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 买卖点 趋势 
炒股叉_20190513_104940.png

炒股叉_20190513_104947.png

[lywrap=通达信主图指标公式][lycode=tdx,true]K2:=EMA(C,5),COLORFFFF00;
K3:=EMA(C,10),COLORFFFF00;
K5:=EMA(C,30),COLORFFFF00;
KK5:=EMA(INDEXC,30),COLORFFFF00;
A10:=EMA(C,10);
K6:=2*(K2-K5);K7:=2*(K2-K3);
K8:=2*(K7+K6),COLORRED;
VAR1:=(100-((90*(HHV(HIGH,21)-CLOSE))/(HHV(HIGH,21)-LLV(LOW,21))));
VAR2:=(100-((90*(HHV(HIGH,21)-CLOSE))/(HHV(HIGH,21)-LLV(LOW,21))));
VAR3:=(100-MA(((100*(HHV(HIGH,6)-CLOSE))/(HHV(HIGH,6)-LLV(LOW,6))),34));
年:=MA(CLOSE,26),COLORGREEN,LINETHICK0;
箱底:LLV(MA((LOW),5),30),COLORGREEN,LINETHICK1;
长箱底:LLV(MA((LOW),5),60),LINETHICK1;
长长箱底:LLV(MA((LOW),5),100),COLORCYAN,LINETHICK1;
长长箱顶:HHV(MA((HIGH),6),120),LINETHICK1;
长箱顶:HHV(MA((HIGH),6),60),COLORRED,LINETHICK1;
箱顶:HHV(MA((HIGH),6),30),COLOR00AAFF,LINETHICK1;
中间:(箱顶+箱底)/2,COLORFF00FF,LINETHICK3;
启动线:EMA(C,2),COLOR00FF00,LINETHICK2;
WX:EMA(C,5),COLORWHITE,LINETHICK2;
STICKLINE(CROSS(WX,中间),中间-0.8,中间+0.8,8,0) ,COLORWHITE;
STICKLINE(CROSS(WX,长箱顶),长箱顶-0.8,长箱顶+0.8,10,0) ,COLORYELLOW,LINETHICK2;
STICKLINE(CROSS(WX,箱顶),箱顶-0.5,箱顶+0.5,10,0) ,COLORGREEN;
STICKLINE(WX>中间,中间,WX,0,-1),COLORFF00FF;
STICKLINE(中间>WX,WX,中间,0,-1),COLORLIGREEN;
STICKLINE(CLOSE<OPEN OR CLOSE=OPEN AND CLOSE<=REF(CLOSE,1),OPEN,CLOSE,5,0),COLORCYAN;
STICKLINE(CLOSE>OPEN OR CLOSE=OPEN AND CLOSE>REF(CLOSE,1),OPEN,CLOSE,5,0),COLORRED;[/lycode][lycode=tdx2,true]K2赋值:收盘价的5日指数移动平均,COLORFFFF00
K3赋值:收盘价的10日指数移动平均,COLORFFFF00
K5赋值:收盘价的30日指数移动平均,COLORFFFF00
KK5赋值:大盘的收盘价的30日指数移动平均,COLORFFFF00
A10赋值:收盘价的10日指数移动平均
K6赋值:2*(K2-K5)
K7赋值:2*(K2-K3)
K8赋值:2*(K7+K6),画红色
VAR1赋值:(100-((90*(21日内最高价的最高值-收盘价))/(21日内最高价的最高值-21日内最低价的最低值)))
VAR2赋值:(100-((90*(21日内最高价的最高值-收盘价))/(21日内最高价的最高值-21日内最低价的最低值)))
VAR3赋值:(100-((100*(6日内最高价的最高值-收盘价))/(6日内最高价的最高值-6日内最低价的最低值))的34日简单移动平均)
年赋值:收盘价的26日简单移动平均,画绿色,线宽为0
输出箱底:30日内(最低价)的5日简单移动平均的最低值,画绿色,线宽为1
输出长箱底:60日内(最低价)的5日简单移动平均的最低值,线宽为1
输出长长箱底:100日内(最低价)的5日简单移动平均的最低值,画青色,线宽为1
输出长长箱顶:120日内(最高价)的6日简单移动平均的最高值,线宽为1
输出长箱顶:60日内(最高价)的6日简单移动平均的最高值,画红色,线宽为1
输出箱顶:30日内(最高价)的6日简单移动平均的最高值,COLOR00AAFF,线宽为1
输出中间:(箱顶+箱底)/2,COLORFF00FF,线宽为3
输出启动线:收盘价的2日指数移动平均,COLOR00FF00,线宽为2
输出WX:收盘价的5日指数移动平均,画白色,线宽为2
当满足条件WX上穿中间时,在中间-0.8和中间+0.8位置之间画柱状线,宽度为8,0不为0则画空心柱. ,画白色
当满足条件WX上穿长箱顶时,在长箱顶-0.8和长箱顶+0.8位置之间画柱状线,宽度为10,0不为0则画空心柱. ,画黄色,线宽为2
当满足条件WX上穿箱顶时,在箱顶-0.5和箱顶+0.5位置之间画柱状线,宽度为10,0不为0则画空心柱. ,画绿色
当满足条件WX>中间时,在中间和WX位置之间画柱状线,宽度为0,-1不为0则画空心柱.,COLORFF00FF
当满足条件中间>WX时,在WX和中间位置之间画柱状线,宽度为0,-1不为0则画空心柱.,画淡绿色
当满足条件收盘价<OPENORCLOSE=OPENANDCLOSE<=1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为5,0不为0则画空心柱.,画青色
当满足条件收盘价>OPENORCLOSE=OPENANDCLOSE>1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为5,0不为0则画空心柱.,画红色
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1f9R1sMd-9yCbC1svG6V5tA

看了该指标的人还看了:
绝佳买点指标    股海神偷指标    短线追踪指标
估抄底F指标    压力走势指标    中线指标

使用道具 举报

回复