指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 操盘控盘 压力支撑 
炒股叉_20190513_104327.png

炒股叉_20190513_104332.png

[lywrap=通达信主图指标公式][lycode=tdx,true]DRAWBAND(MA(CLOSE,5),RGB(155,50,50),MA(CLOSE,10),RGB(83,123,68));{画带状线}
DRAWKLINE(H,O,L,C);
MA5:MA(CLOSE,5),COLORWHITE;
MA10:MA(CLOSE,10),COLORYELLOW;
MA20:MA(CLOSE,24),COLORMAGENTA;
MA60:MA(CLOSE,60),COLORGREEN;
MA120:MA(CLOSE,120),COLORLIMAGENTA;
MA240:MA(CLOSE,240),COLORBLUE;
DRAWICON(CROSS(MA10,MA20),MA20,1); {10日上穿20日做记号}
DRAWICON(CROSS(MA20,MA60),MA60,1); {20日上穿60日做记号}
DRAWICON(CROSS(MA20,MA120),MA120,1); {20日上穿60日做记号}
DRAWICON(CROSS(MA20,MA240),MA240,1);{20日上穿120日做记号}
DRAWICON(CROSS(MA60,MA120),MA60,1); {60日上穿120日做记号}
DRAWICON(CROSS(MA60,MA240),MA240,1); {60日上穿240日做记号}
DRAWICON(CROSS(MA120,MA240),MA240,1);{120日上穿240日做记号}
DRAWICON(CROSS(MA10,MA5),MA10,2); {5日下穿10日做记号}
DRAWICON(CROSS(MA20,MA10),MA20,2); {10日下穿20日做记号}
DRAWICON(CROSS(MA60,MA20),MA60,2); {20日下穿60日做记号}
DRAWICON(CROSS(MA120,MA60),MA60,2); {60日下穿120日做记号}
反弹托:=MA5>MA20 AND MA5>MA20 AND MA20<MA60 AND MA60<MA120 AND CROSS(MA10,MA20);
月价托:=MA5>MA20 AND MA20>MA60 AND MA60>MA120 AND MA5>MA20 AND CROSS(MA10,MA20);
季价托:=MA20>MA60 AND MA20>MA60 AND CROSS(MA20,MA60);
短长价托:=MA5>MA60 AND MA5>MA10 AND CROSS(MA10,MA60);
半年托:=MA60>MA120 AND MA60>MA120 AND CROSS(MA60,MA120);
熊来:=MA60<MA120 AND MA60<MA120 AND CROSS(MA120,MA60);
年托:=MA120>MA240 AND MA120>MA240 AND CROSS(MA120,MA240);
月蜘蛛:=MA5>MA10 AND MA10>MA20 AND CROSS(MA5,MA20)AND CROSS(MA10,MA20);
DRAWTEXT(月蜘蛛,MA20-0.08,'金蜘蛛'),COLORMAGENTA;
DRAWTEXT(反弹托,MA20-0.08,'反弹托'),COLORMAGENTA;
DRAWTEXT(月价托 ,MA20-0.2,'月托'),COLORMAGENTA;
DRAWTEXT(季价托,MA60-0.08,'季托'),COLORMAGENTA;
DRAWTEXT(短长价托,L+0.015,'短长托'),COLOR36C0C1;
DRAWTEXT(半年托,MA120-0.08,'牛市来'),COLORRED;
DRAWTEXT(熊来,MA60+0.08,'小心熊'),COLORGREEN;
DRAWTEXT(年托,MA240-0.08,'年托'),COLORRED;
压:=MA10<MA20 AND MA20>MA10 AND CROSS(MA20,MA10);
DRAWTEXT(压,MA20+0.012,'压'),COLORYELLOW;
VOL5:=MA(VOL,5),COLORWHITE;
VOL10:=MA(VOL,10),COLORYELLOW;
VOL40:=MA(VOL,40),COLORFF00FF ;
量托:=VOL5>=VOL40 AND CROSS(VOL10,VOL40) AND REF(VOL10,1)<REF(VOL40,1);
DRAWTEXT(量托,L-0.012,'量托'),COLORWHITE;
AA1:=BARSLAST(MA60>MA20 AND (MA20=MA10 OR MA20>MA10));
BB1:=REF(COUNT(C<MA60,AA1)=AA1,1);
CC1:=CROSS(C,MA60) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;
芙蓉出水:=BB1 AND CC1,COLOR00FF00;
DRAWTEXT(芙蓉出水,H+0.12,'芙蓉出水'),COLORFF00FF;
STICKLINE(芙蓉出水,H,L,0.5,1),COLORFF00FF;
STICKLINE(芙蓉出水,O,C,4,1),LINETHICK2,COLORFF00FF;
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,30);
ZJ:=AMOUNT/10000;{资金}
TM:=V-MA(V,10);{量填满}
一穿三:=MA1>O AND MA2>O AND MA3>O AND MA1<C AND MA2<C AND MA3<C AND CLOSE>OPEN ;
DRAWTEXT(一穿三,L-0.012,'穿三线'),COLORFF00FF;
C6:=REF(C,1);
涨停:=IF((C-C6)*100/C6>=(10-0.01*100/C6),1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORMAGENTA;
STICKLINE(涨停,H,L,0,0),COLORLIRED;
{压力一}
TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);
前高位:REF(C,BARSLAST(HD)),COLOR00FF00,POINTDOT;
STICKLINE(C,前高位,前高位,8,0),COLORYELLOW;[/lycode][lycode=tdx2,true]画带状线
K线
输出MA5:收盘价的5日简单移动平均,画白色
输出MA10:收盘价的10日简单移动平均,画黄色
输出MA20:收盘价的24日简单移动平均,画洋红色
输出MA60:收盘价的60日简单移动平均,画绿色
输出MA120:收盘价的120日简单移动平均,画淡洋红色
输出MA240:收盘价的240日简单移动平均,画蓝色
当满足条件MA10上穿MA20时,在MA20位置画1号图标
当满足条件MA20上穿MA60时,在MA60位置画1号图标
当满足条件MA20上穿MA120时,在MA120位置画1号图标
当满足条件MA20上穿MA240时,在MA240位置画1号图标
当满足条件MA60上穿MA120时,在MA60位置画1号图标
当满足条件MA60上穿MA240时,在MA240位置画1号图标
当满足条件MA120上穿MA240时,在MA240位置画1号图标
当满足条件MA10上穿MA5时,在MA10位置画2号图标
当满足条件MA20上穿MA10时,在MA20位置画2号图标
当满足条件MA60上穿MA20时,在MA60位置画2号图标
当满足条件MA120上穿MA60时,在MA60位置画2号图标
反弹托赋值:MA5>MA20 AND MA5>MA20 AND MA20<MA60 AND MA60<MA120 AND MA10上穿MA20
月价托赋值:MA5>MA20 AND MA20>MA60 AND MA60>MA120 AND MA5>MA20 AND MA10上穿MA20
季价托赋值:MA20>MA60 AND MA20>MA60 AND MA20上穿MA60
短长价托赋值:MA5>MA60 AND MA5>MA10 AND MA10上穿MA60
半年托赋值:MA60>MA120 AND MA60>MA120 AND MA60上穿MA120
熊来赋值:MA60<MA120 AND MA60<MA120 AND MA120上穿MA60
年托赋值:MA120>MA240 AND MA120>MA240 AND MA120上穿MA240
月蜘蛛赋值:MA5>MA10 AND MA10>MA20 AND MA5上穿MA20AND MA10上穿MA20
当满足条件月蜘蛛时,在MA20-0.08位置书写文字,画洋红色
当满足条件反弹托时,在MA20-0.08位置书写文字,画洋红色
当满足条件月价托时,在MA20-0.2位置书写文字,画洋红色
当满足条件季价托时,在MA60-0.08位置书写文字,画洋红色
当满足条件短长价托时,在最低价+0.015位置书写文字,COLOR36C0C1
当满足条件半年托时,在MA120-0.08位置书写文字,画红色
当满足条件熊来时,在MA60+0.08位置书写文字,画绿色
当满足条件年托时,在MA240-0.08位置书写文字,画红色
压赋值:MA10<MA20 AND MA20>MA10 AND MA20上穿MA10
当满足条件压时,在MA20+0.012位置书写文字,画黄色
VOL5赋值:成交量(手)的5日简单移动平均,画白色
VOL10赋值:成交量(手)的10日简单移动平均,画黄色
VOL40赋值:成交量(手)的40日简单移动平均,COLORFF00FF
量托赋值:VOL5>=VOL40 AND VOL10上穿VOL40 AND 1日前的VOL10<1日前的VOL40
当满足条件量托时,在最低价-0.012位置书写文字,画白色
AA1赋值:上次MA60>MA20AND(MA20=MA10ORMA20>MA10)距今天数
BB1赋值:1日前的统计AA1日中满足收盘价<MA60的天数=AA1
CC1赋值:收盘价上穿MA60 AND 成交量(手)>成交量(手)的5日简单移动平均 AND (收盘价-1日前的收盘价)/1日前的收盘价*100>3
芙蓉出水赋值:BB1 AND CC1,COLOR00FF00
当满足条件芙蓉出水时,在最高价+0.12位置书写文字,COLORFF00FF
当满足条件芙蓉出水时,在最高价和最低价位置之间画柱状线,宽度为0.5,1不为0则画空心柱.,COLORFF00FF
当满足条件芙蓉出水时,在开盘价和收盘价位置之间画柱状线,宽度为4,1不为0则画空心柱.,线宽为2,COLORFF00FF
MA1赋值:收盘价的5日简单移动平均
MA2赋值:收盘价的10日简单移动平均
MA3赋值:收盘价的30日简单移动平均
ZJ赋值:成交额(元)/10000
TM赋值:成交量(手)-成交量(手)的10日简单移动平均
一穿三赋值:MA1>开盘价 AND MA2>开盘价 AND MA3>开盘价 AND MA1<收盘价 AND MA2<收盘价 AND MA3<收盘价 AND 收阳线
当满足条件一穿三时,在最低价-0.012位置书写文字,COLORFF00FF
C6赋值:1日前的收盘价
涨停赋值:如果(收盘价-C6)*100/C6>=(10-0.01*100/C6),返回1,否则返回0
当满足条件涨停时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,画洋红色
当满足条件涨停时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画淡红色
TY赋值:收盘价
A1赋值:10日前的TY=2*10+1日内TY的最高值
B1赋值:A1的10日过滤
C1赋值:若B1则将最近10+1周期置为1
HD赋值:C1的10日过滤
A2赋值:10日前的TY=2*10+1日内TY的最低值
B2赋值:A2的10日过滤
C2赋值:若B2则将最近10+1周期置为1
LD赋值:C2的10日过滤
输出前高位:上次HD距今天数日前的收盘价,COLOR00FF00,POINTDOT
当满足条件收盘价时,在前高位和前高位位置之间画柱状线,宽度为8,0不为0则画空心柱.,画黄色
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1ewZrNxbvwoaSYajjqViu6A

看了该指标的人还看了:
RSI突破下降趋势线指标    股海神偷指标    高抛低吸指标
抄死主力指标    股神短线指标    多空电波指标

使用道具 举报

回复