指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 压力支撑 
炒股叉_20190513_103944.png

炒股叉_20190513_103951.png

[lywrap=通达信主图指标公式][lycode=tdx,true]{趋势线}
VAR1:=(C+H+O+L)/4;
卖出:EMA(VAR1,15)*(1+2/25),COLORGREEN,LINETHICK2;
买入:EMA(VAR1,25)*(1-1/10),COLORMAGENTA,LINETHICK2;
{红绿线}
A:=EMA(CLOSE,7)-EMA(CLOSE,21);
B:=EMA((0.668*REF(A,1)+0.333*A),3);
{均线}
买线:=EMA(C,5);
卖线:=EMA(SLOPE(C,20)*10+C,40);
{增幅线}
EMA14:=EMA(C,14);
增幅%:(EMA14-REF(EMA14,1))/REF(EMA14,1)*100,NODRAW;
{指示}
买:=C>=EMA(C,5) AND A>B AND B>REF(B,1) AND 增幅%>0 AND 买线>=卖线 AND 卖出>REF(卖出,1);
卖:=C<EMA(C,5) OR A<=B OR 增幅%<0 OR 买线<卖线 OR 卖出<=REF(卖出,1);
STICKLINE(买,LOW*0.99,LOW*0.97,2.9,0),COLORYELLOW;
STICKLINE(卖,LOW*0.99,LOW*0.97,2.9,0),COLORBLUE;
初涨点:IF(增幅%>=0,REF(EMA(C,14),BARSLAST(CROSS(增幅%,0))+1),DRAWNULL)COLORRED,LINETHICK1;
初跌点:IF(增幅%<0,REF(EMA(C,14),BARSLAST(CROSS(0,增幅%))+1),DRAWNULL)COLORGREEN,LINETHICK1;
累计涨幅%:IF(增幅%>=0,(C-初涨点)/初涨点*100,DRAWNULL)COLORFF00FF,NODRAW;
累计跌幅%:IF(增幅%<0,(C-初跌点)/初跌点*100,DRAWNULL)COLORGREEN,NODRAW;
STICKLINE(CROSS(增幅%,0),C,O,2,0)COLORFF00FF;
STICKLINE(CROSS(0,增幅%),C,O,2,0)COLORGREEN;
STICKLINE(CROSS(增幅%,0) OR CROSS(0,增幅%),REF(EMA(C,14),1),REF(EMA(C,14),1)*0.998,2,0)COLORWHITE;[/lycode][lycode=tdx2,true]VAR1赋值:(收盘价+最高价+开盘价+最低价)/4
输出卖出:VAR1的15日指数移动平均*(1+2/25),画绿色,线宽为2
输出买入:VAR1的25日指数移动平均*(1-1/10),画洋红色,线宽为2
A赋值:收盘价的7日指数移动平均-收盘价的21日指数移动平均
B赋值:(0.668*1日前的A+0.333*A)的3日指数移动平均
买线赋值:收盘价的5日指数移动平均
卖线赋值:收盘价的20日线性回归斜率*10+收盘价的40日指数移动平均
EMA14赋值:收盘价的14日指数移动平均
输出增幅%:(EMA14-1日前的EMA14)/1日前的EMA14*100,NODRAW
买赋值:收盘价>=收盘价的5日指数移动平均 AND A>B AND B>1日前的B AND 增幅%>0 AND 买线>=卖线 AND 卖出>1日前的卖出
卖赋值:收盘价<收盘价的5日指数移动平均 OR A<=B OR 增幅%<0 OR 买线<卖线 OR 卖出<=1日前的卖出
当满足条件买时,在最低价*0.99和最低价*0.97位置之间画柱状线,宽度为2.9,0不为0则画空心柱.,画黄色
当满足条件卖时,在最低价*0.99和最低价*0.97位置之间画柱状线,宽度为2.9,0不为0则画空心柱.,画蓝色
输出初涨点:如果增幅%>=0,返回上次增幅%上穿0距今天数+1日前的收盘价的14日指数移动平均,否则返回无效数画红色,线宽为1
输出初跌点:如果增幅%<0,返回上次0上穿增幅%距今天数+1日前的收盘价的14日指数移动平均,否则返回无效数画绿色,线宽为1
输出累计涨幅%:如果增幅%>=0,返回(收盘价-初涨点)/初涨点*100,否则返回无效数COLORFF00FF,NODRAW
输出累计跌幅%:如果增幅%<0,返回(收盘价-初跌点)/初跌点*100,否则返回无效数画绿色,NODRAW
当满足条件增幅%上穿0时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.COLORFF00FF
当满足条件0上穿增幅%时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.画绿色
当满足条件增幅%上穿0ORCROSS(0,增幅%)时,在1日前的收盘价的14日指数移动平均和1日前的收盘价的14日指数移动平均*0.998位置之间画柱状线,宽度为2,0不为0则画空心柱.画白色
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1k3463pEr8x270Pap1bnvjg

看了该指标的人还看了:
绝佳买点指标    堪称一绝指标    盈富宝典指标
买卖精品指标    顶底管家指标    波段指标

使用道具 举报

回复