指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 
炒股叉_20190513_103100.png

炒股叉_20190513_103104.png

[lywrap=通达信主图指标公式][lycode=tdx,true]O1:(SUM(EMA((CLOSE+LOW)/2,1)/3,3)),COLOR00FFFF,LINETHICK1;
O2:EMA(O1,3),COLORFF00FF,LINETHICK1;
O3:EMA(O2,3),COLOR00FF00,LINETHICK1;
MMM:=MA(CLOSE,20);
DRAWTEXT((CLOSE<MMM),MMM,'*'),COLOR00FF00,LINETHICK5;
DRAWTEXT((CLOSE>MMM),MMM,'*'),COLOR0000FF,LINETHICK5;
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3.2,0),COLORFF3300;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2.7,0),COLORFF5500;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2.1,0),COLORFF7700;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),1.5,0),COLORFF9900;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0.9,0),COLORFFBB00;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0.3,0),COLORFFDD00;
DRAWTEXT(FILTER(VAR19=1,5),LOW,' 买进'),COLORFF00FF;
DRAWICON(FILTER(VAR19=1,5),LOW,9);
DRAWTEXT(FILTER(VAR1A=1,5),HIGH,' 逃顶'),COLOR00FF00;
DRAWICON(FILTER(VAR1A=1,5),HIGH,15);[/lycode][lycode=tdx2,true]输出O1:((收盘价+最低价)/2的1日指数移动平均/3的3日累和),COLOR00FFFF,线宽为1
输出O2:O1的3日指数移动平均,COLORFF00FF,线宽为1
输出O3:O2的3日指数移动平均,COLOR00FF00,线宽为1
MMM赋值:收盘价的20日简单移动平均
当满足条件(收盘价<MMM)时,在MMM位置书写文字,COLOR00FF00,线宽为5
当满足条件(收盘价>MMM)时,在MMM位置书写文字,COLOR0000FF,线宽为5
VAR1赋值:收盘价>1日前的收盘价 AND 收盘价>2日前的收盘价
VAR2赋值:1日前的VAR1 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR3赋值:1日前的VAR2 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR4赋值:1日前的VAR3 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR5赋值:1日前的VAR4 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR6赋值:1日前的VAR5 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR7赋值:1日前的VAR6 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR8赋值:1日前的VAR7 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR9赋值:1日前的VAR8 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VARA赋值:1日前的VAR9 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VARB赋值:1日前的VARA AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VARC赋值:1日前的VARB AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VARD赋值:收盘价<1日前的收盘价 AND 收盘价<2日前的收盘价
VARE赋值:1日前的VARD AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VARF赋值:1日前的VARE AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR10赋值:1日前的VARF AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR11赋值:1日前的VAR10 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR12赋值:1日前的VAR11 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR13赋值:1日前的VAR12 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR14赋值:1日前的VAR13 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR15赋值:1日前的VAR14 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR16赋值:1日前的VAR15 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR17赋值:1日前的VAR16 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR18赋值:1日前的VAR17 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR19赋值:1日前的VARDORVAREORVARFORVAR10ORVAR11ORVAR12ORVAR13ORVAR14ORVAR15ORVAR16ORVAR17ORVAR18 AND VAR1
VAR1A赋值:1日前的VAR1ORVAR2ORVAR3ORVAR4ORVAR5ORVAR6ORVAR7ORVAR8ORVAR9ORVARAORVARBORVARC AND VARD
当满足条件VAR1A时,在1日前的收盘价和2日前的收盘价位置之间画柱状线,宽度为3.2,0不为0则画空心柱.,COLORFF3300
当满足条件VAR1A时,在1日前的收盘价和2日前的收盘价位置之间画柱状线,宽度为2.7,0不为0则画空心柱.,COLORFF5500
当满足条件VAR1A时,在1日前的收盘价和2日前的收盘价位置之间画柱状线,宽度为2.1,0不为0则画空心柱.,COLORFF7700
当满足条件VAR1A时,在1日前的收盘价和2日前的收盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORFF9900
当满足条件VAR1A时,在1日前的收盘价和2日前的收盘价位置之间画柱状线,宽度为0.9,0不为0则画空心柱.,COLORFFBB00
当满足条件VAR1A时,在1日前的收盘价和2日前的收盘价位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,COLORFFDD00
当满足条件VAR19=1的5日过滤时,在最低价位置书写文字,COLORFF00FF
当满足条件VAR19=1的5日过滤时,在最低价位置画9号图标
当满足条件VAR1A=1的5日过滤时,在最高价位置书写文字,COLOR00FF00
当满足条件VAR1A=1的5日过滤时,在最高价位置画15号图标
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1UQu43_LZ4BKBwKZ8tcC6GA

看了该指标的人还看了:
叶公跟庄指标    股海神偷指标    降龙贰式指标
均线进多头指标    主力主升指标    画线指标指标

使用道具 举报

回复