指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 
炒股叉_20190513_102904.png

炒股叉_20190513_102909.png

[lywrap=通达信副图指标公式][lycode=tdx,true]V1:=BARSCOUNT(CLOSE)*3.142/180;
A2: SIN(V1*8)*100,LINETHICK1;
A3: COS(V1*8)*100,LINETHICK1;
X1:0,COLORFFFFCC;
VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,10);
VAR3:=MA(CLOSE,20);
VAR4:=MA(CLOSE,30);
VAR5:=(VAR1+VAR2+VAR3+VAR4)/4;
VAR6:=(VAR5-REF(VAR5,5))/REF(VAR5,5)*1500;
VAR7:=(VAR5-REF(VAR5,5))/REF(VAR5,5)*1500;
VAR8:=EMA(VAR6,8);
底部注意: STICKLINE(VAR6>REF(VAR6,1) AND VAR6<0 AND VAR6<VAR8,VAR6,0,1,0),COLORFF00FF;
低位转强: STICKLINE(VAR8>REF(VAR8,1) AND VAR6<0 AND VAR6>VAR8,VAR8,0,1,0),COLORYELLOW;
买点: STICKLINE(VAR6>REF(VAR6,1) AND VAR6>0 AND VAR8<0,VAR6,VAR8,4,0),COLOR0099FF;
VAR9:=TROUGHBARS(3,15,1)<10;
VAR10:=PEAKBARS(3,15,1)<10;
VAR11:=IF(VAR9=1,50,0);
VAR12:=IF(VAR10=1,50,0);
底部:= IF(VAR11=50,50,0);
头部:= IF(VAR12=50,100,0);
A:IF( 底部>REF(底部,1),50,0);
AA:IF(头部>REF(头部,1),50,0);
DRAWTEXT(A=50,90,'买进'),COLORRED,LINETHICK1;
DRAWTEXT(AA=50,90,'卖出'),COLOR00FF00,LINETHICK1;
DRAWICON(FILTER(VAR6>REF(VAR6,1) AND VAR6>0 AND VAR8<0,30),-40,1);
DRAWTEXT(FILTER(VAR6>REF(VAR6,1) AND VAR6>0 AND VAR8<0,30),-40,'短买'),COLORFFFFFF;
坚定持股: STICKLINE(VAR8>REF(VAR8,1) AND VAR8>0,VAR6,0,1,0),COLORRED;
谨慎观望: STICKLINE(VAR6<REF(VAR6,1) AND VAR8>REF(VAR8,1) AND VAR6>0,VAR6,VAR8,1,0),COLOR00FF00;
果断持币: STICKLINE(VAR6<REF(VAR6,1) AND VAR6<VAR8,VAR6,VAR8,1,1),COLORFFCC66;[/lycode][lycode=tdx2,true]V1赋值:收盘价的有效数据周期数*3.142/180
输出A2: V1*8的正弦*100,线宽为1
输出A3: V1*8的余弦*100,线宽为1
输出X1:0,COLORFFFFCC
VAR1赋值:收盘价的5日简单移动平均
VAR2赋值:收盘价的10日简单移动平均
VAR3赋值:收盘价的20日简单移动平均
VAR4赋值:收盘价的30日简单移动平均
VAR5赋值:(VAR1+VAR2+VAR3+VAR4)/4
VAR6赋值:(VAR5-5日前的VAR5)/5日前的VAR5*1500
VAR7赋值:(VAR5-5日前的VAR5)/5日前的VAR5*1500
VAR8赋值:VAR6的8日指数移动平均
输出底部注意: 当满足条件VAR6>1日前的VAR6ANDVAR6<0ANDVAR6<VAR8时,在VAR6和0位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORFF00FF
输出低位转强: 当满足条件VAR8>1日前的VAR8ANDVAR6<0ANDVAR6>VAR8时,在VAR8和0位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色
输出买点: 当满足条件VAR6>1日前的VAR6ANDVAR6>0ANDVAR8<0时,在VAR6和VAR8位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR0099FF
VAR9赋值:收盘价15%之字转向的前1个波谷位置<10
VAR10赋值:收盘价15%之字转向的前1个波峰位置<10
VAR11赋值:如果VAR9=1,返回50,否则返回0
VAR12赋值:如果VAR10=1,返回50,否则返回0
底部赋值: 如果VAR11=50,返回50,否则返回0
头部赋值: 如果VAR12=50,返回100,否则返回0
输出A:如果底部>1日前的底部,返回50,否则返回0
输出AA:如果头部>1日前的头部,返回50,否则返回0
当满足条件A=50时,在90位置书写文字,画红色,线宽为1
当满足条件AA=50时,在90位置书写文字,COLOR00FF00,线宽为1
当满足条件VAR6>1日前的VAR6ANDVAR6>0ANDVAR8<0的30日过滤时,在-40位置画1号图标
当满足条件VAR6>1日前的VAR6ANDVAR6>0ANDVAR8<0的30日过滤时,在-40位置书写文字,COLORFFFFFF
输出坚定持股: 当满足条件VAR8>1日前的VAR8ANDVAR8>0时,在VAR6和0位置之间画柱状线,宽度为1,0不为0则画空心柱.,画红色
输出谨慎观望: 当满足条件VAR6<1日前的VAR6ANDVAR8>1日前的VAR8ANDVAR6>0时,在VAR6和VAR8位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00FF00
输出果断持币: 当满足条件VAR6<1日前的VAR6ANDVAR6<VAR8时,在VAR6和VAR8位置之间画柱状线,宽度为1,1不为0则画空心柱.,COLORFFCC66
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1xgXnHRfpev_B11P_iwk-bg

看了该指标的人还看了:
涨势跌势确立指标    三增三阳指标    明明白白指标
超级抄底指标    股海扬帆指标    博奕杀手指标

使用道具 举报

回复