指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 趋势 操盘控盘 
炒股叉_20190510_095412.png

炒股叉_20190510_095418.png

[lywrap=通达信主图指标公式][lycode=tdx,true]日C:=C#DAY;时C:=C#MIN60;时O:=O#MIN60;
ZQXZ1:=PERIOD=0||PERIOD=1||PERIOD=2;
ZQXZ2:=PERIOD=2||PERIOD=3||PERIOD=4||PERIOD=8;
日:=DAY!=REF(DAY,1);日O:=REF(O,BARSLAST(日=1));
STICKLINE(日C>日O&&ZQXZ2,日O,日C,3.6,0),COLOR0088FF;
STICKLINE(日C<=日O&&ZQXZ2,日O,日C,3.6,0),COLORFF9888;
STICKLINE(时C>时O&&ZQXZ1,时O,时C,5,0),COLORFF88FF;
STICKLINE(时C<=时O&&ZQXZ1,时O,时C,5,0),COLORFF8800;
DRAWBAND(MA(C,5),RGB(125,18,125),MA(C,20),RGB(0,118,118));
STICKLINE(MA(C,20)>MA(C,60),MA(C,20),MA(C,60),0,-1),COLOR0088AA;
STICKLINE(MA(C,20)<MA(C,60),MA(C,20),MA(C,60),0,-1),COLOR18A118;
攻击线:MA(C,5),COLORWHITE,LINETHICK2;
魔鬼线:MA(C,10),COLORYELLOW,LINETHICK1;
操盘线:MA(C,20),COLORRED,LINETHICK2;
决策线:MA(C,60),COLOR0000CC,CIRCLEDOT;
AAA:=操盘线+操盘线-REF(操盘线,1);
BBB:=IF(操盘线<AAA,AAA,操盘线);
趋势线:BBB-(EMA(C,2)-BBB),COLORLIBLUE;
涨停:=(C-REF(C,1))*100/REF(C,1)>=9.5&&C=H;
跌停:=((C-REF(C,1))*100/REF(C,1))<=-9.1&&C=L;
IF(趋势线<攻击线,趋势线,DRAWNULL),COLOR0088FF;
DRAWICON(跌停,L*0.98,4);DRAWICON(涨停,H*1.02,5);
IF(决策线<REF(决策线,1),决策线,DRAWNULL),COLOR18A118,CIRCLEDOT;
IF(操盘线<REF(操盘线,1),操盘线,DRAWNULL),COLORLIBLUE,LINETHICK2;
IF(攻击线<REF(攻击线,1),攻击线,DRAWNULL),COLOR18A118,LINETHICK2;
逃命跳:=H<REF(L,1);STICKLINE(逃命跳,H,REF(L,1),5,-1),COLORWHITE;
上攻蹦:=L>REF(H,1);STICKLINE(上攻蹦,L,REF(H,1),5,-1),COLORFF18FF;

STICKLINE(C>O,C,O,3.00,1),COLOR000088;
STICKLINE(C>O,C,O,2.39,1),COLOR000099;
STICKLINE(C>O,C,O,1.51,1),COLOR0000CC;
STICKLINE(C>O,C,O,0.48,1),COLOR0000DD;
STICKLINE(C<=O,C,O,3.00,1),COLORAAAA00;
STICKLINE(C<=O,C,O,2.39,1),COLORBBBB00;
STICKLINE(C<=O,C,O,1.51,1),COLORCCCC00;
STICKLINE(C<=O,C,O,0.48,1),COLORDDDD00;
[/lycode][lycode=tdx2,true]日C赋值:收盘价[取日线数据]
时C赋值:收盘价[取60分钟数据]
时O赋值:开盘价[取60分钟数据]
ZQXZ1赋值:周期类型=0或者周期类型=1或者周期类型=2
ZQXZ2赋值:周期类型=2或者周期类型=3或者周期类型=4或者周期类型=8
日赋值:日不等于1日前的日
日O赋值:上次日=1距今天数日前的开盘价
当满足条件日C>日O并且ZQXZ2时,在日O和日C位置之间画柱状线,宽度为3.6,0不为0则画空心柱.,COLOR0088FF
当满足条件日C<=日O并且ZQXZ2时,在日O和日C位置之间画柱状线,宽度为3.6,0不为0则画空心柱.,COLORFF9888
当满足条件时C>时O并且ZQXZ1时,在时O和时C位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLORFF88FF
当满足条件时C<=时O并且ZQXZ1时,在时O和时C位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLORFF8800
画带状线
当满足条件收盘价的20日简单移动平均>收盘价的60日简单移动平均时,在收盘价的20日简单移动平均和收盘价的60日简单移动平均位置之间画柱状线,宽度为0,-1不为0则画空心柱.,COLOR0088AA
当满足条件收盘价的20日简单移动平均<收盘价的60日简单移动平均时,在收盘价的20日简单移动平均和收盘价的60日简单移动平均位置之间画柱状线,宽度为0,-1不为0则画空心柱.,COLOR18A118
输出攻击线:收盘价的5日简单移动平均,画白色,线宽为2
输出魔鬼线:收盘价的10日简单移动平均,画黄色,线宽为1
输出操盘线:收盘价的20日简单移动平均,画红色,线宽为2
输出决策线:收盘价的60日简单移动平均,COLOR0000CC,CIRCLEDOT
AAA赋值:操盘线+操盘线-1日前的操盘线
BBB赋值:如果操盘线<AAA,返回AAA,否则返回操盘线
输出趋势线:BBB-(收盘价的2日指数移动平均-BBB),画淡蓝色
涨停赋值:(收盘价-1日前的收盘价)*100/1日前的收盘价>=9.5并且收盘价=最高价
跌停赋值:((收盘价-1日前的收盘价)*100/1日前的收盘价)<=-9.1并且收盘价=最低价
如果趋势线<攻击线,返回趋势线,否则返回无效数,COLOR0088FF
当满足条件跌停时,在最低价*0.98位置画4号图标
当满足条件涨停时,在最高价*1.02位置画5号图标
如果决策线<1日前的决策线,返回决策线,否则返回无效数,COLOR18A118,CIRCLEDOT
如果操盘线<1日前的操盘线,返回操盘线,否则返回无效数,画淡蓝色,线宽为2
如果攻击线<1日前的攻击线,返回攻击线,否则返回无效数,COLOR18A118,线宽为2
逃命跳赋值:最高价<1日前的最低价
当满足条件逃命跳时,在最高价和1日前的最低价位置之间画柱状线,宽度为5,-1不为0则画空心柱.,画白色
上攻蹦赋值:最低价>1日前的最高价
当满足条件上攻蹦时,在最低价和1日前的最高价位置之间画柱状线,宽度为5,-1不为0则画空心柱.,COLORFF18FF
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为3.00,1不为0则画空心柱.,COLOR000088
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为2.39,1不为0则画空心柱.,COLOR000099
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为1.51,1不为0则画空心柱.,COLOR0000CC
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为0.48,1不为0则画空心柱.,COLOR0000DD
当满足条件收盘价<=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3.00,1不为0则画空心柱.,COLORAAAA00
当满足条件收盘价<=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2.39,1不为0则画空心柱.,COLORBBBB00
当满足条件收盘价<=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1.51,1不为0则画空心柱.,COLORCCCC00
当满足条件收盘价<=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为0.48,1不为0则画空心柱.,COLORDDDD00
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1StaRzT7405HlBm_b57mcgg

看了该指标的人还看了:
RSI突破下降趋势线指标    股海神偷指标    高抛低吸指标
抄死主力指标    股神短线指标    多空电波指标

使用道具 举报

回复