指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 趋势 
指标在出现'★'时买进后再等到出现“卖”时卖出;黄柱出现时买进一路持有至蓝柱时卖出
炒股叉_20190509_102932.png

炒股叉_20190509_102939.png

[lywrap=通达信主图指标公式][lycode=tdx,true]N:=20;
N1:=7;
N2:=69;
M3:=EMA(CLOSE,3);
M8:EMA(CLOSE,8),COLOR008000;
M13:EMA(M8,13),COLOR0000FF;
M62:EMA(M8,55),COLORF0F000;
VAR1:=EMA(M13,62);
M81:EMA(M62,81),COLOR00FFFF;
M144:EMA(VAR1,144),LINETHICK2,COLOR0000FF;
M250:EMA(VAR1,250),POINTDOT,LINETHICK2,COLORF00FF0;
VAR2:=(CLOSE+HIGH+LOW)/(3);
VAR3:=(EMA(VAR2,10));
VAR4:=(REF(VAR3,1));
STICKLINE((VAR3>VAR4),VAR3,VAR4,4,0),COLOR00FFFF;
STICKLINE((VAR3<VAR4),VAR3,VAR4,4,0),COLORFF0000;
VAR5:=((REF(HIGH,1)+REF(LOW,1))/(2));
VAR6:=MA(CLOSE,N)+((2)*(STD(CLOSE,N)));
DRAWTEXT(CROSS(VAR3,VAR4),(VAR3)*(0.98),'★'),COLOR00FFFF;
DRAWTEXT(CROSS(VAR5,VAR6),(HIGH)*(1.04),'↓卖'),COLOR008000;
VAR7:=REF(CLOSE,1);
VAR8:=((SMA(MAX(CLOSE-VAR7,0),N1,1))/(SMA(ABS(CLOSE-VAR7),N1,1)))*(100);
VAR9:=CROSS(N2,VAR8);
VARA:=(FILTER(VAR9,4));
DRAWTEXT(VARA,(HIGH)*(1.04),'↓卖'),COLORFFFFFF;
VARB:=((2)*(CLOSE)+HIGH+LOW)/(4);
VARC:=LLV(LOW,34);
VARD:=HHV(HIGH,34);
VARE:=(EMA(((VARB-VAR1)/(VAR5-VAR1))*(100),7));
VARF:=(EMA((0.667)*(REF(VARE,1))+(0.333)*(VARE),5));
DRAWTEXT(IF(((COUNT((CLOSE<REF(CLOSE,1)),8))/(8)>0.6) AND (VOL>=(1.5)*(MA(VOL,5))) AND COUNT((VARE>=VARF),3) AND (REF(LOW,1)=LLV(LOW,120)),1,0),LOW,'●买进'),COLORFF00FF;
DRAWTEXT(IF(((COUNT((CLOSE<REF(CLOSE,1)),13))/(13)>0.6) AND COUNT((VARE>VARF),6) AND (REF(LOW,5)=LLV(LOW,120)) AND REF((CLOSE>=OPEN),4) AND REF((CLOSE>OPEN),3) AND REF((CLOSE>OPEN),2) AND REF((OPEN>CLOSE),1) AND (OPEN>REF(CLOSE,1)),1,0),LOW,'●买进'),COLOR00FFFF;
VAR10:=(MA(CLOSE,80)-(MA(CLOSE,10))/(3));
DRAWTEXT(IF((CLOSE<VAR10) AND ((VOL)/(240)>(MA(VOL,5))/(240)) AND (CLOSE>(REF(CLOSE,1))*(1.08)) AND (CLOSE<(MA(CLOSE,13))*(1.3)),1,0),LOW,'●抄底'),COLOR0000FF;
XG:CROSS(VAR3,VAR4),COLORFFFFFF,NODRAW;[/lycode][lycode=tdx2,true]N赋值:20
N1赋值:7
N2赋值:69
M3赋值:收盘价的3日指数移动平均
输出M8:收盘价的8日指数移动平均,COLOR008000
输出M13:M8的13日指数移动平均,COLOR0000FF
输出M62:M8的55日指数移动平均,COLORF0F000
VAR1赋值:M13的62日指数移动平均
输出M81:M62的81日指数移动平均,COLOR00FFFF
输出M144:VAR1的144日指数移动平均,线宽为2,COLOR0000FF
输出M250:VAR1的250日指数移动平均,POINTDOT,线宽为2,COLORF00FF0
VAR2赋值:(收盘价+最高价+最低价)/(3)
VAR3赋值:(VAR2的10日指数移动平均)
VAR4赋值:(1日前的VAR3)
当满足条件(VAR3>VAR4)时,在VAR3和VAR4位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR00FFFF
当满足条件(VAR3<VAR4)时,在VAR3和VAR4位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLORFF0000
VAR5赋值:((1日前的最高价+1日前的最低价)/(2))
VAR6赋值:收盘价的N日简单移动平均+((2)*(收盘价的N日估算标准差))
当满足条件VAR3上穿VAR4时,在(VAR3)*(0.98)位置书写文字,COLOR00FFFF
当满足条件VAR5上穿VAR6时,在(最高价)*(1.04)位置书写文字,COLOR008000
VAR7赋值:1日前的收盘价
VAR8赋值:((收盘价-VAR7和0的较大值的N1日[1日权重]移动平均)/(收盘价-VAR7的绝对值的N1日[1日权重]移动平均))*(100)
VAR9赋值:N2上穿VAR8
VARA赋值:(VAR9的4日过滤)
当满足条件VARA时,在(最高价)*(1.04)位置书写文字,COLORFFFFFF
VARB赋值:((2)*(收盘价)+最高价+最低价)/(4)
VARC赋值:34日内最低价的最低值
VARD赋值:34日内最高价的最高值
VARE赋值:(((VARB-VAR1)/(VAR5-VAR1))*(100)的7日指数移动平均)
VARF赋值:((0.667)*(1日前的VARE)+(0.333)*(VARE)的5日指数移动平均)
当满足条件如果((统计8日中满足(收盘价<1日前的收盘价)的天数)/(8)>0.6)AND(成交量(手)>=(1.5)*(成交量(手)的5日简单移动平均))ANDCOUNT((VARE>=VARF),3)AND(1日前的最低价=120日内最低价的最低值),返回1,否则返回0时,在最低价位置书写文字,COLORFF00FF
当满足条件如果((统计13日中满足(收盘价<1日前的收盘价)的天数)/(13)>0.6)ANDCOUNT((VARE>VARF),6)AND(5日前的最低价=120日内最低价的最低值)ANDREF((收盘价>=开盘价),4)ANDREF((收阳线),3)ANDREF((收盘价>OPE,返回?,否则返回?时,在),2)ANDREF((收阴线),1)AND(开盘价>1日前的收盘价),1,0)位置书写文字,COLOR00FFFF
VAR10赋值:(收盘价的80日简单移动平均-(收盘价的10日简单移动平均)/(3))
当满足条件如果(收盘价<VAR10)AND((成交量(手))/(240)>(成交量(手)的5日简单移动平均)/(240))AND(收盘价>(1日前的收盘价)*(1.08))AND(收盘价<(收盘价的13日简单移动平均)*(1.3)),返回1,否则返回0时,在最低价位置书写文字,COLOR0000FF
输出XG:VAR3上穿VAR4,COLORFFFFFF,NODRAW
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1ukHciVAAicY_VZ1y0NVsdw

看了该指标的人还看了:
与私募同进出指标    真涨指标,成功率非常高    三碗不过岗指标
主力买卖指标    明明白白指标    绝对底部指标

使用道具 举报

回复