指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 抄底逃顶 
炒股叉_20190509_101306.png

炒股叉_20190509_101312.png

[lywrap=通达信副图指标公式][lycode=tdx,true]VAR2:=IF(MONTH<12,1,1);
VAR3:=(2*CLOSE+HIGH+LOW)/4;
VAR4:=LLV(LOW,34);
VAR5:=HHV(HIGH,34);
主力:EMA((VAR3-VAR4)/(VAR5-VAR4)*100,13)*VAR2,LINETHICK4,COLORRED;
小股民:EMA(0.667*REF(主力,1)+0.333*主力,2),LINETHICK2,COLORFF9933;
小心被套:IF(CROSS(主力,75) AND 小股民<主力,75,62),STICK,LINETHICK2,COLORGREEN;62,STICK,LINETHICK2,COLOR000000;
冲顶:IF(CROSS(主力,65) AND 小股民<主力,61,49),STICK,LINETHICK2,COLORF00FF0;49,STICK,LINETHICK2,COLOR000000;
上扬:IF(CROSS(主力,30) AND 小股民<主力,48,35),STICK,LINETHICK2,COLORYELLOW;35,STICK,LINETHICK2,COLOR000000;
强弱分界线: 50, POINTDOT, LINETHICK2, COLORFFFF00;
DRAWTEXT(CROSS(主力,小股民) AND 主力<22,20,'起动'),LINETHICK2,COLOR0099FF;
DRAWICON(CROSS(主力,小股民) AND 主力<22,25,1);
DRAWTEXT(CROSS(主力,30) AND 小股民<主力,40,'上扬 '),LINETHICK2,COLOR00CCFF;
DRAWICON(CROSS(主力,30) AND 小股民<主力,35,1);
DRAWTEXT(CROSS(主力,65) AND 小股民<主力,55,'冲顶 '),LINETHICK2,COLOR9933FF;
DRAWICON(CROSS(主力,65) AND 小股民<主力,70,2);
DRAWTEXT(CROSS(主力,75) AND 小股民<主力,67,'小心被套'),LINETHICK2,COLOR009900;
DRAWICON(CROSS(主力,75) AND 小股民<主力,80,2);
DRAWTEXT(CROSS(小股民,主力) AND 小股民>75,80,'头部'), COLORYELLOW;
DRAWICON(CROSS(小股民,主力) AND 小股民>75,85,2);
买入脉冲:IF(CROSS(主力,小股民) AND 主力<35,55,5),LINETHICK4,COLORGREEN;
卖出脉冲:IF(CROSS(小股民,主力) AND 小股民>75,75,90),LINETHICK4,COLORRED;[/lycode][lycode=tdx2,true]VAR2赋值:如果月份<12,返回1,否则返回1
VAR3赋值:(2*收盘价+最高价+最低价)/4
VAR4赋值:34日内最低价的最低值
VAR5赋值:34日内最高价的最高值
输出主力:(VAR3-VAR4)/(VAR5-VAR4)*100的13日指数移动平均*VAR2,线宽为4,画红色
输出小股民:0.667*1日前的主力+0.333*主力的2日指数移动平均,线宽为2,COLORFF9933
输出小心被套:如果主力上穿75AND小股民<主力,返回75,否则返回62,STICK,线宽为2,画绿色
62,STICK,线宽为2,COLOR000000
输出冲顶:如果主力上穿65AND小股民<主力,返回61,否则返回49,STICK,线宽为2,COLORF00FF0
49,STICK,线宽为2,COLOR000000
输出上扬:如果主力上穿30AND小股民<主力,返回48,否则返回35,STICK,线宽为2,画黄色
35,STICK,线宽为2,COLOR000000
输出强弱分界线: 50, POINTDOT, 线宽为2, COLORFFFF00
当满足条件主力上穿小股民AND主力<22时,在20位置书写文字,线宽为2,COLOR0099FF
当满足条件主力上穿小股民AND主力<22时,在25位置画1号图标
当满足条件主力上穿30AND小股民<主力时,在40位置书写文字,线宽为2,COLOR00CCFF
当满足条件主力上穿30AND小股民<主力时,在35位置画1号图标
当满足条件主力上穿65AND小股民<主力时,在55位置书写文字,线宽为2,COLOR9933FF
当满足条件主力上穿65AND小股民<主力时,在70位置画2号图标
当满足条件主力上穿75AND小股民<主力时,在67位置书写文字,线宽为2,COLOR009900
当满足条件主力上穿75AND小股民<主力时,在80位置画2号图标
当满足条件小股民上穿主力AND小股民>75时,在80位置书写文字, 画黄色
当满足条件小股民上穿主力AND小股民>75时,在85位置画2号图标
输出买入脉冲:如果主力上穿小股民AND主力<35,返回55,否则返回5,线宽为4,画绿色
输出卖出脉冲:如果小股民上穿主力AND小股民>75,返回75,否则返回90,线宽为4,画红色
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1ezxz4loqW61Smq-SfM4vnw

看了该指标的人还看了:
绝佳买点指标    股海神偷指标    短线追踪指标
估抄底F指标    压力走势指标    中线指标

使用道具 举报

回复