指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 抄底逃顶 
炒股叉_20190507_101327.png

炒股叉_20190507_101334.png

[lywrap=通达信主图][lycode=tdx,true]N:=50;{N 20   200  50}
TS:=BARSLAST(L=LLV(L,N));
开始信号:=FILTERX(TS=0,BARSSINCE(C));
开始天数:=BARSLAST(开始信号);
天数横线:=CONST(开始天数);
低点:DRAWLINE(L=LLV(L,N),L,ISLASTBAR,REF(L,TS),1),COLOR00CC00;
高点:DRAWLINE(L=LLV(L,N),CONST(HHV(H,天数横线)),ISLASTBAR,REF(CONST(HHV(H,天数横线)),
TS),1),COLOR00CCCC;
STICKLINE(开始信号,L,CONST(HHV(H,天数横线)),0,0),COLOR00AA00;
STICKLINE(ISLASTBAR,低点,高点,0,0),COLOR00AA00;

C2:=REF(C,1);
涨停:=REF(C,1)*1.1-C<0.01 AND H=C,NODRAW;
STICKLINE(涨停,OPEN,CLOSE,1,0),COLORRED;
STICKLINE(涨停,H,L,0,0),COLORRED;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2) AND L=C,1,0),NODRAW;
STICKLINE(跌停,OPEN,CLOSE,1,0),COLORGREEN;
STICKLINE(跌停,H,L,0,1),COLORGREEN;

差:=(高点-低点)/天数横线;
收盘差:=CONST(C)-低点;
对角差:=高点-低点;
对角角度:ATAN((对角差/(对角差*((天数横线-1)/天数横线))-1)*100)*57.3,COLORFFFF00,NODRAW;
差60度:=(高点-低点)*60/对角角度;
差45度:=(高点-低点)*45/对角角度;
差55度:=(高点-低点)*55/对角角度;
差50度:=(高点-低点)*50/对角角度;
差65度:=(高点-低点)*65/对角角度;
角度65:IF(TS>=0 AND 低点+(差65度/天数横线)*TS<=高点,低点+(差65度/天数横线)*TS,DRAWNULL),COLORLIBLUE,DOTLINE;
角度50:IF(TS>=0 AND 低点+(差50度/天数横线)*TS<=高点,低点+(差50度/天数横线)*TS,DRAWNULL),COLORLIBLUE,DOTLINE;
角度55:IF(TS>=0 AND 低点+(差55度/天数横线)*TS<=高点,低点+(差55度/天数横线)*TS,DRAWNULL),COLORLIBLUE,DOTLINE;
对角线:IF(TS>=0 AND 低点+差*TS<=高点,低点+差*TS,DRAWNULL),COLORYELLOW,LINETHICK2;

角度60:IF(TS>=0 AND 低点+(差60度/天数横线)*TS<=高点,低点+(差60度/天数横线)*TS,DRAWNULL),COLORLIBLUE,DOTLINE;
角度45:IF(TS>=0 AND 低点+(差45度/天数横线)*TS<=高点,低点+(差45度/天数横线)*TS,DRAWNULL),COLORGREEN,LINETHICK1;

收盘角度:(收盘差*对角角度)/对角差,NODRAW;
收盘线:=IF(TS>=0 AND 低点+(收盘差/天数横线)*TS<=高点,低点+(收盘差/天数横线)*TS,DRAWNULL);
差40度:=(高点-低点)*40/对角角度;
差35度:=(高点-低点)*35/对角角度;
差30度:=(高点-低点)*30/对角角度;
差25度:=(高点-低点)*25/对角角度;
差20度:=(高点-低点)*20/对角角度;
差15度:=(高点-低点)*15/对角角度;
角度40:IF(TS>=0 AND 低点+(差40度/天数横线)*TS<=高点,低点+(差40度/天数横线)*TS,DRAWNULL),COLOR008080,LINETHICK1;
角度35:IF(TS>=0 AND 低点+(差35度/天数横线)*TS<=高点,低点+(差35度/天数横线)*TS,DRAWNULL),COLORLIBLUE,DOTLINE;
角度30:IF(TS>=0 AND 低点+(差30度/天数横线)*TS<=高点,低点+(差30度/天数横线)*TS,DRAWNULL),COLORWHITE,LINETHICK1;
角度25:IF(TS>=0 AND 低点+(差25度/天数横线)*TS<=高点,低点+(差25度/天数横线)*TS,DRAWNULL),COLORLIBLUE,DOTLINE;
角度20:IF(TS>=0 AND 低点+(差20度/天数横线)*TS<=高点,低点+(差20度/天数横线)*TS,DRAWNULL),COLORGREEN,LINETHICK2;
角度15:IF(TS>=0 AND 低点+(差15度/天数横线)*TS<=高点,低点+(差15度/天数横线)*TS,DRAWNULL),COLORWHITE,LINETHICK1;[/lycode][lycode=tdx2,true]N赋值:50
TS赋值:上次最低价=N日内最低价的最低值距今天数
开始信号赋值:TS=0的首次收盘价距今天数日反向过滤
开始天数赋值:上次开始信号距今天数
天数横线赋值:开始天数的最后一日取值设为常数
输出低点:当满足条件最低价=N日内最低价的最低值时,在最低价位置画直线起点,当满足条件是否最后一个周期时,在TS日前的最低价位置画直线终点,1表示是否延长.,COLOR00CC00
输出高点:当满足条件最低价=N日内最低价的最低值时,在天数横线日内最高价的最高值的最后一日取值设为常数位置画直线起点,当满足条件是否最后一个周期时,在TS日前的天数横线日内最高价的最高值的最后一日取值设为常数位置画直线终点,1表示是否延长.,COLOR00CCCC
当满足条件开始信号时,在最低价和天数横线日内最高价的最高值的最后一日取值设为常数位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00AA00
当满足条件是否最后一个周期时,在低点和高点位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00AA00
C2赋值:1日前的收盘价
涨停赋值:1日前的收盘价*1.1-收盘价<0.01 AND 最高价=收盘价,NODRAW
当满足条件涨停时,在开盘价和收盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,画红色
当满足条件涨停时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画红色
跌停赋值:如果(C2-收盘价)*100/C2>=(10-0.01*100/C2)ANDL=收盘价,返回1,否则返回0,NODRAW
当满足条件跌停时,在开盘价和收盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,画绿色
当满足条件跌停时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画绿色
差赋值:(高点-低点)/天数横线
收盘差赋值:收盘价的最后一日取值设为常数-低点
对角差赋值:高点-低点
输出对角角度:(对角差/(对角差*((天数横线-1)/天数横线))-1)*100的反正切*57.3,COLORFFFF00,NODRAW
差60度赋值:(高点-低点)*60/对角角度
差45度赋值:(高点-低点)*45/对角角度
差55度赋值:(高点-低点)*55/对角角度
差50度赋值:(高点-低点)*50/对角角度
差65度赋值:(高点-低点)*65/对角角度
输出角度65:如果TS>=0AND低点+(差65度/天数横线)*TS<=高点,返回低点+(差65度/天数横线)*TS,否则返回无效数,画淡蓝色,DOTLINE
输出角度50:如果TS>=0AND低点+(差50度/天数横线)*TS<=高点,返回低点+(差50度/天数横线)*TS,否则返回无效数,画淡蓝色,DOTLINE
输出角度55:如果TS>=0AND低点+(差55度/天数横线)*TS<=高点,返回低点+(差55度/天数横线)*TS,否则返回无效数,画淡蓝色,DOTLINE
输出对角线:如果TS>=0AND低点+差*TS<=高点,返回低点+差*TS,否则返回无效数,画黄色,线宽为2
输出角度60:如果TS>=0AND低点+(差60度/天数横线)*TS<=高点,返回低点+(差60度/天数横线)*TS,否则返回无效数,画淡蓝色,DOTLINE
输出角度45:如果TS>=0AND低点+(差45度/天数横线)*TS<=高点,返回低点+(差45度/天数横线)*TS,否则返回无效数,画绿色,线宽为1
输出收盘角度:(收盘差*对角角度)/对角差,NODRAW
收盘线赋值:如果TS>=0AND低点+(收盘差/天数横线)*TS<=高点,返回低点+(收盘差/天数横线)*TS,否则返回无效数
差40度赋值:(高点-低点)*40/对角角度
差35度赋值:(高点-低点)*35/对角角度
差30度赋值:(高点-低点)*30/对角角度
差25度赋值:(高点-低点)*25/对角角度
差20度赋值:(高点-低点)*20/对角角度
差15度赋值:(高点-低点)*15/对角角度
输出角度40:如果TS>=0AND低点+(差40度/天数横线)*TS<=高点,返回低点+(差40度/天数横线)*TS,否则返回无效数,COLOR008080,线宽为1
输出角度35:如果TS>=0AND低点+(差35度/天数横线)*TS<=高点,返回低点+(差35度/天数横线)*TS,否则返回无效数,画淡蓝色,DOTLINE
输出角度30:如果TS>=0AND低点+(差30度/天数横线)*TS<=高点,返回低点+(差30度/天数横线)*TS,否则返回无效数,画白色,线宽为1
输出角度25:如果TS>=0AND低点+(差25度/天数横线)*TS<=高点,返回低点+(差25度/天数横线)*TS,否则返回无效数,画淡蓝色,DOTLINE
输出角度20:如果TS>=0AND低点+(差20度/天数横线)*TS<=高点,返回低点+(差20度/天数横线)*TS,否则返回无效数,画绿色,线宽为2
输出角度15:如果TS>=0AND低点+(差15度/天数横线)*TS<=高点,返回低点+(差15度/天数横线)*TS,否则返回无效数,画白色,线宽为1
[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1JeZ3d8zn1BqOiMc5S6F4Ew

看了该指标的人还看了:
绝佳买点指标    股海神偷指标    短线追踪指标
估抄底F指标    压力走势指标    中线指标

使用道具 举报

回复