指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 买卖点 画线 趋势 操盘控盘 压力支撑 
炒股叉_20190412_102844.png

炒股叉_20190412_102912.png

[lywrap=通达信主图指标公式][lycode=tdx,true]N1:=5;{N1   1   1000   5}
周期:=220;
自动C:=INDEXC;
自动O:=INDEXO;
自动H:=INDEXH;
自动L:=INDEXL;
指定O:="SH999999$O";
指定H:="SH999999$H";
指定L:="SH999999$L";
指定C:="SH999999$C";
大盘低:=CONST(LLV(指定L,周期));
大盘高:=CONST(HHV(指定H,周期));
大盘差:=大盘高-大盘低;
当前低:=CONST(LLV(L,周期));
当前高:=CONST(HHV(H,周期));
当前差:=当前高-当前低;
比1:=当前差/大盘差;
变C:=当前低+(指定C-大盘低)*比1;
变H:=当前低+(指定H-大盘低)*比1;
变L:=当前低+(指定L-大盘低)*比1;
变O:=当前低+(指定O-大盘低)*比1;
STICKLINE(CURRBARSCOUNT<周期,变H,变L,0,0),COLOR663300;
STICKLINE(CURRBARSCOUNT<周期,变O,变C,3,0),COLOR663300;
STICKLINE(CURRBARSCOUNT<周期 AND 变C>=变O,变O,变C,3,1),COLOR663300;
DRAWKLINE(H,O,L,C);
UR:=N1;
LR:=N1;
TC1:=IF(H=HHV(H,8*UR),H,DRAWNULL);
TC2:=CONST(BARSLAST(TC1=H))+1;
UP:=CONST(IF(TC2=1,H,REF(H,TC2-1)));
BC1:=IF(L=LLV(L,8*LR),L,DRAWNULL);
BC2:=CONST(BARSLAST(BC1=L))+1;
LL:=CONST(IF(BC2=1,L,REF(L,BC2-1)));
LP:=CURRBARSCOUNT<=BC2 AND L=LL;
HP:=CURRBARSCOUNT<=TC2 AND H=UP;
NOD:=(IF(TC2>BC2,TC2,BC2)-IF(TC2>BC2,BC2,TC2));
LR1:=FORCAST(C,NOD+1);
NP:=IF(CURRBARSCOUNT<=MAX(BC2,TC2),CONST(IF(MIN(TC2,BC2)=1,LR1,REF(LR1,MIN(TC2,BC2)-1))),DRAWNULL),POINTDOT,COLOR93BDA8;{近点}
LR2:=SLOPE(C,NOD+1);
LR3:=CONST(IF(MIN(TC2,BC2)=1,LR2,REF(LR2,MIN(TC2,BC2)-1)));
FP:=NP-LR3*(NOD),POINTDOT,COLOR93BDA8;
AD:=ABS(NP-FP);
DBL:=BARSLAST(BC1!=DRAWNULL)+1;
DBH:=BARSLAST(TC1!=DRAWNULL)+1;
BSP:=IF(BC2>TC2,DBL,DBH)-1;
LRL:=IF(NP>FP,FP+AD/NOD*BSP,FP-AD/NOD*BSP);
AT1:=IF(BETWEEN(CURRBARSCOUNT,BC2,TC2) AND H>LRL,H,LRL);
AT2:=HHV(AT1-LRL,MAX(BC2,TC2));
AT3:=CONST(BARSLAST(AT1-LRL=AT2));
AT4:=CONST(IF(AT3=0,H,REF(H,AT3)));
AT5:=CONST(IF(AT3=0,AT1-LRL,REF(AT1-LRL,AT3)));
ATL:=LRL+AT5;
UT1:=IF(BETWEEN(CURRBARSCOUNT,BC2,TC2) AND L<LRL,L,LRL);
UT2:=HHV(LRL-UT1,MAX(BC2,TC2));
UT3:=CONST(BARSLAST(LRL-UT1=UT2));
UT4:=CONST(IF(UT3=0,H,REF(H,UT3)));
UT5:=CONST(IF(UT3=0,LRL-UT1,REF(LRL-UT1,UT3)));
UTL:=LRL-UT5;
RH:=IF(CURRBARSCOUNT>=MIN(BC2,TC2)-10,ATL,CONST(REF(ATL,MIN(BC2,TC2)-11)));
RL:=IF(CURRBARSCOUNT>=MIN(BC2,TC2)-10,UTL,CONST(REF(UTL,MIN(BC2,TC2)-11)));
上轨:IF(NP>FP,IF(ATL<=RH,ATL,DRAWNULL),IF(ATL>=RL,ATL,DRAWNULL)),COLORFF0066,DOTLINE;
中轨:IF(NP>FP,IF(LRL<=RH,LRL,DRAWNULL),IF(LRL>=RL,LRL,DRAWNULL)),COLORFF0066,DOTLINE;
下轨:IF(NP>FP,IF(UTL<=RH,UTL,DRAWNULL),IF(UTL>=RL,UTL,DRAWNULL)),COLORFF0066,DOTLINE;
降△边:DRAWLINE(HIGH>=HHV(HIGH,10),HIGH,LOW<=LLV(LOW,3),HHV(HIGH,3),1),COLORCYAN,DOTLINE;
涨△边:DRAWLINE(LOW<=LLV(LOW,10),LOW,HIGH>=HHV(HIGH,3),LLV(LOW,3),1),COLORLIRED,DOTLINE;
个涨:=(C-REF(C,1))*100/REF(C,1),NODRAW;
统计:=COUNT(个涨>6,3),NODRAW;
沪市:=("999998$C"-REF("999998$C",1))*100/REF("999998$C",1);
深市:=("399107$C"-REF("399107$C",1))*100/REF("399107$C",1),NODRAW;
中板:=("399101$C"-REF("399101$C",1))*100/REF("399101$C",1),NODRAW;
沪离:=(个涨+REF(个涨,1)+REF(个涨,2))-(沪市+REF(沪市,1)+REF(沪市,2));
深离:=(个涨+REF(个涨,1)+REF(个涨,2))-(深市+REF(深市,1)+REF(深市,2));
中离:=(个涨+REF(个涨,1)+REF(个涨,2))-(中板+REF(中板,1)+REF(中板,2));
偏离廿:=IF(CODELIKE('6'),沪离,IF(CODELIKE('000'),深离,中离)),NODRAW;
沪涨:=个涨-沪市;
深涨:=个涨-深市;
中涨:=个涨-中板;
偏离七:=IF(CODELIKE('6'),沪涨,IF(CODELIKE('000'),深涨,中涨)),NODRAW;
龙:=偏离廿>20 AND  统计>2,NODRAW;
虎:=(偏离七>7 AND 个涨>5)  OR (偏离七<-7 AND 个涨<-5),NODRAW;
换:=100*VOL/(FINANCE(7)/100),NODRAW;
振:=(H-L)*100/REF(C,1),NODRAW;
虎盘:=龙 OR 虎  OR 换>20 OR  振>15,NODRAW;
DRAWICON(虎盘 AND PERIOD=5,HIGH+0.09,41);
VOL5:=MA(VOL,5),COLORWHITE;
VOL10:=MA(VOL,10),COLORYELLOW;
VOL40:=MA(VOL,40),COLORFF00FF;
三日不破:=MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(L,3);
三日量缩:=(MAX(MAX(V,REF(V,1)),REF(V,2))<REF(V,3));
三日价涨A:=C>=REF(C,1);
三日价涨B:=C<REF(C,1);
三日价涨C:=MIN(MIN(C,REF(C,1)),REF(C,2))>=REF(L,3);
TIM:=IF(DATE<1140214,1,0);
缩倍柱:=(VOL*1.95<=REF(VOL,1))*TIM;
百日低量:=(VOL=LLV(VOL,100))*TIM;
倍量柱:=C>REF(C,1)*1.04 AND (VOL>=1.9*REF(VOL,1))*TIM;
四日前倍量柱:=(REF(VOL,3)>1.9*REF(VOL,4))*TIM;
四日前高量柱:=(REF(VOL,3)>=REF(VOL,4) AND REF(VOL,3)<1.9*REF(VOL,4) AND 三日量缩)*TIM;
前三引用不成立:=COUNT(REF(四日前倍量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0 AND COUNT(REF(四日前高量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0;
倍量黄金柱:=四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
高量黄金柱:=四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
黄金柱:=倍量黄金柱 OR 高量黄金柱;
次倍量黄金柱:=NOT(黄金柱) AND 四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次高量黄金柱:=NOT(黄金柱) AND 四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次黄金柱:=次倍量黄金柱 OR 次高量黄金柱;
准倍量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前倍量柱 AND ((三日量缩 AND 三日价涨C) OR (COUNT(倍量柱,3)>=1 AND 三日不破)) AND 前三引用不成立;
准高量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前高量柱 AND (三日量缩 AND 三日价涨C) AND 前三引用不成立;
准黄金柱:=准倍量黄金柱 OR 准高量黄金柱;
倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前倍量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前高量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
将军柱:=倍量将军柱 OR 高量将军柱;
次倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱) AND 四日前倍量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱) AND 四日前高量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次将军柱:=次倍量将军柱 OR 次高量将军柱;
准倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱) AND 四日前倍量柱 AND 三日价涨C AND 前三引用不成立;
准高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱) AND 四日前高量柱 AND 三日价涨C AND 前三引用不成立;
准将军柱:=准倍量将军柱 OR 准高量将军柱;
JJ:=(3*C+H+L+O)/6;
VARA1:=(8*JJ+7*REF(JJ,1)+6*REF(JJ,2)+5*REF(JJ,3)+4*REF(JJ,4)+3*REF(JJ,5)+2*REF(JJ,6)+REF(JJ,8))/36;
TTJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VARA1 AND C>REF(C,1);
LJL:=FILTER(TTJ1,5);
TTJ2:=IF(BARSLAST(LJL)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(LJL)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(LJL)=3 AND CLOSE>REF(HIGH,3),1,0)));
TP:=TTJ2=1;
STICKLINE(CLOSE,REF(LOW,BARSLAST(LJL)),REF(LOW,BARSLAST(LJL)),6,0),COLORYELLOW;{划线}
TTJ3:=IF(BARSLAST(LJL)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(LJL)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(LJL)=3 AND CLOSE>REF(LOW,3),1,0)));
STFZ:=TTJ3=1;
CL:=STFZ AND TP;
TJCL:=FILTER(CL,3);
STICKLINE(LJL,C,O,2,0),COLORYELLOW;
MA5:MA(CLOSE,5),COLORWHITE;
MA10:MA(CLOSE,10),COLORYELLOW;
MA20:MA(CLOSE,20),COLORLIMAGENTA;
MA60:MA(CLOSE,60),COLORGREEN;
MA120:MA(CLOSE,120),COLORBLUE;
MA250:MA(CLOSE,250);
DP:=IF(C=INDEXC,0,1);
GJ:=AMOUNT/V/100;
【明日阻力】:L+(GJ-L)+(C-L),COLORRED,NODRAW;
【明日支撑】:L+(C-GJ),NODRAW;
年:=YEAR,NODRAW;
月:=MONTH,NODRAW;
星期:=WEEKDAY,NODRAW;
日1:=DATETODAY(DATE);
上市日:=REF(DATE,TOTALBARSCOUNT-CURRBARSCOUNT);
自然日:=日1-DATETODAY(上市日)+1;
ZB:=(自然日-REF(自然日,1))!=星期-REF(星期,1)
OR TOTALBARSCOUNT-CURRBARSCOUNT=0;
本周第几天:=BARSLAST(ZB)+1;
本月第几天:=BARSLAST(年*100+月!=REF(年*100+月,1))+1;
M1:=REF(C,本周第几天);
M2:=REF(M1,本周第几天);
M3:=REF(M2,本周第几天);
M4:=REF(M3,本周第几天);
M5:=REF(M4,本周第几天);
M6:=REF(M5,本周第几天);
M7:=REF(M6,本周第几天);
M8:=REF(M7,本周第几天);
M9:=REF(M8,本周第几天);
十周价:=(C+M1+M2+M3+M4+M5+M6+M7+M8+M9)/10;
决策:REFDATE(十周价,DATE),COLORBROWN,LINETHICK1;
DRAWTEXT(ISLASTBAR,决策,' 决策线'),COLORBROWN;
DRAWTEXT_FIX(C>0,0.004,0.0001,0,STRCAT('三季报业绩:',EXTERNSTR(0,10))),COLORLIRED,LINETHICK2;
{DRAWTEXT_FIX(C>0,0.004,0.05,0,STRCAT('一季报业绩:',EXTERNSTR(0,8))),COLORBROWN,LINETHICK2;}
{DRAWTEXT_FIX(C>0,0.004,0.1,0,STRCAT('中报预报:',EXTERNSTR(0,6))),COLORLIGRAY,LINETHICK2;}
DRAWTEXT_FIX(C>0,0.004,0.05,0,STRCAT('年报预告:',EXTERNSTR(0,16))),COLORWHITE,LINETHICK2;
DRAWTEXT_FIX(C>0,0.004,0.1,0,STRCAT('股东变动:',EXTERNSTR(0,9))),COLORLIGRAY,LINETHICK2;
DRAWTEXT_FIX(C>0,0.004,0.15,0,STRCAT('机构持仓:',EXTERNSTR(0,1))),COLORLIGRAY,LINETHICK2;
{DRAWTEXT_FIX(ISLASTBAR,0,0,0,GNBLOCK),COLORYELLOW;}{概念板块左上角}
DRAWTEXT_FIX(ISLASTBAR,0,28,0,GNBLOCK),COLOR0099CC;{板块概念左下角}
DRAWTEXT_FIX(1,0.34,28,0,HYBLOCK)COLOR0099CC;{所属行业左下角}
DRAWTEXT_FIX(1,0.40,28,0,DYBLOCK)COLOR0099CC;{所属地区左下角}
DRAWTEXT_FIX(1,0.48,28,0,EXTERNSTR(0,2))COLOR0099CC;{主题投资左下角};
半分位:=(O+C)/2;
昨半分位:=REF(半分位,1);
STICKLINE(ISLASTBAR,昨半分位,昨半分位,10,0),COLORWHITE;
DRAWNUMBER(ISLASTBAR,昨半分位,昨半分位),COLORBROWN;
DRAWTEXT(ISLASTBAR,昨半分位,' 昨半分位'),COLORGRAY;[/lycode][lycode=tdx2,true]N1赋值:5
周期赋值:220
自动C赋值:大盘的收盘价
自动O赋值:大盘的开盘价
自动H赋值:大盘的最高价
自动L赋值:大盘的最低价
指定O赋值:"SH999999$开盘价"
指定H赋值:"SH999999$最高价"
指定L赋值:"SH999999$最低价"
指定C赋值:"SH999999$收盘价"
大盘低赋值:周期日内指定L的最低值的最后一日取值设为常数
大盘高赋值:周期日内指定H的最高值的最后一日取值设为常数
大盘差赋值:大盘高-大盘低
当前低赋值:周期日内最低价的最低值的最后一日取值设为常数
当前高赋值:周期日内最高价的最高值的最后一日取值设为常数
当前差赋值:当前高-当前低
比1赋值:当前差/大盘差
变C赋值:当前低+(指定C-大盘低)*比1
变H赋值:当前低+(指定H-大盘低)*比1
变L赋值:当前低+(指定L-大盘低)*比1
变O赋值:当前低+(指定O-大盘低)*比1
当满足条件到最后交易的周期<周期时,在变H和变L位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR663300
当满足条件到最后交易的周期<周期时,在变O和变C位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR663300
当满足条件到最后交易的周期<周期AND变C>=变O时,在变O和变C位置之间画柱状线,宽度为3,1不为0则画空心柱.,COLOR663300
K线
UR赋值:N1
LR赋值:N1
TC1赋值:如果最高价=8*UR日内最高价的最高值,返回最高价,否则返回无效数
TC2赋值:上次TC1=最高价距今天数的最后一日取值设为常数+1
UP赋值:如果TC2=1,返回最高价,否则返回TC2-1日前的最高价的最后一日取值设为常数
BC1赋值:如果最低价=8*LR日内最低价的最低值,返回最低价,否则返回无效数
BC2赋值:上次BC1=最低价距今天数的最后一日取值设为常数+1
LL赋值:如果BC2=1,返回最低价,否则返回BC2-1日前的最低价的最后一日取值设为常数
LP赋值:到最后交易的周期<=BC2 AND 最低价=LL
HP赋值:到最后交易的周期<=TC2 AND 最高价=UP
NOD赋值:(如果TC2>BC2,返回TC2,否则返回BC2-如果TC2>BC2,返回BC2,否则返回TC2)
LR1赋值:收盘价的NOD+1日线性回归预测值
NP赋值:如果到最后交易的周期<=BC2和TC2的较大值,返回如果TC2和BC2的较小值=1,返回LR1,否则返回TC2和BC2的较小值-1日前的LR1的最后一日取值设为常数,否则返回无效数,POINTDOT,COLOR93BDA8
LR2赋值:收盘价的NOD+1日线性回归斜率
LR3赋值:如果TC2和BC2的较小值=1,返回LR2,否则返回TC2和BC2的较小值-1日前的LR2的最后一日取值设为常数
FP赋值:NP-LR3*(NOD),POINTDOT,COLOR93BDA8
AD赋值:NP-FP的绝对值
DBL赋值:上次BC1不等于无效数距今天数+1
DBH赋值:上次TC1不等于无效数距今天数+1
BSP赋值:如果BC2>TC2,返回DBL,否则返回DBH-1
LRL赋值:如果NP>FP,返回FP+AD/NOD*BSP,否则返回FP-AD/NOD*BSP
AT1赋值:如果到最后交易的周期位于BC2和TC2之间ANDH>LRL,返回最高价,否则返回LRL
AT2赋值:BC2和TC2的较大值日内AT1-LRL的最高值
AT3赋值:上次AT1-LRL=AT2距今天数的最后一日取值设为常数
AT4赋值:如果AT3=0,返回最高价,否则返回AT3日前的最高价的最后一日取值设为常数
AT5赋值:如果AT3=0,返回AT1-LRL,否则返回AT3日前的AT1-LRL的最后一日取值设为常数
ATL赋值:LRL+AT5
UT1赋值:如果到最后交易的周期位于BC2和TC2之间ANDL<LRL,返回最低价,否则返回LRL
UT2赋值:BC2和TC2的较大值日内LRL-UT1的最高值
UT3赋值:上次LRL-UT1=UT2距今天数的最后一日取值设为常数
UT4赋值:如果UT3=0,返回最高价,否则返回UT3日前的最高价的最后一日取值设为常数
UT5赋值:如果UT3=0,返回LRL-UT1,否则返回UT3日前的LRL-UT1的最后一日取值设为常数
UTL赋值:LRL-UT5
RH赋值:如果到最后交易的周期>=BC2和TC2的较小值-10,返回ATL,否则返回BC2和TC2的较小值-11日前的ATL的最后一日取值设为常数
RL赋值:如果到最后交易的周期>=BC2和TC2的较小值-10,返回UTL,否则返回BC2和TC2的较小值-11日前的UTL的最后一日取值设为常数
输出上轨:如果NP>FP,返回如果ATL<=RH,返回ATL,否则返回无效数,否则返回如果ATL>=RL,返回ATL,否则返回无效数,COLORFF0066,DOTLINE
输出中轨:如果NP>FP,返回如果LRL<=RH,返回LRL,否则返回无效数,否则返回如果LRL>=RL,返回LRL,否则返回无效数,COLORFF0066,DOTLINE
输出下轨:如果NP>FP,返回如果UTL<=RH,返回UTL,否则返回无效数,否则返回如果UTL>=RL,返回UTL,否则返回无效数,COLORFF0066,DOTLINE
输出降△边:当满足条件最高价>=10日内最高价的最高值时,在最高价位置画直线起点,当满足条件最低价<=3日内最低价的最低值时,在3日内最高价的最高值位置画直线终点,1表示是否延长.,画青色,DOTLINE
输出涨△边:当满足条件最低价<=10日内最低价的最低值时,在最低价位置画直线起点,当满足条件最高价>=3日内最高价的最高值时,在3日内最低价的最低值位置画直线终点,1表示是否延长.,画淡红色,DOTLINE
个涨赋值:(收盘价-1日前的收盘价)*100/1日前的收盘价,NODRAW
统计赋值:统计3日中满足个涨>6的天数,NODRAW
沪市赋值:("999998$收盘价"-1日前的"999998$收盘价")*100/1日前的"999998$收盘价"
深市赋值:("399107$收盘价"-1日前的"399107$收盘价")*100/1日前的"399107$收盘价",NODRAW
中板赋值:("399101$收盘价"-1日前的"399101$收盘价")*100/1日前的"399101$收盘价",NODRAW
沪离赋值:(个涨+1日前的个涨+2日前的个涨)-(沪市+1日前的沪市+2日前的沪市)
深离赋值:(个涨+1日前的个涨+2日前的个涨)-(深市+1日前的深市+2日前的深市)
中离赋值:(个涨+1日前的个涨+2日前的个涨)-(中板+1日前的中板+2日前的中板)
偏离廿赋值:如果模糊匹配品种代码,返回沪离,否则返回如果模糊匹配品种代码,返回深离,否则返回中离,NODRAW
沪涨赋值:个涨-沪市
深涨赋值:个涨-深市
中涨赋值:个涨-中板
偏离七赋值:如果模糊匹配品种代码,返回沪涨,否则返回如果模糊匹配品种代码,返回深涨,否则返回中涨,NODRAW
龙赋值:偏离廿>20 AND  统计>2,NODRAW
虎赋值:(偏离七>7 AND 个涨>5)  OR (偏离七<-7 AND 个涨<-5),NODRAW
换赋值:100*成交量(手)/(流通股本(股)/100),NODRAW
振赋值:(最高价-最低价)*100/1日前的收盘价,NODRAW
虎盘赋值:龙 OR 虎  OR 换>20 OR  振>15,NODRAW
当满足条件虎盘ANDPERIOD=5时,在最高价+0.09位置画41号图标
VOL5赋值:成交量(手)的5日简单移动平均,画白色
VOL10赋值:成交量(手)的10日简单移动平均,画黄色
VOL40赋值:成交量(手)的40日简单移动平均,COLORFF00FF
三日不破赋值:最低价和1日前的最低价的较小值和2日前的最低价的较小值>=3日前的最低价
三日量缩赋值:(成交量(手)和1日前的成交量(手)的较大值和2日前的成交量(手)的较大值<3日前的成交量(手))
三日价涨A赋值:收盘价>=1日前的收盘价
三日价涨B赋值:收盘价<1日前的收盘价
三日价涨C赋值:收盘价和1日前的收盘价的较小值和2日前的收盘价的较小值>=3日前的最低价
TIM赋值:如果日期<1140214,返回1,否则返回0
缩倍柱赋值:(成交量(手)*1.95<=1日前的成交量(手))*TIM
百日低量赋值:(成交量(手)=100日内成交量(手)的最低值)*TIM
倍量柱赋值:收盘价>1日前的收盘价*1.04 AND (成交量(手)>=1.9*1日前的成交量(手))*TIM
四日前倍量柱赋值:(3日前的成交量(手)>1.9*4日前的成交量(手))*TIM
四日前高量柱赋值:(3日前的成交量(手)>=4日前的成交量(手) AND 3日前的成交量(手)<1.9*4日前的成交量(手) AND 三日量缩)*TIM
前三引用不成立赋值:统计3日中满足1日前的四日前倍量柱AND(1日前的三日不破ORREF(三日价涨C,1))的天数=0 AND 统计3日中满足1日前的四日前高量柱AND(1日前的三日不破ORREF(三日价涨C,1))的天数=0
倍量黄金柱赋值:四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立
高量黄金柱赋值:四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立
黄金柱赋值:倍量黄金柱 OR 高量黄金柱
次倍量黄金柱赋值:取反 AND 四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立
次高量黄金柱赋值:取反 AND 四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立
次黄金柱赋值:次倍量黄金柱 OR 次高量黄金柱
准倍量黄金柱赋值:取反 AND 四日前倍量柱 AND ((三日量缩 AND 三日价涨C) OR (统计3日中满足倍量柱的天数>=1 AND 三日不破)) AND 前三引用不成立
准高量黄金柱赋值:取反 AND 四日前高量柱 AND (三日量缩 AND 三日价涨C) AND 前三引用不成立
准黄金柱赋值:准倍量黄金柱 OR 准高量黄金柱
倍量将军柱赋值:取反 AND 四日前倍量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立
高量将军柱赋值:取反 AND 四日前高量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立
将军柱赋值:倍量将军柱 OR 高量将军柱
次倍量将军柱赋值:取反 AND 四日前倍量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立
次高量将军柱赋值:取反 AND 四日前高量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立
次将军柱赋值:次倍量将军柱 OR 次高量将军柱
准倍量将军柱赋值:取反 AND 四日前倍量柱 AND 三日价涨C AND 前三引用不成立
准高量将军柱赋值:取反 AND 四日前高量柱 AND 三日价涨C AND 前三引用不成立
准将军柱赋值:准倍量将军柱 OR 准高量将军柱
JJ赋值:(3*收盘价+最高价+最低价+开盘价)/6
VARA1赋值:(8*JJ+7*1日前的JJ+6*2日前的JJ+5*3日前的JJ+4*4日前的JJ+3*5日前的JJ+2*6日前的JJ+8日前的JJ)/36
TTJ1赋值:成交量(手)=10日内成交量(手)的最高值 AND 成交量(手)>2*1日前的成交量(手) AND 收盘价>VARA1 AND 收盘价>1日前的收盘价
LJL赋值:TTJ1的5日过滤
TTJ2赋值:如果上次LJL距今天数=1ANDCLOSE>1日前的最高价,返回1,否则返回如果上次LJL距今天数=2ANDCLOSE>2日前的最高价,返回1,否则返回如果上次LJL距今天数=3ANDCLOSE>3日前的最高价,返回1,否则返回0
TP赋值:TTJ2=1
当满足条件收盘价时,在上次LJL距今天数日前的最低价和上次LJL距今天数日前的最低价位置之间画柱状线,宽度为6,0不为0则画空心柱.,画黄色
TTJ3赋值:如果上次LJL距今天数=1ANDCLOSE>1日前的最低价,返回1,否则返回如果上次LJL距今天数=2ANDCLOSE>2日前的最低价,返回1,否则返回如果上次LJL距今天数=3ANDCLOSE>3日前的最低价,返回1,否则返回0
STFZ赋值:TTJ3=1
CL赋值:STFZ AND TP
TJCL赋值:CL的3日过滤
当满足条件LJL时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色
输出MA5:收盘价的5日简单移动平均,画白色
输出MA10:收盘价的10日简单移动平均,画黄色
输出MA20:收盘价的20日简单移动平均,画淡洋红色
输出MA60:收盘价的60日简单移动平均,画绿色
输出MA120:收盘价的120日简单移动平均,画蓝色
输出MA250:收盘价的250日简单移动平均
DP赋值:如果收盘价=大盘的收盘价,返回0,否则返回1
GJ赋值:成交额(元)/成交量(手)/100
输出【明日阻力】:最低价+(GJ-最低价)+(收盘价-最低价),画红色,NODRAW
输出【明日支撑】:最低价+(收盘价-GJ),NODRAW
年赋值:年份,NODRAW
月赋值:月份,NODRAW
星期赋值:星期,NODRAW
日1赋值:日期对应的转换天数
上市日赋值:总的周期数-到最后交易的周期日前的日期
自然日赋值:日1-上市日对应的转换天数+1
ZB赋值:(自然日-1日前的自然日)不等于星期-1日前的星期OR 总的周期数-到最后交易的周期=0
本周第几天赋值:上次ZB距今天数+1
本月第几天赋值:上次年*100+月不等于1日前的年*100+月距今天数+1
M1赋值:本周第几天日前的收盘价
M2赋值:本周第几天日前的M1
M3赋值:本周第几天日前的M2
M4赋值:本周第几天日前的M3
M5赋值:本周第几天日前的M4
M6赋值:本周第几天日前的M5
M7赋值:本周第几天日前的M6
M8赋值:本周第几天日前的M7
M9赋值:本周第几天日前的M8
十周价赋值:(收盘价+M1+M2+M3+M4+M5+M6+M7+M8+M9)/10
输出决策:日期日十周价,画棕色,线宽为1
当满足条件是否最后一个周期时,在决策位置书写文字,画棕色
当满足条件收盘价>0时,在横轴0.004纵轴0.0001位置书写文字,画淡红色,线宽为2
当满足条件收盘价>0时,在横轴0.004纵轴0.05位置书写文字,画白色,线宽为2
当满足条件收盘价>0时,在横轴0.004纵轴0.1位置书写文字,画淡灰色,线宽为2
当满足条件收盘价>0时,在横轴0.004纵轴0.15位置书写文字,画淡灰色,线宽为2
当满足条件是否最后一个周期时,在横轴0纵轴28位置书写文字,COLOR0099CC
当满足条件1时,在横轴0.34纵轴28位置书写文字COLOR0099CC
当满足条件1时,在横轴0.40纵轴28位置书写文字COLOR0099CC
当满足条件1时,在横轴0.48纵轴28位置书写文字COLOR0099CC

半分位赋值:(开盘价+收盘价)/2
昨半分位赋值:1日前的半分位
当满足条件是否最后一个周期时,在昨半分位和昨半分位位置之间画柱状线,宽度为10,0不为0则画空心柱.,画白色
当满足条件是否最后一个周期时,在昨半分位位置书写数字,画棕色
当满足条件是否最后一个周期时,在昨半分位位置书写文字,画深灰色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1ZuzMhAVvNMXIsXFg87EMcQ

看了该指标的人还看了:
绝佳买点指标    股海神偷指标    短线追踪指标
估抄底F指标    压力走势指标    中线指标

使用道具 举报

回复