指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 抄底逃顶 
炒股叉_20190412_101423.png

炒股叉_20190412_101434.png

[lywrap=通达信副图指标公式][lycode=tdx,true]量能:=(CLOSE-MA(CLOSE,30))/MA(CLOSE,20)*500;
HAN:=DATE<1151230;
金资:IF(量能>0,量能,0)*10*HAN,COLORMAGENTA,LINETHICK2;
行情:STICKLINE(量能>0,量能*5,0,3.8,-1)*800000*HAN,COLOR000555;
STICKLINE(量能>0,量能*5,0,2.7,-1)*800000*HAN,,COLOR000777;
STICKLINE(量能>0,量能*5,0,1.9,-1)*800000*HAN,COLOR000999;
STICKLINE(量能>0,量能*5,0,1.3,-1)*800000*HAN,COLOR000BBB;
STICKLINE(量能>0,量能*5,0,0.1,-1)*800000*HAN,COLOR000DDD;
STICKLINE(量能<0,0,量能*5,3,0)*800000*HAN,COLOR005500;
STICKLINE(量能<0,0,量能*5,2.3,0)*800000*HAN,COLOR007700;
STICKLINE(量能<0,0,量能*5,1.6,0)*800000*HAN,COLOR009900;
STICKLINE(量能<0,0,量能*5,0.8,0)*800000*HAN,COLOR00BB00;
STICKLINE(量能<0,0,量能*5,0.1,0)*800000*HAN,COLOR00DD00;
主力:EMA(EMA(量能,30),3)*20*HAN,CIRCLEDOT,COLORGREEN;
乖离:=(C-MA(C,5))/MA(C,5)*1000,CIRCLEDOT,COLORGREEN,LINETHICK2;

主力S:IF(主力>REF(主力,1),主力,DRAWNULL)*HAN,,CIRCLEDOT,COLORRED,LINETHICK3;
Q2:=(CLOSE-LLV(LOW, 18))/(HHV(HIGH, 18)-LLV(LOW, 18))*100;
Q3:=SMA(Q2, 9, 1);
Q4:=SMA(Q3, 3, 1);
专用:=3*Q3-2*Q4;
Q8:=HHVBARS(HIGH, 50);
Q10:=(CLOSE-REF(OPEN, Q8))/REF(OPEN, Q8)*100;
顶:=STICKLINE(CROSS(专用, 8) AND Q10<-13, 0,340,10,0);
底顶:=FILTER(顶,50);
跨越:=EMA(Q3, 3);
DRAWTEXT(FILTER(CROSS(跨越,专用) AND REF(专用,1)>80 AND 跨越>80,20)*HAN, -260,'..庄家逃跑'),COLORWHITE  ,LINETHICK5;
AA:=STICKLINE(CROSS(跨越,专用) AND REF(专用,1)>80 AND 跨越>80, 0,270,10,0);
底顶A:=FILTER(AA,30);
STICKLINE(底顶A, 0,-260,5,0)*HAN,COLOR000077;
STICKLINE(底顶A, 0,-260,4,0)*HAN,COLOR000099;
STICKLINE(底顶A, 0,-260,3,0)*HAN,COLOR0000BB;
STICKLINE(底顶A, 0,-260,2,0)*HAN,COLOR0000DD;
STICKLINE(底顶A, 0,-260,1,0)*HAN,COLOR0000FF;
V3:=100-(100-3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))
*100,20,1)+2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))
*100,20,1),15,1));
V4:=100-(100-3*SMA((O-LLV(L,55))/(HHV(H,55)-LLV(L,55))
*100,20,1)+2*SMA(SMA((O-LLV(L,55))/(HHV(H,55)-LLV(L,55))
*100,20,1),15,1));
T7:=V3>REF(V4,1) AND V>REF(V,1) AND C>REF(C,1);
风:=STICKLINE(T7 AND COUNT(T7,30)=1,0,20,2,0);
风A:=STICKLINE(底顶 OR 风, 0,270,5,0) ;
风AA:=FILTER(风A,20);
STICKLINE(风AA, 0,260,5,0)*HAN,COLORFF11FF;
STICKLINE(风AA, 0,260,4,0)*HAN,COLORFF33FF;
STICKLINE(风AA, 0,260,3,0)*HAN,COLORFF55FF;
STICKLINE(风AA, 0,260,2,0)*HAN,COLORFF77FF;
STICKLINE(风AA, 0,260,1,0)*HAN,COLORFF99FF;
DRAWTEXT(FILTER(风AA,20),250,'..庄家出现')*HAN,COLORYELLOW,LINETHICK5;
V1:=MA(100*(C-LLV(C,34))/(HHV(H,34)-LLV(L,34)),5)-20;
V2:=2*ABS(V1);
V5:=(H+L+C)/3;
V6:=(V5-MA(V5,10))/(0.015*AVEDEV(V5,10));
V7:=(V5-MA(V5,30))/(0.015*AVEDEV(V5,30));
V8:=IF(V6>=150 AND V6<200 AND V7>=150 AND V7<200,10,0);
V9:=IF(V6<=-150 AND V6>-200 AND V7<=-150 AND V7>-200,-10,V8);
VA:=(C-MA(C,13))/MA(C,13)*100;
VB:=100-ABS(VA);
VC:=3*SMA((INDEXC-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55))*100,20,1)-2
*SMA(SMA((INDEXC-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55))*100,20,1),15,1);
顶线:= IF(VB<90,VB,100);
多方:= IF(V1>0,V1,0);
空方:= -IF(V1<0,V2,0);
预警系统:= (IF((V7>=200 AND V6>=150) OR CROSS(65,多方),15,IF(V7<=-200 AND V6<=-150,-15,V9))+65);
T1:=C>MA(C,20) AND MA(C,20)>=REF(MA(C,20),1);
T3:=多方>60 AND 预警系统>65 AND 顶线=100;
T4:=多方>48 AND 预警系统>65 AND 顶线<100;
T8:=V3<=REF(V4,1) AND C AND 空方>=REF(空方,1) AND VC*HAN;
DRAWTEXT(T1 AND COUNT(T1,30)=1,-150,'上升通道!')*HAN,COLOR00FFFF;[/lycode][lycode=tdx2,true]量能赋值:(收盘价-收盘价的30日简单移动平均)/收盘价的20日简单移动平均*500
HAN赋值:日期<1151230
输出金资:如果量能>0,返回量能,否则返回0*10*HAN,画洋红色,线宽为2
输出行情:当满足条件量能>0时,在量能*5和0位置之间画柱状线,宽度为3.8,-1不为0则画空心柱.*800000*HAN,COLOR000555
当满足条件量能>0时,在量能*5和0位置之间画柱状线,宽度为2.7,-1不为0则画空心柱.*800000*HAN,,COLOR000777
当满足条件量能>0时,在量能*5和0位置之间画柱状线,宽度为1.9,-1不为0则画空心柱.*800000*HAN,COLOR000999
当满足条件量能>0时,在量能*5和0位置之间画柱状线,宽度为1.3,-1不为0则画空心柱.*800000*HAN,COLOR000BBB
当满足条件量能>0时,在量能*5和0位置之间画柱状线,宽度为0.1,-1不为0则画空心柱.*800000*HAN,COLOR000DDD
当满足条件量能<0时,在0和量能*5位置之间画柱状线,宽度为3,0不为0则画空心柱.*800000*HAN,COLOR005500
当满足条件量能<0时,在0和量能*5位置之间画柱状线,宽度为2.3,0不为0则画空心柱.*800000*HAN,COLOR007700
当满足条件量能<0时,在0和量能*5位置之间画柱状线,宽度为1.6,0不为0则画空心柱.*800000*HAN,COLOR009900
当满足条件量能<0时,在0和量能*5位置之间画柱状线,宽度为0.8,0不为0则画空心柱.*800000*HAN,COLOR00BB00
当满足条件量能<0时,在0和量能*5位置之间画柱状线,宽度为0.1,0不为0则画空心柱.*800000*HAN,COLOR00DD00
输出主力:量能的30日指数移动平均的3日指数移动平均*20*HAN,CIRCLEDOT,画绿色
乖离赋值:(收盘价-收盘价的5日简单移动平均)/收盘价的5日简单移动平均*1000,CIRCLEDOT,画绿色,线宽为2
输出主力S:如果主力>1日前的主力,返回主力,否则返回无效数*HAN,,CIRCLEDOT,画红色,线宽为3
Q2赋值:(收盘价-18日内最低价的最低值)/(18日内最高价的最高值-18日内最低价的最低值)*100
Q3赋值:Q2的9日[1日权重]移动平均
Q4赋值:Q3的3日[1日权重]移动平均
专用赋值:3*Q3-2*Q4
Q8赋值:50日内最高价距今天数
Q10赋值:(收盘价-Q8日前的开盘价)/Q8日前的开盘价*100
顶赋值:当满足条件专用上穿8ANDQ10<-13时,在0和340位置之间画柱状线,宽度为10,0不为0则画空心柱.
底顶赋值:顶的50日过滤
跨越赋值:Q3的3日指数移动平均
当满足条件跨越上穿专用ANDREF(专用,1)>80AND跨越>80的20日过滤*HAN时,在-260位置书写文字,画白色  ,线宽为5
AA赋值:当满足条件跨越上穿专用ANDREF(专用,1)>80AND跨越>80时,在0和270位置之间画柱状线,宽度为10,0不为0则画空心柱.
底顶A赋值:AA的30日过滤
当满足条件底顶A时,在0和-260位置之间画柱状线,宽度为5,0不为0则画空心柱.*HAN,COLOR000077
当满足条件底顶A时,在0和-260位置之间画柱状线,宽度为4,0不为0则画空心柱.*HAN,COLOR000099
当满足条件底顶A时,在0和-260位置之间画柱状线,宽度为3,0不为0则画空心柱.*HAN,COLOR0000BB
当满足条件底顶A时,在0和-260位置之间画柱状线,宽度为2,0不为0则画空心柱.*HAN,COLOR0000DD
当满足条件底顶A时,在0和-260位置之间画柱状线,宽度为1,0不为0则画空心柱.*HAN,COLOR0000FF
V3赋值:100-(100-3*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的20日[1日权重]移动平均+2*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均)
V4赋值:100-(100-3*(开盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的20日[1日权重]移动平均+2*(开盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均)
T7赋值:V3>1日前的V4 AND 成交量(手)>1日前的成交量(手) AND 收盘价>1日前的收盘价
风赋值:当满足条件T7ANDCOUNT(T7,30)=1时,在0和20位置之间画柱状线,宽度为2,0不为0则画空心柱.
风A赋值:当满足条件底顶OR风时,在0和270位置之间画柱状线,宽度为5,0不为0则画空心柱.
风AA赋值:风A的20日过滤
当满足条件风AA时,在0和260位置之间画柱状线,宽度为5,0不为0则画空心柱.*HAN,COLORFF11FF
当满足条件风AA时,在0和260位置之间画柱状线,宽度为4,0不为0则画空心柱.*HAN,COLORFF33FF
当满足条件风AA时,在0和260位置之间画柱状线,宽度为3,0不为0则画空心柱.*HAN,COLORFF55FF
当满足条件风AA时,在0和260位置之间画柱状线,宽度为2,0不为0则画空心柱.*HAN,COLORFF77FF
当满足条件风AA时,在0和260位置之间画柱状线,宽度为1,0不为0则画空心柱.*HAN,COLORFF99FF
当满足条件风AA的20日过滤时,在250位置书写文字*HAN,画黄色,线宽为5
V1赋值:100*(收盘价-34日内收盘价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)的5日简单移动平均-20
V2赋值:2*V1的绝对值
V5赋值:(最高价+最低价+收盘价)/3
V6赋值:(V5-V5的10日简单移动平均)/(0.015*V5的10日平均绝对偏差)
V7赋值:(V5-V5的30日简单移动平均)/(0.015*V5的30日平均绝对偏差)
V8赋值:如果V6>=150ANDV6<200ANDV7>=150ANDV7<200,返回10,否则返回0
V9赋值:如果V6<=-150ANDV6>-200ANDV7<=-150ANDV7>-200,返回-10,否则返回V8
VA赋值:(收盘价-收盘价的13日简单移动平均)/收盘价的13日简单移动平均*100
VB赋值:100-VA的绝对值
VC赋值:3*(大盘的收盘价-55日内大盘的最低价的最低值)/(55日内大盘的最高价的最高值-55日内大盘的最低价的最低值)*100的20日[1日权重]移动平均-2*(大盘的收盘价-55日内大盘的最低价的最低值)/(55日内大盘的最高价的最高值-55日内大盘的最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均
顶线赋值: 如果VB<90,返回VB,否则返回100
多方赋值: 如果V1>0,返回V1,否则返回0
空方赋值: -如果V1<0,返回V2,否则返回0
预警系统赋值: (如果(V7>=200ANDV6>=150)ORCROSS(65,多方),返回15,否则返回如果V7<=-200ANDV6<=-150,返回-15,否则返回V9+65)
T1赋值:收盘价>收盘价的20日简单移动平均 AND 收盘价的20日简单移动平均>=1日前的收盘价的20日简单移动平均
T3赋值:多方>60 AND 预警系统>65 AND 顶线=100
T4赋值:多方>48 AND 预警系统>65 AND 顶线<100
T8赋值:V3<=1日前的V4 AND 收盘价 AND 空方>=1日前的空方 AND VC*HAN
当满足条件T1ANDCOUNT(T1,30)=1时,在-150位置书写文字*HAN,COLOR00FFFF[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1aNtz9xkfbikX80HyNa7SSg

看了该指标的人还看了:
叶公跟庄指标    股海神偷指标    降龙贰式指标
均线进多头指标    主力主升指标    画线指标指标

使用道具 举报

回复