指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 操盘控盘 
炒股叉_20190409_113520.png

炒股叉_20190409_113527.png

[lywrap=通达信主图指标公式][lycode=tdx,true]VAR1:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VAR2:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
DIR1:=ABS(CLOSE-REF(CLOSE,5));
VIR1:=SUM(ABS(CLOSE-REF(CLOSE,1)),5);
ER1:=DIR1/VIR1;
CS1:=ER1*(0.8-2/8)+2/8;
CQ1:=CS1*CS1;
AMA1:EMA(DMA(CLOSE,CQ1),2) ,COLORWHITE;
DIR2:=ABS(CLOSE-REF(CLOSE,10));
VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),10);
ER2:=DIR2/VIR2;
CS2:=ER2*(0.8-2/24)+2/24;
CQ2:=CS2*CS2;
AMA2:EMA(DMA(CLOSE,CQ2),2),COLORGREEN,LINETHICK2;
AMA3:IF(AMA2/REF(AMA2,1)>0.997,AMA2,DRAWNULL),COLORYELLOW,LINETHICK2;
AMA4:IF(AMA2/REF(AMA2,1)>1.001,AMA2,DRAWNULL),COLORRED,LINETHICK2;
STICKLINE((VAR2 < MA(VAR3,6)),CLOSE,OPEN,3,1),COLOR008000;
STICKLINE((VAR2 > MA(VAR3,6)),OPEN,CLOSE,3,1),COLORRED;
STICKLINE(((OPEN > CLOSE) AND (VAR2 > MA(VAR3,6))),(OPEN * 0.998),(CLOSE * 1.0001),2.3,0),COLOR008000;
STICKLINE(((OPEN < CLOSE) AND (VAR2 < MA(VAR3,6))),(CLOSE * 0.998),(OPEN * 1.002),2.3,0),COLORRED;
STICKLINE(((OPEN > CLOSE) AND (VAR2 < MA(VAR3,6))),CLOSE,OPEN,2.3,0),COLOR008000;
DRAWICON(CROSS(VAR2,MA(VAR3,6)),(LOW - (LOW*0.04)),7);
DRAWICON(CROSS(MA(VAR3,6),VAR1),(HIGH+(HIGH*0.03)),8);
PT:=REF(H,1)-REF(L,1);
CDP:=(REF(H,1)+REF(L,1)+REF(C,1)*2)/4;
AH:=CDP+PT;
AL:=CDP-PT;
NH:=CDP*2-REF(L,1);
NL:=CDP*2-REF(H,1);
强:IF(AH>REF(C,1)*1.1,REF(C,1)*1.1,AH)NODRAW;
阻:IF(NH>强,(强-CDP)*0.618+CDP,NH)NODRAW,COLORCYAN;
M:=IF(AL<REF(C,1)/1.1,REF(C,1)/1.1,AL);
撑:IF(NL<M,CDP-(CDP-M)*0.618,NL)NODRAW;
底:IF(AL<REF(C,1)/1.1,REF(C,1)/1.1,AL)NODRAW;[/lycode][lycode=tdx2,true]VAR1赋值:(100 - ((90 * (14日内最高价的最高值 - 收盘价)) / (14日内最高价的最高值 - 14日内最低价的最低值)))
VAR2赋值:(100 - ((90 * (14日内最高价的最高值 - 收盘价)) / (14日内最高价的最高值 - 14日内最低价的最低值)))
VAR3赋值:(100 - ((100*(6日内最高价的最高值-收盘价))/(6日内最高价的最高值-6日内最低价的最低值))的34日简单移动平均)
DIR1赋值:收盘价-5日前的收盘价的绝对值
VIR1赋值:收盘价-1日前的收盘价的绝对值的5日累和
ER1赋值:DIR1/VIR1
CS1赋值:ER1*(0.8-2/8)+2/8
CQ1赋值:CS1*CS1
输出AMA1:以CQ1为权重收盘价的动态移动平均的2日指数移动平均 ,画白色
DIR2赋值:收盘价-10日前的收盘价的绝对值
VIR2赋值:收盘价-1日前的收盘价的绝对值的10日累和
ER2赋值:DIR2/VIR2
CS2赋值:ER2*(0.8-2/24)+2/24
CQ2赋值:CS2*CS2
输出AMA2:以CQ2为权重收盘价的动态移动平均的2日指数移动平均,画绿色,线宽为2
输出AMA3:如果AMA2/1日前的AMA2>0.997,返回AMA2,否则返回无效数,画黄色,线宽为2
输出AMA4:如果AMA2/1日前的AMA2>1.001,返回AMA2,否则返回无效数,画红色,线宽为2
当满足条件(VAR2<VAR3的6日简单移动平均)时,在收盘价和开盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,COLOR008000
当满足条件(VAR2>VAR3的6日简单移动平均)时,在开盘价和收盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,画红色
当满足条件((收阴线)AND(VAR2>VAR3的6日简单移动平均))时,在(开盘价*0.998)和(收盘价*1.0001)位置之间画柱状线,宽度为2.3,0不为0则画空心柱.,COLOR008000
当满足条件((收阳线)AND(VAR2<VAR3的6日简单移动平均))时,在(收盘价*0.998)和(开盘价*1.002)位置之间画柱状线,宽度为2.3,0不为0则画空心柱.,画红色
当满足条件((收阴线)AND(VAR2<VAR3的6日简单移动平均))时,在收盘价和开盘价位置之间画柱状线,宽度为2.3,0不为0则画空心柱.,COLOR008000
当满足条件VAR2上穿VAR3的6日简单移动平均时,在(最低价-(最低价*0.04))位置画7号图标
当满足条件VAR3的6日简单移动平均上穿VAR1时,在(最高价+(最高价*0.03))位置画8号图标
PT赋值:1日前的最高价-1日前的最低价
CDP赋值:(1日前的最高价+1日前的最低价+1日前的收盘价*2)/4
AH赋值:CDP+PT
AL赋值:CDP-PT
NH赋值:CDP*2-1日前的最低价
NL赋值:CDP*2-1日前的最高价
输出强:如果AH>1日前的收盘价*1.1,返回1日前的收盘价*1.1,否则返回AHNODRAW
输出阻:如果NH>强,返回(强-CDP)*0.618+CDP,否则返回NHNODRAW,画青色
M赋值:如果AL<1日前的收盘价/1.1,返回1日前的收盘价/1.1,否则返回AL
输出撑:如果NL<M,返回CDP-(CDP-M)*0.618,否则返回NLNODRAW
输出底:如果AL<1日前的收盘价/1.1,返回1日前的收盘价/1.1,否则返回ALNODRAW[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/15-0v4ffHba82tJlaflONKA

看了该指标的人还看了:
绝佳买点指标    堪称一绝指标    盈富宝典指标
买卖精品指标    顶底管家指标    波段指标

使用道具 举报

回复