指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 
炒股叉_20190409_105251.png

炒股叉_20190409_105257.png

[lywrap=通达信主图指标公式][lycode=tdx,true]短期线:EMA(CLOSE,6);
持股线:EMA(CLOSE,14);
生命线:EMA(CLOSE,26);
双月线:EMA(CLOSE,56);
牛熊线:EMA(CLOSE,166);
X1:=(C+L+H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),
EMA8,'∠35上升'),COLORYELLOW;
支撑:MA(REF(LLV(C,30),1),2),COLORABFF46;
MTM:=C-REF(C,1);DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWTEXT(FILTER(买=1,5),LOW-0.03,'抄底'),COLORYELLOW;
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR11:=VARF<REF(VAR10,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,LOW*0.95,'大资金活动'),LINETHICK1,COLORFF00FF;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
Z1:=MA(C,13);
ZX:=REF(Z1,13/2+1);
DRAWICON(CROSS(ZX,C),H*1.01,2);
DRAWTEXT(CROSS(88,RSI),HIGH * 1.02,'▼逃顶'),COLOR00FFFF;[/lycode][lycode=tdx2,true]输出短期线:收盘价的6日指数移动平均
输出持股线:收盘价的14日指数移动平均
输出生命线:收盘价的26日指数移动平均
输出双月线:收盘价的56日指数移动平均
输出牛熊线:收盘价的166日指数移动平均
X1赋值:(收盘价+最低价+最高价)/3
BB13赋值:X1的13日指数移动平均-1日前的X1的13日指数移动平均的反正切*3.1416*10
EMA8赋值:收盘价的8日指数移动平均
当满足条件BB13>1ANDEMA(X1,13)>1日前的X1的8日指数移动平均的10日过滤时,在EMA8位置书写文字,画黄色
输出支撑:1日前的30日内收盘价的最低值的2日简单移动平均,COLORABFF46
MTM赋值:收盘价-1日前的收盘价
DX赋值:100*MTM的6日指数移动平均的6日指数移动平均/MTM的绝对值的6日指数移动平均的6日指数移动平均
买赋值:如果2日内DX的最低值=7日内DX的最低值ANDCOUNT(DX<0,2)ANDCROSS(DX,DX的2日简单移动平均),返回1,否则返回0
当满足条件买=1的5日过滤时,在最低价-0.03位置书写文字,画黄色
VARE赋值:100*(收盘价-34日内收盘价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)的5日简单移动平均-20
VARF赋值:100-3*(收盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均+2*(收盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均
VAR10赋值:100-3*(开盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均+2*(开盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均
VAR11赋值:VARF<1日前的VAR10 AND 成交量(手)>1日前的成交量(手) AND 收盘价>1日前的收盘价
当满足条件VAR11ANDCOUNT(VAR11,30)=1时,在最低价*0.95位置书写文字,线宽为1,COLORFF00FF
LC赋值:1日前的收盘价
RSI赋值:(((收盘价-LC)和0的较大值的3日[1日权重]移动平均 / (收盘价-LC)的绝对值的3日[1日权重]移动平均) * 100)
Z1赋值:收盘价的13日简单移动平均
ZX赋值:13/2+1日前的Z1
当满足条件ZX上穿收盘价时,在最高价*1.01位置画2号图标
当满足条件88上穿RSI时,在最高价*1.02位置书写文字,COLOR00FFFF[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1-MblzWJTBnWf7fUF7Ks7vA

看了该指标的人还看了:
涨势跌势确立指标    三增三阳指标    明明白白指标
超级抄底指标    股海扬帆指标    博奕杀手指标

使用道具 举报

回复