指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 趋势 操盘控盘 
炒股叉_20190409_104502.png

炒股叉_20190409_104507.png

[lywrap=通达信副图指标公式][lycode=tdx,true]STICKLINE(C>0,90,95,10,0),COLOR408000;
STICKLINE(C>0,10,5,10,0),COLOR408000;
HDY:=EMA (100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3);
DRAWBAND(HDY,RGB(255,000,139),10,RGB(255,255,71));
STICKLINE(C>0,90,10,10,0),COLOR000000;
风险:HDY,COLORMAGENTA,LINETHICK2;
获利1:WINNER(C)*100,COLORBROWN,NODRAW;
获利5:MA(获利1,5),COLORBROWN,NODRAW;
短套:EMA(100*(1-WINNER(1.10*C)),1),COLORBROWN,NODRAW;
中套:EMA(100*(1-WINNER(1.2*C)),1),COLORBROWN,NODRAW;
获利:FILTER(CROSS(获利1,获利5) AND 获利5>80,5) AND 中套=0;
STICKLINE(CROSS(获利1,获利5),0,11,0.8,1),COLORWHITE;
DRAWTEXT(CROSS(获利1,获利5),11,'获'),COLORWHITE;
SL2:=FILTER(COUNT(CROSS(获利1,获利5),15)>=3 AND 获利1>61.8,15) AND C<MA(C,3);
SL:=(获利 OR SL2);
DRAWBAND(100,RGB(0,250,0),(100-SL*15),RGB(18,250,18));
AA:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
BB:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
CC:=EMA(AA,2);
DD:=EMA(BB,5);
TJ0:=CROSS(CC,DD);
上:=EMA(C,3);
中:=EMA(C,5);
下:=EMA(中,5);
TJ1:=CROSS(上,中);
TJ2:=上>REF(上,1);
X1:=(C+L+H)/3;
BB5:=ATAN(EMA(X1,5)-REF(EMA(X1,5),1))*3.1416*10;
EMA3:=EMA(C,3);
TJ3:=BB5>1 AND EMA(X1,5)>REF(EMA(X1,3),1);
投资:TJ1 AND TJ2  AND TJ0 AND TJ3,COLORYELLOW,NODRAW;
STICKLINE(TJ1 AND TJ2  AND TJ0 AND TJ3,0,10,1.6,0),COLOR009999;
STICKLINE(TJ1 AND TJ2  AND TJ0 AND TJ3,0,10,1.2,0),COLOR00BBBB;
STICKLINE(TJ1 AND TJ2  AND TJ0 AND TJ3,0,10,0.8,0),COLOR00DDDD;
STICKLINE(TJ1 AND TJ2  AND TJ0 AND TJ3,0,10,0.4,0),COLOR00FFFF;
STICKLINE(TJ1 AND TJ2  AND TJ0 AND TJ3,0,10,0,0),COLORFF00FF;
投机:100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5)),COLOR0080FF,NODRAW;
投机1:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30)),COLOR00FFFF,NODRAW;
STICKLINE(CROSS(投机,投机1),0,11,0.1,1),COLOR0080FF;
DRAWTEXT(CROSS(投机,投机1),4,'投'),COLOR0080FF;
RSV1:=(CLOSE-LLV(LOW,35))/(HHV(HIGH,35)-LLV(LOW,35))*100;
K1:=SMA(RSV1,13,1);
D1:=SMA(K1,13,1);
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),8,0),COLORFF5D00;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),7,0),COLORFF5D10;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),6,0),COLORFF7710;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),5,0),COLORFF8810;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),4,0),COLORFF9910;
VA1:=HHV(HIGH,9)-LLV(LOW,9);
VA2:=HHV(HIGH,9)-CLOSE;
VA3:=CLOSE-LLV(LOW,9);
VA4:=VA2/VA1*100-70;
VA5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VA6:=(CLOSE+HIGH+LOW)/3;
VA7:=SMA(VA3/VA1*100,3,1);
VA8:=LLV(LOW,34);
VA9:=SMA(VA7,3,1)-SMA(VA4,9,1);
VARA:=IF(VA9>100,VA9-100,0);
VARB:=HHV(HIGH,34);
VARC:=EMA((VA6-VA8)/(VARB-VA8)*100,13);
VARD:=EMA(0.667*REF(VARC,1)+0.333*VARC,2);
VARE:=SMA(MAX(CLOSE-REF(CLOSE,1),0)/CLOSE,8,1)/SMA(ABS(INDEXC-REF(INDEXC,1))/INDEXC,8,1)*100-25;
VARF:=MA(VARE,3);
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=((VAR2)/(VAR1))*(100)-70;
VAR5:=((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)))*(100);
VAR6:=((2)*(CLOSE)+HIGH+LOW)/(4);
VAR7:=SMA(((VAR3)/(VAR1))*(100),3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VAR10:=IF((VAR9>100),VAR9-100,0);
VAR11:=HHV(HIGH,34);
B1:=EMA(((VAR6-VAR8)/(VAR11-VAR8))*(100),8);
DRAWKLINE(EMA(B1,5),EMA(B1,5),B1+1,B1);
操作:EMA(B1,5),COLORRED;
生命:EMA(VARD,1),COLORYELLOW;
V1:=MA(C,5)=HHV(MA(C,5),20);
V2:=MA(C,5)>MA(C,10);
V3:=MA(V,5)>MA(V,40)*1.01;
V4:=COUNT(MA(C,1)>REF(C,1),2)=2;
VV:=V1 AND V2 AND V3 AND V4;
A1:=EMA(CLOSE,8);
A2:=EMA(A1,20);
A3:=CROSS(A1,A2);
A4:=A1<EMA(CLOSE,120);
STICKLINE((A3 AND A4)OR(V1 AND V2 AND V3 AND V4),B1*1.03,B1*1.120,1,0),COLORYELLOW;
A5:=3*SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,21,1)-2*
SMA(SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,20,1),8,1),CIRCLEDOT ,COLORFF9900 ;
安全:=20;
转强:IF(CROSS(A5,安全),9,0),STICK,COLORLIRED,LINETHICK2;
拉升:IF(CROSS(VARC,生命) AND VARC>VARD AND VARC<55 AND C>O,9,0),STICK,COLORRED,LINETHICK2;
VAR18:=HHV(HIGH,30);
VAR19:=LLV(LOW,30);
NL:=EMA((CLOSE-VAR19)/(VAR18-VAR19)*100,5)/8*10,COLORYELLOW,LINETHICK2;
DRAWTEXT(CROSS(5,NL),4,'★做底'),COLORRED;
VAR44:=REF(CLOSE,1);
VAR45:=SMA(MAX(CLOSE-VAR44,0),6,1)/SMA(ABS(CLOSE-VAR44),6,1)*100;
STICKLINE(CROSS(84,VAR45),0,9,0.8,1),COLORGREEN;
DRAWTEXT(CROSS(84,VAR45),4,'空警'),COLORGREEN;[/lycode][lycode=tdx2,true]当满足条件收盘价>0时,在90和95位置之间画柱状线,宽度为10,0不为0则画空心柱.,COLOR408000
当满足条件收盘价>0时,在10和5位置之间画柱状线,宽度为10,0不为0则画空心柱.,COLOR408000
HDY赋值:100*(收盘价-34日内最低价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)的3日指数移动平均
画带状线
当满足条件收盘价>0时,在90和10位置之间画柱状线,宽度为10,0不为0则画空心柱.,COLOR000000
输出风险:HDY,画洋红色,线宽为2
输出获利1:以收盘价计算的获利盘比例*100,画棕色,NODRAW
输出获利5:获利1的5日简单移动平均,画棕色,NODRAW
输出短套:100*(1-以1.10*收盘价元价格计算的获利盘比例)的1日指数移动平均,画棕色,NODRAW
输出中套:100*(1-以1.2*收盘价元价格计算的获利盘比例)的1日指数移动平均,画棕色,NODRAW
输出获利:获利1上穿获利5AND获利5>80的5日过滤 AND 中套=0
当满足条件获利1上穿获利5时,在0和11位置之间画柱状线,宽度为0.8,1不为0则画空心柱.,画白色
当满足条件获利1上穿获利5时,在11位置书写文字,画白色
SL2赋值:统计15日中满足获利1上穿获利5的天数>=3AND获利1>61.8的15日过滤 AND 收盘价<收盘价的3日简单移动平均
SL赋值:(获利 OR SL2)
画带状线
AA赋值:(收盘价的1日简单移动平均+收盘价的3日简单移动平均+收盘价的5日简单移动平均+收盘价的7日简单移动平均+收盘价的9日简单移动平均)/5
BB赋值:(收盘价的2日简单移动平均+收盘价的4日简单移动平均+收盘价的6日简单移动平均+收盘价的8日简单移动平均+收盘价的10日简单移动平均)/5
CC赋值:AA的2日指数移动平均
DD赋值:BB的5日指数移动平均
TJ0赋值:CC上穿DD
上赋值:收盘价的3日指数移动平均
中赋值:收盘价的5日指数移动平均
下赋值:中的5日指数移动平均
TJ1赋值:上上穿中
TJ2赋值:上>1日前的上
X1赋值:(收盘价+最低价+最高价)/3
BB5赋值:X1的5日指数移动平均-1日前的X1的5日指数移动平均的反正切*3.1416*10
EMA3赋值:收盘价的3日指数移动平均
TJ3赋值:BB5>1 AND X1的5日指数移动平均>1日前的X1的3日指数移动平均
输出投资:TJ1 AND TJ2  AND TJ0 AND TJ3,画黄色,NODRAW
当满足条件TJ1ANDTJ2ANDTJ0ANDTJ3时,在0和10位置之间画柱状线,宽度为1.6,0不为0则画空心柱.,COLOR009999
当满足条件TJ1ANDTJ2ANDTJ0ANDTJ3时,在0和10位置之间画柱状线,宽度为1.2,0不为0则画空心柱.,COLOR00BBBB
当满足条件TJ1ANDTJ2ANDTJ0ANDTJ3时,在0和10位置之间画柱状线,宽度为0.8,0不为0则画空心柱.,COLOR00DDDD
当满足条件TJ1ANDTJ2ANDTJ0ANDTJ3时,在0和10位置之间画柱状线,宽度为0.4,0不为0则画空心柱.,COLOR00FFFF
当满足条件TJ1ANDTJ2ANDTJ0ANDTJ3时,在0和10位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFF00FF
输出投机:100*(收盘价-5日内最低价的最低值)/(5日内收盘价的最高值-5日内最低价的最低值),COLOR0080FF,NODRAW
投机1赋值:100*(收盘价-30日内最低价的最低值)/(30日内收盘价的最高值-30日内最低价的最低值),COLOR00FFFF,NODRAW
当满足条件投机上穿投机1时,在0和11位置之间画柱状线,宽度为0.1,1不为0则画空心柱.,COLOR0080FF
当满足条件投机上穿投机1时,在4位置书写文字,COLOR0080FF
RSV1赋值:(收盘价-35日内最低价的最低值)/(35日内最高价的最高值-35日内最低价的最低值)*100
K1赋值:RSV1的13日[1日权重]移动平均
D1赋值:K1的13日[1日权重]移动平均
当满足条件D1的3日指数移动平均>1日前的D1的3日指数移动平均时,在D1的3日指数移动平均和1日前的D1的3日指数移动平均位置之间画柱状线,宽度为8,0不为0则画空心柱.,COLORFF5D00
当满足条件D1的3日指数移动平均>1日前的D1的3日指数移动平均时,在D1的3日指数移动平均和1日前的D1的3日指数移动平均位置之间画柱状线,宽度为7,0不为0则画空心柱.,COLORFF5D10
当满足条件D1的3日指数移动平均>1日前的D1的3日指数移动平均时,在D1的3日指数移动平均和1日前的D1的3日指数移动平均位置之间画柱状线,宽度为6,0不为0则画空心柱.,COLORFF7710
当满足条件D1的3日指数移动平均>1日前的D1的3日指数移动平均时,在D1的3日指数移动平均和1日前的D1的3日指数移动平均位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLORFF8810
当满足条件D1的3日指数移动平均>1日前的D1的3日指数移动平均时,在D1的3日指数移动平均和1日前的D1的3日指数移动平均位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLORFF9910
VA1赋值:9日内最高价的最高值-9日内最低价的最低值
VA2赋值:9日内最高价的最高值-收盘价
VA3赋值:收盘价-9日内最低价的最低值
VA4赋值:VA2/VA1*100-70
VA5赋值:(收盘价-60日内最低价的最低值)/(60日内最高价的最高值-60日内最低价的最低值)*100
VA6赋值:(收盘价+最高价+最低价)/3
VA7赋值:VA3/VA1*100的3日[1日权重]移动平均
VA8赋值:34日内最低价的最低值
VA9赋值:VA7的3日[1日权重]移动平均-VA4的9日[1日权重]移动平均
VARA赋值:如果VA9>100,返回VA9-100,否则返回0
VARB赋值:34日内最高价的最高值
VARC赋值:(VA6-VA8)/(VARB-VA8)*100的13日指数移动平均
VARD赋值:0.667*1日前的VARC+0.333*VARC的2日指数移动平均
VARE赋值:收盘价-1日前的收盘价和0的较大值/收盘价的8日[1日权重]移动平均/大盘的收盘价-1日前的大盘的收盘价的绝对值/大盘的收盘价的8日[1日权重]移动平均*100-25
VARF赋值:VARE的3日简单移动平均
VAR1赋值:9日内最高价的最高值-9日内最低价的最低值
VAR2赋值:9日内最高价的最高值-收盘价
VAR3赋值:收盘价-9日内最低价的最低值
VAR4赋值:((VAR2)/(VAR1))*(100)-70
VAR5赋值:((收盘价-60日内最低价的最低值)/(60日内最高价的最高值-60日内最低价的最低值))*(100)
VAR6赋值:((2)*(收盘价)+最高价+最低价)/(4)
VAR7赋值:((VAR3)/(VAR1))*(100)的3日[1日权重]移动平均
VAR8赋值:34日内最低价的最低值
VAR9赋值:VAR7的3日[1日权重]移动平均-VAR4的9日[1日权重]移动平均
VAR10赋值:如果(VAR9>100),返回VAR9-100,否则返回0
VAR11赋值:34日内最高价的最高值
B1赋值:((VAR6-VAR8)/(VAR11-VAR8))*(100)的8日指数移动平均
K线
输出操作:B1的5日指数移动平均,画红色
输出生命:VARD的1日指数移动平均,画黄色
V1赋值:收盘价的5日简单移动平均=20日内收盘价的5日简单移动平均的最高值
V2赋值:收盘价的5日简单移动平均>收盘价的10日简单移动平均
V3赋值:成交量(手)的5日简单移动平均>成交量(手)的40日简单移动平均*1.01
V4赋值:统计2日中满足收盘价的1日简单移动平均>1日前的收盘价的天数=2
VV赋值:V1 AND V2 AND V3 AND V4
A1赋值:收盘价的8日指数移动平均
A2赋值:A1的20日指数移动平均
A3赋值:A1上穿A2
A4赋值:A1<收盘价的120日指数移动平均
当满足条件(A3ANDA4)OR(V1ANDV2ANDV3ANDV4)时,在B1*1.03和B1*1.120位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色
A5赋值:3*(收盘价-18日内最低价的最低值)/(18日内最高价的最高值-18日内最低价的最低值)*100的21日[1日权重]移动平均-2*(收盘价-18日内最低价的最低值)/(18日内最高价的最高值-18日内最低价的最低值)*100的20日[1日权重]移动平均的8日[1日权重]移动平均,CIRCLEDOT ,COLORFF9900
安全赋值:20
输出转强:如果A5上穿安全,返回9,否则返回0,STICK,画淡红色,线宽为2
输出拉升:如果VARC上穿生命ANDVARC>VARDANDVARC<55ANDC>开盘价,返回9,否则返回0,STICK,画红色,线宽为2
VAR18赋值:30日内最高价的最高值
VAR19赋值:30日内最低价的最低值
NL赋值:(收盘价-VAR19)/(VAR18-VAR19)*100的5日指数移动平均/8*10,画黄色,线宽为2
当满足条件5上穿NL时,在4位置书写文字,画红色
VAR44赋值:1日前的收盘价
VAR45赋值:收盘价-VAR44和0的较大值的6日[1日权重]移动平均/收盘价-VAR44的绝对值的6日[1日权重]移动平均*100
当满足条件84上穿VAR45时,在0和9位置之间画柱状线,宽度为0.8,1不为0则画空心柱.,画绿色
当满足条件84上穿VAR45时,在4位置书写文字,画绿色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/12wjVGmwjvtzT6h-sx2VH4A

看了该指标的人还看了:
涨势跌势确立指标    三增三阳指标    明明白白指标
超级抄底指标    股海扬帆指标    博奕杀手指标

使用道具 举报

回复