指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 买卖点 趋势 操盘控盘 
炒股叉_20190403_111253.png

炒股叉_20190403_111300.png

[lywrap=通达信主图指标公式][lycode=tdx,true]VAR2:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR3:=(20*VAR2+19*REF(VAR2,1)+18*REF(VAR2,2)+17*REF(VAR2,3)+16*REF(VAR2,4)+15*REF(VAR2,5)+14*REF(VAR2,6)+13*REF(VAR2,7)+
12*REF(VAR2,8)+11*REF(VAR2,9)+10*REF(VAR2,10)+9*REF(VAR2,11)+8*REF(VAR2,12)+7*REF(VAR2,13)+6*REF(VAR2,14)+5*REF(VAR2,15)
+4*REF(VAR2,16)+3*REF(VAR2,17)+2*REF(VAR2,18)+REF(VAR2,20))/210;
VAR4:=MA(VAR3,13);
VAR5:=EMA(MA(CLOSE,3),34);
VAR6:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
VAR7:=MA(VAR6,5);
VAR8:=MA(VAR6,10);
STICKLINE(IF(VAR3<VAR5,VAR3<=1.015*VAR4,VAR3<=1.005*VAR4),VAR3,VAR4,10,1),COLOR006600 ;
STICKLINE(VAR3>1.005*VAR4,VAR3,VAR4,10,1),COLORFF00FF;
DRAWTEXT(FILTER(MA(VAR6,10)<VAR7,1),VAR8,'↑'),COLORRED;
DRAWTEXT(FILTER(MA(VAR6,10)>=VAR6,1),VAR8,'↓'),COLOR00FF00;
多空安全线: VAR5,COLORWHITE;
〖关注点〗: STICKLINE(COUNT(VAR3>1.005*VAR4 AND VAR3<=REF(VAR3,1),2)=2 OR
COUNT(IF(VAR3<VAR5,VAR3<=1.015*VAR4,VAR3<=1.005*VAR4) AND VAR3>=REF(VAR3,1),2)=2,VAR3,VAR4,10,0),COLORYELLOW;

DRAWTEXT(REF(CROSS(VAR3,VAR4),2) AND VAR3>1.005*VAR4,VAR4,'★买入点'),COLORWHITE;
DRAWTEXT(CROSS(VAR6,VAR7) AND VAR7<VAR8,VAR3*0.95,'▲多空争夺'),COLORYELLOW;
{DRAWTEXT(CROSS(VAR7,VAR6) AND VAR7>VAR8,VAR3*1.05,'▼洗盘'),COLORWHITE;}
VAR9:=1/WINNER(CLOSE);
VARA:=MA(CLOSE,13);
VARB:=100-ABS((CLOSE-VARA)/VARA*100);
VARC:=LLV(LOW,75);
VARD:=HHV(HIGH,75);
VARE:=(VARD-VARC)/100;
VARF:=SMA((CLOSE-VARC)/VARE,20,1);
VAR10:=SMA((OPEN-VARC)/VARE,20,1);
VAR11:=3*VARF-2*SMA(VARF,15,1);
VAR12:=3*VAR10-2*SMA(VAR10,15,1);
VAR13:=100-VAR12;
VAR14:=100-VAR11;
VAR15:=MA(WINNER(CLOSE*0.95)*100,3);
VAR16:=100-IF(VAR9>5,IF(VAR9<100,VAR9,VARB-10),0);
VAR17:=VAR15>VARB;
VAR18:=REF(LOW,1)*0.9;
VAR19:=LOW*0.9;
VAR1A:=(VAR19*VOL+VAR18*(CAPITAL-VOL))/CAPITAL;
VAR1B:=EMA(VAR1A,30);
VAR1C:=CLOSE-REF(CLOSE,1);
VAR1D:=MAX(VAR1C,0);
VAR1E:=ABS(VAR1C);
VAR1F:=SMA(VAR1D,7,1)/SMA(VAR1E,7,1)*100;
VAR20:=SMA(VAR1D,13,1)/SMA(VAR1E,13,1)*100;
VAR21:=BARSCOUNT(CLOSE);
VAR22:=SMA(MAX(VAR1C,0),6,1)/SMA(ABS(VAR1C),6,1)*100;
VAR23:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR24:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR25:=SMA((SMA(VAR24,4,1)-50)*2,3,1);
VAR26:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR27:=SMA(VAR26,4,1);
VAR28:=SMA(VAR27,3,1);
VAR29:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR2A:=VAR22<=25 AND VAR23<-95 AND VAR29>20 AND VAR25<-30 AND VAR28<30 AND VAR1B-CLOSE>=-0.25 AND VAR1F<22 AND VAR20<28
AND VAR21>50;
DRAWTEXT(CROSS(VAR2A,0.5) AND COUNT(VAR2A=1,10)=1,VAR4,'♂发射资金'),COLORRED;
DRAWTEXT(CROSS(VAR17,0.5) AND COUNT(VAR17=1,10)=1,VAR3,'激烈交锋'),COLORWHITE;
VAR326:=IF(CLOSE>REF(CLOSE, 1),88,0);
VAR327:=CLOSE/REF(CLOSE, 1)>1.050  AND HIGH/CLOSE<1.010 AND VAR326>0;
STICKLINE(VAR327>90,L*0.99,L*0.95,4,0),COLORYELLOW;
DRAWTEXT(VAR327>90,LOW*0.95,'追涨'),COLORYELLOW;[/lycode][lycode=tdx2,true]VAR2赋值:(3*收盘价+最低价+开盘价+最高价)/6
VAR3赋值:(20*VAR2+19*1日前的VAR2+18*2日前的VAR2+17*3日前的VAR2+16*4日前的VAR2+15*5日前的VAR2+14*6日前的VAR2+13*7日前的VAR2+12*8日前的VAR2+11*9日前的VAR2+10*10日前的VAR2+9*11日前的VAR2+8*12日前的VAR2+7*13日前的VAR2+6*14日前的VAR2+5*15日前的VAR2+4*16日前的VAR2+3*17日前的VAR2+2*18日前的VAR2+20日前的VAR2)/210
VAR4赋值:VAR3的13日简单移动平均
VAR5赋值:收盘价的3日简单移动平均的34日指数移动平均
VAR6赋值:(收盘价的3日简单移动平均+收盘价的6日简单移动平均+收盘价的12日简单移动平均+收盘价的24日简单移动平均)/4
VAR7赋值:VAR6的5日简单移动平均
VAR8赋值:VAR6的10日简单移动平均
当满足条件如果VAR3<VAR5,返回VAR3<=1.015*VAR4,否则返回VAR3<=1.005*VAR4时,在VAR3和VAR4位置之间画柱状线,宽度为10,1不为0则画空心柱.,COLOR006600
当满足条件VAR3>1.005*VAR4时,在VAR3和VAR4位置之间画柱状线,宽度为10,1不为0则画空心柱.,COLORFF00FF
当满足条件VAR6的10日简单移动平均<VAR7的1日过滤时,在VAR8位置书写文字,画红色
当满足条件VAR6的10日简单移动平均>=VAR6的1日过滤时,在VAR8位置书写文字,COLOR00FF00
输出多空安全线: VAR5,画白色
输出〖关注点〗: 当满足条件统计2日中满足VAR3>1.005*VAR4ANDVAR3<=1日前的VAR3的天数=2ORCOUNT(如果VAR3<VAR5,返回VAR3<=1.015*VAR4,否则返回VAR3<=1.005*VAR4ANDVAR3>=1日前的VAR3,2)=2时,在VAR3和VAR4位置之间画柱状线,宽度为10,0不为0则画空心柱.,画黄色
当满足条件2日前的VAR3上穿VAR4ANDVAR3>1.005*VAR4时,在VAR4位置书写文字,画白色
当满足条件VAR6上穿VAR7ANDVAR7<VAR8时,在VAR3*0.95位置书写文字,画黄色
VAR9赋值:1/以收盘价计算的获利盘比例
VARA赋值:收盘价的13日简单移动平均
VARB赋值:100-(收盘价-VARA)/VARA*100的绝对值
VARC赋值:75日内最低价的最低值
VARD赋值:75日内最高价的最高值
VARE赋值:(VARD-VARC)/100
VARF赋值:(收盘价-VARC)/VARE的20日[1日权重]移动平均
VAR10赋值:(开盘价-VARC)/VARE的20日[1日权重]移动平均
VAR11赋值:3*VARF-2*VARF的15日[1日权重]移动平均
VAR12赋值:3*VAR10-2*VAR10的15日[1日权重]移动平均
VAR13赋值:100-VAR12
VAR14赋值:100-VAR11
VAR15赋值:以收盘价*0.95计算的获利盘比例*100的3日简单移动平均
VAR16赋值:100-如果VAR9>5,返回如果VAR9<100,返回VAR9,否则返回VARB-10,否则返回0
VAR17赋值:VAR15>VARB
VAR18赋值:1日前的最低价*0.9
VAR19赋值:最低价*0.9
VAR1A赋值:(VAR19*成交量(手)+VAR18*(当前流通股本(手)-成交量(手)))/当前流通股本(手)
VAR1B赋值:VAR1A的30日指数移动平均
VAR1C赋值:收盘价-1日前的收盘价
VAR1D赋值:VAR1C和0的较大值
VAR1E赋值:VAR1C的绝对值
VAR1F赋值:VAR1D的7日[1日权重]移动平均/VAR1E的7日[1日权重]移动平均*100
VAR20赋值:VAR1D的13日[1日权重]移动平均/VAR1E的13日[1日权重]移动平均*100
VAR21赋值:收盘价的有效数据周期数
VAR22赋值:VAR1C和0的较大值的6日[1日权重]移动平均/VAR1C的绝对值的6日[1日权重]移动平均*100
VAR23赋值:(-200)*(60日内最高价的最高值-收盘价)/(60日内最高价的最高值-60日内最低价的最低值)+100
VAR24赋值:(收盘价-15日内最低价的最低值)/(15日内最高价的最高值-15日内最低价的最低值)*100
VAR25赋值:(VAR24的4日[1日权重]移动平均-50)*2的3日[1日权重]移动平均
VAR26赋值:(大盘的收盘价-14日内大盘的最低价的最低值)/(14日内大盘的最高价的最高值-14日内大盘的最低价的最低值)*100
VAR27赋值:VAR26的4日[1日权重]移动平均
VAR28赋值:VAR27的3日[1日权重]移动平均
VAR29赋值:(30日内最高价的最高值-收盘价)/收盘价*100
VAR2A赋值:VAR22<=25 AND VAR23<-95 AND VAR29>20 AND VAR25<-30 AND VAR28<30 AND VAR1B-收盘价>=-0.25 AND VAR1F<22 AND VAR20<28AND VAR21>50
当满足条件VAR2A上穿0.5ANDCOUNT(VAR2A=1,10)=1时,在VAR4位置书写文字,画红色
当满足条件VAR17上穿0.5ANDCOUNT(VAR17=1,10)=1时,在VAR3位置书写文字,画白色
VAR326赋值:如果收盘价>1日前的收盘价,返回88,否则返回0
VAR327赋值:收盘价/1日前的收盘价>1.050  AND 最高价/收盘价<1.010 AND VAR326>0
当满足条件VAR327>90时,在最低价*0.99和最低价*0.95位置之间画柱状线,宽度为4,0不为0则画空心柱.,画黄色
当满足条件VAR327>90时,在最低价*0.95位置书写文字,画黄色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1S3F22HFqXY_MEl6iXFhowg

看了该指标的人还看了:
波段利器指标    金财神SB指标    主力买卖指标
主力轨迹买卖指标    瀑布线指标    沉船寻宝指标

使用道具 举报

回复