指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 抄底逃顶 
炒股叉_20190403_110804.png

炒股叉_20190403_110811.png

[lywrap=通达信副图指标公式][lycode=tdx,true]STICKLINE(C>0,0,120,15,0),COLORBLUE;
RSV:=(CLOSE-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100;
FASTK:=SMA(RSV,3,1);
龙:SMA(FASTK,2,1);
龙D:=SMA(龙,5,1);
DRAWBAND(龙D,RGB(0,104,154),龙,RGB(255,0,0));
STICKLINE(龙>=龙D,龙D,龙,3,0),COLOR000085;
STICKLINE(龙<龙D,龙D,龙,3,0),COLOR324800;
DRAWTEXT(CROSS(龙D,龙) AND 龙>70,50,'卖'),COLORGREEN;
L1:=(CLOSE-LLV(LOW,11))/(HHV(HIGH,11)-LLV(LOW,11))*200-60;
凤:SMA(L1,3,1),COLORYELLOW;
凤D:=SMA(凤,3,1),COLORRED;
DRAWBAND(凤D,RGB(0,128,0),凤,RGB(255,97,0));
DRAWTEXT(CROSS(凤D,凤)AND 凤>78,凤,'←快卖');

DIFF:= EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=1000* (2*(DIFF-DEA))/EMA(C,30);
VARA:=EMA(REF(CLOSE,1),4);
VAR1:=(SMA(MAX(CLOSE-VARA,0),6,1)/SMA(ABS(CLOSE-VARA),6,1)*100);
VAR2:=FILTER(MACD<0 AND MACD>REF(MACD,1) AND VAR1<20,5);
VAR3:=CROSS(VAR1,90);
准备:IF(VAR1<3.5,15,0),COLORCYAN,LINETHICK2;
DRAWTEXT(VAR1<3.5,7,'准备'),COLORCYAN;
钱进:IF(VAR2,20,0),COLORMAGENTA,LINETHICK3;
DRAWTEXT(VAR2,10,'“钱”进'),COLORRED;
{DRAWTEXT(VAR3,70,'凤舞ラ小心'),COLORCYAN;}

VAR4:=LLV(LOW,10);
VAR5:=HHV(H,25);
VAR6:=EMA((C-VAR4)/(VAR5-VAR4)*4,4);
DRAWTEXT(CROSS(3.5,VAR6),110,'急卖');
恭喜:STICKLINE(CROSS(VAR6,0.3),-50,-30,3,0), COLOR00AAFF,LINETHICK1;
STICKLINE(CROSS(VAR6,0.3),-40,-30,3,0),COLORRED,LINETHICK1;
DRAWTEXT(CROSS(VAR6,0.3),-45,'恭喜'),COLORMAGENTA;
发财:STICKLINE(CROSS(3.5,VAR6),100,120,2,0), COLORRED,LINETHICK2;
STICKLINE(CROSS(3.5,VAR6),110,120,2,0),COLORYELLOW,LINETHICK2;
DRAWTEXT(CROSS(3.5,VAR6),90,'发财'),COLORYELLOW;

龙行凤影:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)
-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)
-LLV(LOW,27))*100,5,1),3,1);
龙飞:IF(龙行凤影<=10,-20,-40),COLOR0000FF,LINETHICK2;
{DRAWTEXT(龙行凤影<=10,-25,'龙飞'),COLORYELLOW;}
DRAWTEXT(CROSS( 0,MACD)AND VAR1>75,110,'☆高空'),COLORFFFFFF;
红红的天:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)
-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)
-LLV(LOW,27))*100,5,1),3,1);
花开:IF(CROSS(红红的天,2),70,-50),COLORLIMAGENTA,LINETHICK2;
DRAWTEXT(CROSS(红红的天,2),75,'花开了'),COLORMAGENTA;
IF(CROSS(红红的天,2),70,DRAWNULL),CROSSDOT,LINETHICK6,COLORFF77FF;
IF(CROSS(红红的天,2),70,DRAWNULL),POINTDOT,LINETHICK4,COLOR00CCFF;

RSV1:=(((CLOSE - LLV(LOW,29)) / (HHV(HIGH,29) - LLV(LOW,29))) * 100);
K1:=MA(RSV1,5);
D1:=MA(K1,2);
J1:=((3 * K1) - (2 * D1));
明天涨:IF((J1 < 5),25,0),COLORRED,LINETHICK2;
DRAWTEXT((J1 < 5),30,'明天涨'),COLORYELLOW;

R:=RSI;
MAR:=MA(R,3);
F:=100*(C-REF(C,1))/REF(C,1);
HHH:=EMA(R,25)+6,COLORBLUE;
GAODIAN:=REF(R,1)>REF(R,2) AND REF(R,1)>R;
DIDIAN:=(REF(R,1)<REF(R,2) AND REF(R,1)<R) OR (REF(R,1)=REF(R,2) AND REF(R,1)<R AND REF(R,2)<REF(R,3));
BIAOJI:=CROSS(HHH,R);
JIN:STICKLINE(REF(R,2)>REF(R,3) AND REF(R,2)>REF(R,1) AND R>REF(R,1)
AND MAR>REF(MAR,1)+1 AND REF(MAR,2)-REF(MAR,1)>-1
AND REF(R,1)<REF(MAR,1) AND REF(R,2)-REF(MAR,2)>-3
AND REF(R,1)<38 AND R<HHH AND F<8,100,120,2,0),COLORRED;
DRAWTEXT(JIN,110,'RSI买'),COLORYELLOW;

VAR7:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
VAR8:=EMA(VAR7,5), LINETHICK2,COLOR6600FF;
VAR9:=100*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60)),LINETHICK2;
STICKLINE(CROSS(VAR8,VAR9),0,20,2,0);
DRAWTEXT(CROSS(VAR8,VAR9),20,'追涨');

VOLUME:=VOL/10000,VOLSTICK;
MAVOL1:=MA(VOLUME,5)/10000;
MAVOL2:=MA(VOLUME,35)/10000;
MAVOL3:=MA(VOLUME,135)/10000;
地量:IF(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),-25,-50),COLORMAGENTA,LINETHICK3;
DRAWTEXT(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),-29,' 地量'),COLORRED;
DRAWTEXT(LAST(MA(C,5)<MA(C,10),5,0) AND "CCI.CCI">REF("CCI.CCI",1) AND CROSS("CCI.CCI",-100),-45,'CCI买点'),COLORYELLOW;

A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
LC:=REF(CLOSE,1);
RSI2:=((SMA(MAX((CLOSE-LC),0),3,1)/SMA(ABS((CLOSE-LC)),3,1))*100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
出局:IF(CROSS(88,RSI2),100,120),COLORLIGREEN,LINETHICK3;
DRAWTEXT(CROSS(88,RSI2),100,'虎'),COLORGREEN;

RSV3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV3,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
进场:IF(CROSS(J,REF(J+0.01,1)) AND X AND J<20,0,-20),COLORYELLOW,LINETHICK2;
DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<20,-10,'龙'),COLORYELLOW;
WZ:=150=CURRBARSCOUNT;[/lycode][lycode=tdx2,true]当满足条件收盘价>0时,在0和120位置之间画柱状线,宽度为15,0不为0则画空心柱.,画蓝色
RSV赋值:(收盘价-4日内最低价的最低值)/(4日内最高价的最高值-4日内最低价的最低值)*100
FASTK赋值:RSV的3日[1日权重]移动平均
输出龙:FASTK的2日[1日权重]移动平均
龙D赋值:龙的5日[1日权重]移动平均
画带状线
当满足条件龙>=龙D时,在龙D和龙位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR000085
当满足条件龙<龙D时,在龙D和龙位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR324800
当满足条件龙D上穿龙AND龙>70时,在50位置书写文字,画绿色
L1赋值:(收盘价-11日内最低价的最低值)/(11日内最高价的最高值-11日内最低价的最低值)*200-60
输出凤:L1的3日[1日权重]移动平均,画黄色
凤D赋值:凤的3日[1日权重]移动平均,画红色
画带状线
当满足条件凤D上穿凤AND凤>78时,在凤位置书写文字
DIFF赋值: 收盘价的12日指数移动平均 - 收盘价的26日指数移动平均
DEA赋值:DIFF的9日指数移动平均
MACD赋值:1000* (2*(DIFF-DEA))/收盘价的30日指数移动平均
VARA赋值:1日前的收盘价的4日指数移动平均
VAR1赋值:(收盘价-VARA和0的较大值的6日[1日权重]移动平均/收盘价-VARA的绝对值的6日[1日权重]移动平均*100)
VAR2赋值:MACD<0ANDMACD>1日前的MACDANDVAR1<20的5日过滤
VAR3赋值:VAR1上穿90
输出准备:如果VAR1<3.5,返回15,否则返回0,画青色,线宽为2
当满足条件VAR1<3.5时,在7位置书写文字,画青色
输出钱进:如果VAR2,返回20,否则返回0,画洋红色,线宽为3
当满足条件VAR2时,在10位置书写文字,画红色
VAR4赋值:10日内最低价的最低值
VAR5赋值:25日内最高价的最高值
VAR6赋值:(收盘价-VAR4)/(VAR5-VAR4)*4的4日指数移动平均
当满足条件3.5上穿VAR6时,在110位置书写文字
输出恭喜:当满足条件VAR6上穿0.3时,在-50和-30位置之间画柱状线,宽度为3,0不为0则画空心柱., COLOR00AAFF,线宽为1
当满足条件VAR6上穿0.3时,在-40和-30位置之间画柱状线,宽度为3,0不为0则画空心柱.,画红色,线宽为1
当满足条件VAR6上穿0.3时,在-45位置书写文字,画洋红色
输出发财:当满足条件3.5上穿VAR6时,在100和120位置之间画柱状线,宽度为2,0不为0则画空心柱., 画红色,线宽为2
当满足条件3.5上穿VAR6时,在110和120位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色,线宽为2
当满足条件3.5上穿VAR6时,在90位置书写文字,画黄色
龙行凤影赋值:3*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均的3日[1日权重]移动平均
输出龙飞:如果龙行凤影<=10,返回-20,否则返回-40,COLOR0000FF,线宽为2
当满足条件0上穿MACDANDVAR1>75时,在110位置书写文字,COLORFFFFFF
红红的天赋值:3*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均的3日[1日权重]移动平均
输出花开:如果红红的天上穿2,返回70,否则返回-50,画淡洋红色,线宽为2
当满足条件红红的天上穿2时,在75位置书写文字,画洋红色
如果红红的天上穿2,返回70,否则返回无效数,CROSSDOT,线宽为6,COLORFF77FF
如果红红的天上穿2,返回70,否则返回无效数,POINTDOT,线宽为4,COLOR00CCFF
RSV1赋值:(((收盘价 - 29日内最低价的最低值) / (29日内最高价的最高值 - 29日内最低价的最低值)) * 100)
K1赋值:RSV1的5日简单移动平均
D1赋值:K1的2日简单移动平均
J1赋值:((3 * K1) - (2 * D1))
输出明天涨:如果(J1<5),返回25,否则返回0,画红色,线宽为2
当满足条件(J1<5)时,在30位置书写文字,画黄色
R赋值:RSI
MAR赋值:R的3日简单移动平均
F赋值:100*(收盘价-1日前的收盘价)/1日前的收盘价
HHH赋值:R的25日指数移动平均+6,画蓝色
GAODIAN赋值:1日前的R>2日前的R AND 1日前的R>R
DIDIAN赋值:(1日前的R<2日前的R AND 1日前的R<R) OR (1日前的R=2日前的R AND 1日前的R<R AND 2日前的R<3日前的R)
BIAOJI赋值:HHH上穿R
输出JIN:当满足条件2日前的R>3日前的RANDREF(R,2)>1日前的RANDR>1日前的RANDMAR>1日前的MAR+1ANDREF(MAR,2)-1日前的MAR>-1ANDREF(R,1)<1日前的MARANDREF(R,2)-2日前的MAR>-3ANDREF(R,1)<38AN时,在R<HHHANDF<8和100位置之间画柱状线,宽度为120,2不为0则画空心柱.,画红色
当满足条件JIN时,在110位置书写文字,画黄色
VAR7赋值:3*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的5日[1日权重]移动平均的3日[1日权重]移动平均
VAR8赋值:VAR7的5日指数移动平均, 线宽为2,COLOR6600FF
VAR9赋值:100*(60日内最高价的最高值-收盘价)/(60日内最高价的最高值-60日内最低价的最低值),线宽为2
当满足条件VAR8上穿VAR9时,在0和20位置之间画柱状线,宽度为2,0不为0则画空心柱.
当满足条件VAR8上穿VAR9时,在20位置书写文字
VOLUME赋值:成交量(手)/10000,VOLSTICK
MAVOL1赋值:VOLUME的5日简单移动平均/10000
MAVOL2赋值:VOLUME的35日简单移动平均/10000
MAVOL3赋值:VOLUME的135日简单移动平均/10000
输出地量:如果0.9上穿1/成交量(手)*1000>0.01AND"KDJ的J"<0,返回-25,否则返回-50,画洋红色,线宽为3
当满足条件0.9上穿1/成交量(手)*1000>0.01AND"KDJ的J"<0时,在-29位置书写文字,画红色
当满足条件从前5日到前0日持续收盘价的5日简单移动平均<收盘价的10日简单移动平均AND"CCI的CCI">1日前的"CCI的CCI"ANDCROSS("CCI的CCI",-100)时,在-45位置书写文字,画黄色
A51赋值:3*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的5日[1日权重]移动平均
LC赋值:1日前的收盘价
RSI2赋值:(((收盘价-LC)和0的较大值的3日[1日权重]移动平均/(收盘价-LC)的绝对值的3日[1日权重]移动平均)*100)
FF赋值:收盘价的3日指数移动平均
MA15赋值:收盘价的21日指数移动平均
输出出局:如果88上穿RSI2,返回100,否则返回120,画淡绿色,线宽为3
当满足条件88上穿RSI2时,在100位置书写文字,画绿色
RSV3赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
K赋值:RSV3的3日[1日权重]移动平均
D赋值:K的3日[1日权重]移动平均
J赋值:3*K-2*D
X赋值:2日内J的最低值=8日内J的最低值
输出进场:如果J上穿1日前的J+0.01ANDXANDJ<20,返回0,否则返回-20,画黄色,线宽为2
当满足条件J上穿1日前的J+0.01ANDXANDJ<20时,在-10位置书写文字,画黄色
WZ赋值:150=到最后交易的周期[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1tJ9nOcU2ApbxAjcap1Ku9A

看了该指标的人还看了:
趋势波段买卖指标    大肥羊指标    上升之星指标
财富临门指标    大肥羊指标    挖金子指标

使用道具 举报

回复