指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 
炒股叉_20190402_103223.png

炒股叉_20190402_103229.png

[lywrap=通达信副图指标公式][lycode=tdx,true]VAR1N:=MA(CLOSE,5);
VAR2N:=MA(CLOSE,10);
VAR3N:=(VAR1N-CLOSE)/CLOSE>13/100;
VAR4N:=(VAR2N+VAR1N)/VAR1N>0.03;
VAR5N:=LLV(CLOSE,1)=LLV(CLOSE,1);
BIAS1 :=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100/0.7;
A1:IF(BIAS1<-12,70,50),COLORRED;
BIAS2 :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100*2;
A2:IF(BIAS2<-9,50,30),COLOR00FF00;
BIAS3 :=(CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*100/0.3/1.3/1.5;
A3:IF(BIAS3<-12,30,10),COLORWHITE;

{到位}
BJ:=HHV(HIGH,5)/C,DOTLINE,COLORRED;
JL:=LLV(L,5)/C,DOTLINE,COLORRED;
HA:=(HHV(HIGH,5)+LLV(LOW,5))/2/C;
RN:=(LLV(LOW,5)*HHV(HIGH,5))/C/C,COLORGREEN;
STICKLINE(CROSS(1.1,RN),1,30,1.0.5,0),COLORYELLOW;
STICKLINE(CROSS(1.2,RN),1,70,1.0.5,0),COLORRED;
STICKLINE(RN>=1.2,1,30.2,0.5,0),COLORLIRED;

{五合一}
{VR}
WVR := SUM((IF(CLOSE>OPEN,VOL,0)+IF(CLOSE=OPEN,VOL/2,0)),26)/
SUM((IF(CLOSE<OPEN,VOL,0)+IF(CLOSE=OPEN,VOL/2,0)),26)*100;
VR买:IF((CROSS(70,WVR)),50,0),COLORYELLOW;
{DPSJ}
RSV:=(INDEXC-LLV(INDEXL,18))/(HHV(INDEXH,18)-LLV(INDEXL,18))*100;
K:=SMA(RSV,12,1);
DPSJ买入:IF((CROSS(K,20)),55,0),COLORWHITE;
{KD}
WRSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
WK:=SMA(WRSV,3,1);
D:=SMA(WK,3,1);
KD买入:IF((CROSS(WK,D)&&WK<20),60,0),COLORRED;
{KDJ}
K1:=SMA(RSV,3,1);
D1:=SMA(K1,3,1);
J:=3*K1-2*D1;
KDJ买入:IF((CROSS(J,0)),65,0),COLORGREEN;
{BOLL}
MID :=MA(CLOSE,20);
UPPER:=MID+2*STD(CLOSE,20);
LOWER:=MID-2*STD(CLOSE,20);
BOLL买入:IF((CROSS(CLOSE,LOWER)),70,0),COLORMAGENTA;[/lycode][lycode=tdx2,true]VAR1N赋值:收盘价的5日简单移动平均
VAR2N赋值:收盘价的10日简单移动平均
VAR3N赋值:(VAR1N-收盘价)/收盘价>13/100
VAR4N赋值:(VAR2N+VAR1N)/VAR1N>0.03
VAR5N赋值:1日内收盘价的最低值=1日内收盘价的最低值
赋值:(收盘价-收盘价的13日简单移动平均)/收盘价的13日简单移动平均*100/0.7
输出A1:如果BIAS1<-12,返回70,否则返回50,画红色
赋值:(收盘价-收盘价的6日简单移动平均)/收盘价的6日简单移动平均*100*2
输出A2:如果BIAS2<-9,返回50,否则返回30,COLOR00FF00
赋值:(收盘价-收盘价的11日简单移动平均)/收盘价的11日简单移动平均*100/0.3/1.3/1.5
输出A3:如果BIAS3<-12,返回30,否则返回10,画白色
BJ赋值:5日内最高价的最高值/收盘价,DOTLINE,画红色
JL赋值:5日内最低价的最低值/收盘价,DOTLINE,画红色
HA赋值:(5日内最高价的最高值+5日内最低价的最低值)/2/收盘价
RN赋值:(5日内最低价的最低值*5日内最高价的最高值)/收盘价/收盘价,画绿色
当满足条件1.1上穿RN时,在1和30位置之间画柱状线,宽度为1.0.5,0不为0则画空心柱.,画黄色
当满足条件1.2上穿RN时,在1和70位置之间画柱状线,宽度为1.0.5,0不为0则画空心柱.,画红色
当满足条件RN>=1.2时,在1和30.2位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,画淡红色
赋值: (如果收阳线,返回成交量(手),否则返回0+如果平盘,返回成交量(手)/2,否则返回0)的26日累和/(如果收阴线,返回成交量(手),否则返回0+如果平盘,返回成交量(手)/2,否则返回0)的26日累和*100
输出VR买:如果(70上穿WVR),返回50,否则返回0,画黄色
RSV赋值:(大盘的收盘价-18日内大盘的最低价的最低值)/(18日内大盘的最高价的最高值-18日内大盘的最低价的最低值)*100
K赋值:RSV的12日[1日权重]移动平均
输出DPSJ买入:如果(K上穿20),返回55,否则返回0,画白色
WRSV赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
WK赋值:WRSV的3日[1日权重]移动平均
D赋值:WK的3日[1日权重]移动平均
输出KD买入:如果(WK上穿D并且WK<20),返回60,否则返回0,画红色
K1赋值:RSV的3日[1日权重]移动平均
D1赋值:K1的3日[1日权重]移动平均
J赋值:3*K1-2*D1
输出KDJ买入:如果(J上穿0),返回65,否则返回0,画绿色
赋值:收盘价的20日简单移动平均
UPPER赋值:MID+2*收盘价的20日估算标准差
LOWER赋值:MID-2*收盘价的20日估算标准差
输出BOLL买入:如果(收盘价上穿LOWER),返回70,否则返回0,画洋红色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1qzIcbeX4mzOOI7I2nTpckg

看了该指标的人还看了:
行情副图指标    做底指标    超级火箭推进指标
游龙剑指标    重上五线指标    波段机会指标

使用道具 举报

回复