指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 画线 操盘控盘 压力支撑 
炒股叉_20190402_103044.png

炒股叉_20190402_103049.png

[lywrap=通达信主图指标公式][lycode=tdx,true]N:=75;P:=5;P1:=10;{N为多少天内的高低值参数,我以自已的初始K线根数定义。P1、P2为短、长支撑压力取点参数}
A1:=REF(H,P)=HHV(H,2*P+1);
B1:=FILTER(A1,P);
C1:=BACKSET(B1,P+1);
D1:=FILTER(C1,P);
E1:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);
F1:=E1>REF(E1,1);
短压:DRAWLINE(D1,H,F1,H,1),COLORCYAN;
A2:=REF(L,P)=LLV(L,2*P+1);
B2:=FILTER(A2,P);
C2:=BACKSET(B2,P+1);
D2:=FILTER(C2,P);
E2:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);
F2:=E2>REF(E2,1);
短支:DRAWLINE(D2,L,F2,L,1),COLORLIRED;
AA1:=REF(H,P1)=HHV(H,2*P1+1);
BB1:=FILTER(AA1,P1);
CC1:=BACKSET(BB1,P1+1);
DD1:=FILTER(CC1,P1);
EE1:=BACKSET(ISLASTBAR,BARSLAST(DD1)+1);
FF1:=EE1>REF(EE1,1);
长压:DRAWLINE(DD1,H,FF1,H,1),COLORGREEN;
AA2:=REF(L,P1)=LLV(L,2*P1+1);
BB2:=FILTER(AA2,P1);
CC2:=BACKSET(BB2,P1+1);
DD2:=FILTER(CC2,P1);
EE2:=BACKSET(ISLASTBAR,BARSLAST(DD2)+1);
FF2:=EE2>REF(EE2,1);
长支:DRAWLINE(DD2,L,FF2,L,1),COLORRED;
STICKLINE(C>=O,C,O,3,0),COLOR000045;
STICKLINE(C>=O,C,O,2.5,0),COLOR000065;
STICKLINE(C>=O,C,O,2,0),COLOR000085;
STICKLINE(C>=O,C,O,1.5,0),COLOR0000A5;
STICKLINE(C>=O,C,O,1,0),COLOR0000C5;
STICKLINE(C>=O,C,O,0.5,0),COLOR0000E5;
STICKLINE(C>=O,H,L,0,0),COLOR0000F5;
STICKLINE(C<O,C,O,3,0),COLOR353500;
STICKLINE(C<O,C,O,2.5,0),COLOR454500;
STICKLINE(C<O,C,O,2,0),COLOR555500;
STICKLINE(C<O,C,O,1.5,0),COLOR656500;
STICKLINE(C<O,C,O,1,0),COLOR757500;
STICKLINE(C<O,C,O,0.5,0),COLOR858500;
STICKLINE(C<O,H,L,0,0),COLOR959500;
高:=REFDATE(HHV(H,N),DATE);
低:=REFDATE(LLV(L,N),DATE);
H1:=高-(高-低)*0.191;
H2:=高-(高-低)*0.382;
H3:=高-(高-低)*0.5;
H4:=高-(高-低)*0.618;
H5:=高-(高-低)*0.809;
DRAWTEXT(CURRBARSCOUNT=1,高,'高'),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1,H1,'809'),COLORCYAN;
DRAWTEXT(CURRBARSCOUNT=1,H2,'618'),COLORGRAY;
DRAWTEXT(CURRBARSCOUNT=1,H3,'中'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=1,H4,'382'),COLORLIRED;
DRAWTEXT(CURRBARSCOUNT=1,H5,'191'),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=1,低,'低'),COLORRED;
STICKLINE(CURRBARSCOUNT=13,高,高,100,-1),COLORGREEN;
STICKLINE(CURRBARSCOUNT=13,H1,H1,100,-1),COLORCYAN;
STICKLINE(CURRBARSCOUNT=13,H2,H2,100,-1),COLORGRAY;
STICKLINE(CURRBARSCOUNT=13,H3,H3,100,-1),COLORYELLOW;
STICKLINE(CURRBARSCOUNT=13,H4,H4,100,-1),COLORLIRED;
STICKLINE(CURRBARSCOUNT=13,H5,H5,100,-1),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=13,低,低,100,-1),COLORRED;[/lycode][lycode=tdx2,true]N赋值:75
P赋值:5
P1赋值:10
A1赋值:P日前的最高价=2*P+1日内最高价的最高值
B1赋值:A1的P日过滤
C1赋值:若B1则将最近P+1周期置为1
D1赋值:C1的P日过滤
E1赋值:若是否最后一个周期则将最近上次D1距今天数+1周期置为1
F1赋值:E1>1日前的E1
输出短压:当满足条件D1时,在最高价位置画直线起点,当满足条件F1时,在最高价位置画直线终点,1表示是否延长.,画青色
A2赋值:P日前的最低价=2*P+1日内最低价的最低值
B2赋值:A2的P日过滤
C2赋值:若B2则将最近P+1周期置为1
D2赋值:C2的P日过滤
E2赋值:若是否最后一个周期则将最近上次D2距今天数+1周期置为1
F2赋值:E2>1日前的E2
输出短支:当满足条件D2时,在最低价位置画直线起点,当满足条件F2时,在最低价位置画直线终点,1表示是否延长.,画淡红色
AA1赋值:P1日前的最高价=2*P1+1日内最高价的最高值
BB1赋值:AA1的P1日过滤
CC1赋值:若BB1则将最近P1+1周期置为1
DD1赋值:CC1的P1日过滤
EE1赋值:若是否最后一个周期则将最近上次DD1距今天数+1周期置为1
FF1赋值:EE1>1日前的EE1
输出长压:当满足条件DD1时,在最高价位置画直线起点,当满足条件FF1时,在最高价位置画直线终点,1表示是否延长.,画绿色
AA2赋值:P1日前的最低价=2*P1+1日内最低价的最低值
BB2赋值:AA2的P1日过滤
CC2赋值:若BB2则将最近P1+1周期置为1
DD2赋值:CC2的P1日过滤
EE2赋值:若是否最后一个周期则将最近上次DD2距今天数+1周期置为1
FF2赋值:EE2>1日前的EE2
输出长支:当满足条件DD2时,在最低价位置画直线起点,当满足条件FF2时,在最低价位置画直线终点,1表示是否延长.,画红色
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR000045
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLOR000065
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR000085
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR0000A5
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0000C5
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR0000E5
当满足条件收盘价>=开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR0000F5
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR353500
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLOR454500
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR555500
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR656500
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR757500
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR858500
当满足条件收阴线时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR959500
高赋值:日期日N日内最高价的最高值
低赋值:日期日N日内最低价的最低值
H1赋值:高-(高-低)*0.191
H2赋值:高-(高-低)*0.382
H3赋值:高-(高-低)*0.5
H4赋值:高-(高-低)*0.618
H5赋值:高-(高-低)*0.809
当满足条件到最后交易的周期=1时,在高位置书写文字,画绿色
当满足条件到最后交易的周期=1时,在H1位置书写文字,画青色
当满足条件到最后交易的周期=1时,在H2位置书写文字,画深灰色
当满足条件到最后交易的周期=1时,在H3位置书写文字,画黄色
当满足条件到最后交易的周期=1时,在H4位置书写文字,画淡红色
当满足条件到最后交易的周期=1时,在H5位置书写文字,画洋红色
当满足条件到最后交易的周期=1时,在低位置书写文字,画红色
当满足条件到最后交易的周期=13时,在高和高位置之间画柱状线,宽度为100,-1不为0则画空心柱.,画绿色
当满足条件到最后交易的周期=13时,在H1和H1位置之间画柱状线,宽度为100,-1不为0则画空心柱.,画青色
当满足条件到最后交易的周期=13时,在H2和H2位置之间画柱状线,宽度为100,-1不为0则画空心柱.,画深灰色
当满足条件到最后交易的周期=13时,在H3和H3位置之间画柱状线,宽度为100,-1不为0则画空心柱.,画黄色
当满足条件到最后交易的周期=13时,在H4和H4位置之间画柱状线,宽度为100,-1不为0则画空心柱.,画淡红色
当满足条件到最后交易的周期=13时,在H5和H5位置之间画柱状线,宽度为100,-1不为0则画空心柱.,画洋红色
当满足条件到最后交易的周期=13时,在低和低位置之间画柱状线,宽度为100,-1不为0则画空心柱.,画红色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1dWh-WdNnls7BJf7ATofkdg

看了该指标的人还看了:
趋势波段买卖指标    大肥羊指标    上升之星指标
财富临门指标    大肥羊指标    挖金子指标

使用道具 举报

回复