指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 操盘控盘 量能 压力支撑 
炒股叉_20190402_102849.png

炒股叉_20190402_102856.png

[lywrap=通达信主图指标公式][lycode=tdx,true]DRAWBAND(MA(CLOSE,60),RGB(80,0,0),MA(CLOSE,120),RGB(0,91,0));
DRAWBAND(MA(CLOSE,5),RGB(155,50,50),MA(CLOSE,10),RGB(83,123,68));
DRAWKLINE(H,O,L,C);
MA5:=MA(CLOSE,5),COLORWHITE;
MA10:=MA(CLOSE,10),COLORYELLOW;
MA30:=MA(CLOSE,30),COLORMAGENTA;
MA60:=MA(CLOSE,60),COLORGREEN;
MA120:=MA(CLOSE,120),COLORLIMAGENTA;
MA240:=MA(CLOSE,240),COLORBLUE,NODRAW;
VOL5:=MA(VOL,5),COLORWHITE;
VOL10:=MA(VOL,10),COLORYELLOW;
VOL40:=MA(VOL,40),COLORFF00FF ;
量托:=VOL5>=VOL40 AND CROSS(VOL10,VOL40) AND REF(VOL10,1)<REF(VOL40,1);
DRAWTEXT(量托,L-0.012,'量托'),COLORWHITE;
AA1:=BARSLAST(MA60>MA30 AND (MA30=MA10 OR MA30>MA10));
BB1:=REF(COUNT(C<MA60,AA1)=AA1,1);
CC1:=CROSS(C,MA60) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;
芙蓉出水:=BB1 AND CC1,COLOR00FF00;
DRAWTEXT(芙蓉出水,H+0.3,'芙蓉出水'),COLORFF00FF;
STICKLINE(芙蓉出水,H,L,1,1),COLORFF00FF;
STICKLINE(芙蓉出水,O,C,3,1),LINETHICK2,COLORFF00FF;
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);
ZJ:=AMOUNT/10000;{资金}
TM:=V-MA(V,10);{量填满}
一穿三:=MA1>O AND MA2>O AND MA3>O AND MA1<C AND MA2<C AND MA3<C AND CLOSE>OPEN ;
DRAWTEXT(一穿三,L-0.012,'一穿三'),COLORFF00FF;
STICKLINE(一穿三,OPEN,CLOSE,1,0),COLORFF00FF;
TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);
前期高位:REF(C,BARSLAST(HD)),COLORBLUE,POINTDOT;
STICKLINE(C,前期高位,前期高位,8,0),COLORBLUE;
{高点:=(C/REF(C,BARSLAST(HD))-1)*100,NODRAW;
STICKLINE((HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667,H,C,0.8,0),COLORBLUE;}
三日不破:=MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(L,3);
三日量缩:=(MAX(MAX(V,REF(V,1)),REF(V,2))<REF(V,3));
三日价涨A:=C>=REF(C,1);
三日价涨B:=C<REF(C,1);
三日价涨C:=MIN(MIN(C,REF(C,1)),REF(C,2))>=REF(L,3);
TIM:=IF(DATE<1140214,1,0);
缩倍柱:=(VOL*1.95<=REF(VOL,1))*TIM;
百日低量:=(VOL=LLV(VOL,100))*TIM;
倍量柱:=C>REF(C,1)*1.04 AND (VOL>=1.9*REF(VOL,1))*TIM;
四日前倍量柱:=(REF(VOL,3)>1.9*REF(VOL,4))*TIM;
四日前高量柱:=(REF(VOL,3)>=REF(VOL,4) AND REF(VOL,3)<1.9*REF(VOL,4) AND 三日量缩)*TIM;
前三引用不成立:=COUNT(REF(四日前倍量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0 AND COUNT(REF(四日前高量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0;
倍量黄金柱:=四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
高量黄金柱:=四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
黄金柱:=倍量黄金柱 OR 高量黄金柱;
次倍量黄金柱:=NOT(黄金柱) AND 四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次高量黄金柱:=NOT(黄金柱) AND 四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次黄金柱:=次倍量黄金柱 OR 次高量黄金柱;
准倍量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前倍量柱 AND ((三日量缩 AND 三日价涨C) OR (COUNT(倍量柱,3)>=1 AND 三日不破)) AND 前三引用不成立;
准高量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前高量柱 AND (三日量缩 AND 三日价涨C) AND 前三引用不成立;
准黄金柱:=准倍量黄金柱 OR 准高量黄金柱;
倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前倍量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前高量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
将军柱:=倍量将军柱 OR 高量将军柱;
次倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱) AND 四日前倍量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱) AND 四日前高量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次将军柱:=次倍量将军柱 OR 次高量将军柱;
准倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱) AND 四日前倍量柱 AND 三日价涨C AND 前三引用不成立;
准高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱) AND 四日前高量柱 AND 三日价涨C AND 前三引用不成立;
准将军柱:=准倍量将军柱 OR 准高量将军柱;
BACKSET100:=BACKSET(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱 OR 准将军柱,4);
FILTER100:=FILTER(BACKSET100,3),NODRAW;
BACKSET101:=BACKSET(黄金柱,4);
FILTER101:=FILTER(BACKSET101,3);
BACKSET102:=BACKSET(次黄金柱,4);
FILTER102:=FILTER(BACKSET102,3);
BACKSET103:=BACKSET(准黄金柱,4);
FILTER103:=FILTER(BACKSET103,3);
BACKSET104:=BACKSET(将军柱,4);
FILTER104:=FILTER(BACKSET104,3);
BACKSET105:=BACKSET(次将军柱,4);
FILTER105:=FILTER(BACKSET105,3);
BACKSET106:=BACKSET(准将军柱,4);
FILTER106:=FILTER(BACKSET106,3);
黄金线下影线:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<=REF(L,3);
黄金线实体下端:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<=MIN(REF(C,3),REF(O,3)) AND MIN(MIN(L,REF(L,1)),REF(L,2))>REF(L,3),LINETHICK0;
黄金线上影线:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(H,3);
黄金线实体上端:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>=MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<REF(H,3);
黄金线实体中间:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3));
黄金线实体中间1:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND REF(L,2)=MIN(MIN(L,REF(L,1)),REF(L,2));
黄金线实体中间2:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND REF(L,1)=MIN(MIN(L,REF(L,1)),REF(L,2));
黄金线实体中间3:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND L=MIN(MIN(L,REF(L,1)),REF(L,2));
BACKSET201:=BACKSET(黄金线下影线,4);
FILTER201:=FILTER(BACKSET201,3),NODRAW;
BACKSET202:=BACKSET(黄金线实体下端,4);
FILTER202:=FILTER(BACKSET202,3),NODRAW;
BACKSET203:=BACKSET(黄金线上影线,4);
FILTER203:=FILTER(BACKSET203,3),NODRAW;
BACKSET204:=BACKSET(黄金线实体上端,4);
FILTER204:=FILTER(BACKSET204,3),NODRAW;
BACKSET205:=BACKSET(黄金线实体中间,4);
FILTER205:=FILTER(BACKSET205,3),NODRAW;
BACKSET2051:=BACKSET(黄金线实体中间1,4);
FILTER2051:=FILTER(BACKSET2051,3),NODRAW;
BACKSET2052:=BACKSET(黄金线实体中间2,4);
FILTER2052:=FILTER(BACKSET2052,3),NODRAW;
BACKSET2053:=BACKSET(黄金线实体中间3,4);
FILTER2053:=FILTER(BACKSET2053,3),NODRAW;
BT201:=IF(BARSLAST(FILTER201)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER201));
BT202:=IF(BARSLAST(FILTER202)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER202));
BT203:=IF(BARSLAST(FILTER203)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER203));
BT204:=IF(BARSLAST(FILTER204)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER204));
BT205:=IF(BARSLAST(FILTER205)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER205));
BT2051:=IF(BARSLAST(FILTER2051)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2051));
BT2052:=IF(BARSLAST(FILTER2052)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2052));
BT2053:=IF(BARSLAST(FILTER2053)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2053));
最近黄金线:=MIN(MIN(MIN(MIN(MIN(MIN(BT201,BT202),BT203),BT204),BT2051),BT2052),BT2053);
DAY1:=SUMBARS(FILTER100,1),NODRAW;
HJX1_1:=IF(SUMBARS(FILTER201,1)=DAY1,IF(DAY1=1,LOW,REF(LOW,DAY1-1)),0),NODRAW;
HJX1_2:=IF(SUMBARS(FILTER202,1)=DAY1,IF(DAY1=1,MIN(C,O),MIN(REF(C,DAY1-1),REF(OPEN,DAY1-1))),0),NODRAW;
HJX1_3:=IF(SUMBARS(FILTER203,1)=DAY1,IF(DAY1=1,HIGH,REF(HIGH,DAY1-1)),0),NODRAW;
HJX1_4:=IF(SUMBARS(FILTER204,1)=DAY1,IF(DAY1=1,MAX(C,O),MAX(REF(C,DAY1-1),REF(OPEN,DAY1-1))),0),NODRAW;
HJX1_51:=IF(SUMBARS(FILTER2051,1)=DAY1,IF(DAY1=2,LOW,IF(DAY1<2,DRAWNULL,REF(LOW,DAY1-2))),0),NODRAW;
HJX1_52:=IF(SUMBARS(FILTER2052,1)=DAY1,IF(DAY1=3,LOW,IF(DAY1<3,DRAWNULL,REF(LOW,DAY1-3))),0),NODRAW;
HJX1_53:=IF(SUMBARS(FILTER2053,1)=DAY1,IF(DAY1=4,LOW,IF(DAY1<4,DRAWNULL,REF(LOW,DAY1-4))),0),NODRAW;
黄金线:=HJX1_1+HJX1_2+HJX1_3+HJX1_4+HJX1_51+HJX1_52+HJX1_53,COLORYELLOW,NODRAW;
立桩量:=VOL=HHV(VOL,40) AND VOL>1.9*REF(VOL,1);
立桩量三日突破:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));
立桩量三日不破:=BARSLAST(立桩量)=3 AND REF(LOW,3)<=MIN(MIN(C,REF(C,1)),REF(C,2));
BACKSET300:=BACKSET(立桩量三日不破,4);
BACKSET301:=BACKSET(立桩量三日突破,4);
立桩量成立:=FILTER(BACKSET300,3) AND BACKSET301 AND 立桩量;
DRAWTEXT(立桩量成立,HIGH*1.01,'↙立桩量'),COLOR00FF00;
DRAWTEXT(FILTER101,LOW*0.986,'↖黄金柱'),COLORYELLOW;
STICKLINE(FILTER101,OPEN,CLOSE,0.5,0),COLORYELLOW;
DRAWTEXT(FILTER102,LOW*0.986,'↖次黄金柱'),COLORYELLOW;
DRAWTEXT(FILTER104,LOW*0.986,'↖将军柱'),COLORYELLOW;
STICKLINE(FILTER104,OPEN,CLOSE,1.5,0),COLORYELLOW;
K1:=SUMBARS(FILTER104,1);
STICKLINE(K1,REF(L,K1-2),REF(L,K1-2),10,0),COLORYELLOW;
K2:=SUMBARS(FILTER101,1);
STICKLINE(K2,REF(L,K2-2),REF(L,K2-2),10,0),COLORYELLOW;[/lycode][lycode=tdx2,true]画带状线
画带状线
K线
MA5赋值:收盘价的5日简单移动平均,画白色
MA10赋值:收盘价的10日简单移动平均,画黄色
MA30赋值:收盘价的30日简单移动平均,画洋红色
MA60赋值:收盘价的60日简单移动平均,画绿色
MA120赋值:收盘价的120日简单移动平均,画淡洋红色
MA240赋值:收盘价的240日简单移动平均,画蓝色,NODRAW
VOL5赋值:成交量(手)的5日简单移动平均,画白色
VOL10赋值:成交量(手)的10日简单移动平均,画黄色
VOL40赋值:成交量(手)的40日简单移动平均,COLORFF00FF
量托赋值:VOL5>=VOL40 AND VOL10上穿VOL40 AND 1日前的VOL10<1日前的VOL40
当满足条件量托时,在最低价-0.012位置书写文字,画白色
AA1赋值:上次MA60>MA30AND(MA30=MA10ORMA30>MA10)距今天数
BB1赋值:1日前的统计AA1日中满足收盘价<MA60的天数=AA1
CC1赋值:收盘价上穿MA60 AND 成交量(手)>成交量(手)的5日简单移动平均 AND (收盘价-1日前的收盘价)/1日前的收盘价*100>3
芙蓉出水赋值:BB1 AND CC1,COLOR00FF00
当满足条件芙蓉出水时,在最高价+0.3位置书写文字,COLORFF00FF
当满足条件芙蓉出水时,在最高价和最低价位置之间画柱状线,宽度为1,1不为0则画空心柱.,COLORFF00FF
当满足条件芙蓉出水时,在开盘价和收盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,线宽为2,COLORFF00FF
MA1赋值:收盘价的5日简单移动平均
MA2赋值:收盘价的10日简单移动平均
MA3赋值:收盘价的20日简单移动平均
ZJ赋值:成交额(元)/10000
TM赋值:成交量(手)-成交量(手)的10日简单移动平均
一穿三赋值:MA1>开盘价 AND MA2>开盘价 AND MA3>开盘价 AND MA1<收盘价 AND MA2<收盘价 AND MA3<收盘价 AND 收阳线
当满足条件一穿三时,在最低价-0.012位置书写文字,COLORFF00FF
当满足条件一穿三时,在开盘价和收盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORFF00FF
TY赋值:收盘价
A1赋值:10日前的TY=2*10+1日内TY的最高值
B1赋值:A1的10日过滤
C1赋值:若B1则将最近10+1周期置为1
HD赋值:C1的10日过滤
A2赋值:10日前的TY=2*10+1日内TY的最低值
B2赋值:A2的10日过滤
C2赋值:若B2则将最近10+1周期置为1
LD赋值:C2的10日过滤
输出前期高位:上次HD距今天数日前的收盘价,画蓝色,POINTDOT
当满足条件收盘价时,在前期高位和前期高位位置之间画柱状线,宽度为8,0不为0则画空心柱.,画蓝色
三日不破赋值:最低价和1日前的最低价的较小值和2日前的最低价的较小值>=3日前的最低价
三日量缩赋值:(成交量(手)和1日前的成交量(手)的较大值和2日前的成交量(手)的较大值<3日前的成交量(手))
三日价涨A赋值:收盘价>=1日前的收盘价
三日价涨B赋值:收盘价<1日前的收盘价
三日价涨C赋值:收盘价和1日前的收盘价的较小值和2日前的收盘价的较小值>=3日前的最低价
TIM赋值:如果日期<1140214,返回1,否则返回0
缩倍柱赋值:(成交量(手)*1.95<=1日前的成交量(手))*TIM
百日低量赋值:(成交量(手)=100日内成交量(手)的最低值)*TIM
倍量柱赋值:收盘价>1日前的收盘价*1.04 AND (成交量(手)>=1.9*1日前的成交量(手))*TIM
四日前倍量柱赋值:(3日前的成交量(手)>1.9*4日前的成交量(手))*TIM
四日前高量柱赋值:(3日前的成交量(手)>=4日前的成交量(手) AND 3日前的成交量(手)<1.9*4日前的成交量(手) AND 三日量缩)*TIM
前三引用不成立赋值:统计3日中满足1日前的四日前倍量柱AND(1日前的三日不破ORREF(三日价涨C,1))的天数=0 AND 统计3日中满足1日前的四日前高量柱AND(1日前的三日不破ORREF(三日价涨C,1))的天数=0
倍量黄金柱赋值:四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立
高量黄金柱赋值:四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立
黄金柱赋值:倍量黄金柱 OR 高量黄金柱
次倍量黄金柱赋值:取反 AND 四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立
次高量黄金柱赋值:取反 AND 四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立
次黄金柱赋值:次倍量黄金柱 OR 次高量黄金柱
准倍量黄金柱赋值:取反 AND 四日前倍量柱 AND ((三日量缩 AND 三日价涨C) OR (统计3日中满足倍量柱的天数>=1 AND 三日不破)) AND 前三引用不成立
准高量黄金柱赋值:取反 AND 四日前高量柱 AND (三日量缩 AND 三日价涨C) AND 前三引用不成立
准黄金柱赋值:准倍量黄金柱 OR 准高量黄金柱
倍量将军柱赋值:取反 AND 四日前倍量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立
高量将军柱赋值:取反 AND 四日前高量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立
将军柱赋值:倍量将军柱 OR 高量将军柱
次倍量将军柱赋值:取反 AND 四日前倍量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立
次高量将军柱赋值:取反 AND 四日前高量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立
次将军柱赋值:次倍量将军柱 OR 次高量将军柱
准倍量将军柱赋值:取反 AND 四日前倍量柱 AND 三日价涨C AND 前三引用不成立
准高量将军柱赋值:取反 AND 四日前高量柱 AND 三日价涨C AND 前三引用不成立
准将军柱赋值:准倍量将军柱 OR 准高量将军柱
BACKSET100赋值:若黄金柱OR次黄金柱OR准黄金柱OR将军柱OR次将军柱OR准将军柱则将最近4周期置为1
FILTER100赋值:BACKSET100的3日过滤,NODRAW
BACKSET101赋值:若黄金柱则将最近4周期置为1
FILTER101赋值:BACKSET101的3日过滤
BACKSET102赋值:若次黄金柱则将最近4周期置为1
FILTER102赋值:BACKSET102的3日过滤
BACKSET103赋值:若准黄金柱则将最近4周期置为1
FILTER103赋值:BACKSET103的3日过滤
BACKSET104赋值:若将军柱则将最近4周期置为1
FILTER104赋值:BACKSET104的3日过滤
BACKSET105赋值:若次将军柱则将最近4周期置为1
FILTER105赋值:BACKSET105的3日过滤
BACKSET106赋值:若准将军柱则将最近4周期置为1
FILTER106赋值:BACKSET106的3日过滤
黄金线下影线赋值:3日前的FILTER100=1 AND 最低价和1日前的最低价的较小值和2日前的最低价的较小值<=3日前的最低价
黄金线实体下端赋值:3日前的FILTER100=1 AND 最低价和1日前的最低价的较小值和2日前的最低价的较小值<=3日前的收盘价和3日前的开盘价的较小值 AND 最低价和1日前的最低价的较小值和2日前的最低价的较小值>3日前的最低价,线宽为0
黄金线上影线赋值:3日前的FILTER100=1 AND 最低价和1日前的最低价的较小值和2日前的最低价的较小值>=3日前的最高价
黄金线实体上端赋值:3日前的FILTER100=1 AND 最低价和1日前的最低价的较小值和2日前的最低价的较小值>=3日前的收盘价和3日前的开盘价的较大值 AND 3日前的FILTER100=1 AND 最低价和1日前的最低价的较小值和2日前的最低价的较小值<3日前的最高价
黄金线实体中间赋值:3日前的FILTER100=1 AND 最低价和1日前的最低价的较小值和2日前的最低价的较小值<3日前的收盘价和3日前的开盘价的较大值 AND 3日前的FILTER100=1 AND 最低价和1日前的最低价的较小值和2日前的最低价的较小值>3日前的收盘价和3日前的开盘价的较小值
赋值:3日前的FILTER100=1 AND 最低价和1日前的最低价的较小值和2日前的最低价的较小值<3日前的收盘价和3日前的开盘价的较大值 AND 3日前的FILTER100=1 AND 最低价和1日前的最低价的较小值和2日前的最低价的较小值>3日前的收盘价和3日前的开盘价的较小值 AND 2日前的最低价=最低价和1日前的最低价的较小值和2日前的最低价的较小值
赋值:3日前的FILTER100=1 AND 最低价和1日前的最低价的较小值和2日前的最低价的较小值<3日前的收盘价和3日前的开盘价的较大值 AND 3日前的FILTER100=1 AND 最低价和1日前的最低价的较小值和2日前的最低价的较小值>3日前的收盘价和3日前的开盘价的较小值 AND 1日前的最低价=最低价和1日前的最低价的较小值和2日前的最低价的较小值
赋值:3日前的FILTER100=1 AND 最低价和1日前的最低价的较小值和2日前的最低价的较小值<3日前的收盘价和3日前的开盘价的较大值 AND 3日前的FILTER100=1 AND 最低价和1日前的最低价的较小值和2日前的最低价的较小值>3日前的收盘价和3日前的开盘价的较小值 AND 最低价=最低价和1日前的最低价的较小值和2日前的最低价的较小值
BACKSET201赋值:若黄金线下影线则将最近4周期置为1
FILTER201赋值:BACKSET201的3日过滤,NODRAW
BACKSET202赋值:若黄金线实体下端则将最近4周期置为1
FILTER202赋值:BACKSET202的3日过滤,NODRAW
BACKSET203赋值:若黄金线上影线则将最近4周期置为1
FILTER203赋值:BACKSET203的3日过滤,NODRAW
BACKSET204赋值:若黄金线实体上端则将最近4周期置为1
FILTER204赋值:BACKSET204的3日过滤,NODRAW
BACKSET205赋值:若黄金线实体中间则将最近4周期置为1
FILTER205赋值:BACKSET205的3日过滤,NODRAW
BACKSET2051赋值:若黄金线实体中间1则将最近4周期置为1
FILTER2051赋值:BACKSET2051的3日过滤,NODRAW
BACKSET2052赋值:若黄金线实体中间2则将最近4周期置为1
FILTER2052赋值:BACKSET2052的3日过滤,NODRAW
BACKSET2053赋值:若黄金线实体中间3则将最近4周期置为1
FILTER2053赋值:BACKSET2053的3日过滤,NODRAW
BT201赋值:如果上次FILTER201距今天数=无效数,返回收盘价的有效数据周期数,否则返回上次FILTER201距今天数
BT202赋值:如果上次FILTER202距今天数=无效数,返回收盘价的有效数据周期数,否则返回上次FILTER202距今天数
BT203赋值:如果上次FILTER203距今天数=无效数,返回收盘价的有效数据周期数,否则返回上次FILTER203距今天数
BT204赋值:如果上次FILTER204距今天数=无效数,返回收盘价的有效数据周期数,否则返回上次FILTER204距今天数
BT205赋值:如果上次FILTER205距今天数=无效数,返回收盘价的有效数据周期数,否则返回上次FILTER205距今天数
BT2051赋值:如果上次FILTER2051距今天数=无效数,返回收盘价的有效数据周期数,否则返回上次FILTER2051距今天数
BT2052赋值:如果上次FILTER2052距今天数=无效数,返回收盘价的有效数据周期数,否则返回上次FILTER2052距今天数
BT2053赋值:如果上次FILTER2053距今天数=无效数,返回收盘价的有效数据周期数,否则返回上次FILTER2053距今天数
最近黄金线赋值:BT201和BT202的较小值和BT203的较小值和BT204的较小值和BT2051的较小值和BT2052的较小值和BT2053的较小值
DAY1赋值:FILTER100累加至1的天数,NODRAW
HJX1_1赋值:如果FILTER201累加至1的天数=DAY1,返回如果DAY1=1,返回最低价,否则返回DAY1-1日前的最低价,否则返回0,NODRAW
HJX1_2赋值:如果FILTER202累加至1的天数=DAY1,返回如果DAY1=1,返回收盘价和开盘价的较小值,否则返回DAY1-1日前的收盘价和DAY1-1日前的开盘价的较小值,否则返回0,NODRAW
HJX1_3赋值:如果FILTER203累加至1的天数=DAY1,返回如果DAY1=1,返回最高价,否则返回DAY1-1日前的最高价,否则返回0,NODRAW
HJX1_4赋值:如果FILTER204累加至1的天数=DAY1,返回如果DAY1=1,返回收盘价和开盘价的较大值,否则返回DAY1-1日前的收盘价和DAY1-1日前的开盘价的较大值,否则返回0,NODRAW
HJX1_51赋值:如果FILTER2051累加至1的天数=DAY1,返回如果DAY1=2,返回最低价,否则返回如果DAY1<2,返回无效数,否则返回DAY1-2日前的最低价,否则返回0,NODRAW
HJX1_52赋值:如果FILTER2052累加至1的天数=DAY1,返回如果DAY1=3,返回最低价,否则返回如果DAY1<3,返回无效数,否则返回DAY1-3日前的最低价,否则返回0,NODRAW
HJX1_53赋值:如果FILTER2053累加至1的天数=DAY1,返回如果DAY1=4,返回最低价,否则返回如果DAY1<4,返回无效数,否则返回DAY1-4日前的最低价,否则返回0,NODRAW
黄金线赋值:HJX1_1+HJX1_2+HJX1_3+HJX1_4+HJX1_51+HJX1_52+HJX1_53,画黄色,NODRAW
立桩量赋值:成交量(手)=40日内成交量(手)的最高值 AND 成交量(手)>1.9*1日前的成交量(手)
立桩量三日突破赋值:如果上次立桩量距今天数=1ANDCLOSE>1日前的最高价,返回1,否则返回如果上次立桩量距今天数=2ANDCLOSE>2日前的最高价,返回1,否则返回如果上次立桩量距今天数=3ANDCLOSE>3日前的最高价,返回1,否则返回0
立桩量三日不破赋值:上次立桩量距今天数=3 AND 3日前的最低价<=收盘价和1日前的收盘价的较小值和2日前的收盘价的较小值
BACKSET300赋值:若立桩量三日不破则将最近4周期置为1
BACKSET301赋值:若立桩量三日突破则将最近4周期置为1
立桩量成立赋值:BACKSET300的3日过滤 AND BACKSET301 AND 立桩量
当满足条件立桩量成立时,在最高价*1.01位置书写文字,COLOR00FF00
当满足条件FILTER101时,在最低价*0.986位置书写文字,画黄色
当满足条件FILTER101时,在开盘价和收盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,画黄色
当满足条件FILTER102时,在最低价*0.986位置书写文字,画黄色
当满足条件FILTER104时,在最低价*0.986位置书写文字,画黄色
当满足条件FILTER104时,在开盘价和收盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,画黄色
K1赋值:FILTER104累加至1的天数
当满足条件K1时,在K1-2日前的最低价和K1-2日前的最低价位置之间画柱状线,宽度为10,0不为0则画空心柱.,画黄色
K2赋值:FILTER101累加至1的天数
当满足条件K2时,在K2-2日前的最低价和K2-2日前的最低价位置之间画柱状线,宽度为10,0不为0则画空心柱.,画黄色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1yCISsSyk71vc-w8-RRAmTg

看了该指标的人还看了:
波段利器指标    金财神SB指标    主力买卖指标
主力轨迹买卖指标    瀑布线指标    沉船寻宝指标

使用道具 举报

回复