指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 
炒股叉_20190402_102715.png

炒股叉_20190402_102721.png

[lywrap=通达信副图指标公式][lycode=tdx,true]VAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
VAR2:=EMA(EMA(EMA(VAR1,4),4),4);
SJ: (VAR2-REF(VAR2,1))/REF(VAR2,1)*100, COLORSTICK;
SD: MA(SJ,2);
SK: MA(SJ,1);
DRAWBAND((SJ-SD)*30000+40000,RGB(255,215,0),40000,RGB(135,206,235));
SHORT:=5;
LONG:=55;
MID:=10;
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:EMA(DIF,MID);
DRAWBAND((DIF-DEA)*20000+20000,RGB(255,215,0),20000,RGB(135,206,235));
{资金流向}
ZC_1:=IF(L<DYNAINFO(7),0,IF(H>DYNAINFO(7),DYNAINFO(7)-(DYNAINFO(7)-H+0.02)/(H-L+0.02),0));
ZC_2:=DMA(ZC_1,V/CAPITAL)*100;
出货:=IF(ZC_2>0 AND ZC_2>REF(ZC_2,1),ZC_2/20,0);
轴:0,COLOR00FF00;
PJJ:=DMA((H + L + C * 2) / 4,0.9);
JJ:=REF(EMA(PJJ,3),1);
QJJ:=VOL / ((H - L) * 2 - ABS(C - O));
XVL:=IF(C > O,QJJ * (H - L),IF(C < O,QJJ * (H - O + (C - L)),VOL / 2)) + IF(C > O,0 - QJJ * (H - C + (O - L)),IF(C < O,0 - QJJ * (H - L),0 - VOL / 2));
ZLL:=VOL / CAPITAL;
HSL1:=IF(ZLL > 10,10,ZLL);
HSL:=XVL / 20 / 1.15;
攻击流量:=HSL * 0.55 + REF(HSL,1) * 0.33 + REF(HSL,2) * 0.22;
GJJ:=EMA(攻击流量,8);
LLJX:=EMA(攻击流量,3);
流量:LLJX,COLORC875B7,COLORRED,NODRAW;
STICKLINE(流量 > 0,流量,0,2.3,0)COLORRED;
STICKLINE(流量 < 0,流量,0,2.3,0),COLORFF4242;
流量基线:GJJ,COLOR00BBBB,COLORGREEN;
STICKLINE(HSL * 0.4 >= 0,HSL * 0.4 * 1.5,0,0.5,0)COLORYELLOW;
STICKLINE(HSL * 0.4 < 0,HSL * 0.4 * 1.5,0,0.5,0)COLORGREEN;
ZJLL:=REF(LLJX,1);
QZJJ:=(((LLJX - ZJLL) / ZJLL) * 100);
流量幅%:IF(((LLJX > 0) AND (ZJLL < 0)),ABS(QZJJ),IF((((LLJX < 0) AND (ZJLL < 0)) AND (LLJX < ZJLL)),(0 - QZJJ),QZJJ))COLORMAGENTA,NODRAW;
力度:HSL / 1000,COLOR9B37FF,COLORRED,NODRAW;
周流量:SUM(LLJX,5),COLORFFBFDF,COLORMAGENTA,NODRAW;
BB:=REF(周流量,1);
ZQZJJ:=(周流量-BB)/BB*100;
周幅%:IF(周流量>0 AND BB<0,ABS(ZQZJJ),IF(周流量<0 AND BB<0 AND 周流量<BB,-ZQZJJ,ZQZJJ))COLORMAGENTA,NODRAW;
VARQ1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VARQ2:=SMA(ABS(LOW-VARQ1),13,1)/SMA(MAX(LOW-VARQ1,0),10,1);
VARQ3:=EMA(VARQ2,10);
VARQ4:=LLV(LOW,33);
VARQ5:=EMA(IF(LOW<=VARQ4,VARQ3,0),3)*100;
主力进场:STICKLINE(VARQ5>REF(VARQ5,1) AND 出货<=0,0,VARQ5,7,0 ),COLORBLUE;
JJJ:MA(SUM(HSL,55),8), COLORRED,LINETHICK2;
DRAWICON(CROSS(JJJ,轴),-5000,1);[/lycode][lycode=tdx2,true]VAR1赋值:(2*收盘价+最高价+最低价+开盘价)/5
VAR2赋值:VAR1的4日指数移动平均的4日指数移动平均的4日指数移动平均
输出SJ: (VAR2-1日前的VAR2)/1日前的VAR2*100, COLORSTICK
输出SD: SJ的2日简单移动平均
输出SK: SJ的1日简单移动平均
画带状线
SHORT赋值:5
LONG赋值:55
MID赋值:10
输出DIF:收盘价的SHORT日指数移动平均-收盘价的LONG日指数移动平均
输出DEA:DIF的MID日指数移动平均
画带状线
ZC_1赋值:如果最低价<现价,返回0,否则返回如果最高价>现价,返回现价-(现价-最高价+0.02)/(最高价-最低价+0.02),否则返回0
ZC_2赋值:以成交量(手)/当前流通股本(手)为权重ZC_1的动态移动平均*100
出货赋值:如果ZC_2>0ANDZC_2>1日前的ZC_2,返回ZC_2/20,否则返回0
输出轴:0,COLOR00FF00
PJJ赋值:以0.9为权重(最高价+最低价+收盘价*2)/4的动态移动平均
JJ赋值:1日前的PJJ的3日指数移动平均
QJJ赋值:成交量(手) / ((最高价 - 最低价) * 2 - 收盘价-开盘价的绝对值)
XVL赋值:如果收阳线,返回QJJ*(最高价-最低价),否则返回如果收阴线,返回QJJ*(最高价-开盘价+(收盘价-最低价)),否则返回成交量(手)/2 + 如果收阳线,返回0-QJJ*(最高价-收盘价+(开盘价-最低价)),否则返回如果收阴线,返回0-QJJ*(最高价-最低价),否则返回0-成交量(手)/2
ZLL赋值:成交量(手) / 当前流通股本(手)
HSL1赋值:如果ZLL>10,返回10,否则返回ZLL
HSL赋值:XVL / 20 / 1.15
攻击流量赋值:HSL * 0.55 + 1日前的HSL * 0.33 + 2日前的HSL * 0.22
GJJ赋值:攻击流量的8日指数移动平均
LLJX赋值:攻击流量的3日指数移动平均
输出流量:LLJX,COLORC875B7,画红色,NODRAW
当满足条件流量>0时,在流量和0位置之间画柱状线,宽度为2.3,0不为0则画空心柱.画红色
当满足条件流量<0时,在流量和0位置之间画柱状线,宽度为2.3,0不为0则画空心柱.,COLORFF4242
输出流量基线:GJJ,COLOR00BBBB,画绿色
当满足条件HSL*0.4>=0时,在HSL*0.4*1.5和0位置之间画柱状线,宽度为0.5,0不为0则画空心柱.画黄色
当满足条件HSL*0.4<0时,在HSL*0.4*1.5和0位置之间画柱状线,宽度为0.5,0不为0则画空心柱.画绿色
ZJLL赋值:1日前的LLJX
QZJJ赋值:(((LLJX - ZJLL) / ZJLL) * 100)
输出流量幅%:如果((LLJX>0)AND(ZJLL<0)),返回QZJJ的绝对值,否则返回如果(((LLJX<0)AND(ZJLL<0))AND(LLJX<ZJLL)),返回(0-QZJJ),否则返回QZJJ画洋红色,NODRAW
输出力度:HSL / 1000,COLOR9B37FF,画红色,NODRAW
输出周流量:LLJX的5日累和,COLORFFBFDF,画洋红色,NODRAW
BB赋值:1日前的周流量
ZQZJJ赋值:(周流量-BB)/BB*100
输出周幅%:如果周流量>0ANDBB<0,返回ZQZJJ的绝对值,否则返回如果周流量<0ANDBB<0AND周流量<BB,返回-ZQZJJ,否则返回ZQZJJ画洋红色,NODRAW
VARQ1赋值:1日前的(最低价+开盘价+收盘价+最高价)/4
VARQ2赋值:最低价-VARQ1的绝对值的13日[1日权重]移动平均/最低价-VARQ1和0的较大值的10日[1日权重]移动平均
VARQ3赋值:VARQ2的10日指数移动平均
VARQ4赋值:33日内最低价的最低值
VARQ5赋值:如果最低价<=VARQ4,返回VARQ3,否则返回0的3日指数移动平均*100
输出主力进场:当满足条件VARQ5>1日前的VARQ5AND出货<=0时,在0和VARQ5位置之间画柱状线,宽度为7,0不为0则画空心柱.,画蓝色
输出JJJ:HSL的55日累和的8日简单移动平均, 画红色,线宽为2
当满足条件JJJ上穿轴时,在-5000位置画1号图标[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1e6YI3AqmLaE47g1SSvo_AA

看了该指标的人还看了:
上升之星指标    抄底神器指标    金财神SB指标
趋势操盘指标    五福临门指标    猎庄买点指标

使用道具 举报

回复