指标公式
软件: 通达信 
公式类型: 副图 
二级分类: MACD指标 无未来函数 操盘控盘 
炒股叉_20190402_102459.png

炒股叉_20190402_102507.png

[lywrap=通达信副图指标公式][lycode=tdx,true]DIFF:EMA(CLOSE,12)-EMA(CLOSE,26),LINETHICK2;
DEA:EMA(DIFF,9),LINETHICK2;
MACD:(DIFF-DEA)*2, COLORSTICK;
DRAWTEXT(REF(MACD,1)>0 AND MACD<0,MACD-0.01,'1');
DRAWTEXT(REF(MACD,2)>0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'2');
DRAWTEXT(REF(MACD,3)>0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'3');
DRAWTEXT(REF(MACD,4)>0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'4');
DRAWTEXT(REF(MACD,5)>0 AND REF(MACD,4)<0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'5');
DRAWTEXT(REF(MACD,6)>0 AND REF(MACD,5)<0 AND REF(MACD,4)<0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'6');
DRAWBAND(DIFF,RGB(224,224,224),DEA,RGB(255,255,96));{60F}
DIF55:=(EMA(CLOSE,30)-EMA(CLOSE,100));
DEA55:=(EMA(DIF55,45));F60:EMA(CLOSE,12/2)-EMA(CLOSE,26/2),COLORCYAN;
A60:EMA(F60,9/2);
DRAWBAND(F60,RGB(0,224,224),A60,RGB(255,96,96));{30F}
F30:(EMA(CLOSE,12/4)-EMA(CLOSE,26/4)),COLORGREEN;
A30:(EMA(F30,9/4));
DRAWBAND(F30,RGB(0,224,0),A30,RGB(255,96,255));{15F};
DRAWTEXT(REF(MACD,1)>0 AND MACD<0,MACD-0.01,'1');
DRAWTEXT(REF(MACD,2)>0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'2');
DRAWTEXT(REF(MACD,3)>0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'3');
DRAWTEXT(REF(MACD,4)>0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'4');
DRAWTEXT(REF(MACD,5)>0 AND REF(MACD,4)<0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'5');
DRAWTEXT(REF(MACD,6)>0 AND REF(MACD,5)<0 AND REF(MACD,4)<0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'6');[/lycode][lycode=tdx2,true]输出DIFF:收盘价的12日指数移动平均-收盘价的26日指数移动平均,线宽为2
输出DEA:DIFF的9日指数移动平均,线宽为2
输出平滑异同平均:(DIFF-DEA)*2, COLORSTICK
当满足条件1日前的MACD>0ANDMACD<0时,在MACD-0.01位置书写文字
当满足条件2日前的MACD>0ANDREF(MACD,1)<0ANDMACD<0时,在MACD-0.01位置书写文字
当满足条件3日前的MACD>0ANDREF(MACD,2)<0ANDREF(MACD,1)<0ANDMACD<0时,在MACD-0.01位置书写文字
当满足条件4日前的MACD>0ANDREF(MACD,3)<0ANDREF(MACD,2)<0ANDREF(MACD,1)<0ANDMACD<0时,在MACD-0.01位置书写文字
当满足条件5日前的MACD>0ANDREF(MACD,4)<0ANDREF(MACD,3)<0ANDREF(MACD,2)<0ANDREF(MACD,1)<0ANDMACD<0时,在MACD-0.01位置书写文字
当满足条件6日前的MACD>0ANDREF(MACD,5)<0ANDREF(MACD,4)<0ANDREF(MACD,3)<0ANDREF(MACD,2)<0ANDREF(MACD,1)<0ANDMACD<0时,在MACD-0.01位置书写文字
画带状线
DIF55赋值:(收盘价的30日指数移动平均-收盘价的100日指数移动平均)
DEA55赋值:(DIF55的45日指数移动平均)
输出F60:收盘价的12/2日指数移动平均-收盘价的26/2日指数移动平均,画青色
输出A60:F60的9/2日指数移动平均
画带状线
输出F30:(收盘价的12/4日指数移动平均-收盘价的26/4日指数移动平均),画绿色
输出A30:(F30的9/4日指数移动平均)
画带状线

当满足条件1日前的MACD>0ANDMACD<0时,在MACD-0.01位置书写文字
当满足条件2日前的MACD>0ANDREF(MACD,1)<0ANDMACD<0时,在MACD-0.01位置书写文字
当满足条件3日前的MACD>0ANDREF(MACD,2)<0ANDREF(MACD,1)<0ANDMACD<0时,在MACD-0.01位置书写文字
当满足条件4日前的MACD>0ANDREF(MACD,3)<0ANDREF(MACD,2)<0ANDREF(MACD,1)<0ANDMACD<0时,在MACD-0.01位置书写文字
当满足条件5日前的MACD>0ANDREF(MACD,4)<0ANDREF(MACD,3)<0ANDREF(MACD,2)<0ANDREF(MACD,1)<0ANDMACD<0时,在MACD-0.01位置书写文字
当满足条件6日前的MACD>0ANDREF(MACD,5)<0ANDREF(MACD,4)<0ANDREF(MACD,3)<0ANDREF(MACD,2)<0ANDREF(MACD,1)<0ANDMACD<0时,在MACD-0.01位置书写文字[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1SOLH564AW8WRSx9763Pl_g

看了该指标的人还看了:
博奕杀手指标    短空抄底指标    一箭封喉指标
牛股起爆指标    二色操盘指标    资金进场指标

使用道具 举报

回复