指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 买卖点 压力支撑 
炒股叉_20190402_102103.png

炒股叉_20190402_102108.png

[lywrap=通达信主图指标公式][lycode=tdx,true]快线:EMA(EMA(EMA(EMA(CLOSE,2),2),2),2),LINETHICK2,COLOR0000FF;
慢线:EMA(REF(快线,1),2),LINETHICK2,COLOR00FFFF;
总趋势:EMA(EMA(EMA(EMA(EMA(CLOSE,55),2),2),2),2),LINETHICK2,COLORFF00FF;
A1:=REF(H,8)=HHV(H,2*8+1);
B1:=FILTER(A1,8);
C1:=BACKSET(B1,8+1);
D1:=FILTER(C1,8);{高点}
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1); S11:=R11>REF(R11,1);
DRAWLINE(D1,H,S11,H,1),COLORBLUE;
A2:=REF(L,8)=LLV(L,2*8+1);
B2:=FILTER(A2,8);
C2:=BACKSET(B2,8+1);
D2:=FILTER(C2,8);{低点}
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1); U11:=T11>REF(T11,1);
DRAWLINE(D2,L,U11,L,1),COLORBLUE;
M:=INTPART(3*8/5);
A12:=REF(H,M)=HHV(H,2*M+1);
B12:=FILTER(A12,M);
C12:=BACKSET(B12,M+1);
D12:=FILTER(C12,M);{高点}
R112:=BACKSET(ISLASTBAR,BARSLAST(D12)+1); S112:=R112>REF(R112,1);
DRAWLINE(D12,H,S112,H,1),COLORRED;
A22:=REF(L,M)=LLV(L,2*M+1);
B22:=FILTER(A22,M);
C22:=BACKSET(B22,M+1);
D22:=FILTER(C22,M);{低点}
T112:=BACKSET(ISLASTBAR,BARSLAST(D22)+1); U112:=T112>REF(T112,1);
DRAWLINE(D22,L,U112,L,1),COLORRED;
VAR1111:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);
VAR2222:=CROSS(VAR1111,0.9);
VAR3333:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);
VAR4444:=CROSS(VAR3333,0.9);
压力:= REF(HIGH,BARSLAST(VAR2222));
STICKLINE(CLOSE,REF(HIGH,BARSLAST(VAR2222)),REF(HIGH,BARSLAST(VAR2222)),0.5,1),COLOREA91B5,LINETHICK3;
支撑:= REF(LOW,BARSLAST(VAR4444));
STICKLINE(CLOSE,REF(LOW,BARSLAST(VAR4444)),REF(LOW,BARSLAST(VAR4444)),0.5,1),COLOR00B4FF,LINETHICK3;
下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
RRRSV:=SMA(下档线,3,1);
KKK:=SMA(RRRSV,3,1);
DDD:=((3 * RRRSV) - (2 * KKK));
JJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
RSV24:=SMA(JJ12,3,1);
K24:=SMA(RSV24,3,1);
D24:=((3 * RSV24) - (2 * K24));
压力2:=IF(CROSS(D24,DDD),HIGH,REF(HIGH,BARSLAST(CROSS(D24,DDD)))),COLORFFFFFF;
底部:=LLV(HIGH,30),COLOR00FF00;
DRAWICON(L<=支撑 AND H>支撑,L,0);
DRAWICON(H>=压力 AND L<压力,H,0);
DRAWICON(CROSS(快线,慢线),L*0.95,5);
DRAWICON(CROSS(慢线,快线),H*1.05,6);[/lycode][lycode=tdx2,true]输出快线:收盘价的2日指数移动平均的2日指数移动平均的2日指数移动平均的2日指数移动平均,线宽为2,COLOR0000FF
输出慢线:1日前的快线的2日指数移动平均,线宽为2,COLOR00FFFF
输出总趋势:收盘价的55日指数移动平均的2日指数移动平均的2日指数移动平均的2日指数移动平均的2日指数移动平均,线宽为2,COLORFF00FF
A1赋值:8日前的最高价=2*8+1日内最高价的最高值
B1赋值:A1的8日过滤
C1赋值:若B1则将最近8+1周期置为1
D1赋值:C1的8日过滤
R11赋值:若是否最后一个周期则将最近上次D1距今天数+1周期置为1
S11赋值:R11>1日前的R11
当满足条件D1时,在最高价位置画直线起点,当满足条件S11时,在最高价位置画直线终点,1表示是否延长.,画蓝色
A2赋值:8日前的最低价=2*8+1日内最低价的最低值
B2赋值:A2的8日过滤
C2赋值:若B2则将最近8+1周期置为1
D2赋值:C2的8日过滤
T11赋值:若是否最后一个周期则将最近上次D2距今天数+1周期置为1
U11赋值:T11>1日前的T11
当满足条件D2时,在最低价位置画直线起点,当满足条件U11时,在最低价位置画直线终点,1表示是否延长.,画蓝色
M赋值:3*8/5的整数部分
A12赋值:M日前的最高价=2*M+1日内最高价的最高值
B12赋值:A12的M日过滤
C12赋值:若B12则将最近M+1周期置为1
D12赋值:C12的M日过滤
R112赋值:若是否最后一个周期则将最近上次D12距今天数+1周期置为1
S112赋值:R112>1日前的R112
当满足条件D12时,在最高价位置画直线起点,当满足条件S112时,在最高价位置画直线终点,1表示是否延长.,画红色
A22赋值:M日前的最低价=2*M+1日内最低价的最低值
B22赋值:A22的M日过滤
C22赋值:若B22则将最近M+1周期置为1
D22赋值:C22的M日过滤
T112赋值:若是否最后一个周期则将最近上次D22距今天数+1周期置为1
U112赋值:T112>1日前的T112
当满足条件D22时,在最低价位置画直线起点,当满足条件U112时,在最低价位置画直线终点,1表示是否延长.,画红色
VAR1111赋值:若2日前的最高价=5日内最高价的最高值则将最近3周期置为1
VAR2222赋值:VAR1111上穿0.9
VAR3333赋值:若2日前的最低价=5日内最低价的最低值则将最近3周期置为1
VAR4444赋值:VAR3333上穿0.9
压力赋值: 上次VAR2222距今天数日前的最高价
当满足条件收盘价时,在上次VAR2222距今天数日前的最高价和上次VAR2222距今天数日前的最高价位置之间画柱状线,宽度为0.5,1不为0则画空心柱.,COLOREA91B5,线宽为3
支撑赋值: 上次VAR4444距今天数日前的最低价
当满足条件收盘价时,在上次VAR4444距今天数日前的最低价和上次VAR4444距今天数日前的最低价位置之间画柱状线,宽度为0.5,1不为0则画空心柱.,COLOR00B4FF,线宽为3
下档线赋值:(((收盘价 - 13日内最低价的最低值) / (13日内最高价的最高值 - 13日内最低价的最低值)) * 100)
RRRSV赋值:下档线的3日[1日权重]移动平均
KKK赋值:RRRSV的3日[1日权重]移动平均
DDD赋值:((3 * RRRSV) - (2 * KKK))
JJ12赋值:(((收盘价 - 55日内最低价的最低值) / (55日内最高价的最高值 - 55日内最低价的最低值)) * 100)
RSV24赋值:JJ12的3日[1日权重]移动平均
K24赋值:RSV24的3日[1日权重]移动平均
D24赋值:((3 * RSV24) - (2 * K24))
压力2赋值:如果D24上穿DDD,返回最高价,否则返回上次D24上穿DDD距今天数日前的最高价,COLORFFFFFF
底部赋值:30日内最高价的最低值,COLOR00FF00
当满足条件最低价<=支撑ANDH>支撑时,在最低价位置画0号图标
当满足条件最高价>=压力ANDL<压力时,在最高价位置画0号图标
当满足条件快线上穿慢线时,在最低价*0.95位置画5号图标
当满足条件慢线上穿快线时,在最高价*1.05位置画6号图标[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1gMNw6mqJSd2OTKWttCWgPA

看了该指标的人还看了:
上升之星指标    抄底神器指标    金财神SB指标
趋势操盘指标    五福临门指标    猎庄买点指标

使用道具 举报

回复