指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 
炒股叉_20190326_105417.png

炒股叉_20190326_105424.png

[lywrap=通达信副图指标公式][lycode=tdx,true]AR1:=((((2 * CLOSE) + HIGH) + LOW) / 4);
AR2:=LLV(LOW,34);
VARB:=HHV(HIGH,34);
VARC:=EMA((((AR1 - AR2) / (VARB - AR2)) * 100),8);
VARD:=EMA(VARC,5);
升:=((VARC - VARD) > 0);
跌:=((VARC - VARD) < 0);
升势:STICKLINE(((VARC - VARD) > 0),VARC,VARD,3,1),COLORFF10FF;
跌势:STICKLINE(((VARC - VARD) < 0),VARC,VARD,3,1),COLOR10FF10;
VAR10:=REF(CLOSE,1);
VAR11:=((SMA(MAX((CLOSE - VAR10),0),7,1) / SMA(ABS((CLOSE - VAR10)),7,1)) * 100);
VAR12:=(FILTER(CROSS(79,VAR11),4) * 190);
DRAWTEXT(VAR12,110,'顶1'),COLORGREEN;
顶1:STICKLINE(VAR12,112,80,3,0),COLORFFFF00;
VAR13:=((REF(HIGH,1) + REF(LOW,1)) / 2);
VAR14:=(MA(CLOSE,20) + (2 * STD(CLOSE,20)));
VAR15:=(FILTER(CROSS(VAR13,VAR14),4) * 200);
DRAWTEXT(VAR15,120,'顶2');
顶2:STICKLINE(VAR15,120,90,6,0),COLORFF00FF;
VAR16:=((3 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1)) - (2 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1),3,1)));
VAR18:=IF((VAR16 > 90),50,100);
VAR19:=(FILTER(CROSS(VAR18,VAR16),4) * 100);
DRAWICON(VAR19,100,12);
VR1:=((4 * SMA((((CLOSE - LLV(LOW,25)) / (HHV(HIGH,25) - LLV(LOW,25))) * 100),5,1)) - (3 * SMA(SMA((((CLOSE - LLV(LOW,25)) / (HHV(HIGH,25) - LLV(LOW,25))) * 100),5,1),3,1)));
买入:=IF(CROSS(VR1,8),2,0),COLORRED;
红柱买:STICKLINE(买入>0,0,50,2,0),COLORRED;
20;
50,POINTDOT ;
100,POINTDOT;[/lycode][lycode=tdx2,true]AR1赋值:((((2 * 收盘价) + 最高价) + 最低价) / 4)
AR2赋值:34日内最低价的最低值
VARB赋值:34日内最高价的最高值
VARC赋值:(((AR1-AR2)/(VARB-AR2))*100)的8日指数移动平均
VARD赋值:VARC的5日指数移动平均
升赋值:((VARC - VARD) > 0)
跌赋值:((VARC - VARD) < 0)
输出升势:当满足条件((VARC-VARD)>0)时,在VARC和VARD位置之间画柱状线,宽度为3,1不为0则画空心柱.,COLORFF10FF
输出跌势:当满足条件((VARC-VARD)<0)时,在VARC和VARD位置之间画柱状线,宽度为3,1不为0则画空心柱.,COLOR10FF10
VAR10赋值:1日前的收盘价
VAR11赋值:(((收盘价-VAR10)和0的较大值的7日[1日权重]移动平均 / (收盘价-VAR10)的绝对值的7日[1日权重]移动平均) * 100)
VAR12赋值:(79上穿VAR11的4日过滤 * 190)
当满足条件VAR12时,在110位置书写文字,画绿色
输出顶1:当满足条件VAR12时,在112和80位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFFFF00
VAR13赋值:((1日前的最高价 + 1日前的最低价) / 2)
VAR14赋值:(收盘价的20日简单移动平均 + (2 * 收盘价的20日估算标准差))
VAR15赋值:(VAR13上穿VAR14的4日过滤 * 200)
当满足条件VAR15时,在120位置书写文字
输出顶2:当满足条件VAR15时,在120和90位置之间画柱状线,宽度为6,0不为0则画空心柱.,COLORFF00FF
VAR16赋值:((3 * (((收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值))*100)的5日[1日权重]移动平均) - (2 * (((收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值))*100)的5日[1日权重]移动平均的3日[1日权重]移动平均))
VAR18赋值:如果(VAR16>90),返回50,否则返回100
VAR19赋值:(VAR18上穿VAR16的4日过滤 * 100)
当满足条件VAR19时,在100位置画12号图标
VR1赋值:((4 * (((收盘价-25日内最低价的最低值)/(25日内最高价的最高值-25日内最低价的最低值))*100)的5日[1日权重]移动平均) - (3 * (((收盘价-25日内最低价的最低值)/(25日内最高价的最高值-25日内最低价的最低值))*100)的5日[1日权重]移动平均的3日[1日权重]移动平均))
买入赋值:如果VR1上穿8,返回2,否则返回0,画红色
输出红柱买:当满足条件买入>0时,在0和50位置之间画柱状线,宽度为2,0不为0则画空心柱.,画红色
20
50,POINTDOT
100,POINTDOT[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1Q-CdIZQuNU9uiNijn_LSwQ

看了该指标的人还看了:
三间战法指标,84%的成功率    鼎牛短线出击指标    龙虎线指标
四线抓牛指标    鱼身战法指标    黑马决策辅助指标

使用道具 举报

回复