指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 
炒股叉_20190326_104453.png

炒股叉_20190326_104504.png

[lywrap=通达信副图指标公式][lycode=tdx,true]VAR2:=(2*CLOSE+HIGH+LOW)/4;
天: 80, LINETHICK2;
{VAR3:=IF(YEAR>=2099 AND MONTH>2,0,1);
};
VAR4:=LLV(LOW,5);
VAR5:=HHV(HIGH,4);
散户: EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4),COLORGREEN,LINETHICK3;
庄家: EMA(0.667*REF(散户,1)+0.333*散户,2),COLORYELLOW,LINETHICK3;
VAR6:=(HHV(HIGH,4)-VAR2)/(HHV(HIGH,4)-LLV(LOW,4))*100-72;
VAR7:=(VAR2-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100;
{倒影:SMA(VAR6,4,1),LINESTICK,LINETHICK2,COLORFF9999;
}VAR8:=SMA(VAR7,2,1);
黄山:SMA(VAR8,2,1),LINESTICK,LINETHICK4,COLORRED;
地平线:0,LINETHICK3,COLORRED;
DRAWTEXT(CROSS(散户,庄家) AND 散户<35 AND 29<散户,15,'短线快进'),COLORWHITE,LINETHICK3;
DRAWTEXT(CROSS(庄家,散户) AND 散户>70 AND 71>散户,50,'短线快出'),COLORFFFF00,LINETHICK3 ;
DRAWTEXT(CROSS(散户,庄家) AND 散户<30,0,'增'),LINETHICK3,COLORYELLOW;
DRAWTEXT(CROSS(庄家,散户) AND 散户>65,70,'减'),LINETHICK3,COLORRED;
DRAWICON(CROSS(散户,庄家) AND 散户<30,20,1);
DRAWICON(CROSS(庄家,散户) AND 散户>70,80,2);
VAR9:=CLOSE-REF(CLOSE,5);
VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5)*100;
VARB:=EMA(EMA(VAR9,10),10)/EMA(EMA(ABS(VAR9),10),10)*100;
VARC:=EMA(EMA(VAR9,20),20)/EMA(EMA(ABS(VAR9),20),20)*100;
{卖出:IF(VARA>0 AND CROSS(VARC,VARA),-40,0),STICK ,;
DRAWTEXT(卖出,-40,'中线逃吧!'),COLORRED,LINETHICK3;
DRAWICON(卖出<0,-25,2);
};[/lycode][lycode=tdx2,true]VAR2赋值:(2*收盘价+最高价+最低价)/4
输出天: 80, 线宽为2

VAR4赋值:5日内最低价的最低值
VAR5赋值:4日内最高价的最高值
输出散户: (VAR2-VAR4)/(VAR5-VAR4)*100的4日指数移动平均,画绿色,线宽为3
输出庄家: 0.667*1日前的散户+0.333*散户的2日指数移动平均,画黄色,线宽为3
VAR6赋值:(4日内最高价的最高值-VAR2)/(4日内最高价的最高值-4日内最低价的最低值)*100-72
VAR7赋值:(VAR2-4日内最低价的最低值)/(4日内最高价的最高值-4日内最低价的最低值)*100
VAR8赋值:VAR7的2日[1日权重]移动平均
输出黄山:VAR8的2日[1日权重]移动平均,LINESTICK,线宽为4,画红色
输出地平线:0,线宽为3,画红色
当满足条件散户上穿庄家AND散户<35AND29<散户时,在15位置书写文字,画白色,线宽为3
当满足条件庄家上穿散户AND散户>70AND71>散户时,在50位置书写文字,COLORFFFF00,线宽为3
当满足条件散户上穿庄家AND散户<30时,在0位置书写文字,线宽为3,画黄色
当满足条件庄家上穿散户AND散户>65时,在70位置书写文字,线宽为3,画红色
当满足条件散户上穿庄家AND散户<30时,在20位置画1号图标
当满足条件庄家上穿散户AND散户>70时,在80位置画2号图标
VAR9赋值:收盘价-5日前的收盘价
VARA赋值:VAR9的5日指数移动平均的5日指数移动平均/VAR9的绝对值的5日指数移动平均的5日指数移动平均*100
VARB赋值:VAR9的10日指数移动平均的10日指数移动平均/VAR9的绝对值的10日指数移动平均的10日指数移动平均*100
VARC赋值:VAR9的20日指数移动平均的20日指数移动平均/VAR9的绝对值的20日指数移动平均的20日指数移动平均*100[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1yh3NXKgq8INLiixfbn5rww

看了该指标的人还看了:
波段利器指标    金财神SB指标    主力买卖指标
主力轨迹买卖指标    瀑布线指标    沉船寻宝指标

使用道具 举报

回复