指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 
微信截图_20190313101915.png

微信截图_20190313101929.png

[lywrap=通达信副图指标公式][lycode=tdx,true]X:=C-REF(MA(C,20),11);
LGL:=IF(EMA(C,5)/EMA(EMA(C,9),16)<=0.85 AND C/REF(C,1)>0.905 AND C/REF(C,1)<1.05 AND VOL/CAPITAL*100<5,50,0);
WR1:=-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100*X;
WR2:=-100*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100;
WR3:=-100*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100*X;
BIAS1:=((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5;
BIAS2:=((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5;
BIAS3:=((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5;
S1:=(WR1+WR2+WR3+BIAS1+BIAS2+BIAS3)/6*X;
S2:=EMA(S1,3);
S3:=ABS(BIAS1-BIAS3);
SX:=(S1+S3)/2;
XC1:=(-1)*(EMA(100*(1-WINNER(CLOSE)),1)-50)+50;
CCC:=XC1+SX;
ZJZ:=IF( LGL>0 AND CCC<0,200,0)*X;
LXL:=IF(SX<0 AND C=LLV(C,5) AND C/REF(C,1)>0.905 AND C/REF(C,1)<1.05 AND VOL/CAPITAL*100<5,-50,0);
JBJ:=IF(CCC<0 AND LXL=-50,100,0)*X;
MA3:= MA(C,3);
C0:=REF(C,2)*0.865;
C1:=REF(C,13)*0.772;
BOT:=MIN(C0,C1);
HSL:=100*VOL/CAPITAL*X;
MA13:=MA(C,13)*X;
CXC:=IF((C-BOT)/C<3/100 AND SUM(HSL,5)/5<1.8,1,0);
VMC:=IF(CXC>0 AND (LXL<0 OR LGL>0),10,0);
满仓:IF((VMC>0),60,0),COLORRED;
半仓:IF(((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR (CXC>0 AND REF(C,1)/REF(C,2)>0.902)) OR (((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR CXC>0) AND (LXL<0 OR LGL>0)) AND VMC<10 ,50,0);
V93:=(((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR CXC>0) AND (LXL<0 OR LGL>0)) ;
V90:=((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR (CXC>0 AND REF(C,1)/REF(C,2)>0.902));
买一点:IF((V93 OR V90),10,0);
VAR2Q:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
神奇线:= MA((CLOSE-VAR2Q)/VAR2Q,1);
买二点:IF(CROSS(神奇线,0) AND LOW/REF(HIGH,1)<1.012 AND ((C-REF(C,2))/C)>0.06,20,0);
YY:=SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,18,1),12,1);
YT:=SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,12,1);
ST:=IF(CROSS(YT,YY),30,0);
VAR5PT:=(HIGH+LOW+CLOSE)/3;
VAR6PT:=(VAR5PT-MA(VAR5PT,14))/(0.015*AVEDEV(VAR5PT,14));
VAR7PT:=(VAR5PT-MA(VAR5PT,85))/(0.015*AVEDEV(VAR5PT,85));
SA:=IF(VAR7PT>=200 AND VAR6PT>=150,10,0);
VAR3QQ:=REF(CLOSE,1);
VAR4QQ:=SMA(MAX(CLOSE-VAR3QQ,0),6,1)/SMA(ABS(CLOSE-VAR3QQ),6,1)*100;
SM:=IF(CROSS(80,VAR4QQ),30,0);
卖点:IF((SM AND (SA OR ST)),30,0);[/lycode][lycode=tdx2,true]X赋值:收盘价-11日前的收盘价的20日简单移动平均
LGL赋值:如果收盘价的5日指数移动平均/收盘价的9日指数移动平均的16日指数移动平均<=0.85ANDC/1日前的收盘价>0.905ANDC/1日前的收盘价<1.05ANDVOL/当前流通股本(手)*100<5,返回50,否则返回0
WR1赋值:-100*(34日内最高价的最高值-收盘价)/(34日内最高价的最高值-34日内最低价的最低值)+100*X
WR2赋值:-100*(50日内最高价的最高值-收盘价)/(50日内最高价的最高值-50日内最低价的最低值)+100
WR3赋值:-100*(70日内最高价的最高值-收盘价)/(70日内最高价的最高值-70日内最低价的最低值)+100*X
BIAS1赋值:((收盘价-收盘价的34日简单移动平均)/收盘价的34日简单移动平均*100+10)*5
BIAS2赋值:((收盘价-收盘价的50日简单移动平均)/收盘价的50日简单移动平均*100+10)*5
BIAS3赋值:((收盘价-收盘价的70日简单移动平均)/收盘价的70日简单移动平均*100+10)*5
S1赋值:(WR1+WR2+WR3+BIAS1+BIAS2+BIAS3)/6*X
S2赋值:S1的3日指数移动平均
S3赋值:BIAS1-BIAS3的绝对值
SX赋值:(S1+S3)/2
XC1赋值:(-1)*(100*(1-以收盘价计算的获利盘比例)的1日指数移动平均-50)+50
CCC赋值:XC1+SX
ZJZ赋值:如果LGL>0ANDCCC<0,返回200,否则返回0*X
LXL赋值:如果SX<0ANDC=5日内收盘价的最低值ANDC/1日前的收盘价>0.905ANDC/1日前的收盘价<1.05ANDVOL/当前流通股本(手)*100<5,返回-50,否则返回0
JBJ赋值:如果CCC<0ANDLXL=-50,返回100,否则返回0*X
MA3赋值: 收盘价的3日简单移动平均
C0赋值:2日前的收盘价*0.865
C1赋值:13日前的收盘价*0.772
BOT赋值:C0和C1的较小值
HSL赋值:100*成交量(手)/当前流通股本(手)*X
MA13赋值:收盘价的13日简单移动平均*X
CXC赋值:如果(收盘价-BOT)/收盘价<3/100ANDSUM(HSL,5)/5<1.8,返回1,否则返回0
VMC赋值:如果CXC>0AND(LXL<0ORLGL>0),返回10,否则返回0
输出满仓:如果(VMC>0),返回60,否则返回0,画红色
输出半仓:如果((ZJZ>0ANDJBJ>0ANDSUM(成交量(手)/当前流通股本(手)*100,5)/5<1)OR(CXC>0ANDREF(收盘价,1)/2日前的收盘价>0.902))OR(((ZJZ>0ANDJBJ>0ANDSUM(成交量(手)/当前流通股本(手)*100,5)/5<1)ORCXC>0)AND(LXL<0ORLGL>0))ANDV,返回收盘价<10,否则返回50
V93赋值:(((ZJZ>0 AND JBJ>0 AND 成交量(手)/当前流通股本(手)*100的5日累和/5<1) OR CXC>0) AND (LXL<0 OR LGL>0))
V90赋值:((ZJZ>0 AND JBJ>0 AND 成交量(手)/当前流通股本(手)*100的5日累和/5<1) OR (CXC>0 AND 1日前的收盘价/2日前的收盘价>0.902))
输出买一点:如果(V93ORV90),返回10,否则返回0
VAR2Q赋值:(收盘价的80日简单移动平均-收盘价的13日简单移动平均/3)
神奇线赋值: (收盘价-VAR2Q)/VAR2Q的1日简单移动平均
输出买二点:如果神奇线上穿0ANDLOW/1日前的最高价<1.012AND((收盘价-2日前的收盘价)/收盘价)>0.06,返回20,否则返回0
YY赋值:(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的18日[1日权重]移动平均的12日[1日权重]移动平均
YT赋值:(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的12日[1日权重]移动平均
ST赋值:如果YT上穿YY,返回30,否则返回0
VAR5PT赋值:(最高价+最低价+收盘价)/3
VAR6PT赋值:(VAR5PT-VAR5PT的14日简单移动平均)/(0.015*VAR5PT的14日平均绝对偏差)
VAR7PT赋值:(VAR5PT-VAR5PT的85日简单移动平均)/(0.015*VAR5PT的85日平均绝对偏差)
SA赋值:如果VAR7PT>=200ANDVAR6PT>=150,返回10,否则返回0
VAR3QQ赋值:1日前的收盘价
VAR4QQ赋值:收盘价-VAR3QQ和0的较大值的6日[1日权重]移动平均/收盘价-VAR3QQ的绝对值的6日[1日权重]移动平均*100
SM赋值:如果80上穿VAR4QQ,返回30,否则返回0
输出卖点:如果(SMAND(SAORST)),返回30,否则返回0[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1OszjuIVfu_6R2Rw12HrTkQ

看了该指标的人还看了:
上升之星指标    抄底神器指标    金财神SB指标
趋势操盘指标    五福临门指标    猎庄买点指标

使用道具 举报

回复