指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 
微信截图_20190313101622.png

微信截图_20190313101641.png

[lywrap=通达信副图指标公式][lycode=tdx,true]VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=CLOSE-REF(CLOSE,1);
VAR13:=MAX(VAR12,0);
VAR14:=ABS(VAR12);
VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;
VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;
VAR17:=BARSCOUNT(CLOSE);
VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR20:=VAR18<=25 AND  VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;
STICKLINE(VAR20,0,95,5,0),LINETHICK2,COLORRED;
DRAWTEXT(CROSS(VAR20,0.5) AND COUNT(VAR20=1,10)=1,60,'发射导弹'),LINETHICK7,COLORWHITE;
发射导弹:IF(VAR20>0,50,0);[/lycode][lycode=tdx2,true]VAR1A赋值:(收盘价-15日内最低价的最低值)/(15日内最高价的最高值-15日内最低价的最低值)*100
VAR1B赋值:(VAR1A的4日[1日权重]移动平均-50)*2的3日[1日权重]移动平均
VAR1C赋值:(大盘的收盘价-14日内大盘的最低价的最低值)/(14日内大盘的最高价的最高值-14日内大盘的最低价的最低值)*100
VAR1D赋值:VAR1C的4日[1日权重]移动平均
VAR1E赋值:VAR1D的3日[1日权重]移动平均
VAR1F赋值:(30日内最高价的最高值-收盘价)/收盘价*100
VARE赋值:1日前的最低价*0.9
VARF赋值:最低价*0.9
VAR10赋值:(VARF*成交量(手)+VARE*(当前流通股本(手)-成交量(手)))/当前流通股本(手)
VAR11赋值:VAR10的30日指数移动平均
VAR12赋值:收盘价-1日前的收盘价
VAR13赋值:VAR12和0的较大值
VAR14赋值:VAR12的绝对值
VAR15赋值:VAR13的7日[1日权重]移动平均/VAR14的7日[1日权重]移动平均*100
VAR16赋值:VAR13的13日[1日权重]移动平均/VAR14的13日[1日权重]移动平均*100
VAR17赋值:收盘价的有效数据周期数
VAR18赋值:VAR12和0的较大值的6日[1日权重]移动平均/VAR12的绝对值的6日[1日权重]移动平均*100
VAR19赋值:(-200)*(60日内最高价的最高值-收盘价)/(60日内最高价的最高值-60日内最低价的最低值)+100
VAR20赋值:VAR18<=25 AND  VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-收盘价>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50
当满足条件VAR20时,在0和95位置之间画柱状线,宽度为5,0不为0则画空心柱.,线宽为2,画红色
当满足条件VAR20上穿0.5ANDCOUNT(VAR20=1,10)=1时,在60位置书写文字,线宽为7,画白色
输出发射导弹:如果VAR20>0,返回50,否则返回0[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1k4iHflNZ42QVEwsGLn_Cbg

看了该指标的人还看了:
与私募同进出指标    真涨指标,成功率非常高    三碗不过岗指标
主力买卖指标    明明白白指标    绝对底部指标

使用道具 举报

回复