指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 操盘控盘 
微信截图_20190313100453.png

微信截图_20190313100504.png

[lywrap=通达信主图指标公式][lycode=tdx,true]空:=EMA(C,5);
均衡:EMA(空,5),COLORWHITE;
中轨:HHV(MA(H,13),13),COLORYELLOW,LINETHICK1;
趋势:LLV(MA(H,13),1),COLORRED,LINETHICK1;
VARA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
VARB:=EMA(0.667*REF(VARA,1)+0.333*VARA,5);
DRAWTEXT(IF(VOL>=1.3*MA(VOL,5) AND COUNT(VARA>=VARB AND VARA<-17,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW,'买入');
VARC:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;

VAR1:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VAR2:=REF(VAR1,1);
VAR3:=SMA(MAX(VAR1-VAR2,0),10,1)/SMA(ABS(VAR1-VAR2),10,1)*100;
VAR4:=FILTER(IF(COUNT(VAR3<20,5)>=1 AND COUNT(VAR1=LLV(VAR1,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0),5);
DRAWICON(VAR4,LOW,1);
VAR5:=FILTER(均衡>REF(均衡,1)AND 中轨<REF(中轨,1)AND C>REF(C,1),11);
DRAWTEXT(VAR5,LOW*0.985,'加仓'),COLORYELLOW;
DRAWTEXT(VAR5,LOW*0.995,'^' ),COLORYELLOW;
VAR6:=REF(CLOSE,1);
VAR7:=SMA(MAX(CLOSE-VAR6,0),6,1)/SMA(ABS(CLOSE-VAR6),6,1)*100;
DRAWTEXT(CROSS(84,VAR7),H*1.035,'减仓'),COLOR00FF00 ;
DRAWTEXT(CROSS(84,VAR7),H*1.015,'◇' ),COLOR00FF00;
IF(MA(CLOSE,20)>REF(MA(CLOSE,20),1),MA(CLOSE,20),DRAWNULL),COLORRED,LINETHICK2;
IF(MA(CLOSE,20)<REF(MA(CLOSE,20),1),MA(CLOSE,20),DRAWNULL),COLORGREEN,LINETHICK2;
KDJ_K:="KDJ.K"(9,3,3);KDJ_D:="KDJ.D"(9,3,3);KDJ_J:="KDJ.J"(9,3,3);
买1:=CROSS(KDJ_J,0) OR (CROSS(KDJ_J,KDJ_K) AND KDJ_D<26);
买2:=CROSS("RSI.RSI1"(6,2,2),20) OR CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
买3:=CROSS("MACD.DIF","MACD.DEA") OR CROSS("MACD.MACD",0);
买0:=买1+买2+买3;
{买:IF(买0>1,买0,0);}
DRAWICON(买0>1,L*0.98,16);

AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,(LOW* 0.97),'老鼠仓'),COLOR4080FF;[/lycode][lycode=tdx2,true]空赋值:收盘价的5日指数移动平均
输出均衡:空的5日指数移动平均,画白色
输出中轨:13日内最高价的13日简单移动平均的最高值,画黄色,线宽为1
输出趋势:1日内最高价的13日简单移动平均的最低值,画红色,线宽为1
VARA赋值:(收盘价-29日前的开盘价)/29日前的开盘价*100
VARB赋值:0.667*1日前的VARA+0.333*VARA的5日指数移动平均
当满足条件如果成交量(手)>=1.3*成交量(手)的5日简单移动平均ANDCOUNT(VARA>=VARBANDVARA<-17,3)ANDREF(最低价,1)=120日内最低价的最低值,返回1,否则返回0时,在最低价位置书写文字
VARC赋值:收盘价-1日前的收盘价和0的较大值的6日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的6日[1日权重]移动平均*100
VAR1赋值:(最高价+最低价+开盘价+2*收盘价)/5
VAR2赋值:1日前的VAR1
VAR3赋值:VAR1-VAR2和0的较大值的10日[1日权重]移动平均/VAR1-VAR2的绝对值的10日[1日权重]移动平均*100
VAR4赋值:如果统计5日中满足VAR3<20的天数>=1ANDCOUNT(VAR1=10日内VAR1的最低值,10)>=1ANDCLOSE>=开盘价*1.038ANDVOL>成交量(手)的5日简单移动平均*1.2,返回1,否则返回0的5日过滤
当满足条件VAR4时,在最低价位置画1号图标
VAR5赋值:均衡>1日前的均衡AND中轨<1日前的中轨ANDC>1日前的收盘价的11日过滤
当满足条件VAR5时,在最低价*0.985位置书写文字,画黄色
当满足条件VAR5时,在最低价*0.995位置书写文字,画黄色
VAR6赋值:1日前的收盘价
VAR7赋值:收盘价-VAR6和0的较大值的6日[1日权重]移动平均/收盘价-VAR6的绝对值的6日[1日权重]移动平均*100
当满足条件84上穿VAR7时,在最高价*1.035位置书写文字,COLOR00FF00
当满足条件84上穿VAR7时,在最高价*1.015位置书写文字,COLOR00FF00
如果收盘价的20日简单移动平均>1日前的收盘价的20日简单移动平均,返回收盘价的20日简单移动平均,否则返回无效数,画红色,线宽为2
如果收盘价的20日简单移动平均<1日前的收盘价的20日简单移动平均,返回收盘价的20日简单移动平均,否则返回无效数,画绿色,线宽为2
KDJ_K赋值:"KDJ的K"(9,3,3)
KDJ_D赋值:"KDJ的D"(9,3,3)
KDJ_J赋值:"KDJ的J"(9,3,3)
买1赋值:KDJ_J上穿0 OR (KDJ_J上穿KDJ_K AND KDJ_D<26)
买2赋值:"RSI的RSI1"(6,2,2)上穿20 OR "RSI的RSI1"(6,12,24)上穿"RSI的RSI2"(6,12,24)
买3赋值:"平滑异同平均的DIF"上穿"平滑异同平均的DEA" OR "平滑异同平均的MACD"上穿0
买0赋值:买1+买2+买3
当满足条件买0>1时,在最低价*0.98位置画16号图标
AA1赋值:成交额(元)/成交量(手)
BB1赋值:最低价<AA1*0.9
CC1赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100>1.2
DD1赋值:最低价<收盘价的5日简单移动平均*0.921
EE1赋值:成交量(手)<成交量(手)的5日简单移动平均*1.5
FF1赋值:BB1 AND CC1 AND DD1 AND EE1
当满足条件FF1时,在(最低价*0.97)位置书写文字,COLOR4080FF[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1svtmturkgZPEUFqx0FRODw

看了该指标的人还看了:
上升之星指标    抄底神器指标    金财神SB指标
趋势操盘指标    五福临门指标    猎庄买点指标

使用道具 举报

回复