指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 筹码 趋势 操盘控盘 
微信截图_20190312110158.png

微信截图_20190312110207.png

[lywrap=通达信主图指标公式][lycode=tdx,true]TS:=1,300,130;
N:=1,100,99;
M:=1,100,3;
DA1:=IF(TS>TOTALBARSCOUNT,TOTALBARSCOUNT,TS);
DA:=IF(CURRBARSCOUNT>DA1,0,DA1);
HI:=REFDATE(HHV(H,DA),DATE);
LO:=REFDATE(LLV(L,DA),DATE);
C1:=IF(CURRBARSCOUNT<=DA,C,DRAWNULL);
GZ:=EXP(LN(HI/LO)/10);
LH1:=SUM(IF(C1>=(HI ),V,0),DA);
LH2:=SUM(IF(C1>=(HI/POW(GZ,2)) AND C1<(HI ),V,0),DA);
LH3:=SUM(IF(C1>=(HI/POW(GZ,3)) AND C1<(HI/POW(GZ,2)),V,0),DA);
LH4:=SUM(IF(C1>=(HI/POW(GZ,4)) AND C1<(HI/POW(GZ,3)),V,0),DA);
LH5:=SUM(IF(C1>=(HI/POW(GZ,5)) AND C1<(HI/POW(GZ,4)),V,0),DA);
LH6:=SUM(IF(C1>=(HI/POW(GZ,6)) AND C1<(HI/POW(GZ,5)),V,0),DA);
LH7:=SUM(IF(C1>=(HI/POW(GZ,7)) AND C1<(HI/POW(GZ,6)),V,0),DA);
LH8:=SUM(IF(C1>=(HI/POW(GZ,8)) AND C1<(HI/POW(GZ,7)),V,0),DA);
LH9:=SUM(IF(C1>=(LO*GZ) AND C1<LO*POW(GZ,2),V,0),DA);
LH10:=SUM(IF(C1>=LO AND C1<LO*GZ,V,0),DA);
L1:=REFDATE(HHV(LH1,DA),DATE),LINETHICK0;
L2:=REFDATE(HHV(LH2,DA),DATE),LINETHICK0;
L3:=REFDATE(HHV(LH3,DA),DATE),LINETHICK0;
L4:=REFDATE(HHV(LH4,DA),DATE);
L5:=REFDATE(HHV(LH5,DA),DATE);
L6:=REFDATE(HHV(LH6,DA),DATE);
L7:=REFDATE(HHV(LH7,DA),DATE);
L8:=REFDATE(HHV(LH8,DA),DATE);
L9:=REFDATE(HHV(LH9,DA),DATE);
L10:=REFDATE(HHV(LH10,DA),DATE);
SS:=(L1+L2+L3+L4+L5+L6+L7+L8+L9+L10);
STICKLINE(CEILING(DA*L1/SS)*3>=CURRBARSCOUNT,HI*N/100,HI ,9,0)COLOR252525,LINETHICK3;
STICKLINE(CEILING(DA*L2/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,1)*N/100,HI/POW(GZ,2),9,0)COLOR252525,LINETHICK3;
STICKLINE(CEILING(DA*L3/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,2)*N/100,HI/POW(GZ,3),9,0)COLOR252525,LINETHICK3;
STICKLINE(CEILING(DA*L4/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,3)*N/100,HI/POW(GZ,4),9,0)COLOR252525,LINETHICK3;
STICKLINE(CEILING(DA*L5/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,4)*N/100,HI/POW(GZ,5),9,0)COLOR252525,LINETHICK3;
STICKLINE(CEILING(DA*L6/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,5)*N/100,HI/POW(GZ,6),9,0)COLOR252525,LINETHICK3;
STICKLINE(CEILING(DA*L7/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,6)*N/100,HI/POW(GZ,7),9,0)COLOR252525,LINETHICK3;
STICKLINE(CEILING(DA*L8/SS)*3>=CURRBARSCOUNT,LO*POW(GZ,2),LO*POW(GZ,3)*N/100,9,0)COLOR252525,LINETHICK3;
STICKLINE(CEILING(DA*L9/SS)*3>=CURRBARSCOUNT,LO*POW(GZ,1),LO*POW(GZ,2)*N/100,9,0)COLOR252525,LINETHICK3;
STICKLINE(CEILING(DA*L10/SS)*3>=CURRBARSCOUNT,LO,LO*POW(GZ,1)*N/100,9,0)COLOR252525,LINETHICK3;
DRAWKLINE(H,O,L,C);

DRAWBAND(MA(CLOSE,60),RGB(55,0,0),MA(CLOSE,120),RGB(0,91,0));
DRAWBAND(MA(CLOSE,5),RGB(255,255,50),MA(CLOSE,10),RGB(0,0,220));
{DRAWBAND(短线,RGB(255,255,50),中线,RGB(0,0,220));}
STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORRED;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,3.1,0 ),COLOR000033;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR000066;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR000099;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000CC;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000FF;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORCC66FF;
STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,3.1,0 ),COLOR990000;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLORCC0000;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORFF8800;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORCYAN;
STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORWHITE;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3.1,0 ),COLOR555555;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;
M1:=1,1000,5;
M2:=1,1000,10;
M3:=1,1000,20;
M4:=1,1000,60;
M5:=1,1000,120;
MA5:MA(CLOSE,M1),COLORWHITE;
MA10:MA(CLOSE,M2),COLORYELLOW;
MA20:MA(CLOSE,M3),COLORMAGENTA;
MA60:MA(CLOSE,M4),COLORGREEN;
MA120:MA(CLOSE,M5),COLORBLUE;
GX:=HHV(C,100),COLORFF9900,LINETHICK1;[/lycode][lycode=tdx2,true]TS赋值:1,300,130
N赋值:1,100,99
M赋值:1,100,3
DA1赋值:如果TS>总的周期数,返回总的周期数,否则返回TS
DA赋值:如果到最后交易的周期>DA1,返回0,否则返回DA1
HI赋值:日期日DA日内最高价的最高值
LO赋值:日期日DA日内最低价的最低值
C1赋值:如果到最后交易的周期<=DA,返回收盘价,否则返回无效数
GZ赋值:HI/LO的自然对数/10的指数
LH1赋值:如果C1>=(HI),返回成交量(手),否则返回0的DA日累和
LH2赋值:如果C1>=(HI/GZ的2乘幂)ANDC1<(HI),返回成交量(手),否则返回0的DA日累和
LH3赋值:如果C1>=(HI/GZ的3乘幂)ANDC1<(HI/GZ的2乘幂),返回成交量(手),否则返回0的DA日累和
LH4赋值:如果C1>=(HI/GZ的4乘幂)ANDC1<(HI/GZ的3乘幂),返回成交量(手),否则返回0的DA日累和
LH5赋值:如果C1>=(HI/GZ的5乘幂)ANDC1<(HI/GZ的4乘幂),返回成交量(手),否则返回0的DA日累和
LH6赋值:如果C1>=(HI/GZ的6乘幂)ANDC1<(HI/GZ的5乘幂),返回成交量(手),否则返回0的DA日累和
LH7赋值:如果C1>=(HI/GZ的7乘幂)ANDC1<(HI/GZ的6乘幂),返回成交量(手),否则返回0的DA日累和
LH8赋值:如果C1>=(HI/GZ的8乘幂)ANDC1<(HI/GZ的7乘幂),返回成交量(手),否则返回0的DA日累和
LH9赋值:如果C1>=(LO*GZ)ANDC1<LO*GZ的2乘幂,返回成交量(手),否则返回0的DA日累和
LH10赋值:如果C1>=LOANDC1<LO*GZ,返回成交量(手),否则返回0的DA日累和
L1赋值:日期日DA日内LH1的最高值,线宽为0
L2赋值:日期日DA日内LH2的最高值,线宽为0
L3赋值:日期日DA日内LH3的最高值,线宽为0
L4赋值:日期日DA日内LH4的最高值
L5赋值:日期日DA日内LH5的最高值
L6赋值:日期日DA日内LH6的最高值
L7赋值:日期日DA日内LH7的最高值
L8赋值:日期日DA日内LH8的最高值
L9赋值:日期日DA日内LH9的最高值
L10赋值:日期日DA日内LH10的最高值
SS赋值:(L1+L2+L3+L4+L5+L6+L7+L8+L9+L10)
当满足条件DA*L1/SS的向上舍入*3>=到最后交易的周期时,在HI*N/100和HI位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR252525,线宽为3
当满足条件DA*L2/SS的向上舍入*3>=到最后交易的周期时,在HI/GZ的1乘幂*N/100和HI/GZ的2乘幂位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR252525,线宽为3
当满足条件DA*L3/SS的向上舍入*3>=到最后交易的周期时,在HI/GZ的2乘幂*N/100和HI/GZ的3乘幂位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR252525,线宽为3
当满足条件DA*L4/SS的向上舍入*3>=到最后交易的周期时,在HI/GZ的3乘幂*N/100和HI/GZ的4乘幂位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR252525,线宽为3
当满足条件DA*L5/SS的向上舍入*3>=到最后交易的周期时,在HI/GZ的4乘幂*N/100和HI/GZ的5乘幂位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR252525,线宽为3
当满足条件DA*L6/SS的向上舍入*3>=到最后交易的周期时,在HI/GZ的5乘幂*N/100和HI/GZ的6乘幂位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR252525,线宽为3
当满足条件DA*L7/SS的向上舍入*3>=到最后交易的周期时,在HI/GZ的6乘幂*N/100和HI/GZ的7乘幂位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR252525,线宽为3
当满足条件DA*L8/SS的向上舍入*3>=到最后交易的周期时,在LO*GZ的2乘幂和LO*GZ的3乘幂*N/100位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR252525,线宽为3
当满足条件DA*L9/SS的向上舍入*3>=到最后交易的周期时,在LO*GZ的1乘幂和LO*GZ的2乘幂*N/100位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR252525,线宽为3
当满足条件DA*L10/SS的向上舍入*3>=到最后交易的周期时,在LO和LO*GZ的1乘幂*N/100位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR252525,线宽为3
K线
画带状线
画带状线
当满足条件收盘价>1日前的收盘价时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画红色
当满足条件收盘价>1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为3.1,0不为0则画空心柱.,COLOR000033
当满足条件收盘价>1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为2.7,0不为0则画空心柱.,COLOR000066
当满足条件收盘价>1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为2.1,0不为0则画空心柱.,COLOR000099
当满足条件收盘价>1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR0000CC
当满足条件收盘价>1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为0.9,0不为0则画空心柱.,COLOR0000FF
当满足条件收盘价>1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,COLORCC66FF
当满足条件收盘价<1日前的收盘价时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画青色
当满足条件收盘价<1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为3.1,0不为0则画空心柱.,COLOR990000
当满足条件收盘价<1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为2.7,0不为0则画空心柱.,COLORCC0000
当满足条件收盘价<1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为2.1,0不为0则画空心柱.,COLORFF4400
当满足条件收盘价<1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORFF8800
当满足条件收盘价<1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为0.9,0不为0则画空心柱.,COLORFFCC00
当满足条件收盘价<1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,画青色
当满足条件收盘价=1日前的收盘价时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画白色
当满足条件收盘价=1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为3.1,0不为0则画空心柱.,COLOR555555
当满足条件收盘价=1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为2.7,0不为0则画空心柱.,COLOR777777
当满足条件收盘价=1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为2.1,0不为0则画空心柱.,COLOR999999
当满足条件收盘价=1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORBBBBBB
当满足条件收盘价=1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为0.9,0不为0则画空心柱.,COLORDDDDDD
当满足条件收盘价=1日前的收盘价时,在开盘价和收盘价位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,COLORFFFFFF
M1赋值:1,1000,5
M2赋值:1,1000,10
M3赋值:1,1000,20
M4赋值:1,1000,60
M5赋值:1,1000,120
输出MA5:收盘价的M1日简单移动平均,画白色
输出MA10:收盘价的M2日简单移动平均,画黄色
输出MA20:收盘价的M3日简单移动平均,画洋红色
输出MA60:收盘价的M4日简单移动平均,画绿色
输出MA120:收盘价的M5日简单移动平均,画蓝色
GX赋值:100日内收盘价的最高值,COLORFF9900,线宽为1[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1OUAOxirlX1tBWdhuscvDLw

看了该指标的人还看了:
与私募同进出指标    真涨指标,成功率非常高    三碗不过岗指标
主力买卖指标    明明白白指标    绝对底部指标

使用道具 举报

回复