指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 趋势 
微信截图_20190306092402.png

微信截图_20190306092415.png

[lywrap=通达信副图指标公式][lycode=tdx,true]N:=1;
V1:=N;{别人收费限时公式,我犯懒只把开关给关上了}
VAR1:=HHV(HIGH,9)-LLV(LOW,9)*V1;
VAR2:=HHV(HIGH,9)-CLOSE*V1;
VAR3:=CLOSE-LLV(LOW,9)*V1;
VAR4:=VAR2/VAR1*100-70*V1;
VAR5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100*V1;
VAR6:=(2*CLOSE+HIGH+LOW)/4*V1;
VAR7:=SMA(VAR3/VAR1*100,3,1)*V1;
VAR8:=LLV(LOW,34)*V1;
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1)*V1;
VARA:=IF(VAR9>100,VAR9-100,0)*V1;
VARB:=HHV(HIGH,34)*V1;
AA:= VARA*2*V1;
BB:= EMA((VAR6-VAR8)/(VARB-VAR8)*100,13)*V1;
VARC:=EMA(0.667*REF(BB,1)+0.333*BB,2)*V1;
CC:=SMA(VAR5,20,1)*V1,COLORRED;
CC1:=SMA(CC,5,1)*V1,COLORGREEN;
IF(CC<REF(CC,1),CC,DRAWNULL),COLORBLUE,LINETHICK1;
IF(CC>REF(CC,1),CC,DRAWNULL),COLORRED,LINETHICK1;
IF(CC1<REF(CC1,1),CC1,DRAWNULL),COLORBLUE,LINETHICK1;
IF(CC1>REF(CC1,1),CC1,DRAWNULL),COLORRED,LINETHICK1;
STICKLINE(CC>CC1,CC,CC1,1,0)*V1,COLORRED;
STICKLINE(CC1>CC,CC,CC1,1,0)*V1,COLORBLUE;
出击:IF((CROSS(CC,CC1) AND (CC1 < 85) ),80,0),COLORRED;[/lycode][lycode=tdx2,true]N赋值:1
V1赋值:N
VAR1赋值:9日内最高价的最高值-9日内最低价的最低值*V1
VAR2赋值:9日内最高价的最高值-收盘价*V1
VAR3赋值:收盘价-9日内最低价的最低值*V1
VAR4赋值:VAR2/VAR1*100-70*V1
VAR5赋值:(收盘价-60日内最低价的最低值)/(60日内最高价的最高值-60日内最低价的最低值)*100*V1
VAR6赋值:(2*收盘价+最高价+最低价)/4*V1
VAR7赋值:VAR3/VAR1*100的3日[1日权重]移动平均*V1
VAR8赋值:34日内最低价的最低值*V1
VAR9赋值:VAR7的3日[1日权重]移动平均-VAR4的9日[1日权重]移动平均*V1
VARA赋值:如果VAR9>100,返回VAR9-100,否则返回0*V1
VARB赋值:34日内最高价的最高值*V1
AA赋值: VARA*2*V1
BB赋值: (VAR6-VAR8)/(VARB-VAR8)*100的13日指数移动平均*V1
VARC赋值:0.667*1日前的BB+0.333*BB的2日指数移动平均*V1
CC赋值:VAR5的20日[1日权重]移动平均*V1,画红色
CC1赋值:CC的5日[1日权重]移动平均*V1,画绿色
如果CC<1日前的CC,返回CC,否则返回无效数,画蓝色,线宽为1
如果CC>1日前的CC,返回CC,否则返回无效数,画红色,线宽为1
如果CC1<1日前的CC1,返回CC1,否则返回无效数,画蓝色,线宽为1
如果CC1>1日前的CC1,返回CC1,否则返回无效数,画红色,线宽为1
当满足条件CC>CC1时,在CC和CC1位置之间画柱状线,宽度为1,0不为0则画空心柱.*V1,画红色
当满足条件CC1>CC时,在CC和CC1位置之间画柱状线,宽度为1,0不为0则画空心柱.*V1,画蓝色
输出出击:如果(CC上穿CC1AND(CC1<85)),返回80,否则返回0,画红色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1mgbxKCgpUuDPpLms_ZuQiw

看了该指标的人还看了:
启爆抄底指标    趋势为王道指标    财神操盘指标
波段机会指标    提示操盘指标    只抓牛股指标

使用道具 举报

回复